PDA

Afficher la version complète : [Non Réglé] Canon i250



bixtch
10/12/2004, 10h53
Bonjour,
j'ai installé Suse9.1 et j'ai une canon i250
J'ai choppé les drivers sur le site Néozélandais de canon qui mets à dispop des rpm pour ce type d'imprimante et le mode d'emploi d'installation des drivers....
Mon soucis vient du gestionnaire d'impression de KDE ou CUPS, je pense.
llorsque je fait Ajout imprimate/ -> choix de l'imprimante -> choix du drivers dans la base -> Tester l'imprimante j'obtient une fenêtre qui me demande un nom d'utilisateur et un mot de passe.
Je mets mon nom d'utilisateur et mon mot de passe et j'obtiens un refus;
J'ai essaué en mettant root comme nom d'utilisateur et le mot de pasxse qui va bien avec mais même réponse....
quelqu'un a une idée?
Merci

jacqueline
10/12/2004, 11h31
Oui j'ai une idée.

Je suis tombée sur le même pb de mdp, après l'install de mon driver particulier. C'est un mdp particulier pour cups et pas le root, ni le user, qu'il faut rentrer avec une cde.. Je crois qu'on trouve ça sur le site de cups.. et là en français

Système d'impression linux (http://casteyde.christian.free.fr/online/install_linux/x4694.html)

Mais finalement je m'en suis passée en refaisant l'install de CUPS après avoir installé mon driver particulier. Dans Yast, installation imprimante , on te propose dans un des menus de réinstaller cups. Pour moi ça a marché, avec la config de base, sans rentrer de mdp.

Sinon il y a ce lien en anglais :

cups avec suse (http://www-uxsup.csx.cam.ac.uk/suse/adminguide-sles9/ch13s06.html)


Après ce serait sympa que tu ajoutes ton imprimante dans la liste, sujet : "Quelle imprimante pour Suse", avec les ref de ton driver canon, le lien, afin de tout regrouper pour aider les suivants équipés une imprimante canon.

Bonne chance.

galagann
15/12/2004, 12h40
ICI les drivers pour la Canon i250 http://www.alionet.org/style_emoticons/<#EMO_DIR#>/arrow.gif http://www.canon.co.nz/products/printers/c...50_drivers.html (http://www.canon.co.nz/products/printers/colour_bj_printers/i250_drivers.html)

jejelerom
15/12/2004, 19h32
Ca pourrait pas marcher pour ma canon i320 a tout hasard (c le model apres la i250) ????

galagann
15/12/2004, 20h19
Tu peux toujours faire un essaye, rien a perdre, que a gagné http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

orlando007
14/03/2005, 21h24
Bonsoir,

je suis tout nouveau sur le système linux, tombé par hasard chez mon buraliste sur le DVD de suse 9.2, disposant d'un 2ème disque j'ai "osé" l'installe. Tout tourne au poil, sauf quelques petites choses, comme pas de son à mon lecteur de DVD et surtout mon imprimante qui n'a pas de driver. C'est une canon i250.
J'ai été voir à l'adresse donnée plus haut, mais l'anglais et moi, nous ne sommes pas copains. Dons je pige rien de rien, tant pour le driver exacte à télécharger et à la procédure à suivre pour que cela fonctionne. Cups c'est quoi ?????
Alors si une personne bien aimable, pouvait m'éclairer de ses lumières, d'avance un grand merci.
Surtout que je commence à aimer Linux, et Gnome en particulier.

richard.31
14/03/2005, 22h11
Pour l'imprimante le plus simple est
http://www.turboprint.de/english.html
tu réponds à quelques questions avant de télécharger la version 1.92-2
soit la version rpm à installer avec un clic droit avec yast soit en ligne de commande
rpm --install turboprint-1.92-2.i386.rpm
et ensuite avec yast matériel imprimantes choisir dans la longue liste canonturboprinti250 et configurer
soit le fichier compressé tar
dans un terminal
cd turboprint etc.... et en root
tar -xvf turboprint-1.91-2.tgz
./setup
et il va te configurer ta canon

Gerinald
14/03/2005, 23h47
Bonjour richard.31,
Merci pour le lien, d'ou j'ai téléchargé ce programme, mais malheureusement, je ne voit pas ma Canon Selphy CP 400.
J'ai comme l'impression que je vait devoir faire une croix dessus http://www.alionet.org/style_emoticons/<#EMO_DIR#>/ohmy.gif((
Ma HP 3820 à bien été reconnue, une chance ;o))
Canon m'a envoyé sur les roses pour mon imprimante, bande de ............. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/mad.gif
@micalement
@+ Gerinald

orlando007
15/03/2005, 00h51
Oui mais le problème avec turboprint, c'est le beau logo qui s'affiche sur les pages imprimées, à moins de payer 29 € et des poussières pour la clef http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

richard.31
15/03/2005, 01h23
mais une fois la clef obtenue tu peux l'utiliser sur autant de pcs que tu veux
je l'ai depuis deux ans et je l'ai installé une dizaine de fois sur plusieurs pcs

siko
15/03/2005, 08h10
Orlando007 sur la page de Canon il y a un rpm pour rajouter les filtres de la i250 à CUPS, installe le et ensuite va dans Yast et installes ton imprimante elle risque d'être reconnue et c'est gratuit. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif

http://www.canon.co.nz/drivers/confirm.asp...-2.3-0.i386.rpm (http://www.canon.co.nz/drivers/confirm.aspx?f=http:/%2fdownload.canon.com.au%2fbj%2fi250linux%2fbjfilt ercups-2.3-0.i386.rpm)

Gerinald c'est quoi comme imprimante ton modèle car même chez Canon je ne la trouve pas. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

Gerinald
15/03/2005, 13h44
Bonjour Siko,
Mon imprimante et à sublimation thermique, je m'en sert enormément pour tirer des photos http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

Voici le lien qui donne plus de détail sur cette petite merveille http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

http://www.canon.fr/for_home/product_finde...cp400/index.asp (http://www.canon.fr/for_home/product_finder/printers/direct_photo/selphy_cp400/index.asp)

J'ai déjà fait joué Google, fait des recherches sous "Drivers imprimante Linux"....
Bref, j'ai cherché tout azimut, rien.

Merci d'y jeter un oeil http://www.alionet.org/style_emoticons/<#EMO_DIR#>/cool.gif

@micalement
@+ Gerinald

orlando007
15/03/2005, 15h54
Bonjour siko, j'ai suivis tes instructions, installé (avec du mal) le fichier téléchargé , yast reconnait bien l'imprimante, mais impossible d'imprimer. Bien que cela soit un fichier pour la i250, cela ne fonctionne pas.

J'en reviens à la case départ. Avec windaube il faut payer, je pensais pas qu'il fallait aussi sortir son portefeuille avec linux, pour avoir un système qui soit entièrement opérationnel. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

siko
15/03/2005, 16h55
Originally posted by orlando007@mardi 15 mars 2005 à 14:54
Bonjour siko, j'ai suivis tes instructions, installé (avec du mal) le fichier téléchargé , yast reconnait bien l'imprimante, mais impossible d'imprimer. Bien que cela soit un fichier pour la i250, cela ne fonctionne pas.

J'en reviens à la case départ. Avec windaube il faut payer, je pensais pas qu'il fallait aussi sortir son portefeuille avec linux, pour avoir un système qui soit entièrement opérationnel. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif
<div align='right'><{POST_SNAPBACK}> (index.php?act=findpost&pid=26207)[/quote]

Point un quand tu as installé ton imprimante as tu essayé de lancer un test depuis Yast.

Point deux: Libre et Opensource ne veut pas dire gratuit il faut bien que les développeurs manges.

orlando007
15/03/2005, 17h11
Point un : Oui j'ai bien essayé une page de test dans Yast, mais rien ne se passe, l'imprimante continue à faire la sieste. Pourtant Yast a bien détecté l'imprimante + le filtre.

Point deux : Entièrement raison.

siko
15/03/2005, 17h41
Si tu sens d'attaque on peut essayer de passer par Cups directement pour la configurer. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif

orlando007
15/03/2005, 19h16
D'attaque ? non pas tellement http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif mais il faut bien arriver à faire fonctionner cette maudite machine.

Je suis repassé sous KDE et j'ai trouvé le gestionnaire d'impression dans le menu, alors que sous gnome, il n'est pas présent. Et je rencontre le même problème que cité plus haut dans un message, concernant l'utilisateur et le mot de passe.
Dans Yaps2 en recherchant "Cups" cela donne :

bjfiltercups -->Protégé
bluez-cups -->non installé
cups -->installé
cups-client -->installé
cups-drivers -->installé
cups-drivers-stp -->installé
cups-libs -->installé
cups-suse-ppds-dat -->installé
gtklp -->non installé
libgnomecups -->installé

Faut il tout désinstaller et ré-installer pour que cela fonctionne enfin ?

orlando007
15/03/2005, 19h30
Je viens d'essayer d'installer bjfilteri250 récupéré chez canon, j'ai le message suivant

linux:/home/roland # rpm -ivh bjfilteri250-2.3-0.i386.rpm
error: Failed dependencies:
libpng.so.2 is needed by bjfilteri250-2.3-0
linux:/home/roland #


C'est quoi le problème ?

siko
15/03/2005, 19h38
Il te manque le Rpm Mupad-2.5, installe le avec Yast.

Ou alors il se trouve

http://rpm.pbone.net/index.php3/stat/4/idp...1.i586.rpm.html (http://rpm.pbone.net/index.php3/stat/4/idpl/1624214/com/mupad-2.5.2-54.1.i586.rpm.html)

orlando007
15/03/2005, 21h12
J'ai installé mupad, même rebooté l'ordi. Toujours le même message pour bjfilter rpm

Je laisse tomber pour aujourd'hui, cela me prend la tête.

bungie
04/10/2005, 12h33
J'ai réussi à faire marcher cette imprimante sous une SuSE 9.3, mais la solution doit aussi marcher pour les autres versions.

Mon howto (http://www.redisdead.org/index.php?2005/08/23/92-faire-marcher-une-imprimante-canon-i250-sous-suse-93)

galagann
04/10/2005, 14h50
En voilà une bonne nouvelle http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

wapwap
04/10/2005, 16h37
Même souci de dépendance avec ma Canon IP3000 en installant les bjfiltermachinchose.rpm récupérés sur le site de canon et installés via Yast, résolu en utilisant une astuce toute simple que j'ai lu je ne sais plus où...

En fait la version de libpng installée avec SUSE est la libpng.so.3.1.2.8, donc a priori plus récente... pour ne pas downgrader ce paquetage et résoudre le problème de dépendance le mieux et d'installer les RPM nécessaires à l'imprimante via YAST, quand il râle en disant qu'il manque libpng.so.2 et qu'il a que du lippng.so.3 en rayon on ignore ce conflit et on installe quand même le vilain RPM. Puis on localise le répertoire où est stocké libpng.so.3, (/usr/lib) et en Root on créé un lien symbolique appelé lipng.so.2 qui pointe vers notre librairie libpng.so.3.1.2.8 et pof, enfumé le caméléon...

Après le plus simple pour configurer l'imprimante et de passer par le gestionnaire d'impression de KDE... Il faut avant tout avoir pris la précaution de créer un compte administateur pour CUPS par la commande (en console sous root) lppasswd -a nomadministrateurcupskonveut, après saisie et vérification du mot de passe ce nom d'utilisateur pourra être utilisé soit directement dans cups soit à la demande du gestionnaire d'impression de KDE pour installer l'imprimante en question...

did
30/01/2006, 14h58
Salut,

A tout les possesseurs d'une Canon i250, sous Suse 10.0 (et même 9.2, je crois), allez voir par là (http://www.alionet.org/index.php?showtopic=7990), vous trouverez peut-être une solution. Ca a marché pour moi!