PDA

Afficher la version complète : Pare feu



manchette
10/09/2006, 14h43
Salut,

- à quoi corresponde les zones svp ? interne, démilitarisée, externe ?

- dans le parefeu de la suse 10.1 , rubrique Services autorisés, que veut dire la case à cocher en bas à gauche ? (protéger le pare feu de la zone interne)

si je coche cette case --> je peut alors sélectionner le serveur Samba (rubrique service à autoriser) et ajouter une ouverture de port TCP 139 , (en bas à droite, bouton avancé)

vous feriez ainsi pour aouvrir ce port pour Samba ?

merci de votre aide http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

phoenix
10/09/2006, 15h00
Hello

manchette, il me semble que c'est expliqué dans les manuels de la Suse.

Et pour les zones, fait une recherche sur le forum.

manchette
10/09/2006, 17h26
Hello

manchette, il me semble que c'est expliqué dans les manuels de la Suse.

Et pour les zones, fait une recherche sur le forum.[/b]

ok j'ai vu les zones, par contre sur le parefeu, une question suite à la doc de suse 10.1 chapitre 28 Samba
dans serveur samba, démarrage :
pour ouvrir les ports dans le parefeu j'ai dsl0 (None) et eth-id..... (Dhcp) au choix . Les 2 doivent t'ils être ouverts pour que le 2d pc du réseau me voit ?

Copernicus_ThebigNewbie
11/09/2006, 08h36
pour la DMZ : http://fr.wikipedia.org/wiki/Zone_d%C3%A9militaris%C3%A9e

Aprés avoir lu tu devrais piger les termes EXTERNE Et INTERNE ...


Pour samba le problème est un peu plus complexe car il bosse avec le netbios et le broadcast (que peu de firewall laisse passer )

---> pour ouvrir correctement le tout voir mon wiki sur Samba

http://wiki.alionet.org/doku.php?id=samba


Pour le FireWall de la Suse YAST - Security and Users - Configure a Firewall - Allowed Services - Zone Externe - Advanced - Samba Server

Save Setting et Redemarrer le FireWall

Puis dans YaST > System > /etc/sysconfig Editor - Network > Firewall > SuSEfirewall2

modifier ou ajouter les parametres (settings):

FW_SERVICES_EXT_TCP = microsoft-ds netbios-dgm netbios-ns netbios-ssn

FW_SERVICES_EXT_UDP = netbios-ns

FW_ALLOW_INCOMING_HIGHPORTS_TCP = microsoft-ds netbios-ns

FW_ALLOW_INCOMING_HIGHPORTS_UDP = microsoft-ds netbios-ns

FW_ALLOW_FW_BROADCAST_EXT = netbios-ns netbios-dgm

Redémarrez le Firewall et cela devrait marcher..

manchette
11/09/2006, 10h34
Puis dans YaST > System > /etc/sysconfig Editor - Network > Firewall > SuSEfirewall2

modifier ou ajouter les parametres (settings):

FW_SERVICES_EXT_TCP = microsoft-ds netbios-dgm netbios-ns netbios-ssn

FW_SERVICES_EXT_UDP = netbios-ns

FW_ALLOW_INCOMING_HIGHPORTS_TCP = microsoft-ds netbios-ns

FW_ALLOW_INCOMING_HIGHPORTS_UDP = microsoft-ds netbios-ns

FW_ALLOW_FW_BROADCAST_EXT = netbios-ns netbios-dgm

Redémarrez le Firewall et cela devrait marcher..[/b]

Salut,
merci ca m'a bien aidé, j'avais lu la doc 'référence' de Suse 10.1 et cela n'y était pas concernant Samba (chap. 28), faut que j'installe le paquet samba-doc en plus je pense u n truc dans le style , merci donc http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif.
en fait il me manquait (au minimum) des choses dans le /etc/sysconfig (en gras ci dessus ce que j'ai du ajouter)

bon, à présent il me reste 2 soucis principaux :
- les droits d'accés : je vois tous les documents que le pc sur xp m'a mis en partage , et depuis le pc xp on voit aussi le pc linux mais par contre certains fichiers sont ok et d'autres sont non autorisés et là je capte pas pourquoi...
-l'impression : toujours ko sur l'epson du pc xp.

AUssi j'aimerai comprendre cette partie de ton wiki sur samba stp (concernant les permissions share et ntfs, et le compte samba), il doit y avoir un lien avec mon souci (j'imagine) :

Normalement si vous avez mis “Everyone Full Control” pour la permission Share et “Everyone Full Control” pour l’NTFS .. cela devrait aller... mais cela ne reste pas top pour la sécurité j’en conviens... Un truc sympa c’est de créer un compte ‘Samba’ dans Windwos XP avec un password et de ne mettre que les permission à l’utilisateur ‘Samba’ c’est ce que je fais et cela marche Ni -

Lors de l’accés à ma machine XP, il vous sera demandé une authentification si vous êtes en ‘PARTAGES AVANCES’ sous windows XP donc il est toujours bon de créer un compte avec un mot de passe sous XP –> d’où le compte ‘Samba’.

Petit truc si vous ne voulez pas créer un dossier utilisateur Samba et surtout ne pas voir le compte lors du loggin de Windows - Créer avec un click droit sur My Computer - Manage - Local Users and Groups - Users - New puis éditez HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon\SpecialAccounts\UserLis t dans le regedit, ajouter un DWORD que vous renommez avec le nom du compte et attribué la valeur 0.

Si vous avez optez pour le ‘PARTAGE SIMPLE’ [My Computer - Tools - Folder Options... - Onglet View - Advanced - Use simple file sharing (Recommended) cochez) il ne devrait pas vous demander de mot de passe.. Mouai .. chez moi cela ne marche pas..

Copernicus_ThebigNewbie
11/09/2006, 10h43
bon, à présent je vois tous les documents que le pc sur xp m'a mis en partage , et depuis le pc xp on voit aussi le pc linux mais par contre certains fichiers sont ok et d'autres sont non autorisés et là je capte pas pourquoi... [/b]

Ces fichiers sont en partages sur Linux ? Si ils sont sur Linux - regarde qui est le propriétaire&groupe et quels sont les droits ? le problème vient a mon avis de là ...

J'suis pas un fan de l'impression - mais via KDE - ajouter une imprimante (avec la wizard il y a une option imprimmer via smb) ou un truc dans le genre - (pas encore compléter le tuto)

manchette
11/09/2006, 20h42
<div class='quotetop'>Citation (manchette @ 11/09/2006 à 11:34) <{POST_SNAPBACK}> (index.php?act=findpost&pid=102904)

bon, à présent je vois tous les documents que le pc sur xp m'a mis en partage , et depuis le pc xp on voit aussi le pc linux mais par contre certains fichiers sont ok et d'autres sont non autorisés et là je capte pas pourquoi... [/b]

Ces fichiers sont en partages sur Linux ? Si ils sont sur Linux - regarde qui est le propriétaire&groupe et quels sont les droits ? le problème vient a mon avis de là ...

J'suis pas un fan de l'impression - mais via KDE - ajouter une imprimante (avec la wizard il y a une option imprimmer via smb) ou un truc dans le genre - (pas encore compléter le tuto)
[/b][/quote]

oui il faut que je regarde les droits mais pour le moment ce n'est pas un sujet clair pour moi...

pour l'impression j'ai une idée, je vais supprimer l'imprimante et réessayer, ca marchera peut être mieux, sait t'on jamais ?

Copernicus_ThebigNewbie
12/09/2006, 15h01
oui il faut que je regarde les droits mais pour le moment ce n'est pas un sujet clair pour moi...[/b]


http://wiki.alionet.org/doku.php?id=systeme_droits_acces :-)