PDA

Afficher la version complète : Problèmes d'USB sous SuSE 9.1



perso258741
23/12/2004, 10h43
Bonjour tout le monde
J'ai installé sur mon PC la SuSE 9.1
Cependant peu de périphériques USB fonctionnent systématiquement :
Scanner EPSON qui marche quand il veut (en général il faut que je redémarre le PC avec le scanner branché pour le faire marcher)
Appareil Photo Kodak DX4900 (je peux y accéder une fois de temps en temps : c'est complètement aléatoire)
Imprimante EPSON Stylus (à peu près le même comportement que le scanner)
Lecteur mp3 : mpman FUB55 (impossible d'y accéder depuis que je suis passé de la 9.0 à la 9.1 alors que sur la 9.0 cela marchait sans problème)


aperçu du message que j'obtiens en faisant dmesg lorsque je branche ma clé USB
<div class='quotetop'>Citation </div>
usb 1-3: new full speed USB device using address 2
Initializing USB Mass Storage driver...
scsi0 : SCSI emulation for USB Mass Storage devices
Vendor: Model: Digital Audio Rev: 1.00
Type: Direct-Access ANSI SCSI revision: 02
SCSI device sda: 512000 512-byte hdwr sectors (262 MB)
sda: assuming Write Enabled
sda: assuming drive cache: write through
sda: sda1
Attached scsi removable disk sda at scsi0, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 0
USB Mass Storage device found at 2
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
sda : READ CAPACITY failed.
sda : status=0, message=00, host=7, driver=00
sda : sense not available.
sda: assuming Write Enabled
sda: assuming drive cache: write through
sda : READ CAPACITY failed.
sda : status=0, message=00, host=7, driver=00
sda : sense not available.
sda: assuming Write Enabled
sda: assuming drive cache: write through
sda:<3>Buffer I/O error on device sda, logical block 0
Buffer I/O error on device sda, logical block 0
Buffer I/O error on device sda, logical block 262143
Buffer I/O error on device sda, logical block 262143
Buffer I/O error on device sda, logical block 0
ldm_validate_partition_table(): Disk read failed.
Buffer I/O error on device sda, logical block 0
unable to read partition table
unable to read partition table
sda : READ CAPACITY failed.[/b]
et ça continue sur encore des dizaines de lignes.
Et quand je tente de la monter à la main :

<div class='quotetop'>Citation </div>
# mount /dev/sda1 ./cleusb
mount: /dev/sda1 n'est pas un périphérique valide de type bloc[/b]

Comment faire pour rendre tout ça compatible étant donné qu'avec la SuSE 9.0 ça fonctionnait sans problème... ?

Merci de votre aide !

galagann
23/12/2004, 13h34
Salux,

Petite question, tu fais régulièrement les mise à jour avec SuSEWatcher ? Notament celui du Kernel !

perso258741
23/12/2004, 14h47
Régulièrement non mais j'en ai fait certaines et j'ai du en faire 2 du kernel apres être passé à la SuSE 9.1

devloop
24/12/2004, 12h57
Moi je n'ai jamais fait les mises à jour kernel (trop lourd pour ma connexion) et ma clé usb marche à merveille...
Peut etre qu'il te manque certains modules en rapport avec l'usb...
ou alors il faut un driver spécial pour ta clé (ça me semble peut probable quand meme)