PDA

Afficher la version complète : suse 9.2 et graveur de cdrom



loco
28/12/2004, 01h09
Tout d'abord, étant nouveau sur ce forum, bonjour et bonnes fêtes ! http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif
Je travaille sous linux depuis 6 ans et sous suse depuis 1 an.
Je viens de passer de la 9.0 pro à la 9.2 pro (install et non mise à jour).
Tout s'est bien passé, matériel reconnu et configuré, j' ai retrouvé mes petits, impec !
Sauf un problème que je ne comprends pas.. Je possède
un lecteur de dvd-cdrom ide samsung en hdc
un graveur cdrom ide samsung en hdd
voici l'extrait de mon fstab :
-------------------------------------------------------------------------------------------------
/dev/cdrecorder /media/cdrecorder subfs fs=cdfss,rw,procuid,nosuid,nodev,exec,iocharset=ut f8 0 0
/dev/dvd /media/dvd subfs fs=cdfss,ro,user,procuid,nosuid,nodev,exec,iochars et=utf8 0 0
------------------------------------------------------------------------------------------------
L'installation a été réalisée par les cdrom, donc dans Yast les media d'installation sont /dev/hdc et /dev/hdd..
Le problème : au bout d'un certain temps (je n'ai pas compté) mon graveur est "bloqué". Impossible de l'ouvrir même en appuyant sur le bouton idoine. Le seul effet que ce "malheureux" geste cause, c'est la mise en route d'un traffic de la machine (le led de la tour s'allume comme si le disque dur tournait sans fin) et rapidement quelques secondes, j'arrive à un gel total du serveur X. Seule solution: le reset. AAAArghh !
Au début je pensais que cela était lié au module de gestion des rpms de Yast.
Quand je veux installer un rpm, si jamais je ne mets pas de cd dans le graveur AVANT de lancer ce module, c'est foutu. Yast va bien prendre en considération ma demande (le brave) mais au moment de me demander d'insérer le cd qui convient ou bien d'ouvrir le lecteur de cdrom pour cela, il va bloquer sur le graveur "vide" et le gel total de X suit dans les secondes...
Est-ce que cela dit quelque chose à quelqu'un ?
Je précise que seul le graveur bloque, le lecteur est lui toujours utilisable.
Serait-ce lié à "l'émulation automatique" en scsi du graveur par le noyau 2.6 ?
Mon matériel n'a rien d'exotique et fonctionne parfaitement. Le graveur grave bien avec k3b, le lecteur de dvd lit bien les dvd..
Bref, sans ce problème qui m'oblige à rebooter chaque fois que veux utiliser mon graveur, ce serait le paradis, car cette suse 9.2 est vraiment superbe, rapide.
J'ai lu le problème de Jacqueline avec l'ACL et si j'ai bien compris elle aussi a des soucis avec ses lecteurs, donc je ne serais pas le seul..
D'avance, merci.

priape2
28/12/2004, 02h02
Je ne sais pas si j'ai tout capté mais évites d'utiliser deux lecteurs pour l'installation (il me semble d'après ton message que tu sais où ça se trouve mais au cas ou : YaST -> logiciels -> changer support d'installation).
Si ton lecteur hdd tourne sans arrêt, ouvre une console en mode superutilisateur : umount /dev/hdd.

loco
29/12/2004, 13h58
Originally posted by priape2@mardi 28 décembre 2004 à 01:02
Je ne sais pas si j'ai tout capté mais évites d'utiliser deux lecteurs pour l'installation (il me semble d'après ton message que tu sais où ça se trouve mais au cas ou : YaST -> logiciels -> changer support d'installation).
Si ton lecteur hdd tourne sans arrêt, ouvre une console en mode superutilisateur : umount /dev/hdd.
<div align='right'><{POST_SNAPBACK}> (index.php?act=findpost&pid=12465)[/quote]
merci
Les deux périphériques avaient été "désignés" comme source d'installation par suse, dès le départ. Je n'y étais pour rien.
J'ai modifié cela, et dans la fenêtre " changer la source d'installation", maintenant j'ai:
Suse Linux Version9.2 cd:///
(avant c'était Suse Linux Version9.2 cd:////dev/hdc;/dev/hdd)
Il est vrai que cela ne bloque plus lors de l'utilisation de Yast install de rpms.
Mais j'ai toujours ce problème de graveur qui se bloque au bout d'un certain temps de marche de la machine ?!!
Je me demande si ce n'est pas le nouveau système de "montage" des périphériques la fenêtre "Poste de travail" sur le bureau.
J'ai refait mes icônes de dvd et graveur directement sur le bureau, et voudrait supprimer cette fonction "Poste de travail". Quelqu'un sait-il où trouver ça ?
J'ai un peu fouillé mes fichiers kde en vain.
Merci