PDA

Afficher la version complète : Comment paramétrer le pare-feu de la suse 9.2?



rak
02/01/2005, 04h00
Je ne trouve pas de tuto sur le net pour paramétrer le firewall intégré à la suse 9.2pro!

Questions:

1) comment le paramétrer?
2)Est il efficace?

Merci http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

siko
02/01/2005, 10h20
Tu vas dans Yast->Sécurité et Utilisateurs->Firewall et ensuite tu te laisse guider il y à toutes les explications voulues.

Avec la 9.1 je l'avait testé avec le serveur de symantec ( je n'ai plus l'adresse http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif < ) et il avait l'air de bien fonctionner.

fredblue
02/01/2005, 11h57
Originally posted by rak@dimanche 02 janvier 2005 à 03:00
Je ne trouve pas de tuto sur le net pour paramétrer le firewall intégré à la suse 9.2pro!

Questions:

1) comment le paramétrer?

L'outil de configuration intégré à Yast est suffisamment clair. Mais si tu dois construire un VPN ou une DMZ, tu peux aussi regarder dans
/etc/sysconfig/SuSEfirewall2. Le fichier est très documenté.

Sinon, cette page est fondée sur une ancienne version de SuSEFirewall, mais les principe de base restent les mêmes en particulierl'explication sur le mode de fonctionnement du firewall. Ne tiens pas compte des aspects installations.
http://www.linux-sottises.net/partage_et_parefeu.php

Autres liens :
http://mesh.dl.sourceforge.net/sourceforge...q/firewall2.pdf (http://mesh.dl.sourceforge.net/sourceforge/susefaq/firewall2.pdf)

<div class='quotetop'>Citation </div>
2)Est il efficace?

Merci http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif[/b]
oui. mais il faut le configurer correctement et faire l'effort de comprendre netfilter.

A lire :
http://www.open-mag.com/features/11_08feat...SE_firewall.htm (http://www.open-mag.com/features/11_08feats/susefw/SuSE_firewall.htm)
Cette page de la version SuSEFirewall on CD. Ce sont les mêmes scripts de base que l'on trouve sur la SuSE 9.2. Il y a des outils d'administration en plus et une meilleure sécurisation du noyau et de la distrib dans SF on CD.

tontonsigmund
04/01/2005, 00h32
pour ce qui est du test, il y a ce site (http://scan.sygatetech.com/)

rak
04/01/2005, 02h33
merci http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

chamaeleo
04/01/2005, 11h17
Il y a aussi

ICI (https://grc.com/x/ne.dll?bh0bkyd2)

ICI (http://www.pcflank.com/about.htm)

et

Là (http://check.sdv.fr/)

rak
04/01/2005, 12h13
Je suis comblé là http://www.alionet.org/style_emoticons/<#EMO_DIR#>/rolleyes.gif

hobbywan
22/02/2005, 15h25
Bonjour,
Completement debutant avec linux, (1 sem), j'ai un probleme pour configurer le parefeu malgré tous mes efforts et mes recherches, notament le tès bon tuto sur souceforge (http://prdownloads.sourceforge.net/susefaq/firewall2-a4-0-9.pdf?download)

je suis en reseau derriere un modem routeur netgear avec 2 xp pro et suse 9.2 sur le 3eme.
si j'active le pare feu je ne n'ai plus aucun acces au reseau
sur suse je ne vois meme pas mon poste ds la liste et sur les autres je n'ai pas acces a smba(monposte)
je peux pinger faire un bureau a distance pas pas acceder aux dossiers partages.

En enlevant le parefeu tout passe impeccable.

J'ai configure le parefeu pour autoriser samba, rajoute les ports tcp et udp netbios bien qu'ils soient normalement deja ouverts avec l'options samba) cad 135 137:139 et 445 53 en tcp udp mais ca ne change rien.
aurai je oubli' qqchose?
merci

siko
23/02/2005, 08h39
Ton routeur neatger ne contient pas de parefeux?

J'ai activé le parefeux de mon routeur et je n'ai pas mis de parefeux dans mon réseau.

hobbywan
23/02/2005, 09h44
si g active le parefeu du routeur
mais j'aimerais bien qd meme reussir a parametrer celui de suze.merci

siko
23/02/2005, 12h04
Ha si c'est pour le fun http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif

Si le serveur Samba contient également un firewall ou s'il est derrière un firewall, il faut savoir que Samba utilise les ports suivant (d'après samba.org):

UDP 137 : NETBIOS Name Service

UDP 138 : NETBIOS Datagram Service

TCP 139 : NETBIOS session service

TCP 445 : Microsoft Directory Services

Le port 445 est assez récent et il semble qu'il remplacera les trois premiers (à vérifier).

Sinon il te reste de regarder ce qui passe par ton interface réseau avec ethereal.

hobbywan
23/02/2005, 15h13
c bien le prob
j'ai deja configure le parefeu en rentrant les ports que tu as indiqué g meme mis pour voir de 1:50000 en tcp udp et ca ne passe pas.
Il n'y a qu'en le désactivant que ca marche.
j'aimerais comprendre.

par exemple: si je ne mets aucune regle en expert je n'ai pas acces au bureau a distance qui passe par le port 5900+ n°display (dans mon cas le 2 donc port 5902)
si je rajoute ce port dans les regles du firewall le bureau vnc marche c'est donc bien que les parametres sont passés.
je fais la meme chose avec 135 137 138 139 445 tcp udp pas d'acces aux dossiers partages c'est fort non?
c vrai je peux m'en passer mais ça me gêne qd même.

siko
23/02/2005, 17h42
Tu n'est pas le premier a avoir des problème avec la configuration du firewall par Yast celui-ci m'a l'air bugé.

En fait les règles sont écrites dans le fichier /etc/sysconfig/SuSEfirewall2 tu l'édites avant et après une modif par Yast pour voire ce qu'il à changé.

hobbywan
25/02/2005, 11h51
toujours pas trouvé!
je desactive le parefeux pour qu'il ne se lance pas au demarrage et j'ai acces au réseau. je l'active ensuite avec mes parametres de port netbios ouvert sans reboot et j'ai toujours acces.
si je reboote sans rien changer le parefeu se lance donc au demarrage et la pas d'acces reseau
je n'y comprends rien.
J'ai edite le fichier de config je n'ai rien vu n'anormal apparement

siko
25/02/2005, 13h13
Attention la configuration du Firewall peut-être contenue dans plusieurs fichiers. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/blink.gif

Le firewall a trois niveaux de démarrage c'est peut-être là qu'il faut chercher.

hobbywan
25/02/2005, 15h23
oui je pense aussi mais la c plus dur lol