PDA

Afficher la version complète : [Réglé] Driver Nvidia FX5200 : accélération 3D... pour root !



herisson26
05/01/2007, 19h17
Bonjour à tous,

J'ai un cas que je n'ai pas retrouvé ailleurs sur internet... Et qui m'amuserait s'il n'était gênant.
J'ai une Nvidia FX5200 et OpenSuSE 10.2. J'ai donc installé les drivers comme le conseille le tuto de SuSE, en passant par YaST parce que c'est plus simple.
Tout s'est bien déroulé, et le test à coup de SaX2 m'a confirmé que j'avais des drivers nvidia et l'accélération 3D activée.

Je relance le système graphique et là, surprise...

herisson26@viso:~> fglrxinfo
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0.0 screen: 0
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce FX 5200/AGP/SSE/3DNOW!
OpenGL version string: 2.1.0 NVIDIA 96.31

J'ai bien les bons drivers, mais le DRI manque...

Je vous passe le détail des pérégrinations à la recherche d'une solution (modifs à la main du xorg.conf pour rajouter Loadd "DRI", ...), et voilà où j'en suis aujourd'hui :


herisson26@viso:~> glxinfo | grep direct
Xlib: extension "XFree86-DRI" missing on display ":0.0".
direct rendering: No

herisson26@viso:~> su
Mot de passe :
viso:/home/herisson26 # glxinfo | grep direct
direct rendering: Yes

Vous voyez le soucis ? Le root a une accélération 3D qui fonctionne (fgl_glxgears donne 233 fps), mais l'utilisateur normal non (fgl_glxgears ne se lance pas, se plaignant de l'absence de DRI).

Maintenant, le truc qui tue :


herisson26@viso:~> su -
Mot de passe :
viso:~ # glxinfo | grep direct
Xlib: extension "XFree86-DRI" missing on display ":0.0".
direct rendering: No

Si je fais su - au lieu de su, le root non plus n'a plus l'accélération !!! http://www.alionet.org/style_emoticons/<#EMO_DIR#>/blink.gif

Si vous avez une idée, je suis preneur... Parce que moi, je nage complètement...

Cordialement,

herisson26
07/01/2007, 11h20
Bonjour tout le monde,

Petit à petit, je progresse...
J'ai découvert une variable d'environnement qui n'était pas passée au su : LD_LIBRARY_PATH="/usr/lib/xorg" est présente lorsque je lance un terminal, mais disparaît lorsque je fais su...

Du coup, j'ai fait le test simple :

declare -x LD_LIBRARY_PATH=

Et là, tadaaaam !


herisson26@viso:~> fgl_glxgears
Using GLX_SGIX_pbuffer
1178 frames in 5.0 seconds = 235.600 FPS

Ça marche...

Question suivante : comment faire pour que, dès le lancement, LD_LIBRARY_PATH soit vide ?

Désolé si cette question paraît idiote...

Merci d'avance.

Clark
07/01/2007, 13h59
Salux !

A la fin de ton /etc/X11/xorg.conf, tu dois rajouter
Section "dri"
Mode 0666
EndSection
Après un redémarrage, cela donne aux utilisateurs d'utiliser le direct rendering, donc la 3D.

herisson26
07/01/2007, 15h34
Bonjour, et merci pour votre réponse.

Bon, j'avais dans mon xorg.conf

Section "DRI"
Group video
Mode 0660
EndSection

Normalement, pas de soucis puisque mon utilisateur normal fait partie du groupe video.
J'ai quand même simplifié :

Section "DRI"
Mode 0666
EndSection

Aucun changement.

Mais j'ai toujours cette solution bâtarde d'écraser LD_LIBRARY_PATH :

export LD_LIBRARY_PATH=""

Et là, ça marche, avec un fgl_glxgears à 200 fps.

(Éclair de génie : )
Est-ce que ça vous paraît possible qu'il y ait un lien avec le fait que j'utilisais avant (ventilo grillé) une carte ATI ?

Je sais, je suis débile de pas avoir dit ça plus tôt !

Clark
07/01/2007, 20h04
effectivement, il me semblait très étonnant de voir une commande "fglrx" avec un résultat en "Nvidia" ! A mon avis, il faut tenter une désinstallation totale de fglrx (qui est le driver pour les ATI), et réinstaller le pilote nivia.

Pour tester le résultat :

glxinfo | grep rendering
Ça doit répondre : direct rendering : Yes (ou NO)

herisson26
10/01/2007, 14h57
Bonjour,

On progresse !
Après avoir viré les drivers ATI (NB : le fichier d'installation comporte un désinstalleur, mais il l'efface à la fin de l'installation, me demandez pas pourquoi. Il faut donc refaire une installation avec l'option pour ne pas supprimer les fichiers d'installation pour enfin pouvoir désinstaller... Ça vaut le «Démarrer -> Arrêter» de Windows !), et refait la configuration nvidia, j'ai enfin une situation un peu plus saine.

Le truc amusant, c'est que

herisson26@viso:~> glxinfo | grep direct
direct rendering: No

mais glxgears à plus de 1000 fps, celestia qui fonctionne parfaitement (pourtant, il paraît qu'il est plutôt gourmand), neverball sans problème...

Bon, quand j'aurai du temps, je referai une installation «from scratch». En attendant, ça paraît bon.

Merci beaucoup pour les conseils.