PDA

Afficher la version complète : [Réglé] Installation driver ATI, l'éternel sujet



Denebe
08/01/2007, 21h29
Bonjour,

J'ai une Opensuse x86_64 et j'essaie d'installer ce driver: ati-driver-installer-8.32.5-x86.x86_64.run.
Je suis dans un terminal et en root. Voici un copier coller de mon terminal:
<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>linux-tvyc:/home/thierry/Desktop # ./ati-driver-installer-8.32.5-x86.x86_64.run --listpkg
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.32.5............................................ ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
.......................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
List of generatable packages:

Package Maintainer(s): Aric Cyr <aric.cyr@ati.com>
Status: Verified
Debian Packages:
Debian/sarge
Debian/stable
Debian/sid
Debian/unstable
Debian/etch
Debian/testing
Debian/experimental

Package Maintainer(s): Niko Mirthes <nmirthes@gmail.com>
Michael Larabel <michael@phoronix.com>>
Status: *UNVERIFIED*
Fedora Packages:
Fedora/FC3
Fedora/FC4
Fedora/FC5
Fedora/FC6
Fedora/RHEL3
Fedora/RHEL4

Package Maintainer(s): Arnaud Patard <apatard@mandriva.com>
Status: Verified
Mandriva Packages:
Mandriva/2006
Mandriva/2007

Package Maintainer(s): Bowen Zhu <bwzhu@redflag-linux.com>
Status: *UNVERIFIED*
RedFlag Packages:
RedFlag/RF50

Package Maintainer(s): ATI
Status: Verified
RedHat Packages:
RedHat/RHEL3_64a
RedHat/RHEL3
RedHat/RHEL4_64a
RedHat/RHEL4

Package Maintainer(s): Stefan Dirsch <sdirsch@suse.de>
Status: Verified
SuSE Packages:
SuSE/NLD9-AMD64
SuSE/SLES9-AMD64
SuSE/SUSE91-AMD64
SuSE/NLD9-IA32
SuSE/SLES9-IA32
SuSE/SUSE91-IA32
SuSE/SUSE100-AMD64
SuSE/SUSE92-AMD64
SuSE/SUSE93-AMD64
SuSE/SUSE100-IA32
SuSE/SUSE92-IA32
SuSE/SUSE93-IA32
SuSE/SLED10-AMD64
SuSE/SLES10-AMD64
SuSE/SUSE101-AMD64
SuSE/SLED10-IA32
SuSE/SLES10-IA32
SuSE/SUSE101-IA32
SuSE/SUSE102-AMD64
SuSE/SUSE102-IA32

Package Maintainer(s): Aric Cyr <aric.cyr@gmail.com>
Status: Verified
Ubuntu Packages:
Ubuntu/warty
Ubuntu/4.10
Ubuntu/hoary
Ubuntu/5.04
Ubuntu/breezy
Ubuntu/5.10
Ubuntu/dapper
Ubuntu/6.06
Ubuntu/edgy
Ubuntu/6.10

For example, to build a Debian Etch package, run the following:
% ./ati-driver-installer-<version>-<architecture>.run --buildpkg Debian/etch

Removing temporary directory: fglrx-install
linux-tvyc:/home/thierry/Desktop # ./ati-driver-installer-8.32.5-x86.x86_64.run --buildpkg SuSE/SUSE102-AMD64
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.32.5............................................ ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
.......................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: SuSE/SUSE102-AMD64
/tmp/ati.I13006
cp: opérande du fichier cible manquant après `/home/thierry/Desktop'
Pour en savoir davantage, faites: « cp --help ».
basename: opérande manquante
Pour en savoir davantage, faites: « basename --help ».
Package /home/thierry/Desktop/ has been successfully generated
Removing temporary directory: fglrx-install
linux-tvyc:/home/thierry/Desktop #[/quote]
Mon bureau est vide de tout fichier rpm.
Normalement je devrais avoir un fichier rpm, non ?



Et quand j'essaie l'installeur ati, ça me donne ça:
[quote]linux-tvyc:/home/thierry/Desktop # chmod u+x ati-driver-installer-8.32.5-x86.x86_64.run
linux-tvyc:/home/thierry/Desktop # ./ati-driver-installer-8.32.5-x86.x86_64.run
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.32.5............................................ ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
.......................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Detected configuration:
Architecture: x86_64 (64-bit)
X Server: Unknown X Window
cp: ne peut évaluer `x710_64a/usr/X11R6/bin/*': Aucun fichier ou répertoire de ce type
find: install/usr/bin/fireglcontrolpanel: Aucun fichier ou répertoire de ce type
Removing temporary directory: fglrx-install
linux-tvyc:/home/thierry/Desktop #
</div>
Je n'ai pas plus de fichier rpm ou quoi que ce soit.
Ceci en ayant sélectionné l'option pour créer spécifiquement le package pour la suse x86_64.
Je suis bloqué...

galagann
09/01/2007, 15h25
Merci d'aller voir le Wiki, car la solution traîne par là depuis en certain temps http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

Denebe
09/01/2007, 19h25
Salut galagann,

Bon, j'ai suivi à peu près le wiki. Et j'ai réussi l'installation "à peu près". A peu près car j'ai eu des message d'erreur pendant l'installation. Mais je suis incapable d'indiquer où, quand et comment ils sont arrivés, ni ce qu'ils disaient. Chouette, une avancée tout de même: mes fenêtres bougent correctement http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif . Dans matériel/informations sur le matériel, il est indiqué que mon driver est bien fglrx_pci.

J'ai quelques soucis quand même.
1_Il m'est impossible de modifier quoi que ce soit dans "carte graphique et moniteur". On me demande mon mot de passe, puis plus rien.
2_A logiciel installé, il y a un cadena sur le driver que je viens d'installer, c'est normal ?
http://img182.imageshack.us/img182/1163/capturehn8.th.png (http://img182.imageshack.us/my.php?image=capturehn8.png)
3_Et sur ce même logiciel, c'est indiqué 7.1. Ca devrait être 7.2 non ? (c.f. l'image ci-contre)
4_Je n'ai accès à aucun choix du genre "activer l'accélération 3d".

Merci pour vos indications,
Denebe.

jeancayron
10/01/2007, 11h34
J'ai aussi installé le driver par l'install automatique (j'ai une ATI) car pas moyen de faire un rpm. Pas moyen de faire un aticonfig, message d'erreur.
Même chose pour les soucis sauf que je peux changer des trucs dans carte graphique et moniteur (sax2) mais dès que je change quelque chose, plus moyen de démarrer le serveur X. Ma config habituelle (VESA à 75Hz) m'a fait planter le truc.
Résultat, seule solution que j'ai eu, redémarrer en mode texte (avec "init 3" comme option de démarrage), désinstaller le driver par le script de désinstallation de fglrx et de reconfigurer le driver libre Radéon. Ca m'a gâché la soirée. Bref, malgré qu'il "supporte" (le mot est bien choisi) la 10.2, ce driver n'est pas encore au top pour ses fonctionnalités (surtout pour les débutants).

Peut-être qu'avec la méthode wiki ça ira mieux.

tindouf
11/01/2007, 11h12
Bonjour,

Le beaujolais nouveau est arrivé, Ati a mis en ligne hier un nouveau driver : 8.33.6.5-x86.x86_64.

Et bien apres 8 jours de bataille avec ma carte Ati (X1650) et bien bonne nouvelle elle est enfin reconnue comme une x1600 (c'est toujours mieux que les scroll's).

Pour mon premier poste c'est une bonne nouvelle.

Bonne journee a toutes et tous.

@+

Lenglemetz
11/01/2007, 11h15
Bienvenue a toi tindouf

Très bonne nouvelle, je profite également du beaujolais nouveau. Ma X700 et ma 9800 Pro sont parfaitement reconnu sous Xorg RC3 http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif

adminlinux
11/01/2007, 12h11
on va pouvoir acheter des cartes ati alors !!

Lenglemetz
11/01/2007, 12h13
Ben perso je n'ai jamais eu de problème avec ATI, les gens râles trop rapidement..... surtout pour ATI

adminlinux
11/01/2007, 12h29
ben les 2 dernière ati en été remplacé par des nvidia..

Denebe
11/01/2007, 21h27
Bon je vais réinstallé tout ça (newbee je suis, comme cela j'apprends aussi: répéter les étapes...). En espérant que ça s'installe hilico...

Denebe
12/01/2007, 04h14
Je viens d'installer opensuse x86_64 avec le dernier driver ati officiel, mais il y a toujours deux trois trucs qui m' interrogent:

1) après avoir rendu le .run executable, m'être identifier en root dans une console, avoir tapé init 3, lorsque je lance ./ati.......run, juste avant la fenêtre d'installation ati, j'ai ce message
<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>linux-by15:/home/thierry/Desktop # ./ati-driver-installer-8.33.6-x86.x86_64.run
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.33.6............................................ ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
.................................................. ..............................
..................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Detected configuration:
Architecture: x86_64 (64-bit)
X Server: Unknown X Window
cp: ne peut évaluer `x710_64a/usr/X11R6/bin/*': Aucun fichier ou répertoire de ce type
find: install/usr/bin/fireglcontrolpanel: Aucun fichier ou répertoire de ce type</div>Qu'est-ce que ça signifie ?

2) une fois cette première étape passée, je réponds logiquement aux questions et on me demande un chemin d'installation (installation path). Que faut-il y indiquer ? (j'y donne un chemin quelconque)

3) ensuite pour finir, malgré avoir tout le temps choisi la création personnalisée du package pour la suse 10.2, au final je me retrouve toujours avec un choix entre plusieurs "redhat packages" ! A ce moment j'arrête l'installation... Qu'en pensez-vous ?

4) la seule méthode qui marche (à ceci près que je ne sais pas ce qui se passe), c'est de choisir une installation en automatique (après un init 3 lancé en root dans une console), puis de faire aticonfig --initial et init 5. Cette obligation de passer en automatique m'interroge (j'ai l'impressoin de revenir à window http://www.alionet.org/style_emoticons/<#EMO_DIR#>/rolleyes.gif ), j'aurais bien aimer en savoir un peu plus...

Bye, Denebe.

Denebe
13/01/2007, 06h25
Euréka, héhé, enfin une installation qui me plaît http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif


-tout d'abord, j'ai configuré l'affichage dans YaST, pour qu'il fasse une rotation à gauche (sinon plus loin un menu est inaccessible (dans mon cas oui...)).
-J'ai téléchargé le pilote sur ati.com ati-driver-installer-8.33.5-....run.
-j'ai ouvert une console en root.
-j'ai lancé ./ati-driver-8.33.............run
-j'ai créé un rpm pour suse 10.2/AMD64. (c'est ici que le menu est inaccessible sans rotation de l'écran)
-j'ai repris la console en su et j'ai tapé "init 3"
-j'ai créé une copie de sauvegarde de "Xorg.conf."
-j'ai été dans le répertoire du rpm par "cd /urc/src/packages/RPMS/x86_64/"
-j'ai installée le rpm par "rpm -ivh fglrx_7_0_1....rpm".
-j'ai juste lancé en console root "sax2 -r -m 0=fglrx".
-voilà c'est fini, l'affichage de l'écran s'est automatiquement remis droit et j'ai accès à plus d'options.

merci à cedricSCL pour son post qui m'a bien aidé.
----------------------------------------------------------------------
En effectuant toutes les opérations en console avec "init 3" au début, à un moment je n'avais pas accès à tous les packages, en particulier celui qui m'intéressait... voilà pourquoi j'ai créé le package en mode graphique.

bye bye http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

manu088
14/01/2007, 00h27
Désolé pour mon ignorance....mais.....comment je fais pour créer un rpm à partir d'un .run ???

Denebe
14/01/2007, 00h54
Salut,

Pas de soucis, j'ai écris la fin de ce post pour aider, pas de désolé ici http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

En fait, tu dois te trouver dans une console en root (tape "su" puis ton mot de passe), ensuite tu vas dans le répertoire où se trouve le fichier "ati-driver.......run" (à l'aide de la commande "cd ......."), et tu tapes "./ati-driver......run" (tape ./at puis utilises la touche tab ça aide).

Normalement une fenêtre s'ouvre, c'est ce qui te permet de créer ton fichier .........rpm (rpm est une extension). Tu choisis la deuxième proposition (donc pas en automatique), et tu continues jusque la fin (exit). Tu dois tout du long privilégier la personnalisation de la création de package en fonction de la distribution opensuse (naturellement). Fais attention à la distribution que tu utilises (chaque cas est différent). Moi j'ai une opensuse 10.2 x86_64. Si tu as une 10.2 x86, fais ton choix en conséquence.

Bref, une fois que tu as appuyer sur la touche "exit", ton fichier .rpm est créé (pour moi c'était dans /usr/src/packages/RPMS/x86_64/).

N'hésite pas si besoin est.

manu088
14/01/2007, 11h34
alors....j'ai fait tout comme tu m'as indiqué....mais mon rpm n'est pas créé.... http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

dans ma console j'ai ca :

<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>
ot de passe :
linux-s5es-manu:/home/manu/Desktop # ./ati-driver-installer-8.32.5-x86.x86_64.ru n
Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.32.5............................... .................................................. .............................. .................................................. .............................. .................................................. .............................. .................................................. .............................. .................................................. .............................. .................................................. .............................. .................................................. .......................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Detected configuration:
Architecture: i686 (32-bit)
X Server: Unknown X Window
cp: ne peut évaluer `x710/usr/X11R6/bin/*': Aucun fichier ou répertoire de ce ty pe
find: install/usr/bin/fireglcontrolpanel: Aucun fichier ou répertoire de ce type
Removing temporary directory: fglrx-install
linux-s5es-manu:/home/manu/Desktop #
</div>

voici les infos quand à la version de suse que j'utilise :
Linux 2.6.18.2-34-xen i686
Utilisateur actuel : manu@linux-s5es-manu
Système : openSUSE 10.2 (i586)
KDE : 3.5.5 "release 50.1"

Denebe
14/01/2007, 17h29
<div class='quotetop'>Citation </div>
Fais attention à la distribution que tu utilises (chaque cas est différent). Moi j'ai une opensuse 10.2 x86_64. Si tu as une 10.2 x86, fais ton choix en conséquence[/b]Comme je l'ai écris précédemment, tu dois choisir le type de package en fonction de la distribution que tu as installée.
Moi j'ai choisis l'opensuse x86_64, mais tu as installé l'opensuse x86 (je le vois dans le message Detected configuration: Architecture: i686 (32-bit).

Ainsi tu dois choisir suse 10.2/IA32 Recommence, ça devrait fonctionner.

Quant à <div class='quotetop'>Citation </div>
cp: ne peut évaluer `x710/usr/X11R6/bin/*': Aucun fichier ou répertoire de ce type
find: install/usr/bin/fireglcontrolpanel: Aucun fichier ou répertoire de ce type[/b]J'ai eu le même message, je ne peux pas t'en dire plus au risque de dire des conneries, ce qui ne t'avancerait pas plus...

manu088
14/01/2007, 18h43
Ainsi tu dois choisir suse 10.2/IA32 Recommence, ça devrait fonctionner.[/b]


C'est ce que j'essaie d'installer depuis le debut http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

mais ca ne fonctionne pas

Denebe
14/01/2007, 20h02
Qu'est-ce que tu entends par ça ne fonctionne pas ? (une fois que le programme a fini son exécution, il n'y a rien d'exceptionnel: va juste vérifier si dans le répertoire /usr/src/packages/RPMS/i386 il y a un fichier rpm)

Est-ce que tu as pu appuyer sur le bouton exit ?

Shikamaru2599
15/01/2007, 19h26
Bonjour a tous!

je poste dans le meme sujet je sais pas si je devrait enfin bon.....

moi j'ai reussit a installer le pilote en installation automatique (pour une radeon x1600) sous SuSE 10.2 x86_64, seulement je n'ai pas de 3d :-( apparament le probleme vient de xorg 7.2 rc2 (celui que j'ai donc)
aprés avoir lu pas mal d'articles, de wiki et autres forums j'ai entendu tout les sons de cloches!!! ma conclusion serait de repasser sous xorg 7.1....
Est ce une bonne solution?
Si oui....et bien comment le faire????

J'attend vos reactions ou vos reponses car la je desespere totalement et j'en ai un peu marre de suivres des tutos qui ne menent a rien sauf un plantage du serveur X...
Voila merci beaucoup!!!

Denebe
15/01/2007, 21h06
Salut,

Oui, j'avais "réussi" aussi en automatique, mais je préfère tout de même le faire en manuel (en partie au moins). Si tu veux tester, il te faut désinstaller les drivers que tu viens d'installer, mettre à jour xorg à la version 7.2rc3 sur ce dépot http://software.opensuse.org/download/xorg72/openSUSE_10.2/, et suivre les étapes indiquées ci-dessus.

Comment le désinstaller ? dans application, il y a un truc qui s'appelle "désinstaller un programme"...

Heu, sinon j'ai une x1950xt, donc si ça marche chez moi, ça devrait marcher chez toi sans problème.

Pour tester si la 3d est activée, tape "glxgears" ou bien "glxinfo | grep rendering". Dans le premier cas, les engrenages doivent tourner avec fluidité, dans le second, il te répond si oui ou non la 3d est activée.

Sinon je suis assez d'acord avec toi, il y a pas mal de tutos périmés qui ont pour conséquences, pour un débutant (dont je fait partie), de perdre grossomodo 1h00 de réinstallation suivant la machine (j'ai mis perso environ 40h00 sinon plus à trouver une distribution qui me plait et installer correctement le driver ati). Oui, on me dit dans l'oreillette http://www.alionet.org/style_emoticons/<#EMO_DIR#>/rolleyes.gif qu'il n'y a pas besoin de réinstaller et que c'est rattrapable ! mais pour un débutant qui n'a personne pour le guider, et bien non..
Par ailleurs, souvent dans les tutos, une commande sur deux ne fonctionne pas car inconnue (j'exagère à peine).

Bye bye.

Shikamaru2599
17/01/2007, 00h42
Saluxx!

je vien de faire pas a pas ta methode (denebe) mon pilote s'installe correctement lorsque je tape glxgears, c'est fluide ,lorsque je tape glxinfo |rendering ,il me repond "yes" mais impossible de cocher la case "activer l acceleration 3d" dans "Sax2" qui reste grisée....
De plus, j'aimerais activer les effets xgl pour profiter du bureau en 3d (raison pour laquelle jaimerais reussir a installer mes pilotes en plus de pouvoir jouer a UT2004!!!)mais il me di que ma carte ne le supporte pas......(ati x1600 512Mb ddr2 en pci-express) si cette carte ne fonctionne pas avec ces effets alor que faut-il??? une carte a 250€??!!!?!?

Donc je suppose qu'il va faloir attendre deja
1) La sortie de Xorg 7.2 finale
2) Que Ati se soucie un peu plus des utilisateur Linux
3)Qu'ils sortent enfin un pilote correcte et 100% fonctionnel avec une sorte de catalyst comme sous windobe afin de pouvoir regler et profiter de son investissement (j'ai quand meme mis 150€ pour cette carte ! ! !)
4) La prochaine carte que j'achete c'est une NVidia ! ! ! (et oui desolé! lol)

Enfin c'etait tout de meme trés gentil de mavoir aider, au moin je peu profiter du 1440x900 sur mon ecran 16:10 ! merci beaucoup!!!!!

cordialemnt,
Vivien

Denebe
17/01/2007, 01h50
Salut,
Une fois installé le driver ati, vérifie que l'accélération 3d est présente en tapant:
glxinfo | grep rendering ou bien glxgears.

Après ceci, vérifie que tous ces paquets soient installés:
compiz, xgl, xgl-hardware-list, gnome-session et libwnck.

Tu vas dans menu, centre de contrôle puis effet de bureau. Normalement, tu devrais voir "accélération 3d: activé". Il ne te reste plus qu'à activer les effets de bureau (on te demandera ton mot de passe su, puis de fermer la session).

Remarque: si à "accélération 3d" c'est indiqué "Désactivé" et que grâce au test ci-dessus, tu es sûr d'avoir l'accélération 3d d'activée, lorsque tu as la fenêtre "paramètres des effets du bureau" devant toi, tu appuyes sur "shift" (en restant appuyé), et tu cliques là où c'est écrit "Désactivé". Ceci a pour effet de reprendre le pouvoir sur la machine (sale bête!!): elle considère maintenant que tu as l'accélération 3d d'activée et te propose maintenant d'activer les effets de bureau...
Personnellement, c'est ce que j'ai fait: pour une raison ou pour une autre (base de données obsolètes ou un petit bug), l'accélération 3d n'était pas reconnue. Pour l'obtenir, j'ai procédé comme indiqué ci-dessus.

Allez, c'est pour bientôt le bureau en 3d, tu as fais le plus dur http://www.alionet.org/style_emoticons/<#EMO_DIR#>/cool.gif
Denebe.

Shikamaru2599
17/01/2007, 12h34
Bonjour,

je vien de faire tout ca, mais ca ne fonctionne pas... J'ai bien tout les paquets que tu as citer, glxinfo|grep me di que la 3d est activé mais il m'est toujours impossible d'activer ni la 3d dans Sax(meme en maintenant shift), ni d'activer les effets xgl... Bon je vais persistermais une chose qui m'interpelle: dans Sax il reconnait ma carte comme VESA Framebuffer graphics et mon moniteur comme un Ati (?!?)

Autre chose sinon moi je me logue toujours en root sur ma machine carje ne supporte pas davoir a taper mon mot de passe toutes les 30 seconde ou alors certaine restriction (genre: vous n'avez pas les droit.....etc... j'ai bien le droit quand meme de faire ce que je veut sur mon pc! lol)

Me loguer toujours en root pose t'il un probleme a ce niveau??

En tout cas merci bien tu m'as beaucoup aider deja pour le debutant que je suis!!

Vivien

Cthulhu
17/01/2007, 13h00
<div class='quotetop'>Citation </div>
je vien de faire tout ca, mais ca ne fonctionne pas... J'ai bien tout les paquets que tu as citer, glxinfo|grep me di que la 3d est activé mais il m'est toujours impossible d'activer ni la 3d dans Sax(meme en maintenant shift), ni d'activer les effets xgl... Bon je vais persistermais une chose qui m'interpelle: dans Sax il reconnait ma carte comme VESA Framebuffer graphics et mon moniteur comme un Ati (?!?)[/b]
J'ai moi aussi constaté ce "VESA".. mais si tu vas faire 1 tour dans ton fichier xorg.conf tu devrais voir que ce mot n'est utilisé que pour nommer ta carte et que le driver utilisé est bien fglrx... c'est juste 1 info que tu dois pouvoir modifier sans problème. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif
Si ce n'est pas le cas... c'est que tes drivers ne sont pas correctement installés/configurés.
<div class='quotetop'>Citation </div>
Me loguer toujours en root pose t'il un probleme a ce niveau??[/b]
Est-il nécessaire de répondre ? http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif
Ce n'est pas 1 problème.. juste une erreur (niveau sécurité) pour la bonne stabilité du système.
Perso.. je ne vois pas pourquoi tu dois entrer sans cesse ton password root... il ne t'ai demandé que lorsque tu souhaites paramétrer/configurer/ajouter 1 soft lié au système. Pour l'utilisation courante de Suse et ses programmes... tu n'as pas besoin de ce password.

Shikamaru2599
17/01/2007, 19h39
Merci pour toutes ces infos c'est bien au moins j'apprend plein de chose sur Linux ! ! !

EDIT: Voici kan meme une partie de xorg.conf ce qui me gene c'est que dans la premiere section Device c'est marqué Driver = "fbdev"

Et en dessous c'est bien marqué "fglrx"
Bon d'accord je suis nul......


Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "fbdev"
VendorName "VESA"
BoardName "Framebuffer Graphics"
Option "Rotate" "cw"
BusID "5:0:0"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
EndSection

tindouf
17/01/2007, 23h57
Merci pour toutes ces infos c'est bien au moins j'apprend plein de chose sur Linux ! ! !

EDIT: Voici kan meme une partie de xorg.conf ce qui me gene c'est que dans la premiere section Device c'est marqué Driver = "fbdev"

Et en dessous c'est bien marqué "fglrx"
Bon d'accord je suis nul......


Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "fbdev"
VendorName "VESA"
BoardName "Framebuffer Graphics"
Option "Rotate" "cw"
BusID "5:0:0"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
EndSection[/b]
Salut,

Ton xorg.conf semble etre la version avant de lancer aticonfig.

Tu devrais plutot nous donner le fichier xorg.0.log qui se trouve dans /var/log/

@+

Shikamaru2599
18/01/2007, 15h06
Luxx!

J'avais pourtant bien fait
#ldconfig
suivi de
#aticonfig --initial

Xorg.0.log :

Le fichier que tu me demande est beaucoup trop gros pour etre envoyer sur le forum !
Tout ce que je peut en dire (ce genre de fichier est du chinois pour moi!) c'est qu'il est bourré d'erreurs! failed failed failed et encore failed ! ! !

En voici tout de meme 2 petit morceaux.....

<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan 18 12:54:49 2007
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Layout[all]"
(**) |-->Screen "aticonfig-Screen[0]" (0)
(**) | |-->Monitor "aticonfig-Monitor[0]"
(**) | |-->Device "aticonfig-Device[0]"
(**) |-->Input Device "Keyboard[0]"
(**) |-->Input Device "Mouse[1]"
(WW) The directory "/usr/share/fonts/local" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/PEX" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/latin2/misc" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/latin2/75dpi" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/latin2/100dpi" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/latin2/Type1" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/latin7/75dpi" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/baekmuk" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/japanese" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/kwintv" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/CID" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/ucs/misc" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/ucs/75dpi" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/ucs/100dpi" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/hellas/misc" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/hellas/75dpi" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/hellas/100dpi" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/hellas/Type1" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/fonts/xtest" does not exist.
Entry deleted from font path.
</div>

<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>
(II) fglrx(0): driver needs X.org 7.1.x.y with x.y >= 0.0
(II) fglrx(0): detected X.org 7.1.-1.903
(II) Loading extension ATIFGLRXDRI
(II) fglrx(0): doing DRIScreenInit
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: Searching for BusID PCI:5:0:0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: drmOpenMinor returns 9
drmOpenByBusid: drmGetBusid reports
drmOpenDevice: node name is /dev/dri/card1
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card2
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card3
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card4
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card5
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card6
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card7
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card8
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card9
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card10
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card11
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card12
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card13
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card14
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: open result is -1, (No such device)
drmOpenDevice: Open failed
drmOpenByBusid: drmOpenMinor returns -19
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
</div>

Merci de vous acharner autant a mon probleme c'est trés sympa ! !
Cordialement,

Shikamaru2599
18/01/2007, 19h16
J'ai finit par formatter , reinstaller SuSE, mis a jour mon xorg et la j'ai refait toutes les etapes une a une...et la oh! surprise il y a la 3D les effets xgl et tout et tout ! ! !

Je tiens tous a vous remercier car c'est graces a vos informations que j'ai reussit c'est parfait maintenant je vais pouvoir m'attaquer a autre chose! lol

En tout cas merci pour votre aide et si le createur du sujet pouvait mettre [resolu] car ce n'est pas moi le createur de ce topic.

Vivien

Denebe
18/01/2007, 20h04
lol, voyant le topic utile pour une autre personne, je venais juste de le réouvrir.

je le laisse ouvert un moment, ça peut servir pour d'autre propriétaire d'ati.

Maintenant que tu as ton driver d'installé, est-ce que tu pourrais tester la lecture de dvd ? (ce serait cool http://www.alionet.org/style_emoticons/<#EMO_DIR#>/rolleyes.gif )
Pourquoi --> http://www.alionet.org/index.php?showtopic=14295

Shikamaru2599
18/01/2007, 21h02
Je vais tester ca de ce pas si ca peut aider je vais le faire bien sur !

Cependant je ne lis pas de dvd avec mon PC ni de divx (c'est pas bien de telecharger !)
Je possede un DVD de salon mais je vais tout de meme essayer ca

Merci encore je posterai mes resltats dans l'autre topic
Vivien

hunagoca2
18/01/2007, 22h05
bonjour ça fait 3 jours que je galere avec ces driver ati
es-ce que quelqu'un peut m'aider
voici mes messages d'erreurs dans Xorg.0.log


Current Operating System: Linux linux 2.6.13-15.13-default #1 Tue Nov 28 13:43:50 UTC 2006 i686
Build Date: 09 January 2007
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan 18 20:56:12 2007
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Layout[all]"
(**) |-->Screen "Screen[0]" (0)
(**) | |-->Monitor "Monitor[0]"
(**) | |-->Device "Device[0]"
(**) |-->Input Device "Keyboard[0]"
(**) |-->Input Device "Mouse[1]"
(WW) The directory "/usr/X11R6/lib/X11/fonts/100dpi" does not exist.
Entry deleted from font path.
-


(WW) The directory "/usr/X11R6/lib/X11/fonts/Speedo" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/PEX" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/latin2/misc" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/latin2/75dpi" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/latin2/100dpi" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/latin2/Type1" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/latin7/75dpi" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/baekmuk" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/japanese" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/kwintv" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/X11R6/lib/X11/fonts/ucs/misc" does not exist.


(WW) Open APM failed (/dev/apm_bios) (No such file or directory)

(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
(--) Chipset RADEON 9600 (RV350 4150) found

(WW) fglrx(0): board is an unknown third party board, chipset is supported
(WW) fglrx(0): Specified desktop setup not supported: 8


(WW) fglrx(0): ***********************************************
(WW) fglrx(0): * DRI initialization failed! *
(WW) fglrx(0): * (maybe driver kernel module missing or bad) *
(WW) fglrx(0): * 2D acceleraton available (MMIO) *
(WW) fglrx(0): * no 3D acceleration available
(WW) fglrx(0): ********************************************* *

WW) fglrx(0): Option "IgnoreEDID" is not used
(WW) fglrx(0): Option "NoTV" is not used
(WW) fglrx(0): Option "CalcAlgorithm" is not used
Could not init font path element /usr/X11R6/lib/X11/fonts/local, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID, removing from list!


tout ça en suivant le wiki,j'espere que ça vous parle.
merci d'avance

Denebe
18/01/2007, 22h23
Et ton xorg.conf, ça donne quoi ?

hunagoca2
18/01/2007, 23h09
Et ton xorg.conf, ça donne quoi ?[/b]

voila le xorg.conf
# /.../
# SaX generated X11 config file
# Created on: 2007-01-18T19:35:15+0100.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2002
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/ttyS0"
InputDevices "/dev/ttyS1"
InputDevices "/dev/ttyS2"
InputDevices "/dev/ttyS3"
InputDevices "/dev/ttyS4"
InputDevices "/dev/ttyS5"
InputDevices "/dev/ttyS6"
InputDevices "/dev/ttyS7"
InputDevices "/dev/ttyS8"
InputDevices "/dev/psaux"
InputDevices "/dev/logibm"
InputDevices "/dev/sunmouse"
InputDevices "/dev/atibm"
InputDevices "/dev/amigamouse"
InputDevices "/dev/atarimouse"
InputDevices "/dev/inportbm"
InputDevices "/dev/gpmdata"
InputDevices "/dev/mouse"
InputDevices "/dev/usbmouse"
InputDevices "/dev/adbmouse"
InputDevices "/dev/input/mice"
InputDevices "/dev/input/event0"
InputDevices "/dev/pointer0"
InputDevices "/dev/pointer1"
InputDevices "/dev/pointer2"
InputDevices "/dev/pointer3"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection
Section "Module"
Load "dri"
Load "glx"
Load "type1"
Load "extmod"
Load "dbe"
Load "freetype"
Load "v4l"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "fr"
Option "XkbModel" "pc102"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "ImPS/2 Generic Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
DisplaySize 340 270ModelName "PROVIEW 782"
Option "DPMS"
VendorName "PTS"
VertRefresh 43-75
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1280x1024" 134.70 1280 1368 1504 1728 1024 1025 1028 1068
Modeline "1024x768" 79.50 1024 1080 1192 1360 768 769 772 801
Modeline "800x600" 47.50 800 840 920 1040 600 601 604 626
Modeline "640x480" 29.80 640 664 728 816 480 481 484 501
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "RV350 AP"
BusID "1:0:0"
Driver "fglrx"
Identifier "Device[0]"
Option "FSAADisableGamma" "no"
Option "TVHPosAdj" "0"
Option "Stereo" "off"
Option "FSAAMSPosX3" "0.000000"
Option "CenterMode" "off"
Option "FSAAMSPosY0" "0.000000"
Option "ScreenOverlap" "0"
Option "mtrr" "off"
Option "FSAAMSPosX4" "0.000000"
Option "FSAAMSPosY1" "0.000000"
Option "IgnoreEDID" "off"
Option "ForceGenericCPU" "no"
Option "NoTV" "yes"
Option "FSAAScale" "1"
Option "FSAAMSPosX5" "0.000000"
Option "FSAAMSPosY2" "0.000000"
Option "FSAAMSPosY3" "0.000000"
Option "GammaCorrectionI" "0x00000000"
Option "no_accel" "no"
Option "FSAAMSPosY4" "0.000000"
Option "FSAACustomizeMSPos" "no"
Option "UseFastTLS" "0"
Option "FSAAMSPosY5 Option "BlockSignalsOnLock" "on"
Option "FSAAEnable" "no"
Option "GammaCorrectionII" "0x00000000"
Option "TVHSizeAdj" "0"
Option "VideoOverlay" "on"
Option "TVVPosAdj" "0"
Option "no_dri" "no"
Option "TVColorAdj" "0"
Option "StereoSyncEnable" "1"
Option "UseInternalAGPGART" "no"
Option "FSAAMSPosX0" "0.000000"
Option "UseInternalAGPGART" "no"
Option "TVHStartAdj" "0"
Option "PseudoColorVisuals" "off"
Option "Capabilities" "0x00000000"
Option "FSAAMSPosX1" "0.000000"
Option "TVStandard" "NTSC-M"
Option "FSAAMSPosX2" "0.000000"
Option "OpenGLOverlay" "off"
Screen 0
VendorName "ATI"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection
Option "TVVSizeAdj" "0"

HorizSync 30-80
Identifier "Monitor[0]"

Denebe
18/01/2007, 23h41
Je ne suis pas vraiment calé (ça fait un peu plus de deux semaines que je suis sous linux, donc sois indulgent...) mais je pense que ton driver est installé.

tape en ligne de commande "glxgears" ou "glxinfo | grep rendering".
Qu'est-ce que ça donne ?

hunagoca2
19/01/2007, 10h06
Je ne suis pas vraiment calé (ça fait un peu plus de deux semaines que je suis sous linux, donc sois indulgent...) mais je pense que ton driver est installé.

tape en ligne de commande "glxgears" ou "glxinfo | grep rendering".
Qu'est-ce que ça donne ?[/b]

salut, voila ce que donne c'est commande

[/code]
serge@linux:~> glxgears
Xlib: extension "GLX" missing on display ":0.0".
glxgears: Error: couldn't get an RGB, Double-buffered visual.
serge@linux:~> glxinfo
name of display: :0.0
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x21 24 tc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
0x22 24 dc 1 0 0 c . . 0 0 0 0 0 0 0 0 0 0 0 0 0 None
[code]


je crois comprendre qu'il manque les libririe GLX, oui mais comment les installer?
autre question
comment inserer dans une fenetre avec ascenseur les resustat d'une commande dans le post pour qu'il ne soit pas trop long?
merci de ton aide,je part travailler

Denebe
19/01/2007, 13h11
1) désinstalle le driver ("fglrx" dans supprimer un logiciel);
2) vérifie que "gcc" et "kernel-source" sont bien installé (installation logiciel);
3) inscris toi à ce dépot http://software.opensuse.org/download/xorg72/openSUSE_10.2/;
4) attend un moment qu'il te propose une mise à jour et fais-la;
5) ensuite tu suis scrupuleusement ce tuto, il est très détaillé (allez, au boulot):<div class='quotetop'>Citation </div>
ATI video drivers

WARNING: These instructions are only a placeholder for a future ATI driver release. If you are reading this paragraph, then ATI has not yet released a driver that supports X.org 7.2, which is what ships with openSUSE 10.2. Following the below instructions will cause X.org to fail to start. I am not sure if this procedure will work with an X.org 7.2-compatible ATI driver when one is released, but it should as far as I can tell. There is also an ATI YaST installation source that may work in the future, but does not currently have a driver that works with openSUSE 10.2. In other words, if you have a late-model ATI video card, 3D acceleration is unavailable at this time. The only workaround is to downgrade to an earlier X.org release, which is a lot of work and will ultimately be unmaintainable, so I strongly suggest that you either wait a few weeks for ATI to catch up to Novell, or choose a different GNU/Linux distribution that better meets your 3D rendering needs.

openSUSE 10.2 ships with the newly revamped open source radeon driver. That may be fine for 2D rendering, but it doesn't do direct rendering for 3D graphics. To get hardware 3D acceleration (and for XGL support), you still need the proprietary ATI fglrx driver.

To install the hardware-accelerated ATI driver, the following packages have to be installed. Some are installed by default -- check to make sure they're all there by typing these names into the Software Management's search box. If they are not there, install them and all of their dependencies before you continue:

* gcc
* make
* kernel-source
* kernel-syms
* compat-expat1
* expat

After that, open up a Web browser (it doesn't matter which one) and go to the ATI driver Web site. In the left field, click on Linux x86 or Linux x86_64 depending on which version of openSUSE you installed (x86 is 32-bit, x86_64 is 64-bit). In the middle field, click on the brand that matches your video card. For most people this will be Radeon or Mobility Radeon, though a small number of readers may have one of the other cards listed. If you are not sure which card you have, consult the documentation that came with either your video card or your computer.

After you have clicked the link for your card brand, the far-right field will show a list of model numbers. Click the one that corresponds with your video card model, then click the little green GO button under the field. If you do not see your model in the list and it is an older card (the original Radeon or the Radeon 7000, for instance), openSUSE should already have hardware 3D support for it in the open source radeon or ati drivers.

Right-click the green link that says ATI Driver Installer. It should be in the first row under the Download Link column. Select Save Link As (or Save Target As, or whatever it is in your browser of preference) and in the ensuing file dialogue, choose to save it to your user's home directory. If your username is onyxia, then save the file to the /home/onyxia directory.

After the file finishes downloading, open up your home folder by clicking the house icon in the lower left portion of the screen. You should see the file you just downloaded among a few standard directories. Right-click on the ati-driver-installer file, then click Properties in the popup menu. When the properties window comes up, click the Permissions tab, then click the checkbox next to is executable, then click OK.

Now open a Konsole terminal by going to your chameleon main menu, then clicking on Applications, then System, then Terminal (you may have to scroll down the list a little to see it), then Terminal Program (Konsole). A Konsole window will come up. Type this in and press Enter to make sure you're in the right directory:

cd

Now it's time to run the ATI driver program as the super user. But first, a note about long file names: When you have to type in a long file name, you don't have to type the whole name into a terminal window. Instead, you can have the terminal do the work for you. Just type the first few letters of the filename and press the Tab key, and the file name will be automatically completed for you. This is useful in situations like the one you're in now, where there is a long and complex file name to type in. This feature is known as tab completion. So type the following command into your terminal, and use the Tab key to complete the ATI driver file name, then press Enter to execute the command:

sudo sh ./ati-driver

The sudo command runs the command that follows it as the root user. You could also use the su command to switch to root, but it's easier to cut-and-paste if everything's in one line. The sh command runs a shell script, which is basically what the ati-driver-installer program is.

The window will go blue and you'll be presented with a basic analysis of your computer's architecture and operating system. Don't worry if it shows your 64-bit system as "x86" -- that's a bug in the message. Press Enter to continue, then press Enter at the next screen as well. For some reason, as of this writing, the program will again show you the system analysis screen. Press Enter to get past it again.

Welcome to the license agreement. Basically it says that you can't do anything with anything, ever, no matter what -- more or less a standard proprietary license agreement. Read it if you want, but press Enter to get to the next step, which is to agree to the license. Whether you agree or not, if you want to install this driver you have to press Enter here (Yes is selected by default).

The next screen asks what kind of installation you'd like to perform. Just press Enter here. After that you'll see a brief progress meter that shows the driver's many little pieces being transferred to your operating environment. When it's done, you'll be asked if you would like to launch a Web browser. Since this only leads back to the ATI/AMD site, press the right arrow key to select No, then press Enter.

A parting message tells you to run the aticonfig program. Don't bother with that -- all it does is overwrite your X.org configuration file, which you don't need to do because you have YaST to do it for you. Or more specifically, you have SaX2, the component of YaST that handles X.org configuration. You can't do sudo on this command because it won't allow access to your X session, so you will have to switch to root permissions by typing this and pressing Enter:

su -

The dash after the su command gives you the root user's environment path. Anyway, once you type in your root password, type in this command to load the module you just built (restarting your computer will do this automatically):

modprobe fglrx

Now type this in:

sax2 -r -m 0=fglrx

That brings you to SaX2 and forces it to use the proprietary ATI driver instead of the open source one that it wants to use by default. You may notice that your monitor settings have gone awry here; you may have to change the monitor, resolution, and color depth. Ideally you want the maximum resolution that your monitor is designed for (or slightly less if you like big text), 24-bit color depth, and make sure the checkbox next to Activate 3D Acceleration is marked (it's at the bottom of the window). When you're done, click OK. A popup message will ask if you'd like to test the new configuration. Click Save, then click OK. Close all open programs, then press Ctrl-Alt-Backspace to restart the X.org server. You should now have hardware 3D acceleration.[/b]Normalement, ton driver est installé. Retape "glxgears" et "glxinfo | grep rendering", qu'est-ce que ça donne ?

ps: il y a un soucis quant à l'installation du fireglcontrolpanel (ou un truc du genre), mais ça n'empêche pas le driver de fonctionner correctement.

hunagoca2
20/01/2007, 10h31
j'essai ça des que possible
merci

hunagoca2
23/01/2007, 14h20
j'essai ça des que possible
merci[/b]


bien voila j'ai installé la 10.2 (mise à jour)et les drivers ati fonctionne parfaitement mais ...
je n'ai plus de wifi donc plus d'internet et il faut le son à fond pour esperer entendre quelque chose.
Ce n'est donc pas tout rose et je pense arreter la suze hic !

pour le wifi j'ai suivi le wiki mais rien n'y fait. Il me faudrait la procedure d'installe en mode console.

je vais tenter de reinstaller la 10.2 completement sans passer par la mise à jour qui a l'air un peu bogger.

merci quand meme
A+

Denebe
24/01/2007, 13h42
Salut,

Bravo pour le driver ati.
Pour le reste, accroche toi, il te reste encore deux grosse galères fondamentales (le son et le réseau). A priori, pour le son, ça devrait simplement se résoudre par un volume qui est trop bas. Pour le wifi, sois sûr du type de chipset de ta carte. Ensuite il y a deux possibilités: ou bien il existe un driver, ou bien il n'en existe pas. Dans ce dernier cas, essaie avec "ndiswrapper".

Le mieux est que tu ouvres un topic spécifique.
Bye bye, Denebe.

hunagoca2
25/01/2007, 16h18
Salut,

Bravo pour le driver ati.
Pour le reste, accroche toi, il te reste encore deux grosse galères fondamentales (le son et le réseau). A priori, pour le son, ça devrait simplement se résoudre par un volume qui est trop bas. Pour le wifi, sois sûr du type de chipset de ta carte. Ensuite il y a deux possibilités: ou bien il existe un driver, ou bien il n'en existe pas. Dans ce dernier cas, essaie avec "ndiswrapper".

Le mieux est que tu ouvres un topic spécifique.
Bye bye, Denebe.[/b]




j'ai trouver un driver rt2500 à compiler soi-meme et ça fonctionne.
merci pour tout
bye

sieg
26/01/2007, 11h09
Bonjour,

Je viens de tester la métode pour installer les drivers ATI.

Quand je fais un glxinfo | grep rendering, j'ai ca:
<div class='quotetop'>Citation </div>
direct rendering: Yes[/b]

Le seul truc, c'est que sous SAX2, je ne peux pas activer l'accélération 3D, la case est grisée.

Voici la sortie quand je fais un glxinfo:

<div class='quotetop'>Citation </div>
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: ATI
client glx version string: 1.3
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_get_proc_address, GLX_SGI_video_sync, GLX_ARB_multisample,
GLX_ATI_pixel_format_float, GLX_ATI_render_texture
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context,
GLX_ARB_multisample
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1600 Series Generic
OpenGL version string: 2.0.6286 (8.33.6)
OpenGL extensions:
GL_ARB_multitexture, GL_EXT_texture_env_add, GL_EXT_compiled_vertex_array,
GL_S3_s3tc, GL_ARB_depth_texture, GL_ARB_fragment_program,
GL_ARB_fragment_program_shadow, GL_ARB_fragment_shader,
GL_ARB_multisample, GL_ARB_occlusion_query, GL_ARB_point_parameters,
GL_ARB_point_sprite, GL_ARB_shader_objects, GL_ARB_shading_language_100,
GL_ARB_shadow, GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
GL_ARB_texture_compression, GL_ARB_texture_cube_map,
GL_ARB_texture_env_add, GL_ARB_texture_env_combine,
GL_ARB_texture_env_crossbar, GL_ARB_texture_env_dot3,
GL_ARB_texture_float, GL_ARB_texture_mirrored_repeat,
GL_ARB_texture_rectangle, GL_ARB_transpose_matrix, GL_ARB_vertex_blend,
GL_ARB_vertex_buffer_object, GL_ARB_pixel_buffer_object,
GL_ARB_vertex_program, GL_ARB_vertex_shader, GL_ARB_window_pos,
GL_ARB_draw_buffers, GL_ATI_draw_buffers, GL_ATI_element_array,
GL_ATI_envmap_bumpmap, GL_ATI_fragment_shader, GL_ATI_map_object_buffer,
GL_ATI_separate_stencil, GL_ATI_shader_texture_lod,
GL_ATI_texture_compression_3dc, GL_ATI_texture_env_combine3,
GL_ATI_texture_float, GL_ATI_texture_mirror_once,
GL_ATI_vertex_array_object, GL_ATI_vertex_attrib_array_object,
GL_ATI_vertex_streams, GL_ATIX_texture_env_combine3,
GL_ATIX_texture_env_route, GL_ATIX_vertex_shader_output_point_size,
GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_func_separate,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
GL_EXT_draw_range_elements, GL_EXT_fog_coord, GL_EXT_framebuffer_object,
GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels, GL_EXT_point_parameters,
GL_EXT_rescale_normal, GL_EXT_secondary_color,
GL_EXT_separate_specular_color, GL_EXT_shadow_funcs, GL_EXT_stencil_wrap,
GL_EXT_texgen_reflection, GL_EXT_texture3D,
GL_EXT_texture_compression_s3tc, GL_EXT_texture_cube_map,
GL_EXT_texture_edge_clamp, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_filter_anisotropic,
GL_EXT_texture_lod_bias, GL_EXT_texture_mirror_clamp,
GL_EXT_texture_object, GL_EXT_texture_rectangle, GL_EXT_vertex_array,
GL_EXT_vertex_shader, GL_HP_occlusion_test, GL_NV_blend_square,
GL_NV_occlusion_query, GL_NV_texgen_reflection, GL_SGI_color_matrix,
GL_SGIS_generate_mipmap, GL_SGIS_texture_border_clamp,
GL_SGIS_texture_edge_clamp, GL_SGIS_texture_lod, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess[/b]


D'après vous, est ce que le pilote est bien installé et pouquoi je ne puis activer la case 3D (car avec Cedega, l'utilitaire de test me dit que la 3D est désactivée).

Merci pour votr aide

Denebe
26/01/2007, 14h35
Salut,
Une fois installé le driver ati, vérifie que l'accélération 3d est présente en tapant:
glxinfo | grep rendering ou bien glxgears. Apparemment, c'est déjà le cas pour toi.

Après ceci, vérifie que tous ces paquets soient installés:
compiz, xgl, xgl-hardware-list, gnome-session et libwnck.

Tu vas dans menu, centre de contrôle puis effet de bureau. Normalement, tu devrais voir "accélération 3d: activé". Il ne te reste plus qu'à activer les effets de bureau (on te demandera ton mot de passe su, puis de fermer la session).

Remarque: si à "accélération 3d" c'est indiqué "Désactivé" et que grâce au test ci-dessus, tu es sûr d'avoir l'accélération 3d d'activée, lorsque tu as la fenêtre "paramètres des effets du bureau" devant toi, tu appuyes sur "shift" (en restant appuyé), et tu cliques là où c'est écrit "Désactivé". Ceci a pour effet de reprendre le pouvoir sur la machine (sale bête!!): elle considère maintenant que tu as l'accélération 3d d'activée et te propose maintenant d'activer les effets de bureau...
Personnellement, c'est ce que j'ai fait: pour une raison ou pour une autre (base de données obsolètes ou un petit bug), l'accélération 3d n'était pas reconnue. Pour l'obtenir, j'ai procédé comme indiqué ci-dessus.

Allez, c'est pour bientôt le bureau en 3d, tu as fais le plus dur http://www.alionet.org/style_emoticons/<#EMO_DIR#>/cool.gif
Denebe.

sieg
26/01/2007, 17h50
Rien a faire, meme en cliquant sur Shift ...

Comme tu le dis, sale bete ^

"Votre carte graphique ne fonctionne pas avec Xgl. Désolé."

Sinon j'ai suivi ca et ca fonctionne:http://en.opensuse.org/Beryl

Denebe
26/01/2007, 18h13
Bon, en fait, c'est double clique qu'il faut faire:
<div class='quotetop'>Citation </div>
If the Desktop Effects tool doesn't recognize your video card, it might think that 3D Acceleration is disabled even though you know it's really enabled. Since Desktop Effects won't let you enable Xgl unless it thinks 3D Acceleration is enabled, this can be a problem.

To override the autodetected setting for 3D Acceleration, hold down the Shift key and then double-click on the word "Disabled" next to "3D Acceleration". Only do this if you are certain that 3D Acceleration is enabled on your machine. (For the record, you can also do this to change its idea of whether or not your video card is supported, but that's even less recommended.)[/b]

Sinon, que se passe-t-il quand tu tapes glxgears, combien de fps as-tu ?

edit: désolé je n'avais pas fait attention à "Sinon j'ai suivi ca et ca fonctionne:http://en.opensuse.org/Beryl". Parfait !

sieg
26/01/2007, 18h24
Sinon, que se passe-t-il quand tu tapes glxgears, combien de fps as-tu ?[/b]


Xlib: extension "XFree86-DRI" missing on display ":0.0".
21170 frames in 5.0 seconds = 4233.895 FPS
21340 frames in 5.0 seconds = 4267.334 FPS
20661 frames in 5.0 seconds = 4130.604 FPS
18120 frames in 5.0 seconds = 3623.943 FPS
15325 frames in 5.0 seconds = 3064.931 FPS


Je pense que c'est bon?

Merci de ton aide http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

EDIT: J'ai tout replanté ... bon et bien Linux ne remplacera pas encore ma station de travail (j'aimerai pourtant).
Le seul problème, c'est que je joue a counter strike et que meme avec Cedega ca plante (j'ai pourtant pris un abonnement de 3 mois pour tester ...)
Mais comme je veux tester Opensuse quand meme, je vais la mettre en Vmware (car avec la SLES10 a la maison, je fais un peu de pratique pour remplacer un environnement de travail windows dans une entreprise) ...

Denebe
26/01/2007, 20h05
Oui très bien.
Le driver ati est bien installé:
<div class='quotetop'>Citation </div>
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1600 Series Generic
OpenGL version string: 2.0.6286 (8.33.6)[/b]<div class='quotetop'>Citation </div>
direct rendering: Yes[/b]<div class='quotetop'>Citation </div>
Xlib: extension "XFree86-DRI" missing on display ":0.0".
21170 frames in 5.0 seconds = 4233.895 FPS
21340 frames in 5.0 seconds = 4267.334 FPS
20661 frames in 5.0 seconds = 4130.604 FPS
18120 frames in 5.0 seconds = 3623.943 FPS
15325 frames in 5.0 seconds = 3064.931 FPS[/b]
De mémoire, je cois qu'il est préférable d'avoir au dessus de 2000fps pour que le bureau 3d fonctionne correctement, donc dans ton cas (~4000 fps) tout va bien de ce côté là. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

Par contre, je ne suis pas sûr que "Xlib: extension "XFree86-DRI" missing on display ":0.0"." soit bien.
Fais voir ton fichier "xorg.conf".