PDA

Afficher la version complète : [Réglé] pas de son pour ecouteur!



kopbx1
04/02/2007, 13h09
bonjour, j'ai un sony VAIO FE41M .

quand je lance amarok tout va bien ,j'ai du son impec.par contre quand je decide de brancher mes ecouteurs sur la sortie ecouteur j'entend rien ,d'ou bien peut venir ce probleme.

merci pour vos repnses:(

dbourrion
04/02/2007, 13h41
Ouvre kmix, tu dois avoir certains canaux en "muet" ou un truc comme cela.

A plus

kopbx1
04/02/2007, 13h49
bonjour,

j'ai ouvvère kmix mais j'ai que le master et PCM c'est tout.

aidez moi svp http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

dbourrion
04/02/2007, 13h50
Pas de canal Headphones ? Parce que sur ma machine c'est là que je dose le son des écouteurs

kopbx1
04/02/2007, 13h54
non pas de canal headphone !!
comment puis-je installer cela ?

merci pour vos reponses!

dbourrion
04/02/2007, 14h11
Tu es certain de ta carte son ?

kopbx1
04/02/2007, 14h27
voila ce que donne la commande lspci:

lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA Storage Controller IDE (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation GeForce Go 7400 (rev a1)
06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
0a:03.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller
0a:03.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller
0a:03.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)
0a:08.0 Ethernet controller: Intel Corporation PRO/100 VE Network Connection (rev 02)

je ne vois pas ce que vous voulez dire pas "certain de ta carte son"

merci pour vos reponses

kopbx1
04/02/2007, 15h54
rebonjour,
il y'a personne qui peut s'inspirer de tout cela ?

merci de vos reopnses!

dbourrion
04/02/2007, 16h16
Tout est normal dans le module Son de Yast ?

kopbx1
04/02/2007, 16h25
qu'est ce que vous entendez avec tous est normale dans le module de yast ?

merci de preciser votre question svp.

dbourrion
04/02/2007, 16h33
Je me demande si ta carte est bien reconnue dans ce module, si rien n'est coché/décoché qui pourrait à tes yeux expliquer pourquoi cela ne marche pas, etc..

kopbx1
04/02/2007, 17h14
bonjour,
voila une capture d'ecran de yast->materiel->son:
http://kopbx1.fac.free.fr/capture1.png

tous me semble normale enfin je crois !

merci pour vos reponses!

pour p+ de precisions :
le son marche parfaitement sous les hauts parleurs de mon portable mais quand je branches mes ecouteurs sur la sortie ecouteurs j'entend rien du tout.

je joins la capture d'ecran de Kmix:
http://kopbx1.fac.free.fr/capture2.png

aidez moi svp

kopbx1
04/02/2007, 19h11
personne n'a été inspiré par tous cela ?

allez les gars un effort je veux vraiment ecouter ma musique sur mes mes enceintes.

merci par avance.

Carnaby
04/02/2007, 21h45
Il me parait un peux minimaliste ton mixeur.

Déjà fait un clique droit mixeur et choisis l'option canaux dans le menu déroulant. Puis dans canaux vérifie qu'ils sont bien tous afficher.
Tu trouvera peut être le canal correspondant à ta sortie.

Tu peux aussi tenter de changer le canal principal (clique droit sur l'icone de Kmix dans le tableau de bord).

kopbx1
04/02/2007, 21h57
bonsoir,
j'ai essayer ce que tu ma dis carnaby mais ca change rien .
voila une nouvelle capture d'ecran !
http://kopbx1.fac.free.fr/capture3.png
j'ai toujours pas de son avec mes enceintes quand je les branches.
merci de m'expliquer ce qu'il faut faire.

Carnaby
04/02/2007, 22h09
C'est peux mieux mais ça reste très limité.

J'ai pas trop d'idée en fait, peut être que le support de ton matériel est pour l'instant limité. Dans les nouveauté de la prochaine version d'alsa (le module qui gère la carte son) j'ai vue qu'il y avait quelques nouveautés concernant les portables Sony ça bénéficiera peut être au tien (ça devrait être dispo dans le mois a venir je pense).

kopbx1
04/02/2007, 22h25
ou est ce que t'as vu que la prochaine version d'alsa gerera ma carte audio ?

merci par avance!:

kopbx1
06/02/2007, 16h14
bonjour,
personne n'a une autre idée pour que je fasses marcher ma sortie audio ?

merci d'avance

phoenix
06/02/2007, 19h35
Si tu as une molette de son sur tes écouteurs, la mettre plus haut http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif

Neolinux
06/02/2007, 20h16
Salux !

Sur ma tour, j'ai un écran plat avec haut-paleurs intégrés et je ne peux avoir le son que via la prise qui se trouve sur l'écran, impossible d'en avoir avec la prise en façade.

Donc, la prise à l'arrière sur laquelle est branché l'écran (et donc, tes haut-parleurs, je suppose) empêche celle de façade de fonctionner, on dirait bien.

Il semblerait donc qu'il faille faire un choix entre le son sur la chaîne Hi-Fi ou sur les haut-parleurs PC.

kopbx1
07/02/2007, 12h33
bonjour,
ce n'est pas un pc fixe que j'ai c'est pc portable sony vaio FE41M le drvier de ma carte son ne reconnait pas la prise audio qui se trouve sur la facade en bas de mon portable ,par contre les haut parleur intégré fonctionne tres bien .si vous driver qui correspond je suis prenant:
vous pouvez voir ce que donne la commande lspci au debut de la discussion.

merci pour vos reponses.
a propos j'ai pas de molette de son sur mon vaio http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

kopbx1
07/02/2007, 16h32
bonjour,
bonne nouvelle j'ai reussi a faire marcher le son de mes ecouteurs en installant le dernier driver ALSA a partir de ce lienici (http://www.alsa-project.org/).
il suffit de telecharger le dernier driver et apres faire:
./configure
make
en root faire :
make install

pour ceux qui n'ont pas reussi a l'installer ce dernier message peut vous etre utile;)

bonne continuation ..............et @bientot http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

Jotar
01/03/2007, 11h38
Bonjour à tous !
Je post ici, vu que c'est aussi sujet a un problème de son/molette http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

Le problème n'est pas compliqué à expliquer : la molette de mon ordinateur portable (fujitsu siemens) ne fonctionne pas sous open suse 10.2.
Le seul moyen pour moi de régler le volume est soit de modifier la volume du speaker interne (sous yast->matos->son->volume) soit avec kmix de modifierla volume de PCM.
En fait, le molette semble ne pas être "reconnue" par le système.
Avez vous une piste ?
C'est un petit embêtant de devoir cliquer à chaque fois avec la souris pour changer le volume http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif

Merci d'avance
Opensusement-votre http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

mthlwn
27/07/2007, 21h19
Bonjour à tous !
Pour info, le problème est documenté ici :
https://launchpad.net/ubuntu/+source/alsa-driver/+bug/33719
avec une solution pour Ubuntu... qui ne semble pas marcher sous openSUSE :-(
Je vais essayer d'installer la dernière version d'ALSA comme proposé plus haut.

Bon, voilà comment configurer ALSA pour le driver snd-hda-intel :
1) installer et compiler la dernière version de ALSA (drivers)
2) lancer "alsaconf" pour configurer alsa
3) ajouter de la ligne

options snd-hda-intel model=vaio

dans le fichier /etc/modprobe.d/sound

(j'ai un vaio, il faut adapter pour les autres, bien sûr).

Et tout marche.