PDA

Afficher la version complète : [Réglé] Gentoo Fatal Error



ganesh
08/02/2007, 12h38
Bonjour,

J'ai voulu faire le malin et installer gentoo en ligne de commande.
J'ai téléchargé le live cd, cliqué sur l'install en ligne et me voilà parti, je sélectionne tout ce qu'est ce qu'il me faut.
Pour info j'ai un routeur donc dans le network je sélectionne eth0, je choisi dhcp sans spécifier les serveurs dns. Et je n'ai pas crée de fichier xml pour le profil (me demandais pas pourquoi j'arréte de fumer et j'ai des réactions pas claire)

Je sélectionne mon serveur, je choisi stager3 (celui qui permet de prendre sur le livecd si rien d'autre n'est dispo) je choisi vanilla-sources, je sélectionne mes package, mon environnement...

Puis vient l'install à proprement parler la barre progresse gentillement, les partitions se créent (youpi), l'archive x86...tar.gz2 se charge. J'arrive à synsing quelque chose, ça passe, puis chroot, ça passe aussi puis lors de portage tree (ou quelque chose comme ça, il y a tree à la fin c'est sur) j'ai le message suivant :

There was an exception received during the install that is outside of the normal install errors. this is a bad thing. the error was : KernelBuildererror : Fatal : Build_kernel : could not build Kernel !
Please submit a bug report with the contents of /var/log/install.log and /tmp/installprofile.xml and the version f the installer you used.
Do you want to clean system to another install? Yes No

Pour info je lors de l'install avec networkless ça passe bien mais je souhaite comprendre et apprendre à utiliser l'install de gentoo avec "network enable" et surtout comprendre ce que je fais mal pour mieux comprendre Linux http://www.alionet.org/style_emoticons/<#EMO_DIR#>/rolleyes.gif

Mon problème vient-il de la non création lors de l'install du fichier XML? du fait que pour eth0 je choisis DHCP sans changer le domainename et le localhost ni indiquer de dns primaire et secondaire. ayant un routeur je n'en vois pas l'utilité sachant qu'en utilisation live j'accède au net et que visible il me récupére bien l'achive X86...tar.gz2. Mon PC est un sony vaio VGN S5M, processeur 32bit Intel, dois je choisir i586 au lieu de x86?

Merci pour vos réponses.

Librement

Bilal

phoenix
08/02/2007, 12h47
Salut,

Tu as regardé les log qu'il t'indique ?

ganesh
08/02/2007, 12h51
Salut,

J'ai essayé d'y accèder mais impossible même en affichant les fichiers cachés dans le system files http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

Mon install se lance depuis le live cd avec une K ouverte ou alors je n'ai pas regardé au bon endroit, peux tu m'indiquer la manip pour les voir stp?

Amicalement

Bilal

phoenix
08/02/2007, 13h07
Tu te met en root, puis tu l'ouvre avec un éditeur de texte quelconque.

ganesh
08/02/2007, 13h10
Hé hé, mais lors de l'install j'ai l'interface graphique et les users ne sont pas crées, je ne sais pas si les fichiers sont copiés et comme je fais l'install depuis l'interface graphique du live cd je ne connais pas le password root...

Temet
09/02/2007, 02h03
Si t'as une interface graphique, tu n'utilises pas la bonne méthode.
L'installeur graphique en est à sa première version, n'est pas soutenue par les devs, pleine de bug ... et en gros, elle est déconseillée par tous les gentooistes.

Va s'y avec ton épingle à nourrice et ton couteau suisse ... je l'ai bien fait, ça m'a pas tué http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif (stage 2 à l'époque d'ailleurs).

topgun
13/02/2007, 16h03
Oui rien de tel qu'un live-cd minimal jamais de problèmes quand on suit bien la doc d'ailleurs je te rappelle que links est dispo et que rien ne t'empêche d'ouvrir 4 terminaux et donc de naviguer entre la doc et l'environnement chrooté http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

Ray ishido
12/03/2007, 16h04
Oui rien de tel qu'un live-cd minimal jamais de problèmes quand on suit bien la doc d'ailleurs je te rappelle que links est dispo et que rien ne t'empêche d'ouvrir 4 terminaux et donc de naviguer entre la doc et l'environnement chrooté http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif[/b]

+1

j'ai installé 3 gentoo en janvier a partir de l'install cd minimal et entierement en ligne de commande. c'est plus simple (la doc est extremement bien faite!), tu n'aura pas de pb, et si tu as un pb tu saura precisement a quelle etape. en plus ca te mettra directement dans le bain! (et vi, fini les outils de configuration grafique sous gentoo,! mais ne t'inquiete pas les differente doc sur le site gentoo.org te prennent vraiment par la main et t'explique chaque etape pas a pas http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif )

autre chose: essaye aussi les gentoo-source si ca, ne parche toujours pas, meme en ligne de commande.
tu peut aussi essayer de configurer ton noyeau avec genkernel si tu soupsonne un pb de configuration de ce dernier.