PDA

Afficher la version complète : Pas d'accélération 3d



xerxesis
26/02/2007, 13h34
Bonjour tout le monde
je me suis lancé sous suse qui est une distribution que j'ai envie de tester depuis vraiment tres tres lontemps
Seulement voila je me sens bloqué pas le fait de ne pas avoir l'accélération 3d
j'ai une ati radeon 9250se
j'ai installé les pilotes linux 8.28.8 comme ç'est décrit dans les tuto des wiki
voici mon xorg.conf

<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>
# /.../
# SaX generated X11 config file
# Created on: 2007-02-26T10:51:48+0100.
#
# Version: 7.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (7.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/local"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/URW"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo"
FontPath "/usr/X11R6/lib/X11/fonts/PEX"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/latin2/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/latin7/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/baekmuk:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/japanese:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/kwintv"
FontPath "/usr/X11R6/lib/X11/fonts/truetype"
FontPath "/usr/X11R6/lib/X11/fonts/uni:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/CID"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/ucs/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/misc:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/75dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/100dpi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/hellas/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/misc/sgi:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "Module"
Load "freetype"
Load "type1"
Load "dbe"
Load "glx"
Load "extmod"
Load "v4l"
Load "dri"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "fr"
Option "XkbModel" "pc102"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "Sunplus USB OpticalWheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
DisplaySize 310 230
HorizSync 30-70
Identifier "Monitor[0]"
ModelName "SAMSUNG MONITOR"
Option "DPMS"
VendorName "SAM"
VertRefresh 43-160
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "RADEON 9250 (RV280 5960)"
BusID "1:0:0"
Driver "fglrx"
Identifier "Device[0]"
Option "FSAADisableGamma" "no"
Option "CapabilitiesEx" "0x00000000"
Option "ScreenOverlap" "0"
Option "FSAAMSPosY0" "0.000000"
Option "FSAAMSPosY1" "0.000000"
Option "mtrr" "off"
Option "FSAAMSPosX4" "0.000000"
Option "ForceGenericCPU" "no"
Option "FSAAMSPosX5" "0.000000"
Option "FSAAMSPosY2" "0.000000"
Option "FSAAScale" "1"
Option "FSAAMSPosY3" "0.000000"
Option "Capabilities" "0x00000000"
Option "GammaCorrectionI" "0x00000000"
Option "no_accel" "no"
Option "FSAAMSPosY4" "0.000000"
Option "UseFastTLS" "0"
Option "FSAAMSPosY5" "0.000000"
Option "FSAACustomizeMSPos" "no"
Option "FSAAEnable" "no"
Option "BlockSignalsOnLock" "on"
Option "GammaCorrectionII" "0x00000000"
Option "KernelModuleParm" "locked-userpages=0"
Option "FSAAMSPosX0" "0.000000"
Option "no_dri" "no"
Option "VideoOverlay" "on"
Option "UseInternalAGPGART" "no"
Option "PseudoColorVisuals" "off"
Option "StereoSyncEnable" "1"
Option "FSAAMSPosX1" "0.000000"
Option "OpenGLOverlay" "off"
Option "FSAAMSPosX2" "0.000000"
Option "Stereo" "off"
Option "FSAAMSPosX3" "0.000000"
Option "CenterMode" "off"
Screen 0
VendorName "ATI"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection


Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
Option "Composite" "Disable"
EndSection
</div>
je voudrais savoir si quelqu'un a la meme probleme que moi sachant que je me suis mis sous suse 10.1 car la 10.2 fonctionne avec xorg 7.2 et qu'il me faut le 6.9 pour la compatibilité de mes drivers
Cordialement

jeancayron
26/02/2007, 15h19
Dans la 10.2, le pilote libre par défaut ("radeon") supporte l'accélération 3D (mais pas XGL) sans devoir installer le pilote ATI.
Étant donné que la 10.2 est bien supérieure point de vue qualité (et bugs) que la 10.1, mieux vaut opter pour une fringante 10.2 avec accélération 3D à 90% (grâce au pilote libre) qu'une bonne mais buguée 10.1 avec son pilote ATI.

C'est mon avis.

xerxesis
01/03/2007, 20h30
et bien tu as surement raison mais alors comment je fais pour pouvoir jouer avec ma 9250se sachant que par défaut c'est impossible (avec radeon) c'est trop lent la souris mais 10 seconde a bouger quand ce n'est pas l'ordi qui plante ?

maxxous
02/03/2007, 00h01
Salut j ai une technique je vais te montrer c facile et sa marche nikel d abord demarre yast tu fais installer un logiciel apres tu installe kernel-source, gcc et make en suite tu va sur le site ati et tu telecharge le dernier pilote ensuite avec le fichier rpm tu fais click droit dessus tu fais proprieter puis droit d acces et tu clik sur executable tu coche en faite.
maintenant tu ouvre le terminal tu te connecte en root su mot de passe tu fais glisser ton fichier rpm sur le terminal puis entrer.

la normalement tu aura le panneau ati qui s'ouvre tu genere le package de ta suse10.2 ou autre.

ensuite tu va dans dossier personnel et la tu va trouver un nouveau fichier fglrx 7.1.rpm je crois tu l installe avec yast tu redemarre et voila.

salut.

xerxesis
02/03/2007, 02h52
je ne peux pas si j'installe la derniere version des pilotes ATi, ils ne sont pas compatible avec ma carte graphique et si j'installe les anciens ( 8.28.8) il n'arrive meme pas a me faire le rpm http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

maxxous
02/03/2007, 07h55
j'ai essayer avec le 8.28.8 et il fais le rpm!
1: telecharger le driver8.28.8.rpm
2: le mettre executable
3: ouvrir le terminal en root
4: faire glisser ton rpm sur le terminal et appuyer sur entrer
5: ta le panneau ati qui s'ouvre la tu clique sur suse puis generate distribution specific driver
6: tu click sur suse package puis SuSE/SUSE102-IA32 et continue la il cree ton rpm qui sera dans ton dossier personnel.et tu linstalle avec yast.

(il faut avoir installer kernel-source gcc et make avant bien sur sinon tu fera planter ton X)

xerxesis
02/03/2007, 17h20
Tu es sur que tu ne te trompe pas parce que personnellement je ne trouve pas driver 8.28.8 en .rpm je ne trouve que des .run ...

maxxous
02/03/2007, 18h47
tu dois avoir dans ton dossier personelles un fichier du genre fglrx tu l installe avec yast noramlement c un rpm.

galagann
02/03/2007, 20h01
Salux,

Je viens de mettre à jour le mode d'emplois pour l'installation du driver ATi : http://wiki.alionet.org/doku.php?id=ati#dr...epuis_suse_10.2 (http://wiki.alionet.org/doku.php?id=ati#drivers_ati_depuis_suse_10.2)

xerxesis
03/03/2007, 00h56
Pourtant j'ai cru comprendre qu'il ne fallait pas que j'installe les drivers proprio mais qu'il fallait que je configure mon xorg pour les drivers radeon ?

galagann
03/03/2007, 11h42
XerXeSis, se que l'on propose d'installer, sont les drivers ATi programmer par ATi http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif

xerxesis
03/03/2007, 13h04
je coyais que xorg était incompatible avec les drivers 8.28.8 ?

maxxous
03/03/2007, 17h27
sa fonctionne avec 8.28.8 tu aura la 3d mais avec ta carte graphique ne t attend pas a des miracles pour les jeux niveaux fps mais si tu mets beryl sa ira nikel voila++

xerxesis
03/03/2007, 18h46
oui c'est vrai que c'est une vieille carte graphique mais elle me suffit amplement pour jouer a Fable quand j'étais sous windows et xmoto pour linux meme tremulous passe tres bien donc j'ai pas a me plaindre
merci de vos réponse et je vous tiens au courant
cordialement