PDA

Afficher la version complète : Carte Nvidia 256Mo 64bits



Gigab
10/03/2007, 22h14
Bonsoir, j'ai des soucis d'installation avec ma carte graphique.
En fait j'ai suivi le wiki consistant en 'installation de la source, puis des drivers nvidia.

Le problème est que l'ordinateur ne démarre plus complètement.
Il redémarre, mais l'écran reste noir et je ne peux absolument rien faire.

Quand je remet ma carte 32mo, c'est en ligne de code que je dois travailler. Il ne redémarre plus du tout comme avant.

Comment faire pour corriger tout ça ? Parce que là je ne peux plus bosser. (nb je suis sous windows actuellement parce que je n'ai plus accès à mon linux)

Merci d'avance pour votre aide..help c'est urgent http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

oh!rocks
10/03/2007, 23h07
Pas de panique !

Au prompt de l'écran noir tu te logues avec ton user et ton mdp puis tu passes en root (su + mdp) ;
tu te rends dans ton répertoire /etc//X11 (cd /etc/X11) ;
la commande ls va te lister le contenu de ce répertoire ;
repère un fichier appelé xorg.conf : c'est celui qui déconne ;
renomme-le en xorg.conf.bad (ne l'efface pas de suite) : mv xorg.conf xorg.conf.bad;
repère le fichier appelé xorg.conf.saxsave : c'est le fichier précédent ta manip' qui a été renommé par sax2 pendant ta manip ;
renomme-le en xorg.conf : cp xorg.conf.saxsave xorg.conf
reboot ;

Ça doit marcher, je viens de le faire !

à plus,

oh!rocks

Gigab
10/03/2007, 23h52
merci pour ton aide .
En fait, j'ai du mettre ma carte 32Mo pour faire les manipulations, car ca ne fonctionnait pas avec la 256Mo.

Comment faut il faire pour la suite ? merci d'avance

oh!rocks
11/03/2007, 00h14
Tu en es où, là, exactement ?
Le modèle précis de ta carte, c'est quoi ?

à plus,

oh!rocks

Gigab
11/03/2007, 09h05
Alors là j'ai un soucis.. Mon message précédent pouvais paraitre assez sec. Cela vient du fait que quand j'ai redémarré après avoir changé les paramètres que tu m'a indiqué, je me suis retrouvé en clavier querty.

J'ai modifié le truc dans Yast en mettant 101 touches PC et non plus 102 (intl).
Le fait est que ce matin, en allumant, l'écran m'a affiché "Fréquence vidéo trop élevée", alors que je n'ai rien touché dans les paramètres d'affichage ou quoi que ce soit.
EDIT : A ce moment, je ne peux vraiment plus rien faire d'autre que démarrer sous windows, mais sans accès à Linux

Mon écran est un Hyundai avec 1280x1024 et 60hz de fréquence. Lors de mon installation, je ne pouvais pas mettre plus. Et là jene peux pas mettre moins que 60...ça fonctionnait bien.

Sinon pour ma carte, j'ai une Nvidia Geforce 6200 256Mo 64bits AGP 8x Point of view.

Merci encore pour ton aide

EDIT 2 : En redémarrant Linux avec ma carte 32Mo, ça fait exactement la même chose. "Fréquence vidéo trop élevée" et puis je ne peux plus rien faire après..
Il y a quand même les écrans de démarrage qui s'affichent (ceux qui donnent les choix de démarrage -disquette, linux, etc) mais arriver au moment où le bureau doit s'afficher, c'est là que j'ai le message de fréquence.

Je ne comprend vraiment pas.j'espère ne pas devoir refaire une installation.

tyrtamos
11/03/2007, 10h03
Bonjour,

En bootant ta suse avec "init 3" comme paramètre de boot (page du menu grub), tu te retrouves en pure texte sans serveur X (=niveau 3 de linux). Tu te logues en "root", et tu peux alors lancer "sax2" qui est justement le programme de configuration du serveur X (celui qui fabrique le fameux fichier "xorg.conf"). Tu peux alors choisir ta carte graphique et ton écran (et ton clavier, ta souris, ...).

D'ailleurs, d'une manière générale, il vaut mieux toucher à la config graphique alors qu'on est en mode texte (pour installer le driver 3D nvidia par exemple).

Tu as d'ailleurs accès aussi à "yast" en mode texte, qui permet de faire à peu près tout ce que yast en mode graphique sait faire.

Tyrtamos

Gigab
11/03/2007, 10h15
<div class='quotetop'>Citation </div>
En bootant ta suse avec "init 3" comme paramètre de boot (page du menu grub)[/b]

Euh comment fait on ?
Parce que là dès que je boote, je n'ai pas trop le choix, j'ai windows, disquette ou kernel.
Si je met les 2 premiers, il ne se passe rien, et si je met kernel, je ne peux rien faire après car j'ai l'alerte de fréquence.

Ce sont les rivers que j'ai installé qui pourrissent tout ?

tyrtamos
11/03/2007, 10h23
Quand tu es sur la page du menu grub, tu sélectionnes ta suse (kernel?), et tu tapes "init 3" qui doit apparaître sur la ligne "options d'amorçage". Et tu fais "entrée" pour valider.

Tyrtamos

Gigab
11/03/2007, 13h40
Bon ça ne fonctionne pas. Je tape bien init 3, j'arrive en mode texte, je passe sous root et je tape sax2, j'ai un message no sax2 is running, et puis après écran noir avec un tiret en haut à gauche, et plus rien de plus..

merci encore de ton aide.

tyrtamos
11/03/2007, 14h02
Bon ça ne fonctionne pas. Je tape bien init 3, j'arrive en mode texte, je passe sous root et je tape sax2, j'ai un message no sax2 is running, et puis après écran noir avec un tiret en haut à gauche, et plus rien de plus..[/b]

A "init 3", ajoute (séparé par un espace) "vga=normal" et réessaye!

Tyrtamos

Gigab
11/03/2007, 14h13
Alors en fait j'ai tapé yast au lieu de sax2, et j'ai pu accéder à une interface graphique.
Après quelques redémarrages parce que l'écran noir apparaissait toujours, j'ai désinstallé les deux paquetages nvidias que j'avais installé. (à savoir : nvidia-gfx-kmp-default et x11-video-nvidia)

Après les avoir désinstallé, comme par enchantement, mon linux a redémarré normalement.
Je repart donc de zéro (moment où j'ai branché ma carte à ma carte mère.)

I lfaut quand même que j'installe quelque chose http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

tyrtamos
11/03/2007, 14h37
I lfaut quand même que j'installe quelque chose http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif[/b]
Je ne sais pas ce que tu veux faire, mais pour ce qui concerne l'accélération 3D, utilise le driver linux du site nvidia: http://www.nvidia.fr/object/linux_fr.html. Et mets-toi en "init 3" pour cela.

Tyrtamos

Gigab
11/03/2007, 15h34
Oui j'avais vu le site..
Par contre visiblement il y a le choix http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

En fait le truc est simple, je veux que ma carte 3D 256Mo 64 bits, soit reconnue comme telle, que je bénéficie dont de l'accélération 3D avec toute la puissance de cette carte

Après pour installer le pilote avec init3, j'avoue que je ne sais pas trop..sauf q'il se trouve déjà dans les sources de Yast http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

Bon en fait j'ai fait ça :
EN MODE CONSOLE
init 3
root
votre mot de passe root :
puis cd /home/votre nom/ ou cd + chemin vers votre fichier nvidia
faite ensuite :
sh NV
sh NVIDIA-Linux-x86_64-1.0-7184.pkg2.run
sax2 -r -m 0=nvidia
(0 le chiffre pas la lettre )
init 5
pour repasser en mode graphique

ça a l'air de s'être bien déroulé, mais est ce la bonne manipulation que j'ai faite ?

Que faut il faire d'autre ?
Merci encore

EDIT : Visiblement dans Yast->matériel->moniteur et carte graphique, ma carte a bien été reconnue.
Faut il que j'essaye d'installer alors nvidia-gfx-kmp-default et x11-video-nvidia ?

Après pour avoir l'activation 3D ? le bureau 3D (si j'ai bien lu il faut que j'installe Bery)l ?
Merci de votre patience http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

EDIT 2 : c'est raté. Après avoir installé le driver, en redémarrant, je me retrouve avec la même erreur qu'au début : écran noir avec "Fréquence vidéo trop élevée".
Décidément ça ne va pas du tout avec cette carte...

Gigab
11/03/2007, 20h00
Personne ?
Je sais que c'est galère.
Pour faire simple, je vais récapituler http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

J'ai acheté donc une carte Geforce 6 256Mo 64bits Nvidia.
Après l'avoir connectée sur ma carte mère, j'ai installé le driver pris sur le site de nvidia, n°9755 (mars 07) avecinit 3.
Depuis je n'arrive plus à démarrer, j'obtiens un écran noir.

Quelqu'un peut il m'aider ?
Un grand merci !

tyrtamos
11/03/2007, 20h05
La manip que tu as faite (entre "init 3" et "init 5") me semble être bonne. J'espère que tu as bien répondu "no" à la proposition de lancer un programme de config: pour nous, c'est sax2. Une fois terminée, la 3D est en principe activée: tu peux le vérifier en appelant sax2: la ligne 3D en bas de la fenêtre doit être cochée.

Si ça ne marche pas, c'est peut-être parce que ta carte est trop récente ou trop ancienne. Les cartes supportées par les drivers standards sont ici: http://www.nvidia.fr/object/linux_supported_fr.html.

Si ta carte est trop ancienne, il y a des drivers "legacy" même pour le linux 64bits: http://www.nvidia.fr/object/linux_display_....0-7184_fr.html (http://www.nvidia.fr/object/linux_display_amd64_1.0-7184_fr.html).

Tyrtamos

Carnaby
11/03/2007, 20h07
Si je comprend bien, quand tu fait

sax2 -r -m 0=nvidia
tu as bien un affichage graphique?

Et même après le
init 5
ça fonctionne encore?

C'est uniquement quand tu redémarre le pc que tu perd l'affichage?

Gigab
11/03/2007, 20h34
A Tyrtamos :<div class='quotetop'>Citation </div>
'espère que tu as bien répondu "no" à la proposition de lancer un programme de config: pour nous, c'est sax2.[/b]

Ah non j'ai mis yes...
Bon je vais refaire une installation alors, en mettant "no"

A Carnaby : <div class='quotetop'>Citation </div>
C'est uniquement quand tu redémarre le pc que tu perd l'affichage?[/b]

Oui c'est exactement ça. Je vais efaire une installation (à cause du "no"), et je vous tiens au courant.

Bon je viens de refaire une installation, ça fait pareil.
J'ai bien mis "no" à la proposition.

Lorsque je fais sax2 -r -m 0=nvidia, ça me fait que no X server is running, qu'il va essayer d'ouvrir le truc, et puis après écran noir, j'ai plus qu'à rebooter, et ainsi de suite. Là j'écris sous windows.
D'après le lien que tu as donné tyrtamos, ma carte est censée être supportée.. c'est une geforce 6200.

Carnaby
11/03/2007, 20h57
Quand tu dit <div class='quotetop'>Citation </div>
Bon je viens de refaire une installation, ça fait pareil.[/b]
tu veux dire que tu réinstalle suse?

Tu n'a plus du tout d'affichage même en choisissant l'option "Failsafe" au démarrage ou en tentant de basculer sur une console (CTRL+ALT+F1) après le démarrage normal?

Gigab
11/03/2007, 21h01
<div class='quotetop'>Citation </div>
tu veux dire que tu réinstalle suse?[/b]


Non juste le driver nvidia 9755.
Je n'ai pas l'option failsafe (ou alors avec le cd d'installation de suse ?)
Et après avoir démarré sur le kernel (un démarrage comme d'habitude) je ne peux plus rien contrôler.
Je n'ai même plus l'erreur "fréquence vidéo trop élevée".
écran noir total.

tyrtamos
12/03/2007, 08h07
Bonjour,

Tu dis avoir utilisé "sax2 -r -m 0=nvidia" mais je ne connaissais pas l'option "-r", et elle ne figure pas dans la notice de nvidia.

Si je regarde dans la page man:

-r Remove detection database and re-init the hardware database

Tu es sûr que cette option est nécessaire?

Tyrtamos

Carnaby
12/03/2007, 10h09
Pas de problème j'utilise aussi cette option.

D'ailleurs elle fait partie de la procédure conseillé par Nvidia/Novell
http://www.suse.de/~sndirsch/nvidia-installer-HOWTO.html

Cooky
22/03/2007, 14h57
Quand tu installes les pilotes et arrives dans Suse en mode graphique, exécutes "nvidia-settings", et dans X-server-Display-configuration, choisis le refresh rate 60Hz, et enregistre.

Je crois si je ne m'abuse que les settings de l'utilitaire Nvidia (quand ils s'enregistrent...) "écrasent" ceux de xorg.conf. Il est probable que lorsque X démarre, ta carte tente de détecter elle même les caractéristiques de ton écran, et si elle trouve pas, elle va supposer par exemple que tu as un écran supportant le 1600x1200 en 60 Hz...ce qui n'est pas.