PDA

Afficher la version complète : [Réglé] Carte ATI Mobility Radeon X1300 sur portable DELL INSPIRON 6400



Richard_sraing
14/03/2007, 00h11
Bonsoir à tous,

voilà, je me lance, je ne sais pas trop où poster ce mesage, alors voyant que le sujet à déjà été aborder, je pense ne pas être au mauvais endroit.

Voilà j'explique mon problème.

J'ai acheté un portable DELL il y a quelque mois, et j'ai décidé de mettre un OpenSuse dessus. J'ai choisit la version 10.1, car elle me semblait très bien.

La configuration est la suivante:

Matériel:

- carte ATI Mobility X1300 128MBRam
- processeur DUO Core 1.83GHz
- 1 GB Ram

O.S.:

- OpenSuse 10.1
- lorsque je tape uname -r en su : 2.6.16.27-0.9-smp
- j'ai installer les drivers du site de ATI -> Drivers -> ...
- j'ai aussi installer un truc par Yast du genre "ati-fglrx-..."

Maintenant, lorsque je lance les effets de bureau de XGL, pendant un petit temps tout va bien(quelques secondes, parfois 1 minutes), mais à partir de là; les fenêtres freeze. Seule la souris continue à bouger, mais toutes les fenêtres sont figées, les menus inaccessibles,..., la meurde quoi... http://www.alionet.org/style_emoticons/<#EMO_DIR#>/blink.gif

Quelqu'un aurait-il une idée de ce que pourrait être mon problème?
Je n'ai pas suivi ce tuto (http://wiki.alionet.org/doku.php?id=ati) ci, mais un autre (dont j'ai d'ailleurs perdu le lien).

Est ce que je doit créer mon rpm moi même pour que ça fonctionne ?? http://www.alionet.org/style_emoticons/<#EMO_DIR#>/huh.gif
[ Et au fait est ce que quelqu'un pourrait m'expliquer brièvement ce qu'est un rpm? ]

Je vous remercie tous d'avance pour l'aide que vous pourrez m'apporter.

Je vous souhaites une bonne soirée et bon amusement avec LINUX...

galagann
14/03/2007, 12h27
Salux et bienvenux,

Pour toi, c'est beaucoup plus bas dans le Wiki : http://wiki.alionet.org/doku.php?id=ati#dr...epuis_suse_10.2 (http://wiki.alionet.org/doku.php?id=ati#drivers_ati_depuis_suse_10.2)

Richard_sraing
14/03/2007, 21h39
Ben voilà,

j'ai essayer de suivre le tuto, mais deux petits problèmes se posent à moi.
http://www.alionet.org/style_emoticons/<#EMO_DIR#>/arrow.gif Premièrement, c'est OpenSuse 10.1 que j'ai installer.
http://www.alionet.org/style_emoticons/<#EMO_DIR#>/arrow.gif Deuxièmement, j'ai activer l'accélération 3D dans SAX2, mais je ne sais pas lancer XMoto (j'ai lu qu'il suffisait de le lancer pour voir si l'accélération était installée) et lorsque je lance glxgears,
j'obtiens une moyenne de 150.156 FPS. ( Je pense que c'est bien 150 , 156 FPS et non pas 150.000 FPS)

Lorsque je veux lancer XGL, j'ai toujours le problème de freezing.

Est ce que cela pourrait venir d'une mauvais install ?? ( drivers ou même OS )

Si oui, comment puis je faire pour virer les drivers installer ?? http://www.alionet.org/style_emoticons/<#EMO_DIR#>/huh.gif YAST ?

Lorsque je tape fglxinfo, j'obtiens les lignes suivantes:

display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Mobility Radeon X1300 Generic
OpenGL version string: 2.0.6011 (8.28.8)

Voilà je pense, avoir pu donner toutes les infos nécessaires,

Merci d'avance pour votre aide, je vous souhaites une bonne soirée...

Richard_sraing

:EDIT:

Lorsque je vais dans le menu pour activer le XGL, il me dit:

Votre carte graphique n'est pas censée être prise en charge par XGL. Cependant, elle semble prendre en charge l'accélération 3D.

Pour Activer XGL, appuyez....

et a la fin il me donne la ligne de commande pour désactiver XGL dans un terminal.

Carnaby
14/03/2007, 21h53
L'accéleration 3d ne fonctionne pas, tu devrait à voir un score dépassant le millier sans problème et xmoto devrait tourner.

Sinon la méthode pour la 10.1 est bien sur la page indiqué, en bas juste au dessus de celle pour la 10.2.

Richard_sraing
14/03/2007, 22h26
Après quelques clics sur la Toile,

je suis tomber sur ce site:

click me (http://gentoo-wiki.com/HARDWARE_Video_Card_Support_Under_XGL)

et j'ai trouver ceci pour ma carte:

Radeon X1300 PCIe
Chipset:
Driver: ati-drivers-8.24.8
Notes: tested on Debian unofficial AMD64 etch. The driver also support other X1k card series.

Ils disent l'avoir tester pour Debian, mai sest ce que cela veut dire qu'elle ne marche pas pour Suse??

J'imagine que je donne l'impression d'être un GROS NULL, ben c'est vrai, j'ai jamais toucher à Linux jusqu'à y a 3 mois +/-, alors veuillez excuser mon ignorence.

galagann
14/03/2007, 22h55
MOBILITY RADEON X1300 (M52 714B) et MOBILITY RADEON X1300 (M52 714C) sont théoriquement compatible !

Richard_sraing
15/03/2007, 23h43
Beh oui c'est fort possible qu'elle soit compatible, mais alors soit je suis trop c** pour l'installer comme il faut,
soit la mienne à un problème.

Quoi qu'il en soit, je ne m'en tracasse pas, toutes les applics dont j'ai besoin pour l'instant tournent, donc,...

Par contre si jamais je trouve une solution à mon problème, je la noterais par ici le plus vite possible.

Merci pour votre aide et vos conseils, bonne soirée et bon clic.

Richard_sraing

Cooky
16/03/2007, 15h48
J'ai une mobility radeon 9700 sur mon portable, avec Suse 10.2. J'ai installé les derniers pilotes fglrx, et j'ai aussi des performances minables avec glxgear : 250 fps ! Je crois que les pilotes ATI sont pas terribles pour les cartes graphiques mobiles...

Agemen
16/03/2007, 18h09
La mobility radeon marche sur les portables : c'est la carte de boulch, et je lui ai installé son driver hier, tout semblait ok. Quant à mo, avec ma Mobility Radeon X700, j'ai à peu près 3900 fps. La question devient donc la suivante : avez vous réellement installé les drivers ATI?
Pour le deux installations que j'ai faite, j'ai noté les "problèmes" (ou plutôt oublis) suivants :
-sur mon pc, les sources kernel n'étaient pas installées. pour ça, on va dans yast, installer et supprimer des logiciels, on cherche les paquets kernel-source, qu'on installe. Si ma mémoire est bonne, il faut aussi gcc, et un autre paquet, mais je me souviens plus, c'est marqué dans un des wiki, et je le retrouve plus http://www.alionet.org/style_emoticons/<#EMO_DIR#>/blink.gif . mais seule les kernel-source manquaient.
- chez boulch, tout semblait ok. j'ai malgré tout refait la procédure intégrale : téléchargement des paquets chez ati, un petit sh ./ pour créer le fichier installable. A noter que ati propose de faire des sources prévues spécialement pour opensuse! Ensuite, clic droit, ouvrir avec, installateur de logiciel.
Et c'est là qu'on voit le deuxième oubli : il est absolument nécessaire de faire un : aticonfig --initial , pour que la config soit installée.

Dans les deux cas, à la fin de l'installation, j'ai lancé sax2, j'ai voulu faire le test... et ça a planté^^ mais j'ai relancé X, et là, oh miracle, j'avais l'accélération 3D (ce que j'ai su en lançant crhomium...)

En espérant que ça serve http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

PS : quand on installe le driver de la sorte, il est clairement indique de faire un "aticonfig" dans la console... mais ils ne précisent pas le "--initial" http://www.alionet.org/style_emoticons/<#EMO_DIR#>/huh.gif donc les petits nouveaux, comme moi, ne savent pas qu'il faut le faire...

Richard_sraing
17/03/2007, 11h50
Bonjour à tous,

ah bben là je dit chapeau, merci pour le petit message reprenant les oublis possible.

Je pense effectivement avoir oublié une des manip, je ne sais pas laquelle, mais je vais refaire toute l procédure et je verrais bien.

Merci beaucoup à toi Agemen, je me lance la dedans tout de suite...