PDA

Afficher la version complète : [Réglé] Fstab droits d'écriture...



pink-petal
15/03/2007, 16h41
Me revoici avec mes problèmes!

Bon, j'ai fait quelques modifications sur mon fichier fstab afin de monter automatiquement mon deuxieme disque dur (hdb1) mais voilà le truc... je ne peux rien déplacer ni effacer sur la partition monté, sauf si je suis en root et en console...

Voici mon fstab

/dev/hda1 / ext3 acl,user_xattr 1 1
/dev/hda3 /home ext3 acl,user_xattr 1 2
/dev/hda2 swap swap defaults 0 0
/dev/hdb1 /hd ext3 defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

qu'est ce qui ne va pas? (j'ai pris pourtant l'exemple sur ma partition hda3...)

Krocket
15/03/2007, 17h32
Me revoici avec mes problèmes!

Bon, j'ai fait quelques modifications sur mon fichier fstab afin de monter automatiquement mon deuxieme disque dur (hdb1) mais voilà le truc... je ne peux rien déplacer ni effacer sur la partition monté, sauf si je suis en root et en console...

Voici mon fstab

/dev/hda1 / ext3 acl,user_xattr 1 1
/dev/hda3 /home ext3 acl,user_xattr 1 2
/dev/hda2 swap swap defaults 0 0
/dev/hdb1 /hd ext3 defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

qu'est ce qui ne va pas? (j'ai pris pourtant l'exemple sur ma partition hda3...)[/b]



ton fichier fstab est bon, le problème provient des droits sur les fichiers

quand tu fais un ls -ltrh (root en console) dans le dossier /hd

tu vois apparaître par ex

ls -ltrh
total 296K
drwxr-xr-x 2 groupe krocket 8,0K 2006-07-08 22:16 Fond_ecran
lrwxrwxrwx 1 groupe krocket 26 2007-03-08 08:44 Examples -> /usr/share/example-content
-rw-r--r-- 1 groupe krocket 275K 2007-03-09 14:32 Firefox_wallpaper.png
drwxr-xr-x 2 groupe krocket 4,0K 2007-03-13 08:10 vmware
drwxr-xr-x 3 groupe krocket 4,0K 2007-03-15 11:13 Desktop

regardons de plus près les chaines
le premier caractére est soit un d pour un dossier ou un l pour lien, ou - pour une fichier
les caractéres suivant r pour lire, w pour écrire, x pour éxecuter
pour mieux comprendre faut découper la chaine donc on la subdivise en 4 groupes
exemple pour desktop
on a le d ,rwx , r-x et r-x
donc le d=dossier
le premier groupe rwx représente les droits sur le fichier pour le propriétaire donc <span style="color:#cc66cc">krocket => krocket peut lire écrire éxecuter le fichier</span>

le deuxième groupe r-x représente les droits sur le fichier pour le groupe donc tous les utilisateurs du groupe <span style="color:#cc66cc">=><span style="color:#000000"> peut lire et éxecuter le fichier, mais non pas le droit "écrire"</span></span>

le troisième groupe r-x représente les droits sur le fichier pour tous les autres utilisateurs <span style="color:#cc66cc">=><span style="color:#000000"> peut lire et éxecuter le fichier, mais non pas le droit "écrire"

Ha mon avis ton problème provient de là. il a plusieur façon pour corriger ton problème tout dépend de ce que tu désires faire .
</span></span>

Tuxie
15/03/2007, 22h17
Dans la colonne où tu as indiqué "defaults", il faut mettre "user".

pink-petal
16/03/2007, 09h51
Dans la colonne où tu as indiqué "defaults", il faut mettre "user".[/b]
C'était effectivement ça, il fallait mettre user à la place de default...

Un grand merci encore à vous tous.

Heero_Yuy
16/03/2007, 10h13
N'oublie pas de mettre [Réglé] devant le titre de ton premier post http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

[Edit] OOps, tu l'as fait en même temps que j'écrivais.

Valdoror
24/03/2007, 01h57
<div class='quotetop'>Citation (Tuxie @ 15/03/2007 à 21:17) <{POST_SNAPBACK}> (index.php?act=findpost&pid=129266)

Dans la colonne où tu as indiqué "defaults", il faut mettre "user".[/b]
C'était effectivement ça, il fallait mettre user à la place de default...

Un grand merci encore à vous tous.
[/b][/quote]
Heureux que tu sois parvenu à tes fins, mais franchement, je ne comprends pas pourquoi le fait de remplacer "defaults" par "user" change quoique ce soit http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

L'option defaults équivaut aux options suivantes : rw, suid, dev, exec, auto, nouser, et async.

Et l'option user (le contraire de l'option nouser ci-dessus) permet à un utilisateur différent de root de pouvoir (dé)monter la partition. Comme tu avais déjà monté ta partition et que ton problème résidait dans le fait de ne pas pouvoir manipuler les fichiers de cette partition, ce n'est pas le fait d'activer l'option user qui change quoique ce soit à mon avis.

J'avais le même problème que toi ce soir (montage de mon premier DD SATA !) et je viens tout juste de le régler, mais pas de la même manière. Le problème résidait dans les droits du point de montage (/hd chez toi). Le répertoire appartenait à root avant le montage de la partition, avec les droits drwxrwxrwx.

Je ne m'en suis pas rendu compte tout de suite, mais le fait de monter la partition en tant que root a modifié les droits du point de montage en drwxr-xr-x ! Il faut croire que le umask de root (paramétré à 0022) s'est appliqué au point de montage - au moment du montage de la partition - comme dans le cas d'une création de fichier...

J'ai donc bêtement tenté un "chmod 777 <point_de_montage>" PARTITION MONTEE et mon problème était réglé. La partition est maintenant accessible à tous les utilisateurs de la machine, en lecture/écriture.

J'ai testé en démontant puis en remontant la partition, les droits sont conservés.

Voilà, je suis simplement curieux de comprendre par quel mécanisme ton problème s'est résolu http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif