PDA

Afficher la version complète : [Réglé] Pb de reconnaissance carte ATI 9250



Gigab
17/03/2007, 21h52
Bonsoir,

Après avoir eu un max de problèmes avec ma carte graphique Nvidia 6200, j'ai changé et acheté une ATI Radeon 9250.
Pour mieux faire, j'ai complètement réinstallé Suse 10.2.

Seulement, ça m'a reconnu comme carte ATI RV280 5960 ???!!! je ne sais absolument pas pourquoi.
J'ai eu le malheur d'accepter cette config et quand l'installation s'est achevée, lors du boot, j'ai eu le très hai "fréquence vidéo trop élevée".
Ne sachant comment pallier le problème, j'ai donc fait une autre réinstallation.
Même config, ATI RV280 5960. et je n'ai pu démarrer qu'en mettant l'écran en 1280x960 au lieu du 1280x1024.

Autant dire que ça ne me satisfait pas du tout ce bidouillage.
Quelqu'un aurait il rencontré le problème ? comment le résoudre ?
Je m'étais pourtant renseigné auprès du vendeur, qui m'a dit que normalement sous Linux, il ne devait pas y avoir de pilote à installer...

Merci d'avance de votre aide http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

Cooky
18/03/2007, 00h20
Le nom de code du 9250 est le RV280. Par contre, 5960, je sais pas d'où ça vient.

Tu as fait "sax2 -r -m 0=fglrx" en mode console ? Une fois l'installation terminée, cette commande permet à sax2 de configurer automatiquement la carte vidéo, en particulier les résolutions d'écran. D'ailleurs, il est possible de configurer le taux de rafraichissement (ie la fréquence vidéo) dans sax2.

Sinon effectivement, sous Linux, les cartes ATI sont reconnues sans pilotes, tout comme les cartes Nvidia au passage, même si l'accélération 3D est -la plupart du temps...- supportée par les premières par le pilote par défaut. Toutefois, les performances sont vraiment médiocres avec ce pilote, il est plus que chaudement recommandé d'installer les pilotes "officiels".

Gigab
18/03/2007, 09h28
Bonjour, merci pour ta réponse.

En fait j'ai trouvé pas mal de wiki, j'en ai compris certains d'autres non..mais mon problème n'est pas résolu.
Voici ce que j'ai fait:
1/ j'ai téléchargé le driver (je suis en x86_64
2/Sous root, init 3 => sh ./ati-driver-installer-8.28.8.run
3 j'arrive sur l'installation

You are running a x86 machine with glibc-2.1
Operating system Suse Linux 10.2
J'ai fait OK (pas le choix)

4/
Choose installation
1 Install driver on Unknown X window
2 Generate distribution specific driver package
J'ai fait le 1

5/ Message indem que 3/

6/Class of install => j'ai fait "Recommended"

7/ Would you like to launch a Web browser => j'ai fait no

8/
There were errors during the installation, for details see /usr/share/fglrx/fglrx-install log

Je suis donc allé vie "vi", regarder ce fichier, et voilà ce que j'ai :


Kernel includes at lib/modules/2.6.18.2-34-default/build/ include do not match current kernel. They are versioned (pas sûr du mot) at "" instead of 2.6.18.2-34-default
You might need to adjust your symlinks
-usr/incule
usr/src/linux

J'ai peut être oublié d'installer des choses, je ne sais pas...
Voilà si vous pouvez m'aider ça sera avec grand plaisir..ça fait une semaine que j'arrive pas à utiliser mon pc à cause de ces config http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

Pour le petit mot, comme lors de cette dernière installation de driver le pc ne démarrait plus, là je suis sur une nouvelle installation..

Merci ! http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

galagann
18/03/2007, 11h33
Gigab, le problème c'est qu'il te faut supprimer le driver nVidia avant de pouvoir faire l'installation du driver ATi.

La meilleure des choses est de réinstaller le Kernel de base en y ajouter bien les sources.

Voir aussi, dans Yast2, Logiciels, Installation et suppression de Logiciels, si tu n'as pas un programme nvidia à supprimer http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

Gigab
18/03/2007, 13h38
Mais pourquoi des drivers nvidia sont installés alors que je n'ai rien de nvidia (hormis le chipset de la carte mère) ??
Et comment désinstaller tout ça ?

Sinon comment réinstaller le kernel de base ? je viens de tout mettre à jour (plus de 140 mises à jour)
Le problème que j'ai eu hier (cf mon précédent message) a eu lieu alors que l'installation était toute 'fraiche'. Je n'avais fait aucune mise à jour de quoi que ce soit

Cooky
18/03/2007, 15h54
Tu as essayé avec l'option "generate distribution specific package" ? Je crois que c'est ce qu'ils conseillent sur le site web d'ATI.

Gigab
18/03/2007, 16h05
oui j'ai essayé mais en cours de l'installation il faut donner un nom de fichier ou d'emplacement, et là je sèche..

EDIT : enfin s'il faut supprimer des drivers nvidia, faire le ménage avant d'installer, mieux vaut le faire..mais comment, je suis sur Linux que depuis très peu de temps..

EDIT 2 : J'ai essayé de reprendre leur procédure d'installation (ATI) et en fait dès le début, j'ai ça

ATI Technologies Linux Driver Installer/Packager
==================================================
Detected configuration:
Architecture: x86_64 (64-bit)
X Server: Xorg 7.1.99.902
find: install/usr/X11R6/lib/modules/dri: Aucun fichier ou répertoire de ce type
find: install/usr/bin/fireglcontrolpanel: Aucun fichier ou répertoire de ce type

Je préfère pas continuer plus..

Merci de votre aide

Gigab
18/03/2007, 19h35
Personne ? il n'y a que moi qui ait ces problèmes ? (que ça ne m'étonnerais pas de toute façon lol )

EDIT : ben faut croire que le sujet n'amène pas du monde.

Ma carte a l'air d'être reconnue. J'installe le driver selon ce wiki (très clair !)
http://wiki.alionet.org/doku.php?id=beryl_kde_ati

Mais quand tout est rebooté et que je fais
# glxinfo | grep rendering
Je n'ai pas yes à rendering, mais "no"

en plus de ceci :

Xlib: extension "XFree86-DRI" missing on display ":0.0".
direct rendering: No

Après pour le glxgears :

glxgears
Xlib: extension "XFree86-DRI" missing on display ":0.0".
1784 frames in 5.0 seconds = 356.647 FPS
1769 frames in 5.0 seconds = 353.727 FPS
1891 frames in 5.0 seconds = 378.135 FPS
1436 frames in 6.3 seconds = 229.022 FPS

Franchement si vous pouviez m'aider, ça serait génial, peut être qu'il n'y a quasimment rien à faire, un petit module non installé ou je ne sais pas quoi...
Merci

Gigab
18/03/2007, 23h05
Je précise une petite chose: mon écran actuellement ne veut pas supporter une résolution plus haute que 1280x960 et 60Hz de taux de rafraichissement..
Théoriquement il devrait arriver à 1280x1024..
C'est un Hyundai ImageQuest L70N

Gigab
19/03/2007, 14h14
ouaouhhh !! quel intérêt !! http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

Faut mettre mon problème dans les annales, catégorie insoluble http://www.alionet.org/style_emoticons/<#EMO_DIR#>/cool.gif

galagann
19/03/2007, 22h15
Pour l'installation rapide et simplement du driver ATi : http://wiki.alionet.org/doku.php?id=ati

Gigab
19/03/2007, 22h41
Merci mais j'ai un 64 bits. J'ai déjà fait la manip et installé le rpm..
Mon écran fait 1280x960 au lieu de 1280x1024 et je n'ai pas l'accélération 3D visiblement (Xmoto ne fonctionne pas)

Je ne sais plus quoi faire

galagann
19/03/2007, 23h03
Il faut après la mise du driver, retourner dans Sax2 pour vérifier les paramètres écran et résolution en passant par la petite case Activé la 3D en bas à gauche http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

Gigab
19/03/2007, 23h11
C'est bien dans Yast > Matériel >Carte graphique et écran ?
Là la case Activer la 3D est chochée et grisée pour qu'on ne puisse pas la décocher.
L'écran est noté en 1280x1024.

Mais la 3D ne fonctionne pas (X Moto ne démarre pas) et l'écran est bien en 1280x960 (avec KrandRtray) sans qu'on puisse modifier plus haut..avec 60Hz de rafraichissement alors que normalement ça devrait être à 70 ou 75.

Gigab
20/03/2007, 08h13
Bon on va commencer par le début.. j'ai re installé le driver, il n'y a rien de plus.
Pour commencer l'installation qu'est ce qui doit être installé (via yast) qu'est ce qui ne doit pas l'être ?

Perso, j'ai installé ati-fglrxD01-kmp-bigsmp et kmp-default.
j'ai plein de x11-xorg (driver input, driver video, font, libfontenc,libs, libs32 bits, et plein d'autres)

Parce que si j'ai installé des trucs qui rentrent en conflit et que je ne le sais pas...
Sinon pour ce qui est des choses à installer ? qu'est ce qui doit l'être ?

Merci de votre réponse

Gigab
20/03/2007, 15h23
Si je ne peux pas recevoir d'aide ici (parce que vous ne savez pas la solution - ce n'est pas péjoratif ce que je dis, ça arrive- ) savez vous où je peux demander ?

Agemen
20/03/2007, 17h24
J'ai une question qui n'a pas grand chose à voir... mais tu as essayé en 32 bits? ça me semble bizarre toutes ces histoires...
Pour le tuto mis en rapport avec beryl, dont tu as donné le lien, il ressemble pas vraiment à ce que j'ai fait pour installer mon driver.
pour moi, il me semble que ça ressemblait plus à un
sh ./ati-driver-installer-********.run, ce qui lançait un installateur graphique. Là, j'ai effectivement généré les paquets spécifiques à OpenSuSe, puis clic droit, ouvrir avec l'ainstallateur de logiciel. Puis pour finir, aticonfig --initial ... Ensuite, j'ai fait planté mon pc avec sax2, j'ai relancé X, et ça marchait.

Gigab
20/03/2007, 21h22
Non je n'ai pas essayé en 32 bits..mais est ce que ça va fonctionner ? comme je suis en 64 bits ...

Agemen
20/03/2007, 21h33
Essaie avec la même méthode qu'en 32 bits, décrites dans un wiki. Je vois pas de raisons pour que ça change quelquechose, mais comme je tourne pas en 64 bits http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif
En tout cas, fait un aticonfig --initial , si t'as pas déjà esayé...

Gigab
21/03/2007, 08h28
Bon j'ai fait plus simple parce que sinon je ne m'y retrouve absolument pas.
J'ai réinstallé tout le système. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

- A l'installation, détection de la carte graphique aTI Radeon 9250 comme une ATI RV280 5960
- Obligation dans la détection des paramètres, de mettre au max l'écran en 1280x960 sinon "Fréquence vidéo trop élevée"
- A chaque installation, erreur lors du test de la connection internet (alors que quand l'installation est achevée j'ai internet comme d'hab et parfait)
- Lors de l'installation, je laisse le pare feu activé (quitte à le désactiver plus tard)
- le port SSH est bloqué (je ne sais pas ce que c'est)
- J'ai inclus juste la source download/..../repo/oss....
- L'installation est actuellement "brute de décoffrage", je n'ai absolument rien fait d'autre, pas installé de sources ni de logiciels, pas de mise à jour. J'ai donc maintenant un système uniquement installé à partir du CD OpenSuse 10.2 64bits..

On repart de zéro, que faut il faire pour ce que cette foutu carte graphique fonctionne avec l'accélération 3D ?? http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif
Quels programmes installer avant ? des kernel? des drivers ? je suis nuuul pour le moment http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif (mais j'apprend, il faut bien commencer) http://www.alionet.org/style_emoticons/<#EMO_DIR#>/unsure.gif

Merci de votre aide et surtout de votre patience !!

thveillon
21/03/2007, 16h54
Salut, si je ne me trompe pas la 9250 n'est plus supportée par les derniers drivers ati, il faut utiliser le 8.28.8...mais ce dernier ne semble pas bien digérer x.org 7.2 qui est installé sous Suse 10.2. Il faudrait peut-être rétrograder en 7.1 ?

Agemen
21/03/2007, 20h56
<div class='quotetop'>Citation </div>
Automated installer and Display Drivers for XFree86 4.3 and X.Org 6.7, 6.8, 6.9, 7.0, 7.1[/b]

Un point pour toi. le driver ati ne supporte pas le dernier Xorg, pour ta carte... j'imagine que tu vas devoir repasser en 7.1...

PS : j'ai installé le driver pour la X700, et je suis aussi sur une 10.2. Je ne sais pas dire a priori quelle version de Xorg je possède, mais a priori c'est la même... et le driver marche!
Dans le doute, essaie ça :
tu chopes le driver pour ta carte directement avec ton navigateur internet, sur le site ati.amd.com :ati (http://ati.amd.com/support/drivers/linux/linux-radeon.html) . ensuite, tu te mets en console en root, puis :
-tu vas dans le dossier ou se trouve le fichier nouevellement chargé
sh ./ *nom du driver* (pour savoir comment il s'appelle tu fais un ls)
là il va te lancer un installateur graphique. tu génères les paquets spécifiques à la 10.2 64 bits.
tu trouves le paquet dernièrement créé, clic droit, ouvrir avec, installateur de logiciel.
là il va t'installer ton driver comme un chef^^
pour finir, tu fais un aticonfig --initial
ensuite, tu lances le test avec sax2 (je me souviens pas de la commande, mais elle est dans un tuto, et aussi dans un des posts du sujet) (je crois que c'est sax2 -r... mais je jurerais pas. de toutes façons, moi ça avait foiré http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif ) si le test plante, tu tues X (ctrl+alt+backspace), ou tu relances ton pc. voilà!

Gigab
21/03/2007, 21h04
Merci de vos réponses. en fait alors, ce serait un problème de Xorg..comment faire pour repasser à la 7.1 alors ?

Et à quoi sert le Xorg ? parce que ça me fait peur si les drivers ne se font plus, j'ai acheté la carte la semaine dernière http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

Alors si on peut plus faire les mises à jour...http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

thveillon
21/03/2007, 22h35
parce que ça me fait peur si les drivers ne se font plus, j'ai acheté la carte la semaine dernière http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

Alors si on peut plus faire les mises à jour...http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif[/b]

C'est la joie d'utiliser des pilotes graphiques propriétaires... par contre ta carte est parfaitement supportée par le pilote libre Mesa (y compris la 3D) qui lui sera mis à jour et s'améliorera régulièrement. Si tu n'es pas un accro du FPS (images par seconde) ce pilote te suffira sans problème, il permet d'installer googleearth, de jouer à xmoto, supertux ou frozenbubble par exemple, en revanche il te laissera sur ta faim concernant Quake ou les derniers effets de bureau 3D (la radeon 9250 n'est de toute façon pas supportée en générale même avec les pilotes ATI, le seul contre exemple que je connaisse c'est la distrib live MCNlive-virtualcity en utilisant aixgl qui fonctionne bien, aucune idée cependant de la manière de reproduire ça sur Suse).

Pour xorg il s'agit d'un serveur graphique, c'est à dire la base du système de fenêtrage qui te permet d'utiliser un bureau et ta souris au lieu de la ligne de commande... Le retour à un système antérieur ne sera pas chose facile car il y a beaucoup de dépendances à xorg, en plus ce n'est pas très logique comme démarche si tu te soucis des mises à jour car xorg n'a pas évolué pour rien et revenir en arrière ne te pemettrait pas de bénéficier des mises à jours de sécurité de tous les paquets dépendant de xorg. En tout cas avant toute manip y compris l'installation d'un pilote graphique c'est une bonne idée de faire une sauvegarde du fichier de configuration de xorg (/etc/X11/xorg.conf) pour y revenir plus tard en cas de pépin !

Pour résumer tu as le choix entre un pilote propriétaire qui n'évolueras plus au prix de pas mal d'effort, le pilote libre au prix de performances un peu moins bonnes, ou le changement de carte graphique (pour une Nvidia peut-être ?) au prix...fort !

Gigab
21/03/2007, 22h48
Dure conclusion...
Surtout que le vendeur m'a dit que c'était parfaitement supporté par Linux..mon intérêt n'est pas trop les jeux, mais surtout pour avoir le bureau 3D http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

La semaine dernière j'avais énormément de problème avec ma nvidia que j'ai rendu finalement..et maintenant la Ati !! ça fait beaucoup..

C'est quoi et dans quel genre de prix une bonne carte ?

thveillon
22/03/2007, 18h02
Je suis peut-être un peu pessimiste concernant la gestion du bureau 3D avec une 9250, si c'est tout ce dont tu as besoin et que tu n'es pas un accro des jeux ça peut suffire en choisissant la bonne solution logicielle parmis toutes les possibilités (xgl,aixgl,béryl etc...). Perso j'ai installé sous OpenSuse 10.2 avec une 9250 xgl et compiz : c'était très buggy, moche à souhait et pas du tout utilisable au quotidien ! Mais tout ça évolue très vite car ces technos sont encore au stade expérimental. Sinon j'ai cru comprendre que Nvidia va intégrer le support du bureau 3D dans ses drivers rendant beaucoup plus simple l'install de Béryl ou autre, renseigne toi si ça t'intéresse et consulte le site officiel du gestionnaire de bureau qui t'intéresse pour vérifier la compatibilité hardware avant tout achat. Peut être qu'un courriel à un développeur du gestionnaire pourrait également arranger des choses, sachant que ta carte est grand public (vendue dans les hypermarchés je crois) ça pourrait être intéressant de la supporter.
Bonne recherche et à +

Gigab
22/03/2007, 21h34
Merci de ta réponse..
Je vais déjà changer de pc je pense, mais où m'orienter pour les cartes graphiques ?

C'est totalement nouveau pour moi, et si je dois acheter une nouvelle carte à chaque fois que le pilote arrête d'être fait ...lol

Qu'est ce qui est le mieux ? (pour utilisation bureau 3D, des jeux parfois, etc)

Merci encore http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

thveillon
24/03/2007, 17h38
Je ne vais pas te faire l'apologie de telle ou telle carte graphique car je ne joue pas et n'utilise pas les effets de bureau 3D, en revanche concernant le suivit des mises à jour il faut consulter la liste des cartes supportées par les derniers pilotes graphiques de la marque et acheter quelque chose de supporté. Pour jouer tout dépend du type de jeu, le mini actuellement chez Nvidia pour jouer à des poids lourds genre Quake et compagnie sera sans doute une carte basée sur du 7300, préférablement du 7600, ce qui nous fait dans les 70-150€ en fonction des modèles. Chez Ati l'équivalent doit s'appeler X1300 et X1600 pour le même prix. Ce sont des produits récents qui seront supportés un moment. en revanche le choix de ta carte me fait penser que tu es sur de l' AGP, or maintenant le pci-express règne en maître et les cartes AGP se font rares et chers, sauf sur les sites de vente en ligne où elles abondent à des prix raisonnables.
Pour des jeux plus cool type xmoto ou supertux ou lbreakout ta carte avec les pilotes libre et la 3D activée fera l'affaire, de même que n'importe quel chipset graphique intégré à une carte mère récente. Ne pas perdre de vu avant de craquer pour une rolls graphique que ces monstres consomment beaucoup (=alim costaud), necessite un processeur qui ne les bride pas (=double coeur ou simple coeur balaise) et de la mémoire vive en pagaille...