PDA

Afficher la version complète : [Réglé] Comment activer le mode silencieux sur un disque dur ?



Aqu@rius
20/03/2007, 00h19
Bonsoir à tous http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif
et merci d'avance pour votre aide http://www.alionet.org/style_emoticons/<#EMO_DIR#>/rolleyes.gif

Depuis l'installation de la Suse 10.2 ( qui n'a posé aucun problème) j'ai eu au redémarrage la désagréable surprise de constater que mes deux disques durs avaient perdu, comment dire... toute leur discrétion .http://www.alionet.org/style_emoticons/<#EMO_DIR#>/unsure.gif

En effet, mes deux Western Digital étant à la base assez bruyants , j'avais activé ,par le biais d'un programme l'AAM afin qu'ils se fassent plus discrets, même s'il paraît qu'on perd légèrement en performances.

Et depuis que j'ai installé la Suse ,c'est comme si elle me désactivait cette fonction. Et mes disques font un bruit terrible (grattage insupportable à chaque lecture-écriture)
J'ai donc relancé le programme en question afin de ré-activer la fonction AAM (je l'ai réglée sur "Quiet" et malheureusement au redémarrage de la Suse, rebelotte... http://www.alionet.org/style_emoticons/<#EMO_DIR#>/mad.gif

J'ai vu dans les propriétés de mes disques qu'on pouvait activer la fonction "mode silencieux" mais lorsque je clique sur "Activer le mode silencieux" de l'onglet "montage" j'ai ce message :
"Le point de montage doit figurer sous /media." Et je ne sais comment faire. Sauriez-vous m'éclairer éventuellement ? A moins qu'il y ait une autre méthode ?

Merci par avance http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

wapwap
20/03/2007, 08h08
Tu fais fausse route... fait un clic droit a proximité de l'option "mode silencieux" puis sur la question "Qu'est-ce que c'est" qui apparait alors... tu verras que cela concerne des messages d'erreur qui ne sont pas rapportés et non le bruit de ton disque...

Par contre si tu ouvres un terminal en tant que root et que tu saisis la commande :


hdparm -I /dev/hda hda est à remplacer par le nom de ton disque...

tu pourras trouver au milieu de tout un tas d'information...

<div class='quotetop'>Citation </div>
Recommended acoustic management value: 128, current value: 254[/b]

Cette ligne qui te donne la valeur recommandé pour ton disque en terme de gestion du bruit et la valeur utilisée par le système actuellement...

Lance ensuite YAST>Système>Gestion de l'Energie et choisi "Modifier les Profils", selectionne un profil à modifier (Performance si c'est celui que tu utilises par défaut) puis regarde dans les options qui défilent en cliquant sur "suivant", il y en a une qui se rapporte aux "Règles sonores" du disque dur... Chez toi c'est sans doute "Performance maximale" qui est sélectionné, passe à "Mode silencieux" valide en cliquant sur "suivant", "OK" puis "Terminer", puis relance la commande hdparm dans un terminal comme précédemment...

Si la valeur "current value" a changé (passer de 254 à 128), c'est gagné !!! sinon il faut faire le réglage à la main par la commande


hdparm -M 128 /dev/hda

Et comme les commandes hdparm se réinitialisent à chaque démarrage, il faudra automatisé le processus en inscrivant cette commande dans le fichier /etc/init.d/boot.local (à éditer en tant que root... clic droit sur le bureau "Exécuter une commande" > kdesu kwrite /etc/init.d/boot.local

Voila, bonne chance et @ +

Heero_Yuy
20/03/2007, 09h20
Salux,

Je prends le sujet en cours car il est intéressant. Je vais regarder cela sur mon portable pour voir, même s'il n'est pas si bruyant, mais ça m'intéresse.

Merci pour l'info http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

krapouyo
20/03/2007, 16h16
NIKEL!!! http://www.alionet.org/style_emoticons/<#EMO_DIR#>/clap_1.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/clap_1.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/clap_1.gif
J'avais le même problème et grâce à wapwap je ne l'ai plus!
Merci bien

Aqu@rius
20/03/2007, 16h18
Bonjour à tous http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

Un grand , grand merci à toi ,wapwap, pour ta réponse on ne peut plus claire et complète. En effet, j'ai appliqué tes recommendations et là... Ô miracle , mes deux disques durs ont retrouvé leur discrétion que j'affectionnais tant http://www.alionet.org/style_emoticons/<#EMO_DIR#>/rolleyes.gif .
Cela faisait un moment que je cherchais une solution à ce problème et le voilà désormais réglé. Je dis bravo http://www.alionet.org/style_emoticons/<#EMO_DIR#>/clap_1.gif
Je ne connaissais pas cette commande hdparm. Il faut dire que mes connaissances "linuxiennes" sont encore très modestes http://www.alionet.org/style_emoticons/<#EMO_DIR#>/unsure.gif
De plus , je n'ai pas eu à effectuer la manip à la main en ligne de commande. Ca a marché du premier coup en fait. J'ai vérifié , la valeur est bien repassée à 128 et après redémarrage , tout était ok ! Le silence était enfin revenu http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

Alors une fois encore, sans tomber dans l'obséquiosité... http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif mille merci pour ton aide wapwap http://www.alionet.org/style_emoticons/<#EMO_DIR#>/thumbup.gif et merci à ce formidable forum d'exister. Voilà, j'arrête la mes éloges ...ça fait un peu "too much" quand même http://www.alionet.org/style_emoticons/<#EMO_DIR#>/laugh.gif

Au plasir de vous lire,
Cordialement
-Aqu@rius-

Heero_Yuy
20/03/2007, 16h43
Ne pas oublié de mettre [Réglé] devant le titre du premier post http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

yoplait
20/03/2007, 19h34
Excellent cette astuce http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

wapwap
20/03/2007, 22h06
http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif De rien, c'est avec grand plaisir que je vous ai filé un ptit coup de main. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif