PDA

Afficher la version complète : hp color laserjet 1600 opensuse10.2 [Réglé]



pomme2tr
30/03/2007, 15h14
bonjour,
je n'arrive pas à faire fonctionner cette imprimante.
quelqu'un peut il me donner la solution car tout ce que j'ai trouvé sur le net ne fonctionne pas et le driver de yast ne donne rien.
à priori c'est le même que pour la 2600, dans yast existe la 2605 mais sans effet.

merci.

Heero_Yuy
30/03/2007, 15h18
Salux,

Il te faut utiliser le driver foo2hp

Source : http://www.linuxprinting.org/show_printer....r_LaserJet_1600 (http://www.linuxprinting.org/show_printer.cgi?recnum=HP-Color_LaserJet_1600)

pomme2tr
30/03/2007, 17h43
merci angel, je suis le driver foo sur cette page
http://foo2hp.rkkda.com/INSTALL

et quand je fais make, j'obtiens :
maison1@maison:~/telechargements/foo2zjs> make
#
# Dependencies...
#
***
*** Error: cc is not installed!
***
*** Install Software Development (gcc) package
***
make: *** [all-test] Erreur 1
maison1@maison:~/telechargements/foo2zjs>
dans yast gcc est installé, je ne sais que faire !!

Heero_Yuy
02/04/2007, 08h53
Salux,

Vérifies dans Yast si les sources du kernel sont installées.

pomme2tr
05/04/2007, 07h46
dans yast je n'ai que kernel default d'installé
faut que je mette kernel-source ?

Heero_Yuy
05/04/2007, 08h08
Salux,

Il faut installer kernel-source, make et gcc pour installer foo2hp.

pomme2tr
06/04/2007, 07h23
il me remets la même ligne
***
*** Install Software Development (gcc) package
***

donc yast n'a pas installé gcc.
quelle version prendre et comment faire ? merci


dans yast j'ai
cpp41, gcc41-gij, gcc-gij, libgcc41, libgcj41 de cochés donc installés

Heero_Yuy
06/04/2007, 08h14
Fais une recherche dans Yast avec le mot clé gcc. Il va te proposer une liste de package. Regardes si celui nommé gcc est coché. S'il n'est pas coché, tu le coches, tu cliques sur le bouton Vérifier Maintenant (en bas de la fenêtre Yast) pour vérifier les dépendances, puis tu fais la même chose avec make.

Tu fais OK (ou Accepter), et il va te l'installer.

pomme2tr
06/04/2007, 09h26
merci de ta reponse
oui c'est ce que j'ai fait mais je n'ai que ceux cité ci dessus et ci dessous
cpp41
gcc41-gij
gcc-gij
libgcc41
libgcj41
de proposé et tous sont cochés (et installés)
il doit manquer qq chose ...........;

Heero_Yuy
06/04/2007, 09h53
Bizarre. Normalement, gcc est inclus dans le DVD.

As-tu ajouté les sources Packman, Guru et openSuSE à Yast ?

Sinon, télécharges suivant ta version (32 ou 64 bits ?) de SUSE :

http://www.alionet.org/style_emoticons/<#EMO_DIR#>/icon_fix.gif 32 bits : ftp.opensuse.org/distribution/10.2/repo/oss/suse/i586/gcc-4.1.3-29.i586.rpm (http://ftp.opensuse.org/distribution/10.2/repo/oss/suse/i586/gcc-4.1.3-29.i586.rpm)
http://www.alionet.org/style_emoticons/<#EMO_DIR#>/icon_fix.gif 64 bits : ftp.opensuse.org/distribution/10.2/repo/oss/suse/x86_64/gcc-4.1.3-29.x86_64.rpm (http://ftp.opensuse.org/distribution/10.2/repo/oss/suse/x86_64/gcc-4.1.3-29.x86_64.rpm)

pomme2tr
06/04/2007, 10h37
oui

j'ai téléchargée et :
#### YaST2 conflicts list - generated 2007-04-06 10:36:02 ####

Impossible d'installer gcc-4.1.3-29.i586[_krpmview_temporary] �cause de d�endances manquantes
Aucun fournisseur de gcc41 d�inissable pour gcc-4.1.3-29.i586[_krpmview_temporary]
R�olution de conflit :
( ) ne pas installer gcc
( ) Ignorer cette exigence cette fois uniquement

#### YaST2 conflicts list END ###

Heero_Yuy
06/04/2007, 10h52
Bizarre car sur le site http://ftp.opensuse.org/pub/opensuse/distr.../oss/suse/i586/ (http://ftp.opensuse.org/pub/opensuse/distribution/10.2/repo/oss/suse/i586/), il y a un package gcc41-4.1.2_20061115-5.i586.rpm.

Est-ce que ce package est installé chez toi ?

pomme2tr
06/04/2007, 11h29
Bizarre car sur le site http://ftp.opensuse.org/pub/opensuse/distr.../oss/suse/i586/ (http://ftp.opensuse.org/pub/opensuse/distribution/10.2/repo/oss/suse/i586/), il y a un package gcc41-4.1.2_20061115-5.i586.rpm.

Est-ce que ce package est installé chez toi ?[/b]
non
l'instal du 4.1.2 donne la même chose et jusque là je n'avais jamais connu ce souci

je reviens mardi tester toutes vos bonnes idées, encore merci.

Heero_Yuy
06/04/2007, 12h06
Alors là, j'en perds mon cri de pinguoin http://www.alionet.org/style_emoticons/<#EMO_DIR#>/blink.gif , euh non mon latin http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif .

Lorsque j'ai eu à faire une install par compilation des sources d'un soft, j'ai jamais eu de soucis. Comprends pas pourquoi ça marche pas chez toi ??????? http://www.alionet.org/style_emoticons/<#EMO_DIR#>/huh.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/blink.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/scratch.gif

J'ai beau me creuser la tête http://www.alionet.org/style_emoticons/<#EMO_DIR#>/bang.gif , je ne vois pas ce qui cloche. En même temps, j'ai pas ma SUSE devant les yeux (ni même avec moi http://www.alionet.org/style_emoticons/<#EMO_DIR#>/cry2.gif ) pour vérifier les packages qui sont installés chez moi.

Je vais regarder ce week end.

pomme2tr
12/04/2007, 10h30
coucou me revoilà avec mes soucis
angel as tu trouvé une solution ?
ou quelqu'un d'autre ?
merci.

Heero_Yuy
12/04/2007, 10h40
Salux,

Désolé, ce week end, avec le temps magnifique qu'il a fait dans le Nord, j'ai pas allumé ma machine.

Je viens de relire le topic depuis le début.

Juste une petite question. En général avant de faire le
make, il faut faire
./configure.
Je ne vois rien dans la doc qui l'indique alors, est-ce que dans l'ensemble des fichiers décompressés, tu as un fichier CONFIGURE ? Si oui, fais en console (en root je crois) :


./configure
puis


make
make install

pomme2tr
12/04/2007, 10h55
non pas de configure

dans yast vient d'apparaitre gcc41 mais ne veut pas l'installer

#### YaST2 conflicts list - generated 2007-04-12 10:52:14 ####

Impossible d'installer gcc41-4.1.2_20061115-5.i586[_krpmview_temporary] � cause de d�pendances manquantes
Aucun fournisseur de libmudflap >= 4.1.2_20061115-5 d�finissable pour gcc41-4.1.2_20061115-5.i586[_krpmview_temporary]
R�solution de conflit :
( ) ne pas installer gcc41
( ) Ignorer cette exigence cette fois uniquement

#### YaST2 conflicts list END ###
peut etre que les dependances vont arriver ?
ou hp fait un driver ?

galagann
12/04/2007, 11h41
gcc41, vire-le est installe à la place gcc http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

pomme2tr
12/04/2007, 11h48
Sauf que je n'ai pas de "gcc" dans YaST.

galagann
12/04/2007, 12h07
Re,

Dans YaST2, Logiciel, Configuration de la mise à jour en ligne, l'as-tu fait après ton installation du système ? Si c'est pas le cas, il est temps de la faire !

Après, fait une mise à jour système http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

On reviendra sur l'installation de l'imprimante après.

Sinon :
http://www.alionet.org/style_emoticons/<#EMO_DIR#>/arrow.gif http://wiki.alionet.org/doku.php?id=howto:deskjet5550
http://www.alionet.org/style_emoticons/<#EMO_DIR#>/arrow.gif http://www.linuxprinting.org/show_printer....P-DeskJet_1600C (http://www.linuxprinting.org/show_printer.cgi?recnum=HP-DeskJet_1600C)
http://www.alionet.org/style_emoticons/<#EMO_DIR#>/arrow.gif http://www.linuxprinting.org/show_printer....-DeskJet_1600CM (http://www.linuxprinting.org/show_printer.cgi?recnum=HP-DeskJet_1600CM)

pomme2tr
12/04/2007, 14h21
je l'avais deja fait lors de l'install mais dans le doute j'ai refait
j'ai eu une erreur mais il a mis a jour la base, et la mise à jour systeme ne se fait pas en automatique (par ex amarok ne se fait pas), j'ai donc abandonné !
et ce n'est pas un modele de rapidité .....

mais je fais les mises à jour regulierement et j'avais mis les sources guru et packman (je ne sais pas si cela a été modifié)

je suis allé voir dans yast et c'est toujours pareil.
merci

galagann
12/04/2007, 16h28
Dans ce cas là, utilise Smart Package Manager pour les mises à jour mineur : http://wiki.alionet.org/doku.php?id=howto:smart

Avec sa "gcc" tu l'installes en 2 sec http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

pomme2tr
12/04/2007, 19h07
qu'est ce que j'ai fait ? j'en sais rien mais opensuse a du avoir peur que je m'enerve http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif
toujours est il que gcc est apparu dans yast et donc installé aussitôt
puis suivi le tuto d'install de foo2hp
foo2hp (http://foo2hp.rkkda.com/) pour rappel

et ........... ça fonctionne avec la couleur http://www.alionet.org/style_emoticons/<#EMO_DIR#>/clap_1.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/clap_1.gif http://www.alionet.org/style_emoticons/<#EMO_DIR#>/clap_1.gif

merci merci beaucoup aux nordistes de la part d'un lyonnais sous les nuages, mais avec une imprimante sous suse !!!

comment faire pour mettre reglé dans le titre?

galagann
12/04/2007, 19h52
Tout simplement en éditant le premier post du topic, en ajoutant simplement [Réglé]