PDA

Afficher la version complète : [Réglé] [RTS réseau] TA Spring sous linux



xiloa
30/03/2007, 23h28
bonjour,

Et bien voila, tout est dans le titre.
Comment peut on installer TA Spring sous Suse 10.2.

J'ai tenté , en vain puisque je suis ici, de suivre les recommandations suivantes
http://spring.clan-sy.com/wiki/Category:Linux_Port
pour installer LE str sur mon install toute propre.

Merci par avance de l'aide que les gourous pourront l'apporter.

kyp
31/03/2007, 11h42
Merci de repasser le titre en minuscules stp http://www.alionet.org/style_emoticons/<#EMO_DIR#>/unsure.gif

Carnaby
31/03/2007, 14h36
Pas la peine de te prendre la tête il éxiste déjà une version packagé pour la Suse 10.2.

C'est sur ce dépot: http://ftp.skynet.be/pub/software.opensuse.../openSUSE_10.2/ (http://ftp.skynet.be/pub/software.opensuse.org/games%3A/strategy%3A/realtime/openSUSE_10.2/)

xiloa
01/04/2007, 17h43
MERCI, c'est une mine d'or !!!
dernier problème , ( je suis trop nul )
Comment fait on pour installer glew ( manquant dans la Suse ?? )

Carnaby
01/04/2007, 17h48
Glew est également disponible sur le dépot que j'ai indiqué.

J'imagine que si tu as des problèmes c'est parce que tu te contente d'aller chercher les rpm manuellement sur le dépôts.
Pour pas être embêté le plus simple c'est d'ajouter le dépôts dans les sources de son gestionnaire de packages (Yast, Smart... voir wiki pour leur utilisation) et de laisser ce dernier résoudre les problèmes de dépendance.

xiloa
01/04/2007, 18h02
Glew est également disponible sur le dépot que j'ai indiqué.[/b]
trop nul, je suis trop nul

<div class='quotetop'>Citation (Carnaby @ 1/04/2007 à 17:48) <{POST_SNAPBACK}> (index.php?act=findpost&pid=131303)</div>
J'imagine que si tu as des problèmes c'est parce que tu te contente d'aller chercher les rpm manuellement sur le dépôts.
Pour pas être embêté le plus simple c'est d'ajouter le dépôts dans les sources de son gestionnaire de packages (Yast, Smart... voir wiki pour leur utilisation) et de laisser ce dernier résoudre les problèmes de dépendance.[/b]

Je suis pas encore completement au point à ce niveau. quand il s'agit de Rpm, ca peut encore aller, mais le moindre tar.gz me met dans l'embarras.
Je n'ai pas encore tout à fait compris ou tout ceci s'installait vraiment ( http://www.alionet.org/style_emoticons/<#EMO_DIR#>/blink.gif ).
MERCI, je viens d'installer le RPM de spring !!!

Dernière question : comment lance t on le lobby ?

Carnaby
01/04/2007, 18h34
Pour ajouter le dépôts précédent dans Yast par exemple voici la manipulation

Lancer Yast -> Logiciel -> Changer le support d'installation
Cliquer sur "Ajouter" puis choisir "http" et rentrer les informations suivantes
Nom du serveur: ftp.skynet.be
Répertoire sur le serveur: pub/software.opensuse.org/games:/strategy:/realtime/openSUSE
Ensuite tu valide et tu fait "Terminer"

Maintenant TASpring et le reste apparaîtront dans la rubrique "Installer et supprimer des logiciels" de yast (suffit de faire une recherche sur spring de cocher la case et hop c'est installé) et tu pourra facilement récupérer les mise à jour (faut juste bien faire attention à cocher la case "Vérification automatique" quand tu installe un logiciel).

Pour les questions concernant TASpring lui même je peux pas te répondre pour le moment car ça fait quelques temps que je n'y ai pas joué.

xiloa
01/04/2007, 19h07
Pour ajouter le dépôts précédent dans Yast par exemple voici la manipulation

Lancer Yast -> Logiciel -> Changer le support d'installation
Cliquer sur "Ajouter" puis choisir "http" et rentrer les informations suivantes
Nom du serveur: ftp.skynet.be
Répertoire sur le serveur: pub/software.opensuse.org/games:/strategy:/realtime/openSUSE
Ensuite tu valide et tu fait "Terminer"

Maintenant TASpring et le reste apparaîtront dans la rubrique "Installer et supprimer des logiciels" de yast (suffit de faire une recherche sur spring de cocher la case et hop c'est installé) et tu pourra facilement récupérer les mise à jour (faut juste bien faire attention à cocher la case "Vérification automatique" quand tu installe un logiciel).

Pour les questions concernant TASpring lui même je peux pas te répondre pour le moment car ça fait quelques temps que je n'y ai pas joué.[/b]

Merci

kyp
01/04/2007, 20h28
N'hesistes pas a aller consulter le Wiki. (http://wiki.alionet.org) C'est une mine d'or, nottament pour Yast et Smart

phoenix
01/04/2007, 22h36
Ne pas oublier de mettre [Réglé] http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

xiloa
01/04/2007, 23h11
C'est pas complètement réglé : TA Spring est installé, mais pas encore opérationnel : le lobby n'est pas accessible. Je n'ai accès pour le moment qu'au jeux en mode test !
A suivre ...

Carnaby
02/04/2007, 00h38
Faudrait que je recherche mais une fois qu'on avait Spring de mémoire il fallait installé au moins deux chose:
- un pack de donnés (mods), le plus connu étant XTA
http://www.clan-sy.com/download/xta/
c'est asseez facile faut juste décompresser les fichier au bon endroits
- le lobby si on veut jouer en réseau, là c'est plus compliqué à l'époque fallait le compilé à la main mais je vois que celui que j'utilisai est obsolète.
Celui ci en java doit pas nécessiter de compilation
http://spring.clan-sy.com/wiki/AFLobby
je testerai à l'occasion

xiloa
02/04/2007, 17h08
Oui, c'est là ou je bute : le lobby. Les liens donnés plus haut permettent d'installer le jeux. J'ai même réussi tout seul comme un grand à installer mes pilotes 3D ( pas peu fier !! ).
Le lobby, logiciel pourtant assez simple, quasi pas graphique, est plus complexe à installer...

En fait, Darkstar est un développeur actif de TAS (mod, cartes, AI) .

A suivre....

galagann
02/04/2007, 18h17
Utilise http://www.alionet.org/style_images/1/t_qr.gif ou http://www.alionet.org/style_images/1/t_reply.gif pour répondre sauf si tu veux répondre a une personne bien précise avec http://www.alionet.org/style_images/1/p_quote.gif, merci !

Carnaby
02/04/2007, 19h57
En fait, Darkstar est un développeur actif de TAS (mod, cartes, AI) .[/b]

Et qui développe aussi AFLobby un lobby packagé en java (donc pas besoin de compilation juste que la machine virtuel fonctionne).
C'est pas trop clair mais via son site je suis arrivé sur le forum d'AFLobby
http://cs.selu.edu/~ssmith/BB/viewforum.php?f=21
Qui lui même à finit par me mener à la page de chargement de la dernière version
http://spring.unknown-files.net/file/2497/AFLobby_alpha_19a/

Leur communication est vraiment pas terrible...

xiloa
02/04/2007, 20h49
Pour le lobby , j'ai réussi à le télécharger là
http://spring.clan-sy.com/phpbb/viewtopic....asc&start=0 (http://spring.clan-sy.com/phpbb/viewtopic.php?t=8691&postdays=0&postorder=asc&start=0)

Je le lance avec sh
J'obtiens un écran bleu, ça fonctionne presque :

J'ai ce message d'erreur au moment du login :
unsatisfied link error, make sure you have a JNI aware Unitsync library in the same folder as AFLobby, path: /usr/games/aflobby/aflobby_alpha19a library path:.

Je pense ne pas l'avoir installé au bon endroit et il doit me manquer quelques bidules. .....

j'ai installé aflobby ..... mais à priori pas au bon endroit. Ca fonctionne presque, mais pas tout à fait. J'ai l'impression qu'il ne fait pas le lien avec spring. Effectivement, c'est pas très fourni en explication.

Carnaby
02/04/2007, 21h06
Ça a pas l'air très au point pour Linux cette histoire de Lobby.

Sur le forum de Spring http://spring.clan-sy.com/phpbb/viewtopic....c&start=240 (http://spring.clan-sy.com/phpbb/viewtopic.php?t=8691&postdays=0&postorder=asc&start=240)
il fournisse déjà une nouvelle version pour la libunitsync.so .
http://members.chello.nl/mjtobi/libunitsync.so

xiloa
08/05/2007, 17h57
Bonjour,

Je profite de ce jour férié pour m'y remettre. Je découvre une nouvelle version de Aflobby (http://spring.clan-sy.com/phpbb/viewtopic.php?t=8691&postdays=0&postorder=asc&start=280&sid=ec51b5787a8b789327cec8f192a2a8c0)
toutefois, si j'arrive bien à installer le "lobby" d'un côté, unitsync de l'autre, et TAspring encore de l'autre, j'ai du mal à voir comment tout ceci fonctionne ensemble. Quelqu'un pourrait il m'aider ? TAspring fonctionne, mais en solo seulement.

J'ai TASpring compilé et AFLobby installé dans /usr/share/games/spring ....
Le lobby fonctionne à priori bien , j'arrive à me connecter, suivre les conversations.... sauf qu'il m'informe qu'il ne fait pas la jonction avec unitsync.so,....

bhouuuuuu, à l'aide.

Merci par avance.

xiloa
20/07/2007, 19h29
il y a du neuf

Un nouveau lobby, compilé pour la suse est ici :
http://spring.unknown-files.net/file/3112/...Open_SUSE_10.2/ (http://spring.unknown-files.net/file/3112/AFlobby_for_Open_SUSE_10.2/)

Voivi une série de liens utiles :

Le forum linux sur le site officiel de spring (http://spring.clan-sy.com/phpbb/viewforum.php?f=20)

Le "setup guide linux " officiel est ici (http://spring.clan-sy.com/wiki/SetupGuide)

Le forum pour Suse Linux est ici (http://spring.clan-sy.com/phpbb/viewtopic.php?t=9899)


Comme d'hab, chez moi , le "client" Spring fonctionne ( 3d, son et tout ! ) , le lobby plantouille ( pbm java semble t il, en cours de réparation ) , mais tout ceci merite d'être testé sur d'autres machines.

Carnaby
25/07/2007, 11h20
La nouvelle version de TA Spring est dispo en rpm sur le build service
http://download.opensuse.org/repositories/home:/accAgon/

Je testerai ce week end.

xiloa
10/08/2007, 23h20
Un nouveau lobby en C++ est en cours de devloppement. Il semble àpeu près opérationnel, et connait une nouvelle version toutes les semaines. Du Neuf sous peu donc, à peaufiner ce wwek end pour ma part. Les premiers résultats à cette heure tardive sont très encourageants.

A voir ici :

http://www.springlobby.info (http://www.springlobby.info/)

Par contre la version .75b2 du client spring est buggy.
J'ai perdu le curseur en route ! ! !!!!! c'est bien bête du coup

xiloa
25/08/2007, 22h33
CA MARCHE !!

grace à accAgon !

http://download.opensuse.org/repositories/...SUSE_10.2/i586/ (http://download.opensuse.org/repositories/home:/accAgon/openSUSE_10.2/i586/)

Vous trouverez ici tout ce qu'il faut, à savoir :
spring 0.75b2
springlobby ( necessite wxWidgets )

suivez bien toutes les indications du setup officiel.
Magnifique :je sors de ma première partie réseau ( grosse branlée après 8 mois d'inactivité, c'est normal )

C'est un grand jour,
Spring est un très grand RTS, inusable ( existe depuis plus de 10 ans ) capable de rivaliser avec les derniers produits de ce type, du moins, de qualité franchement professionnelle.
Personnellement, je préfère meme Spring (GPL) à son successeur (propriétaire) Suprem commander.

******* On ne peut plus dire qu'il n'y a pas de jeux sous linux. *******

Burn2
06/10/2007, 17h59
Hum je vais l'installer pour voir tien :)
Hum il ne veut pas se lancer, il me dit qu'il faut l'extention texture gl_arb_texture_compression. Pourtant j'ai les drivers nvidia bel est bien installé... Une idée?