PDA

Afficher la version complète : driver webcam suse 10.2



noor
05/04/2007, 19h22
Bonsoir à tous,
je possède une webcam logitech for notebook pro. J'ai donc téléchargé les drivers uvc sur :
http://svn.berlios.de/svnroot/repos/linux-...inux-uvc/trunk/ (http://svn.berlios.de/svnroot/repos/linux-uvc/linux-uvc/trunk/)
Puis dans le répertoire de téléchargement, j'ai fait make et voici l'erreur :

Building USB Video Class driver...
make[1]: entrant dans le répertoire « /usr/src/linux-2.6.18.8-0.1-obj/i386/default »
make[1]: *** Pas de règle pour fabriquer la cible « modules ». Arrêt.
make[1]: quittant le répertoire « /usr/src/linux-2.6.18.8-0.1-obj/i386/default »
make: *** [uvcvideo] Erreur 2

Quelqu'un aurait-il une idée du problème? Merci d'avance pour votre aide.

richard.31
05/04/2007, 19h40
je peux me tromper mais il faut le driver spca ou gspca dispo en kernel -module
http://software.opensuse.org/download/driv...SUSE_10.2/i586/ (http://software.opensuse.org/download/drivers:/webcam/openSUSE_10.2/i586/)

Carnaby
05/04/2007, 19h49
Sinon pour les problèmes de compilations c'est les sources du kernel qui doivent pas être préparé (est tu certain qu'elles sont dispo et que ce sont les bonnes).

En lançant les commandes suivantes en mode root ça devrait mieux se passer ensuite

cd /usr/src/linux
make clean
make cloneconfig
make modules

noor
05/04/2007, 19h52
je peux me tromper mais il faut le driver spca ou gspca dispo en kernel -module
http://software.opensuse.org/download/driv...SUSE_10.2/i586/ (http://software.opensuse.org/download/drivers:/webcam/openSUSE_10.2/i586/)[/b]
merci de ton aide.
Sur le site http://mxhaard.free.fr/spca5xx.html , voici ce qui est indiqué pour ma webcam
2 0x046d 0x08c3 QC for Notebooks Pro bridge : spca525a driver : linux-UVC

Ne faut-il pas que je télécharge le driver uvc sur la page que tu m'as indiquée : uvcvideo-kmp-default-r87_2.6.18.2_34-14.1.i586.rpm

richard.31
05/04/2007, 20h53
en effet tu as raison suivant ta webcam
mais je crois que ton kernel n'est pas a jour ainsi que kernel-source
en console en su
"uname -a"
"rpm -q kernel-source "
voir si les deux sont les memes normalement d'apres les kernel.modules dispo= 2.6.18.2-34
sinon faire une mise a jour via yast

noor
05/04/2007, 22h14
en effet tu as raison suivant ta webcam
mais je crois que ton kernel n'est pas a jour ainsi que kernel-source
en console en su
"uname -a"
"rpm -q kernel-source "
voir si les deux sont les memes normalement d'apres les kernel.modules dispo= 2.6.18.2-34
sinon faire une mise a jour via yast[/b]

En effet, je pense que le problème vient de là : j'ai réinstallé le kernel 2.6.18.2-34. Quant au kernel source, il n'est pas installé. Je l'installe et je t'en dis plus.

J'ai installé le bon kernel et kernel source ainsi que le pilote uvc. Maintenant comment est-ce que je sais si ma webcam est reconnue? Dans kopete elle n'apparaît pas .

<div class='quotetop'>Citation (noor @ 5/04/2007 à 22:01) <{POST_SNAPBACK}> (index.php?act=findpost&pid=131876)</div>
<div class='quotetop'>Citation (richard.31 @ 5/04/2007 à 20:53) <{POST_SNAPBACK}> (index.php?act=findpost&pid=131870)

en effet tu as raison suivant ta webcam
mais je crois que ton kernel n'est pas a jour ainsi que kernel-source
en console en su
"uname -a"
"rpm -q kernel-source "
voir si les deux sont les memes normalement d'apres les kernel.modules dispo= 2.6.18.2-34
sinon faire une mise a jour via yast[/b]

En effet, je pense que le problème vient de là : j'ai réinstallé le kernel 2.6.18.2-34. Quant au kernel source, il n'est pas installé. Je l'installe et je t'en dis plus.

J'ai installé le bon kernel et kernel source ainsi que le pilote uvc. Maintenant comment est-ce que je sais si ma webcam est reconnue? Dans kopete elle n'apparaît pas .
[/b][/quote]
Bon, Quand j'ouvre kopete, dans la configuration, il apparaît : "usb video class device". Mais je ne vois qu'un écran vert !!! On approche tout doucement de la solution, du moins je l'espère.

kyp
05/04/2007, 22h15
Tu peux aussi essayer en suivant le tutoriel (http://wiki.alionet.org/doku.php?id=howto:webcam_gspca&s=logitech)d'AlioWiki.
D'apres la liste mxhaard il s'agit du meme pilote donc de la meme methode. Si tu es aussi feignant que moi j'ai fait une version "rpm" de cette install en deuxieme partie du tuto.

noor
05/04/2007, 22h18
Je crois avoir été un peu brouillon dans ma dernière réponse. Je reprends donc. Quand j'ouvre kopete, dans la configuration, il apparaît : "usb video class device". Mais je ne vois qu'un écran vert !!! On approche tout doucement de la solution, du moins je l'espère.

richard.31
05/04/2007, 22h21
essayes de charger le module
"modprobe uvcvideo" ou redemarres
et avec kdetv par ex sous l'onglet video verifie que uvc camera est bien selectionné
si une erreur apparait voir avec la configurer kdetv dans video que tous les modules externes video4linux soient cochés

noor
05/04/2007, 22h45
Lorsque j'ouvre Kdetv, la led de ma webcam s'allume mais d'un seul coup mon écran se fige ... Obligé de rebooter en débranchant. Pourtant tout ce qui concerne V4L et V4L2 est coché.

thveillon
06/04/2007, 18h39
Pas mal de drivers pour webcam sont accessibles directement là http://software.opensuse.org/download/driv.../openSUSE_10.2/ (http://software.opensuse.org/download/drivers:/webcam/openSUSE_10.2/) et s'installent nickel via smart, en plus ça évite de recompiler à chaque kernel update.

noor
06/04/2007, 21h55
Après maintes manip, je sèche ....
Le kernel et le source kernel : OK
Les drivers uvc : installés via yast sur le site opensuse
Mais lorsque j'ouvre kopete : écran vert et lorsque j'ouvre kdetv avec les modules V4L2 ma webcam s'allume mais tout freeze. J'ai téléchargé amsn mais ma webcam ne démarre pas. Merci de votre aide

richard.31
06/04/2007, 22h36
peut etre essayer de fabriquer toi meme le rpm uvc avec le rpm src
http://software.opensuse.org/download/driv...nSUSE_10.2/src/ (http://software.opensuse.org/download/drivers:/webcam/openSUSE_10.2/src/)
en konsole en su lancer la commande = rpmbuild --rebuild (nom du srv.rpm)
par ex =rpmbuild --rebuild uvcvideo-r87-14.1.src.rpm
si il te manque une dépendance la console t'avertiras (normalement il te faut kernel-syms)
tu retrouveras tous les rpm adaptés a ton noyau dans
/usr/src/packages
supprime celui que tu as installé et réinstalle le nouveau en choisissant le kmp correspondant a "uname -r"