PDA

Afficher la version complète : [Réglé] [Réglé] Son sasasasacacacadédédédé



igabiva
12/04/2007, 18h14
Bonjour,

J'ai récupéré un portable Sony PCG-FR102 que personne ne voulait car "trop vieux", moi je le trouve bien!!!

J'ai installé la 10.2 avec KDE mais j'ai le son qui saccade (comme dans le titre). A priori l'installation et le driver sont OK (composant VT8233/8235/8237 et driver snd_via82xx). Je dis que c'est OK car j'ai essayé avec la Knoppix 5.1 avec KDE aussi et dans matériel->son j'ai la même configuration et là le on est nickel. La seul différence entre le 2 distributions est que sur la Suse j'ai un kernel 2.6.18 et sur la Knoppix le kernel est 2.6.19.

Est-ce que ce problème puisse venir du kernel ou ai-je loupé quelque chose?

galagann
12/04/2007, 18h52
Il y a aussi la version d'Alsa.

Voici le mode d'emplois pour upgrader le programme : http://wiki.alionet.org/doku.php?id=howto:alsa

igabiva
12/04/2007, 18h58
J'avais déjà essayé avec alsa, toute l'installation c'est bien passé mais pas de changement

Entre-temps j'ai récupéré "kernel-source-2.6.20.2-ccj48.i586.rpm" sur "rpm.pbone.net" et l'ai installé sans comprendre grand chose à ce qui ce passait. Un grand merci donc à celui ou à ceux qui ont fait le howto:compilation_noyau du centre de documentation car je l'ai suivi à la lettre et ça marche. Si un petit truc le make menuconfig n'a pas marché (erreur 2 à la fin), au début il y a eu error: curses.h: No such file, j'aivais pourtant bien installé ncurses donc tout a été compilé (c'est long).

Maintenant le son est nickel, ça devait venir du kernel car je suis retourné voir dans "matériel-son" et la config n'a pas changé. Il va aussi falloir que je rentre dans les détails de menuconfig pour profiter d'une compilation plus adapté à cette machine.

igabiva
16/04/2007, 13h53
Je reviens à la charge.

J'ai complètement réinstaller la 10.2 avec son kernel 2.6.18 d'origine et là pour faire un autre test j'ai installé le drive nvidia pour la carte graphique (une geforce4 420 go de mémoire) et le son s'est mis à fonctionner correctement.

Quelqu'un a-t-il un idée du comment du pourquoi?

Est-ce une info que peut intéresser les développeurs, malgré que ce soit du vieux matériel (PCG-FR102) et à qui l'envoyer?

galagann
16/04/2007, 19h38
Encore un des gros mystère de l'informatique http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif