PDA

Afficher la version complète : [Réglé] Icone d'un disque amovible inexistant sur le bureau Gnome



Netlio
30/05/2007, 14h32
Depuis ma dernière réinstallation de openSUSE 10.2 avec Gnome, j'ai une icone persistante sur le bureau: il s'agit d'un lecteur F correspondant à un disque amovible que j'ai démonté et qui a servi à l'installation.
Si je clique sur propriétés, il n'y a rien de renseigné.
La seule option que j'ai est "monter" mais cela produit un message d'erreur: mount point /windows/f does not exist.
Comment faire pour supprimer cette icone inutile sachant qu'il n'est pas possible de l'envoyer dans la corbeille?
Merci pour votre aide,

galagann
30/05/2007, 15h18
Salux et bienvenux,

Je ne suis pas un spécialiste Gnome, mais je pense que Gnome pense que t'as la partition Windows qui est encore actif.

Je sais qui y a un programme qui s'appelle "gnome-volume-manager", tu vas certainement le trouver dans le menu de configuration.

Netlio
30/05/2007, 16h09
En fait, je n'ai que 4 partitions windows active. La F n'est plus visible (plus montée).

Les différents dev sont bons mais il y a cette icone de type removable media avec écrit F en dessous, entre le dossier home et la corbeille.

N'y a t'il pas moyen d'accéder aux icones du desktop quelque part ?

Merci d'avance.

galagann
30/05/2007, 16h15
Salux,

Je pense que c'est de l'automount comme sous KDE, dans ce cas là donne nous le contenu de ton /etc/fstab http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

zeb
30/05/2007, 16h22
Salut

Je ne suis pas non plus connaisseur de Gnome, mais a tout hasard tu n'aurait pas une carte (style appareil photo) qui serai resté dans un lecteur de carte (si tu en a un biensur) ?.
Comme elle sont formatées le plus souvent en Fat32 ça pourrait expliquer le "removable media avec écrit F en dessous".

C'est un peu simpliste, mais je pense que ça peut arriver. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

Peut-etre un indice...

Netlio
30/05/2007, 16h57
Salux,

Je pense que c'est de l'automount comme sous KDE, dans ce cas là donne nous le contenu de ton /etc/fstab http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif[/b]
Effectivement, je viens de regarder mon fstab et il y a bien un F...qui n'existe pas concrètement.

Voici mon fstab:
/dev/sdb6 / ext3 acl,user_xattr 1 1
/dev/sdb7 /home ext3 acl,user_xattr 1 2
/dev/sda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sdb1 /windows/D ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sdc1 /windows/E ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sdh1 /windows/F ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sdc5 /windows/G ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sdb5 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

En fait, j'ai uniquement 3 disques durs: sda, sdb et sdc.
Le sdh est un disque amovible que j'ai utilisé pour l'installation (car DVD IDE pas pris en charge par le Kernel pour l'installation)).
Puis retirer manuellement la ligne /dev/sdh1 ?

<div class='quotetop'>Citation (zeb @ 30/05/2007 à 17:22) <{POST_SNAPBACK}> (index.php?act=findpost&pid=138496)</div>
Salut

Je ne suis pas non plus connaisseur de Gnome, mais a tout hasard tu n'aurait pas une carte (style appareil photo) qui serai resté dans un lecteur de carte (si tu en a un biensur) ?.
Comme elle sont formatées le plus souvent en Fat32 ça pourrait expliquer le "removable media avec écrit F en dessous".

C'est un peu simpliste, mais je pense que ça peut arriver. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

Peut-etre un indice...[/b]
Merci pour l'idée. J'y avait pensé...j'avais débranché la docking de mon Pocket PC au cas où.
Cela ne changeait rien.
Le fstab semble donner des indications!

<div class='quotetop'>Citation (galagann @ 30/05/2007 à 17:15) <{POST_SNAPBACK}> (index.php?act=findpost&pid=138494)</div>
Salux,

Je pense que c'est de l'automount comme sous KDE, dans ce cas là donne nous le contenu de ton /etc/fstab http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif[/b]
Je viens d'éditer le fstab et de supprimer la ligne "/dev/sdh1 /windows/F ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0".
L'icone a disparu du Bureau.
Cela doit être un petit bug...c'est le genre de casse-tête qui me plaît bien avec Linux!
Merci beaucoup pour l'aide.

Neolinux
30/05/2007, 17h02
Salux !

C'est tout à fait normal. Tu dis t'être servi d'une partition pour installer depuis celle-ci. Et bien, durant l'installation, cette partition a été comptée parmi celles à ajouter à la fstab.

Ce que je te conseille, c'est de faire une réparation automatique, à un moment, ça va vérifier les entrées de la fstab, par rapport aux partitions réellement sur la machine, donc, proposer de supprimer ce qu'il convient.

Cette réparation automatique est le plus simple que je puisse te proposer, mais il faudrait que tu graves l'ISO sur CD ou DVD (selon le type d'ISO choisie), car, si tu réutilises ce que je suppose être un HDD USB, ça ne changera rien, il sera de nouveau inclu dans les partitions.

Une fois en possession d'un support disque, tu rebootes en modifiant l'option de démarrage sur le lecteur disque, tu lances une installation, tu mets la langue en français, tu acceptes la licence et à l'écran suivant, tu cliques sur [Autres...], de là, tu choisis Réparer le système installé et tu prends la réparation automatique.

Édit : Oui, la suppression de la ligne dans la fstab revient au même, mais, par prudence, je préfère toujours conseiller l'option de réparation présente sur le support d'installation, avant toute manipulation directe. Ça évite souvent des surprises. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

Netlio
30/05/2007, 21h49
Salux !

C'est tout à fait normal. Tu dis t'être servi d'une partition pour installer depuis celle-ci. Et bien, durant l'installation, cette aprtition a été comptée parmi celles à ajouter à la fstab.

Ce que je te conseille, c'est de faire une réparation automatique, à un moment, ça va vérifier les entrées de la fstab, par rapport aux partitions réellement sur la machine, donc, proposer de supprimer ce qu'il convient.

Cette réparation automatique est le plus simple que je puisse te proposer, mais il faudrait que tu graves l'ISO sur CD ou DVD (selon le type d'ISO choisie), car, si tu réutilises ce que je suppose être un HDD USB, ça ne changera rien, il sera de nouveau inclu dans les partitions.

Une fois en possession d'un support disque, tu rebootes en modifiant l'option de démarrage sur le lecteur disque, tu lances une installation, tu mets la langue en français, tu acceptes la licence et à l'écran suivant, tu cliques sur [Autres...], de là, tu choisis Réparer le système installé et tu prends la réparation automatique.

Édit : Oui, la suppression de la ligne dans la fstab revient au même, mais, par prudence, je préfère toujours conseiller l'option de réparation présente sur le support d'installation, avant toute manipulation directe. Ça évite souvent des surprises. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif[/b]
C'est tout à fait juste, j'ai dû réinstaller mon système depuis un HDD USB sur lequel j'avais préalablement copié le DVD Suse car le lecteur CD IDE n'est pas pris en charge par le kernel pour ma nouvelle carte mère.
Par conséquent, je ne peux pas booter sur le DVD pour faire une réparation automatique.
A priori, la seule solution serait de rajouter un lecteur DVD SATA.
Pour l'nstant, cette suppression manuelle n'a pas l'air de poser de problèmes! On verra.
Merci pour ton aide,