PDA

Afficher la version complète : [Réglé] codecs mp3,mpeg,avi pour gstreamer sur suse 10.3



siden
13/08/2007, 20h19
Bonjour, je viens d'installer suse 10.3 beta en version 64 bit

je n'arrive pas a ce que rhythmbox lise les mp3 ou totem lise les divx ou fichier avi

pourtant le paquet lame est installé.

j'ai ajouté les dépots officiels de suse 10.3 c'est peut-être pour ca...incomplets

sinon ou je peux trouver les dépots pour ces codecs?

perso258741
14/08/2007, 00h48
Salut,
personnellement je n'utilise pas rythmbox ni totem. Mais avec mplayer j'ai les divx qui marchent et avec amarok les mp3 fonctionnent également. Pour cela il faut avoir les supports packman et guru.

C'est juste un peu bizarre avec amarok, car il ne veut pas fonctionner avec xine. Mais je n'ai pas encore trop eu le temps de chercher.

Voici la liste des sources que j'ai dans Yast :
openSuse-10.3-Updates et le DVD qui ont été mis automatiquement.
dans les Factory : GNOME, OSS et NON-OSS (ça en fait 3) je les ai cochés dans "Community repositories" ***
Pour finir j'ai aussi Guru et Packman.
Pour Guru et Packman, c'est les même adresses que pour la 10.2 mais en remplaçant 10.2 par 10.3

Ensuite tu installes w32-codecs-all euh et libxine1 je crois aussi.


*** le "programme" Community repositories est assez long lorsqu'on coche des supports. Je crois que si on le quitte à la barbare (un kill ou autre..), ça altère le fonctionnement des supports dans Yast.

siden
14/08/2007, 09h08
bon j'ai rajouté packman et j'arrive a lire les video avec xine en rajoutant des paquets
par contre je comprend plus rien pour rhythmbox et totem
j'ai installé le paquet gstreamer-fluendo pour avoir le mp3 et ca marche toujours pas.

le mp3 marche quand j'utilise helix-banshee mais je déteste ce lecteur car il fait pleins de coupures dans la musique dès que une autre application prend un peu de mémoire, et de plus il est super long a lancer. c'était comme ca déja avec les autres suse (10.2 , 10.1, 10.0) et ca n'a pas changé c'est vraiment n'importe quoi!!!! d'accord pour mettre du propriétaire dans une distribution mais il faut un minimum de qualité!!

j'ai vraiment l'impression que cette distribution a des parfum de windows pour le multimédia, car tout a été rendu super compliqué pour avoir le codecs come il faut mais en plus quand on les a, ca marche pas!
et pas moyen de faire aller vlc!! dans un terminal il me met "aborted" puis se coupe. j'ai jamais vu ca
d'accord c'est une bêta mais bon ca n'excuse pas tout

Pumpkin
14/08/2007, 10h52
Voilà un tuto qui peut s'appliquer à la 10.3 : http://www.linuxpourlesnuls.org/v4/dokuwik...d_sous_opensuse (http://www.linuxpourlesnuls.org/v4/dokuwiki/doku.php?id=tutoriaux:multimedia:lire_des_mp3_et_d es_dvd_sous_opensuse)

perso258741
14/08/2007, 11h30
Et il ne faut pas crier au feu trop vite ! Il s'agit d'une version béta ! ça veut dire ce que ça veut dire. De nombreux supports comme packman et guru sont encore incomplets. Et d'autres n'existent pas encore pour la 10.3.
On ne peut pas repprocher à ces supports de ne pas encore tout proposer puisque il faut du temps pour sortir tous les paquetages, et d'autre part, un nombre très restreint de personnes utilisent cette béta.

J'ai regardé pour voir si j'arrivais à mettre banshee mais j'ai un problème de dépendances. Rien d'étonnant pour des supports d'installation encore incomplets.

En attendant tu devrais pouvoir lire tes mp3 avec kaffeine ou amarok, même si ce n'est peut-être pas dans tes habitudes.

siden
14/08/2007, 11h46
bon finalement après un reboot le mp3 sur rhythmbox marche.
mais pas de video sur totem malgré le paquet gstreamer-ffmpeg ajouté.

j'en fait pas un drame je sais très bien que les bersion beta sont encore remplies de bugs

c'est juste que j'ai plus l'haitude, j'utilise une debian lenny/sid où je ne rencontre aucun problèmes

je suppose que c'st pour ca aussi qu'il n'y a pas de paquets pour les pilotes nvidia... en plus que l'installation par le .run débloque

perso258741
14/08/2007, 11h55
Ok http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

Pour les drivers nvidia, moi ça a marché sans trop de difficulté. J'ai utilisé le topic de Burn2 : http://www.alionet.org/index.php?showtopic=16984

Sinon j'ai essayé une vidéo avec totem, ça ne marche pas non plus chez moi.

siden
14/08/2007, 14h08
pour le driver nvidia c'est ok j'avait oublier d'installer le paquet kernel-source

sinon pour rhythmbox c'est pas corrigé finalement, c'est un fichier ogg qu'il m'a lu. les mp3 ne se lisent toujours pas

enfin c'est pas grave.