PDA

Afficher la version complète : problème de boot du système RedHat



alladnen
27/08/2007, 15h05
je suis nouveau dans ce forum et j'ai besoin d'une assistance technique si vous pouvez m'aider (problème boot):

lors du démarrage du système et avant la décompression du noyau, le système se bloque et affiche le message suivant:

Error 13: Invalid or unsupported executable format
Press any key to continue...

Et il reste en boucle.

NB: -le système installé est RedHat Enterprise Linux 4 , la version du noyau est 2.6.9-5.EL
-les fichiers /boot/initrd-2.6.9-5.EL.img et /boot/vmlinuz-2.6.9-5.EL existent
-les fichiers grub.conf et /etc/fstab sont bien configurés
et merci d'avance.

yoplait
27/08/2007, 15h16
2.6.9 ? ... c'est normal que ca soit si "vieux" ?

Si j'étais toi, je booterai en liveCD, je me chrooterai dans la redhat et je recompilerai un p'tit noyau.
... Ou alors je réinstallerai une autre distrib pour changer http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif .

pour l'erreur : ca a l'air d'être une erreur grub, c'est bien ca ?
tu as regardé un peu ce que google te disait ? ... je vois pas mal de sites qui en parle ...
http://www.google.fr/search?hl=fr&q=gr...;meta=&aq=t (http://www.google.fr/search?hl=fr&q=grub+error+13&btnG=Recherche+Google&meta=&aq=t)

notamment ce p'tit message, si tu aimes l'anglais :
http://www.linuxquestions.org/questions/sh...amp;postcount=4 (http://www.linuxquestions.org/questions/showpost.php?p=1914226&postcount=4)

tiens nous au courant http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif .

alladnen
27/08/2007, 16h10
justement, je savoir comment recompiler un nouveau noyau








<div class='quotetop'>Citation (yoplait @ 27/08/2007 à 16:16) <{POST_SNAPBACK}> (index.php?act=findpost&pid=147821)</div>
2.6.9 ? ... c'est normal que ca soit si "vieux" ?

Si j'étais toi, je booterai en liveCD, je me chrooterai dans la redhat et je recompilerai un p'tit noyau.
... Ou alors je réinstallerai une autre distrib pour changer http://www.alionet.org/style_emoticons/<#EMO_DIR#>/tongue.gif .

pour l'erreur : ca a l'air d'être une erreur grub, c'est bien ca ?
tu as regardé un peu ce que google te disait ? ... je vois pas mal de sites qui en parle ...
http://www.google.fr/search?hl=fr&q=gr...;meta=&aq=t (http://www.google.fr/search?hl=fr&q=grub+error+13&btnG=Recherche+Google&meta=&aq=t)

notamment ce p'tit message, si tu aimes l'anglais :
http://www.linuxquestions.org/questions/sh...amp;postcount=4 (http://www.linuxquestions.org/questions/showpost.php?p=1914226&postcount=4)

tiens nous au courant http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif .[/b]

tyrtamos
29/08/2007, 17h07
Effectivement, ça ressemble à une erreur grub. Vérifie bien tes fichiers grub (device.map et menu.lst).

Et une autre solution pour moderniser la red hat, c'est de choisir la centos 5:

- Kernel 2.6.18-8
- KDE 3.5.4-11

Tyrtamos