PDA

Afficher la version complète : [Réglé] Webcam Labtec



jack13
29/01/2005, 23h09
salut a tous

j ai un probleme je ne c est pas comment faire marcher ma webcam labtec
j ai lu sur des tropic qu il fallais recopiler le moyau
je suis un peu perdu
qu elle q un pourais t il me donner des tuyau pour faire fontionner ma webcam

ca serais synpa de votre part
je suis mouveau sur linux

mais j apprend vite

merci de votre aide
ps elle et reconnu dans yast

merci

jack13
29/01/2005, 23h29
r slt
dans la console quand je fait isusb
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 002: ID 10df:0100 In-Win Development, Inc.
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 002: ID 0425:0101 Motorola Semiconductors HK, Ltd
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 007: ID 046d:0870 Logitech, Inc. QuickCam Express
Bus 001 Device 006: ID 03f0:2f11 Hewlett-Packard
Bus 001 Device 005: ID 0731:0528 Susteen, Inc.
Bus 001 Device 004: ID 0451:2046 Texas Instruments, Inc. TUSB2046 Hub
Bus 001 Device 001: ID 0000:0000
ca me donne ca si ca peut aider a faire avancer la chose
merci

siko
29/01/2005, 23h40
Ta webcam est vu par l'usb c'est déjà ça. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/huh.gif

J'ai trouvé un tuto sur l'installation de ta webcam, il ne faut pas compiler le kernel mais le driver de la webcam.

http://www.trustonme.net/didactels/172.html

jack13
30/01/2005, 01h11
merci j avais trouver un autre qui parler de la meme chose
mais j ai trop d ereur je reeserais demain matin
car je ne peut pas pose le contenu des ereures elle est trop long
en resumer a la fin des commande il ne me trouve pas de webcam

merci a toi siko

siko
30/01/2005, 07h55
De rien. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/smile.gif

Si jamais poste juste la fin de tes erreurs et on pourra voire pour les règler les unes après les autres, parfois c'est la même erreur qui donne un paquet de messages. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/blink.gif

jack13
30/01/2005, 11h45
slt

lns-vlq-17f-81-56-162-109:/home/jack13/Documents/webcam/qc-usb-0.6.2 # make all
make -C "/lib/modules/2.6.8-24.11-default/build" SUBDIRS="/home/jack13/Documents
/webcam/qc-usb-0.6.2" modules V=1 USER_OPT=""
make[1]: Entering directory `/usr/src/linux-2.6.8-24.11-obj/x86_64/default'
make -C ../../../linux-2.6.8-24.11 O=../linux-2.6.8-24.11-obj/x86_64/default mod
ules
make -C /usr/src/linux-2.6.8-24.11-obj/x86_64/default \
KBUILD_SRC=/usr/src/linux-2.6.8-24.11 KBUILD_VERBOSE=1 \
KBUILD_CHECK= KBUILD_EXTMOD="/home/jack13/Documents/webcam/qc-usb-0.6.2" \
-f /usr/src/linux-2.6.8-24.11/Makefile modules
mkdir -p /home/jack13/Documents/webcam/qc-usb-0.6.2/.tmp_versions
make -f /usr/src/linux-2.6.8-24.11/scripts/Makefile.build obj=/home/jack13/Documents/webcam/qc-usb-0.6.2
gcc -Wp,-MD,/home/jack13/Documents/webcam/qc-usb-0.6.2/.qc-driver.o.d -nostdinc -iwithprefix include -D__KERNEL__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.8-24.11/include -I/home/jack13/Documents/webcam/qc-usb-0.6.2 -Wall -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -O2 -fomit-frame-pointer -mno-red-zone -mcmodel=kernel -pipe -fno-reorder-blocks -Wno-sign-compare -fno-asynchronous-unwind-tables -funit-at-a-time -DNOKERNEL -DMODULE -DKBUILD_BASENAME=qc_driver -DKBUILD_MODNAME=quickcam -c -o /home/jack13/Documents/webcam/qc-usb-0.6.2/.tmp_qc-driver.o /home/jack13/Documents/webcam/qc-usb-0.6.2/qc-driver.c
/home/jack13/Documents/webcam/qc-usb-0.6.2/qc-driver.c: In function `qc_i2c_init':
/home/jack13/Documents/webcam/qc-usb-0.6.2/qc-driver.c:813: error: structure has no member named `timeout'
/home/jack13/Documents/webcam/qc-usb-0.6.2/qc-driver.c: At top level:
/home/jack13/Documents/webcam/qc-usb-0.6.2/qc-driver.c:2975: warning: initialization from incompatible pointer type
make[4]: *** [/home/jack13/Documents/webcam/qc-usb-0.6.2/qc-driver.o] Erreur 1
make[3]: *** [_module_/home/jack13/Documents/webcam/qc-usb-0.6.2] Erreur 2
make[2]: *** [modules] Erreur 2
make[1]: *** [modules] Erreur 2
make[1]: Leaving directory `/usr/src/linux-2.6.8-24.11-obj/x86_64/default'
make: *** [quickcam.ko] Erreur 2
lns-vlq-17f-81-56-162-109:/home/jack13/Documents/webcam/qc-usb-0.6.2 #

siko
31/01/2005, 14h58
<div class='quotetop'>Citation </div>
make[1]: Entering directory `/usr/src/linux-2.6.8-24.11-obj/x86_64/default'
make -C ../../../linux-2.6.8-24.11 O=../linux-2.6.8-24.11-obj/x86_64/default mod[/b]

D'après ce message tu utilise un système 64Bits, est-tu sure que le drive est compatible 64Bits? http://www.alionet.org/style_emoticons/<#EMO_DIR#>/sad.gif

jack13
31/01/2005, 17h31
slt

j ai meme tout formater hier et j y et mis la version 9.2 i 386 et ca me metter la meme erreur
j ai essayer plusieur manip du site mais ca na rien fait
et l autre site que je te disais c est le meme programme
je ne c et plus quoi faire
http://www.alionet.org/style_emoticons/<#EMO_DIR#>/laugh.gif

siko
31/01/2005, 21h28
Tu as fais comment pour mettre la version 32Bits car si c'est avec le DVD il faut lui dire de le faire autrement il met automatiquement en 64Bits.

jack13
01/02/2005, 01h06
Originally posted by siko@lundi 31 janvier 2005 à 20:28
Tu as fais comment pour mettre la version 32Bits car si c'est avec le DVD il faut lui dire de le faire autrement il met automatiquement en 64Bits.
<div align='right'><{POST_SNAPBACK}> (index.php?act=findpost&pid=18680)[/quote]
r slt il me le diser des que je m etais le dvd version bit et avais un modele bit
c etais un version que j avais recupere en cd pour la bits

galagann
06/02/2005, 13h06
La Webcam correspond à un Chipset Logitec :

4.5. Logitech (formerly Connectix) Quickcam Support

The QuickCam VC USB and parallel port model webcams are supported by the driver offered here (http://digilander.libero.it/demarchidaniele/qcamvc/quickcam-vc.html). A kernel patch and recompile are necessary for support of this model.

The Quickcam Express Linux project offers two different flavors of driver for certain Quickcam models, both of which are stand-alone drivers that do not require a kernel patch or recompile. The qce-ga (http://qce-ga.sourceforge.net/) and qc-usb (http://www.ee.oulu.fi/~tuukkat/quickcam/quickcam.html) drivers support the following models : Logitech Quickcam Express
Quickcam Web
Legocam
Dexxa Webcam
Labtec Webcam
The qc-usb driver is more experimental but reportedly works better on some models such as the Quickcam Web. See the above links for more information. Note to Redhat users: The qce-ga driver doesn't compile properly using the modified kernel source provided in Redhat 9, but a fix is available here (http://www.ee.oulu.fi/~tuukkat/quickcam/FAQ).

Some Logitech camera models are supported by the Philips driver in Section 4.7 (http://www.linux.com/howtos/Webcam-HOWTO/devices.shtml#PHILIPS)

Edit : autre petit lien http://www.alionet.org/style_emoticons/<#EMO_DIR#>/arrow.gif http://home.tiscali.dk/tomasgc/labtec/

jack13
25/02/2005, 00h30
slt a tous
voila j ai regler mon probleme de webcam
1er j ai recuperais les drivers qc-usb-0.6.2
sur ce lien http://www.trustonme.net/didactels/172.html
2 eme puis j ai mis mon kernel a jour 2.6.10
3 eme depuis la console en root je suis aller chercher mon dossier
$cd qc-usb-0.6.2
puis j ai fait ./quickcam.sh
et ca ma installer le driver
et apres j ai pris mon programme gqcan
et ca marche bien
merci a tous de m avoir aider
slt
donc mon probleme est regler

siko
25/02/2005, 07h31
Peux-tu mettre Réglé dans le sujet, merci. http://www.alionet.org/style_emoticons/<#EMO_DIR#>/biggrin.gif

jack13
25/02/2005, 08h12
slt oiu mais je cest pas comme on fait
si tu pourrais me dire la procedure ce serais synpa de ta part
j ai charchar j ai pas trouver
merci atoi siko

siko
25/02/2005, 08h41
Tu édites ton premier ton premier message et dans le Titre tu mets [Réglé] au début.

TomVenom
29/06/2007, 01h07
Salux !!

Juste ce petit up pour témoigner que ca a bien fonctionné chez moi aussi.
J'avais le même problème, avec les mêmes symptomes. Le tuto sur trustonme.net fonctionne parfaitement.

Merci à tous et à jack13 http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

tom.