PDA

Afficher la version complète : Decalage souris avec carte ATI



Xelno
13/01/2008, 09h45
Bonjour,

Je viens d'installer les pilotes ATI pour ma carte X300 par la méthode du dépôt. Après cela, j'ai eu un problème de résolution, (1024*768) etait ma resolution maximum dans le panneau de config ati que j'ai modifié en 1280*1024 en bidouillant dans la panneau de contrôle. Cela résolut le problème de la résolution mais j'ai un nouveau problème embêtant, en fait mon curseur de souris affichée a l'écran ne correspond pas a l'endroit réelle du curseur, elle se trouve de quelques centimètres au dessus, et la longueur change, pour pouvoir cliquer je dois trouver approximativement l'endroit du curseur réelle et cliquer. C'est très embêtants car a cause de ce problème je ne peux plus cliquer sur la partie basse de l'écran.

Merci de votre aide.

Edit : après plusieurs redémarrages du serveurs X avec ctrl-alt-backspace, ma résolution maximal devient 1152*864 dans le panneau d'ATI et j'ai plus mon problème de souris, maintenant il faut que je retrouve une resolution de 1280*1024.

Eärendil
13/01/2008, 10h43
Moi aussi, j'avais ça : en fait, le curseur réel était à la moitié de la distance "haut de l'écran"/"curseur visuel"
Je crois en fait que le pilote propriétaire Ati est buggé et archi buggé. Et en plus de ce problème, si je passais mon curseur en bas, il réapparaissait en haut (sans pouvoir toutefois le redescendre). Il me mettait parfois aussi des lignes multicolores par endroit. Bon, et comme si tous ces soucis ne suffisaient pas, j'avais des freeze lorsque je faisait mon sax2 -r.
J'en ai eu marre, et suis repassé au drivers libre "radeon" utilisé par défaut. Il marche bien, sauf avec Google Earth...

thveillon
13/01/2008, 12h16
Si ton curseur apparaît déformé il y a une chance que la résolution est encore un problème, as-tu vérifié la valeur utilisé dans xorg.conf, et as-tu un réglage possible sur l'écran ? Dans certain cas l'écran peut interpoler l'image pour couvrir la surface même s'il reçoit une image à la mauvaise résolution, dans ce cas l'image est souvent déformée. Les cartes graphiques peuvent aussi pratiquer une telle interpolation avec les mêmes effets, ce qu'il faut c'est que 1024x1280 soit ta résolution native. Tu peux supprimer les autres valeurs tu xorg.conf (fait une sauvegarde) pour être sur d'utiliser la bonne.

GoogleEarth fonctionne avec les pilotes "radeon" (pas "radeonhd") mais il faut le réinstaller et parfois effacer les préférences avant que ça marche.

belphegor
24/01/2008, 01h17
Salut,
J'ai le même problème que toi : décalage de la souris.
C'est bien chiant ça. Comme tu le marques, aller dans une résolution plus basse, corrige le problème momentanément.

Si quelq'un a une solution ...

Matériel :
Souris Logitech sans-fil bluetooth
ATI Radeon X800 XL PCIe