PDA

Afficher la version complète : [Réglé] trendnet 424ub



jtf
10/02/2008, 22h39
bonjour
je suis passé sous linux il y maintenant 10 jour avec la distribution mandriva et maintenant opensuse 10.3
je voudrais donc installer la clé usb wifi "trendnet 424ub" donc voila je sait qu'il y a eu beaucoup de demande a se sujet mais aucune n'a jusqu'à maintenant marcher donc je vient ici en dernière espoir avant de resombré dans les ténèbres de windows

je vient donc demander secours sur se forum

merci d'une futur réponse
et désoler pour les multiple fautes d'orthographe malgré le correcteur automatique (très pratique)
bonne soirées

catr
10/02/2008, 23h05
salut et bienvenu à toi!

Je pense que tu devrais pouvoir trouver de l'aide ici, mais il faut que tu sois plus explicite.

Sais-tu un peu te servir de la console? si oui, tapes "lsusb" sans les " dans la console lorsque ta clé usb est branchée, et donne le résultat : normalement, tu auras plusieurs lignes qui s'affichent et l'une d'elles devrait désigner ta clé usb. (ce qu'on appelle, d'ailleurs un "dongle").

as-tu tenté de te servir de ndiswrapper? as-tu un pilote Windows pour cette clé (fichiers .inf .cat et .sys, il est souvent important d'avoir les trois).

essaye de donner plus d'informations, sinon personne ne pourra t'aider.

courage!

jtf
11/02/2008, 02h08
merci pour cette réponse très rapide

oui j'ai effectivement tester la console que se soit sous mandriva ou suse mais (et oui il y a toujours un mais) sous suse 10.3 le "lsusb" est une commande inconnue. "lspci" lui marche bien (enfin je croit)

j'ai aussi essayer ndiswrapper sous les deux distribution d'ailleurs (ndiswrapper v1.47 pour les deux) moins sous mandriva mais sous suse j'ai installer deux driver donné dans la liste du site de ndiswrapper ("163u" et "rtl8187") le dernier étant dans les paquet a télécharger de opensuse 10.3 , le nom du dongle est "WLAN_RTL8187_ADAPTATEUR" (trouver dans info sur le matériel dans yast)
et quand je fait "ndiswrapper -L" il me dit :
"163u installer
rtl8187 installer"
(dsl pour les traduction un peut légère mais je peut avoir la connexion filaire a tout temps donc je suis obliger de "swapper" entre windows et opensuse)
mais sans l'attribution a un port usb qui doit être afficher si l'on suit le wiki de ndiswrapper

ps: je suis sur un vieux laptop dell latitude c610 qui n'inclue que des port usb 1.1 et non 2.0 comme le dongle est prévu pour devrai-je le négliger ?

ps2: y a t'il un "assistant de connexion" comme sous windows (sans insulte a linux puisque mandriva était doté de se type d'outil ) plutôt que de taper tout en ligne de code (iwconfig ou du même style )

catr
11/02/2008, 16h21
je ne suis certainement pas le plus expérimenté pour te répondre, mais je vais tenter de mon mieux, en étant efficace, parce que rebooter pour tester ce que je te dis, si ca sert à rien, c'est encore plus rageant.
je suis moi même sous mac pour le moment, alors j'aurai du mal à être précis.

premier point : il NE FAUT PAS installer plusieurs drivers en même temps, en règle général (j'avais lu un fil sur le site de ndiswrapper, ou je te conseille de te rendre, qui disait que pour certaines tres rares cartes, plusieurs pilotes étaient nécessaires). essaye donc déjà de décharger/effacer un pilote, réessaye, puis teste avec l'autre. sinon blackliste un des deux. (vérifie dans le dossier ndiswrapper, en plus de la commande ndiswrapper -l, que le driver est bien supprimé. je ne sais plus ou il est, désolé)

deuxième point : lspci ne doit pas te servir à grand chose vu ton cas... c'est étonnant que lsusb ne renvoit rien (attention, ce ne sont pas des 1 mais des "l", L, LSUSB). essaye en super utilisateur : tape su, puis ton mot de passe, et reessaye lsusb.

troisième point : normalement, il me semble que usb 1.1 et 2.0 sont compatibles. lu sur comment ca marche : La compatibilité entre périphériques USB 1.0, 1.1 et 2.0 est assurée. Toutefois l'utilisation d'un périphérique USB 2.0 sur un port USB à bas débit (i.e. 1.0 ou 1.1), limitera le débit à 12 Mbit/s maximum. De plus, le système d'exploitation est susceptible d'afficher un message expliquant que le débit sera bridé.
`
quatrième point : "assistant de connexion" -> yast t'aide à configurer tes ports usb et ta config normalement. essaye kinternet et .... trou de mémoire.... quelqu'un peut dire comment s'appelle l'autre logiciel de gestion de connexion? il ne vaut mieux pas lancer les deux en même temps je pense.

5eme point : tant que tu n'auras pas "hardware detected" ou quelque chose de similaire avec ndiswrapper, alors à mon avis il ne servira à rien d'essayer de te connecter. tente des wlan info à tout hasard, mais je doute. il y a aussi iwconfig scan je crois qui pourrait te confirmer que tu n'as pas de possibilité de scanner le réseau.

6eme point : regarde du coté de madwifi à tout hasard, je crois qu'il peut prendre en charge les dongle. vérifie tout de même. de même, IL NE FAUT PAS que madwifi soit installé en même temps que ndiswrapper.

j'espère que ca te feras un peu avancer et que d'autres passants du forum sauront être plus précis.

bon courage!

jtf
11/02/2008, 22h12
<div class='quotetop'>Citation </div>
premier point : il NE FAUT PAS installer plusieurs drivers en même temps, en règle général (j'avais lu un fil sur le site de ndiswrapper, ou je te conseille de te rendre, qui disait que pour certaines tres rares cartes, plusieurs pilotes étaient nécessaires). essaye donc déjà de décharger/effacer un pilote, réessaye, puis teste avec l'autre. sinon blackliste un des deux. (vérifie dans le dossier ndiswrapper, en plus de la commande ndiswrapper -l, que le driver est bien supprimé. je ne sais plus ou il est, désolé)[/b]

je remédie dessuite a ceci : tout les pilotes sont supprimés




<div class='quotetop'>Citation </div>
deuxième point : lspci ne doit pas te servir à grand chose vu ton cas... c'est étonnant que lsusb ne renvoit rien (attention, ce ne sont pas des 1 mais des "l", L, LSUSB). essaye en super utilisateur : tape su, puis ton mot de passe, et reessaye lsusb.[/b]

sa ne marche toujours pas j'ai tenter le "usbutils" qui n'existe pas au yeux de yast que faire ??

<div class='quotetop'>Citation </div>
troisième point : normalement, il me semble que usb 1.1 et 2.0 sont compatibles. lu sur comment ca marche : La compatibilité entre périphériques USB 1.0, 1.1 et 2.0 est assurée. Toutefois l'utilisation d'un périphérique USB 2.0 sur un port USB à bas débit (i.e. 1.0 ou 1.1), limitera le débit à 12 Mbit/s maximum. De plus, le système d'exploitation est susceptible d'afficher un message expliquant que le débit sera bridé.[/b]

donc normalement pas de problème de détection pour la commande "lsusb"
`
<div class='quotetop'>Citation </div>
quatrième point : "assistant de connexion" -> yast t'aide à configurer tes ports usb et ta config normalement. essaye kinternet et .... trou de mémoire.... quelqu'un peut dire comment s'appelle l'autre logiciel de gestion de connexion? il ne vaut mieux pas lancer les deux en même temps je pense.[/b]
j'ai télécharger le paquetage et le deuxième serait t'il network manager?? sont t'il des aplication qui tourne en fond de tache??
<div class='quotetop'>Citation </div>
5eme point : tant que tu n'auras pas "hardware detected" ou quelque chose de similaire avec ndiswrapper, alors à mon avis il ne servira à rien d'essayer de te connecter. tente des wlan info à tout hasard, mais je doute. il y a aussi iwconfig scan je crois qui pourrait te confirmer que tu n'as pas de possibilité de scanner le réseau.[/b]

effectivement "iwconfig" ne détecte rien

<div class='quotetop'>Citation </div>
6eme point : regarde du coté de madwifi à tout hasard, je crois qu'il peut prendre en charge les dongle. vérifie tout de même. de même, IL NE FAUT PAS que madwifi soit installé en même temps que ndiswrapper.[/b]

inconnu au bataillon des paquetages opensuse

merci beaucoup pour cette aide
mais je croit que je vais attendre quelque mois que les rang de l'école me livre les secret bien caché de linux

j'attends bien sur toujours de l'aide pour me faire patienter
a bonne entendeur salut
et un grand merci a catr pour tes réponse rapide

se n'est ni un adieu ni en en revoir juste un positionnement de ma volonté quand a aquerir des connaissance sur linux

El DiabloOoOo&#33;&#33;&#33;
26/02/2008, 18h25
Salux,

J'ai aussi une trendnet, mais en pci, c'est la TEW423, moi j'ai installé le pilote que j'avais eu avec la carte (donc celui win) grace à ndiswrapper, et ça fonctionne bien! (bon, une carte reconnue nativement fonctionnerait encore mieux, mais là n'est pas le problème)

Par contre, j'avais eu des soucis avec les versions 64bits de linux, peu importe la distrib, le driver ne fonctionnait pas même si j'obtenais: driver present hardware present

Voilà, j'espère que celà pourra t'aider

Vas même faire un tour sur le site de trndnet afin de choper les derniers pilotes (je l'ai fait aussi) là par contre j'ai du en essayer plusieur avant que celà fonctionne genre ceux pour win98, win2000/XP mais il y a aussi beaucoup de type différents pour ma carte, si toi tu as la chance qu'il n'y en ai qu'une sorte...

thveillon
26/02/2008, 19h55
usbutils existe, promis, je l'ai rencontré personnellement ! ;) Tu le trouveras en faisant une recherche ici (http://software.opensuse.org/search) (testé à l'instant). Le chemin complet de la commande est /usr/bin/lsusb.