PDA

Afficher la version complète : 3D-Nvidia



moniroje
11/02/2008, 18h33
J'ai remarqué que le paquet moniroje est beaucoup plus réactif avec sa debian.

Bon, 3D.
D'abord, un truc curieux. Je sais que je ne l'ai pas installé mais hier, j'avais mis Foobillard; donc tout à l'heure, je l'active et... surprise, ça marche!!! bon, par à-coups, avec des sauts d'images; mais c'est là!!! En Suse, sans 3D, l'icône mouline puis disparaît.

Fort de mon expérience Suse avec la 3D, je note par Yast ce que j'ai en espérant mettre pareil pour Debian.
J'ai: Nvidia-gfxGO1-kmp-default (oui, parce que ma carte graphique est une récente, donc pas prendre les legacy); X11-video-NvidiaGO1, kernel-default-2.6.22.16-0.2-i586 (parce que j'ai installé par erreur Suse 10.3 en 32 bits au lieu de 64 bits)

Maintenant Debian, j'ouvre Synaptic, Rechercher: nvidia et là: rien de ressemblant à ce que j'ai ci-dessus!!
Je note nvidia-glx et nvidia-glx-legacy les nvidia-kernel-(2.6.18.686 & legacy-2.6.18.6 & source & legacy-source), nvidia'settings, nvidia-xconfig et aussi, mais celui-là, je l'ai et il va être mis à jour: le xserver-xorg-video-nv.

Donc, comme le paquet moniroje a besoin de dépendances Alionet pour fonctionner...

Au fait, me suis pas rasé depuis avant-hier et je prends un ton bourru avec ma légale; je débianne vite, hein??

thveillon
11/02/2008, 19h10
Il n'y a pas de sax sur Debian, et de mon point de vue c'est un sacré avantage...

Je n'ai pas utilisé les paquets de la distribution, je télécharge toujours chez nvidia et j'installe à la main (enfin à la console ;) ) , ça prend 1 minutes (vrai) et ça marche à tous les coups. Maintenant je n'ai pas remarqué de problèmes fréquents avec les paquets officiels, ça devrait marcher aussi. Les paquets nvidia-kernel-2.xxx sont des metapackage qui servent juste à installer toutes les dépendances nécessaires, il suffit de choisir celui qui correspond à ton noyau. Sinon tu peux choisir nvidia-kernel-sources pour arriver au même résultat. Il y aussi des utilitaires de configuration.

moniroje
11/02/2008, 22h49
J'ai donc fait: uname -r qui m'a répondu: 2.6.18-6-k7
Puis Synaptic-Edition-Actualiser la liste des dépôts puis Rechercher:nvidia
et là, j'ai installé nvidia-kernel-sources.
Je fais quoi ensuite???

Sinon, ton install par la console, je m'en rappelle que je m'en suis servi pour suse 10.2; mais je n'arrive pas à retrouver ...
Peux-tu me passer le lien, stp?

thveillon
11/02/2008, 23h25
Pour ce qui est du "je fais quoi ensuite ?", normalement tu redémarres, et tu vérifies que ça marche (glxinfo, glxgears...), si tu est toujours en vesa ou nv, tu vas faire un tour dans ton xorg.conf, tu remplaces "nv" ou "vesa" par "nvidia" pour le pilote (section Device), et tu ajoutes Load "glx" à la section Module.

Si tu es coincé avec un écran de console, ou noir, et que rien ne semble fonctionner, la commande à retenir est -


dpkg-reconfigure -phigh xserver-xorg (à noter sur un post-it)


Pour les pilotes nvidia, tu les télécharges sur le site nvidia (http://www.nvidia.fr/Download/index.aspx?lang=fr), tu enregistres le .run dans ton ~ (/home/moniroje) pour faire simple, tu quittes ta session et tu passes en console, et là en root tu navigues vers ton ~ avec cd, et tu exécutes l'installateur avec
sh NVIDIA-1.xxxx.run

Ensuite il faut répondre à quelques questions par oui, sauf une ou il est demandé s'il faut essayer de télécharger un module sur nvidia.com, et c'est tout.

Si tu as un avertissement disant que ta version de gcc ne correspond pas à celle utilisée pour compiler ton noyau blabla, tu réponds "non" pour poursuivre l'installation quand même.

moniroje
12/02/2008, 00h53
J'ai re-démarré et ai tapé en console: glxinfo =>command not found
Je recommence en su; pareil...
Je tape glxgear que je me rappelle qu'il y a un cube tournant: command not found

Alors j'essaye la méthode "manuelle": le site NVIDIA, choisir geforce série 7 (ma carte est une Geforce 7600 GT),j'accepte la licence;ça me conseille:
ÉTAPE 2: Téléchargez le pilote
Téléchargez le fichier - NVIDIA-Linux-x86-169.09-pkg1.run
ça me rappelle pour ma Suse 10.2 que je suivais cette méthode, donc, je saurai faire; je clique sur le lien du run et là, au lieu de télécharger, ça mouline sur cette page:
http://fr.download.nvidia.com/XFree86/Linu...169.09-pkg1.run (http://fr.download.nvidia.com/XFree86/Linux-x86/169.09/NVIDIA-Linux-x86-169.09-pkg1.run)
que vous pouvez voir on dirait une console avec plein de signes cabalistiques!!!
A tout hasard, je regarde dans mon répertoire Téléchargements où Iceweasel met ce que je télécharge: c'est vide.
On dirait qu'il y a un couac.
Sur la page bizarre, je note ceci:
<div class='quotetop'>Citation </div>
NVIDIA Driver Installation .run file
#
# If you were trying to download this file through a web browser, and
# instead are seeing this, please click your browser's back button,
# left click on the link, and select "Save as..." (or do whatever is
# appropriate for your web browser to download a file, rather than view
# it).[/b]
j'essaie de clique-gauche mais c'est clic droite, que j'essaye aussi, pour Save as les liens précédents: j'accepte ou le fichier run; rien n'y fait; puis je fais Enregistrer le lien sous et je retourne à ce lien enregistré dans Téléchargement. Je clique dessus: c'est l'accord de la licence qui s'ouvre avec le navigateur Konqueror!!! et là, avec Konqueror, dès que je clique J'accepte, enfin!!! le fichier, je le télécharge!!! nom de nom! Quand Iceweasel ne peut pas, penser à Konqueror!!!

Donc, je fais:

alain@debian:~$ su
Password:
debian:/home/alain# cd /home/alain
debian:/home/alain# sh NVIDIA-Linux-x86-169.09-pkg1.run
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86 169.09............................................ ..............................
.................................................. ..............................
.................................................. ..............................
...............................................
debian:/home/alain#
avec une fenêtre immédiate: Error: you appear to be running an X server; please exit X before installing...
je dis OK et il se termine par: Error: installation has failed.
Donc, je suppose que avant de recommencer, il faudrait que je exit X ; on fait comment???

thveillon
12/02/2008, 01h29
glxinfo et glxgears font partie du paquet "mesa-utils", s'il n'est pas intallé forcément ça marche moins bien...

Pour le téléchargement des pilotes nvidia, il faut faire "l'étape 1" (lire la licence), puis cliquer sur la flèche de retour en arrière en haut à gauche de la page de licence, et à ce moment là le lien de téléchargement en "étape 2" est actif, on fait un "clic droit > enregistrer la cible du lien" dans Iceweasel.

Pour l'erreur d'installation Nvidia : <div class='quotetop'>Citation </div>
tu quittes ta session et tu passes en console[/b] ... :rolleyes:

Donc oui, il faut quitter toute session graphique, pour faire ça tu fais un clic droit sur le bureau > déconnecter > terminer la session, ensuite sur l'écran de login dans le petit menu en bas l'option "passer en mode console" est proposée. Sinon c'est "alt+n" (ou "ctrl+n", je confond parfois parce que c'est l'inverse sur la suse et Debian).

moniroje
12/02/2008, 14h13
Hier, dès que j'acceptais la licence, hop!! ça téléchargeait.Bon, question réglée, j'ai eu mon .run
J'ai ensuite fait exactement comme tu as dit; mais j'ai quand même eu droit à Error: you appear to be runningg an X server. Me suis sorti avec halt.
Puis j'ai rebooté et choisi Terminal de secours-Modifier la session puis mon user, son mdp; mais une fois arrivé à la fenêtre Nvidia après avoir fait: sh , j'ai encore eu le même message: You appear to be running an X server....

thveillon
12/02/2008, 14h42
C'est normal, comme tu n'as pas encore installé guarddog ou firestarter et configuré ton pare-feu, ton voisin a ouvert une session graphique sous root sur ta machine... :blink: Je rigole. Je ne sais pas pourquoi tu as une session graphique qui tourne, fait un top, et si tu vois une trace de Xorg tu le kill . Si tu ne le vois pas fais un
ps -e ou
ps -aux, tu verras sur quel terminal ça se passe, et tu pourras noter le pid du processus pour le zigouiller.

moniroje
12/02/2008, 15h04
En attendant ta réponse, j'ai un peu cogité et me suis dit que peut-être ma 3D est déjà installé???
En effet, rappel: j'avais installé nvidia-kernel-sources et cela semblait en double-emploi avec la méthode à la main, non??
Depuis, j'ai aussi installé mesa-utils pour avoir accès aux commandes glxinfo et glxgears (avec les tites roues crantées qui tournent: souvenir suse)
Donc attendant réponse, je fais glxinfo et voilà le résultat:

name of display: :0.0
display: :0 screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_copy_sub_buffer,
GLX_OML_swap_method, GLX_SGI_make_current_read, GLX_SGIS_multisample,
GLX_SGIX_fbconfig, GLX_EXT_texture_from_pixmap
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)
OpenGL extensions:
GL_ARB_depth_texture, GL_ARB_imaging, GL_ARB_multitexture,
GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow,
GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
GL_ARB_texture_non_power_of_two, GL_ARB_texture_rectangle,
GL_ARB_transpose_matrix, GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra,
GL_EXT_blend_color, GL_EXT_blend_func_separate, GL_EXT_blend_logic_op,
GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
GL_EXT_copy_texture, GL_EXT_draw_range_elements, GL_EXT_fog_coord,
GL_EXT_framebuffer_object, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,
GL_EXT_point_parameters, GL_EXT_polygon_offset, GL_EXT_rescale_normal,
GL_EXT_secondary_color, GL_EXT_separate_specular_color,
GL_EXT_shadow_funcs, GL_EXT_stencil_wrap, GL_EXT_subtexture,
GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias, GL_EXT_texture_object,
GL_EXT_texture_rectangle, GL_EXT_vertex_array, GL_APPLE_packed_pixels,
GL_ATI_texture_env_combine3, GL_ATI_texture_mirror_once,
GL_ATIX_texture_env_combine3, GL_IBM_texture_mirrored_repeat,
GL_INGR_blend_func_separate, GL_MESA_pack_invert, GL_MESA_ycbcr_texture,
GL_NV_blend_square, GL_NV_point_sprite, GL_NV_texgen_reflection,
GL_NV_texture_rectangle, GL_SGIS_generate_mipmap,
GL_SGIS_texture_border_clamp, GL_SGIS_texture_edge_clamp,
GL_SGIS_texture_lod, GL_SGIX_depth_texture, GL_SGIX_shadow,
GL_SGIX_shadow_ambient, GL_SUN_multi_draw_arrays

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
0x23 24 tc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x24 24 tc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x25 24 tc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x26 24 tc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x27 24 dc 0 24 0 r y . 8 8 8 0 0 16 0 0 0 0 0 0 0 None
0x28 24 dc 0 24 0 r y . 8 8 8 0 0 16 8 16 16 16 0 0 0 None
0x29 24 dc 0 32 0 r y . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
0x2a 24 dc 0 32 0 r . . 8 8 8 8 0 16 8 16 16 16 16 0 0 None
alain@debian:~$
comme ça ne me dit rien du tout, je fais glxgears et... surprise, j'ai les roues crantées qui tournent!! avec:

alain@debian:~$ glxgears
3948 frames in 5.1 seconds = 777.783 FPS
3920 frames in 5.1 seconds = 776.170 FPS
3920 frames in 5.0 seconds = 778.937 FPS
3920 frames in 5.0 seconds = 778.840 FPS
3920 frames in 5.1 seconds = 771.186 FPS
J'essaye Foobillard pour voir si je retrouve mon billard de Suse; oui et non: là, il est comme s'il allait planter, avec des à-coups: donc pas satisfaisant du tout.
Bon, je regarde ton comment et... action

moniroje
12/02/2008, 16h20
Il y a Surveillance du système de KDE (mon expérience Suse) qui me montre, à la fin de sa fenêtre: Processus en cours: Xorg.
Comme pas encore de réponse, je vais de ce pas le killer parce que j'ai envie de thveillonné le driver Nvidia 3D.
Normalement, ça doit pas poser de pb que je remette le Nvidia au cas où il y serait déjà???
Vrai que cette méthode "à la main", je l'avais réussie avec suse 10.2 presque aussi vite que thveillon (lui, moins d'une minute, moi 16 minutes) et donc ça m'énerve d'avoir passé quelques heures et de ne pas y être encore arrivé...

Au fait, j'ai fait Synaptic et Tout mettre à jour pour me Lennyfier complètement. Voilà, c'est fait!!! (954 maj, 182 nouveaux et 10 désinstallés) Dites à la liste des fichiers de Synaptic, certains sont accompagnés d'un arrobass rose: ça veut dire quoi, ça???

thveillon
12/02/2008, 16h21
Tu n'utilises pas les pilotes nvidia :
<div class='quotetop'>Citation </div>
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.5.1)[/b]

glxgears tourne, mais avec des scores qui n'ont rien à voir avec ceux des pilotes nvidia, et en utilisant le processeur et non la carte graphique.

Il ne faut pas installer le pilote téléchargé "par dessus" celui installé avec apt-get, il faut d'abord désinstaller l'ancien.


<div class='quotetop'>Citation </div>
Surveillance du système de KDE (mon expérience Suse) qui me montre, à la fin de sa fenêtre: Processus en cours: Xorg.[/b]

Les commandes que je t'ai donné sont à faire en console, pas en mode graphique : c'est normal d'avoir xorg qui tourne sous kde...



arrobass rose c'est pas un @ rose, c'est logo Debian Powaaa

http://pix.nofrag.com/b/7/e/88c51657a95daa628d6d9b70e9d5c.png (http://pix.nofrag.com/b/7/e/88c51657a95daa628d6d9b70e9d5c.html)

moniroje
12/02/2008, 17h29
Suite et pas fin, snif !!!
Je suis donc sur Terminal, je fais su, puis je fais top; un furtif xorg PID 3956 sur ma tite fenêtre de console; je tape q pour quitter ce tableau et ensuite, je tape k 3956 =>command not found; j'essaye: kill 3956 => command not found
Bon, je recommence: top; là, je l'ai bien vu: Xorg PID 3956 ; je tape: k3956 et il réagit: PID to kill:3956 !!! Je fais Entrée et il écrit: Kill PID 3956 with signal [15]: j'attends; en attendant, je remarque un truc curieux: au début du fichier top, il y a écrit: 2 users ... thveillon aurait-il raison en rigolant??? yaurait un voisin qui profiterait ??? Et ce : qui semble attendre une réponse. A tout hasard, je fais y
et hop!! la fenêtre qui s'éteint et revient la page d'accueil de l'identifiant!! on dirait que j'y suis arrivé à killer ce ... de xorg!!!
Donc je recommence: Terminal de secours_Modifier la session, etc. jusqu'au fameux sh NVIDIA touche TAB et Entrée et...
déception: You appear to be running an X server: please exit X before...
Commencer à envisager que Debian, c'est trop fort pour moi... ou bien je garde Debian tel que et j'ai quand même ma suse pour les joies de la 3D (sans compiz-fusion trop problématique)
Mais vrai aussi qu'il est 16h30; tiens, j'vais goûter...

phoenix
12/02/2008, 17h59
Quand on tue le serveur X, il est automatiquement relancé.

Si on veut qu'il ne le soit pas, il faire en root :
/etc/init.d/x11-common stop

Cette commande va arreter le serveur X.

Ainsi que
/etc/init.d/kdm stop

Et celle-ci arreter kdm. Hum il faut peut-être la faire en premier d'ailleurs.

moniroje
12/02/2008, 18h13
Donc je dois faire:

/etc/init.d/kdm stop
puis:
p
/etc/init.d/x11-common stop
et donc, inutile de le top puis kill alors, puisqu'il est arrêté???
J'y retourne!!
ah... et si ça foire, comment je fais pour retrouver mes petits??? je tape quoi à la place de stop ???

phoenix
12/02/2008, 18h19
Tu mets start à la place de stop ;)

Au pire, si tu ne t'y retrouve plus, tu reboot, ces services se chargeront normalement.

moniroje
12/02/2008, 18h55
Résultats des courses:
1°) /etc/init.d/kdm stop: aucun fichier ou répertoire de ce type. bon, je reboote, je regarde dans /etc/init.d et effectivement, je ne vois pas de kdm
2°) ayant vu que le x11-common y était, je me remets en terminal de secours, en su et vas-y que je tente l'aventure:
su puis
cd /etc/init.d
puis:
/etc/init.d/x11-common stop
aucune réaction mais c'est que ça a marché; il n'a pas donné de message d'erreur.
Alors je continue:
cd /home/alain suivi d'un
sh NVIDIA touche TAB qui m'ouvre la fenêtre mais... toujours "You appear to be running on X server...

Suggestion: puisque je suis aussi peu doué à la commande, vous le voyez bien!!! proposez-moi un truc comme opensuse-xgl-settings qui installe les Nvidia : onglet Installer Nvidia et touche Enable et hop!!!! la 3D roule!!
et qui installe aussi Compiz , touche Enable ou Disable et voilà les cubes qui tournent ou le Bureau sagement en 2D
et Compiz-Fusion pas trop au point encore et qui m'a valu une re-install de ma suse 10.3!! et donc avec mention: moniroje: pas toucher!!!

phoenix
12/02/2008, 19h06
Tu n'utilise pas kdm pour te connecter ?

Sinon, une fois fait le /etc/init.d/x11-common stop, il faut tuer X, par exemple avec Ctrl + Alt + Back.

Mais je pense qu'il faut tuer ton gestionnaire de connexion avant, kdm, gdm, ....

moniroje
12/02/2008, 19h55
utiliser kdm pour me connecter??? chais pas... je viens d'installer Debian Etch acheté dans une librairie de presse et voilà...

Dis donc, c'est une véritable tuerie que tu me proposes pour installer à la main Nvidia, façon thveillon... Au fait, il n'en peut plus de moi??? le pauvre!!! il ne savait pas ce que c'était qu'un moniroje...

Bon, moi saucisse, je laisse tomber Cette méthode, je l'ai appliquée pour Suse sans problème et plus d'une fois... Là, j'ai appris pas mal, donc c'est positif.
Mais si vous connaissez un truc d'install façon Opensuse-xgl-settings, je suis preneur.

En tout cas, merci Phoenix, merci Thveillon... mais là, la 3D, je verrai plus tard.

thveillon
12/02/2008, 20h36
Le problème viens de la façon dont tu passes en console je pense, tu t'y prends comment pour arriver sur ton "terminal de secours" ?

Si tu as suivi ce que je disais : clic droit sur le bureau > déconnecter > terminer la session, ensuite sur l'écran de login de kde tu tapes juste "alt+n" (la touche "alt" et la touche "n") et tu es en console où tu te connectes en root. Je viens de le faire à l'instant (c'est qu'il me ferait douter l'animal ;) ) et je te garantie que je n'ai pas de xorg qui tourne...

Nota: <div class='quotetop'>Citation </div>
au début du fichier top, il y a écrit: 2 users[/b] deux users, voyons voyons, toi et root peut-être ? :whistling: Sinon c'est le voisin OU une session graphique lancé sur une autre console virtuelle. Pour le savoir il faut regarder le "tty" dans la ligne xorg renvoyé par la commande
ps -aux

moniroje
12/02/2008, 21h08
Comment je m'y prenais??? une fois la session déconnectée par MenuK-déconnexion-terminer la session, je retrouvais l'écran où on attend que moi user, je mette mon identifiant; là, d'abord, j'allais à Actions et je choisissais Terminal de secours et je cliquais sur Modifier; ensuite, je mettais mon nom puis mon mdp et hop!! j'vais une tite fenêtre de commandes, comme une console quoi...

Cette fois-ci, j'ai fait: clic-droite sur le Bureau-Déconnecter-terminer la session; tout s'éteint puis se rallume sur l'écran de login de KDE; là où ça attend que je mette l'identifiant. Donc, j'appuie sur la touche Alt que je garde appuyée puis la touche n: je relâche; ça ne fait rien du tout. Donc je mets l'identifiant et son mdp et et aussitôt... non pas la console mais le Bureau KDE....

J'ai recommencé mais cette fois-ci, en appuyant d'abord sur la touche n puis Alt mais c'est pas bon, ça met plein de n sur l'identifiant

phoenix
12/02/2008, 22h38
Ouvrir un terminal de secours, ça lance le serveur X quand même :)

thveillon
13/02/2008, 02h22
Sur l'écran de loggin, c'est ça qu'il faut faire :

http://pix.nofrag.com/4/2/c/2cfaf68f3385f9c6007723d2dc76ft.jpg (http://pix.nofrag.com/4/2/c/2cfaf68f3385f9c6007723d2dc76f.html)

C'est dans le menu "menu" pas "type de session".

Moi je n'ai pas de menu "action", ni de terminal de secours, tu ne dois pas utiliser kdm mais gdm ou je ne sais pas quoi... Tu parles de kde, à l'installation tu as eu kde d'office ?

moniroje
18/02/2008, 17h28
Ayant raté l'install de la 3D dite "à la main" lors de ma Debian II (au fait, c'est vrai que c'est humiliant d'avoir dû reformater sa Debian? là, j'en suis à ma Debian III, vous êtes sympas, me sens pas humilié pour autant!), je suis attiré par:
http://jmelst.net/modules.php?name=News&am...icle&sid=95 (http://jmelst.net/modules.php?name=News&file=article&sid=95)
faut juste installer des paquets et hop, vlà la 3D!!! et sera actualisé par les prochaines maj!!!! c'est trop bien!!! Donc, j'essaye:

uname -r me répond que mon noyau kernel est 2.6.22-3-k7

Synaptic: j'installe mesa-utils qui contient les commandes glxinfo et glxgears (les roues crantées de toutes les couleurs qui tournent si il y a la 3D)
et je fais Rechercher: nvidia Il y a bien (nvidia-kernel-source) & (nvidia-kernel-common) & (nvidia-glx) mais je ne vois pas de paquets (nvidia-kernel-2.6.22-3-k7); je vois bien le (nvidia-kernel-2.6.18-6-686) qui correspondait à mon noyau précédent et aussi je note le (nvidia-kernel-2.6-k7)
Donc, si j'ai bien compris, faudra que je trouve autre méthode ou bien que j'attende la sortie du paquet (nvidia-kernel-2.6.22-3-k7)?

thveillon
18/02/2008, 20h12
glxgears ça tourne même avec un pilote moulé à la louche, pas d'accélération matérielle et le cpu scotché à 100%, si tu as un gros cpu ça peut même donner de bon score ! Pour savoir si l'accélération matérielle est activée c'est
glxinfo | grep rendering.

Pour commencer installe "nvidia-kernel-source" et "nvidia-kernel-common" et rien d'autre, ensuite en console lance "module-assistant" en root ou sudo (apt-get install si tu ne l'as pas). Là tu fais toutes les étapes une par une, en prenant soin de lire ce qu'on te raconte, jusqu'à arriver au choix du module que tu veux compiler. Sélectionne "nvidia-kernel" (avec la barre d'espace pour sélectionner) et suis les étapes proposées. Accepte avec "oui" (o) ou "yes"(y) s'il te demande s'il faut télécharger des dépendances, reboot à la fin du processus.

Ça c'est la "Debian way" (la façon Debian).

Si au reboot ça choucroute c'est
dpkg-reconfigure -phigh xserver-xorg qu'il faut avoir noté sur le post-it en bas de l'écran ;) .




Pour comparer avec la version "à la main" :

Télécharge le NVIDIA-XXX.run dans ton ~, installe les sources du noyau, gcc et make, passe en console avec
init 1 en root.

Là tu donnes le mot de passe root, tu tapes sh /home/moniroje/NVIDIA-xxxx.run , tu réponds poliment aux questions par "oui", tu dis "non" quand même quand il veut aller télécharger un module qui n'existe pas sur www.nvidia.com, s'il t'insulte en te disant que ta version de gcc ne correspond pas à celle qui a compilé ton noyau, là tu dis "non" aussi parce que bon, faut pas pousser quand même, et quand c'est fini tu reboot avec "reboot"... Super dur, non ?

moniroje
18/02/2008, 20h52
<div class='quotetop'>Citation </div>
Pour commencer installe "nvidia-kernel-source" et "nvidia-kernel-common" et rien d'autre,[/b]
J'en suis là: j'ai installé nvidia-kernel-source et nvidia-kernel-common mais ça m'a obligé d'installer 30 dépendances dont gcc, libc6-dev, kernel-package,nvidia-glx, nvidia-kernel-2.6.18-6-486. Si je clique Annuler pour ne pas installer ces dépendances, ça annule l'install de nvidia-kernel-source et de nvidia-kernel-common.
Donc, j'ai installé ces 2 trucs et leurs dépendances. Là, j'attends si tu dis que ça va et que je peux continuer.

sudo, je l'ai vu par synaptic qu'il est installé
Pour module-assistant, si je me souviens bien, c'est en faisant MenuK-Installer une commande, n'est-ce pas???

thveillon
18/02/2008, 21h18
Quand je disais "seulement ça", ça inclu bien sur les "quelques" dépendances !

Le problème de sudo c'est qu'il faut le configurer, sur Debian les utilisateurs ne sont pas autorisé à l'utiliser par défaut comme c'est le cas sur suse, pour l'instant on zappe et on utilise "su" pour passer en root.

module-assistant se lance en tapant "module-assistant" sans les guillemets dans une console root, avant il faut l'avoir installé avec synaptic si ce n'est pas déjà fait.

moniroje
18/02/2008, 22h49
J'installe par synaptic: module-assistant
En root, je tape module-assistant
Chouette, ça marche;
houl, dès la première page il me propose ce choix:
Overview: afficher toutes les commandes
Update: mettre à jour les infos de
Prepare: configurer le système pour compiler
Select: sélectionne le module ou le paquet
Exit
"arriver au choix du module que tu veux compiler" as-tu dit; donc je choisis Select puis Entrée

Fenêtre avec plein de trucs listés et je trouve nvidia-kernel ; donc, je suis sur la bonne voie. Hop Espace pour le sélectionner, Entrée pour continuer, roule ma poule!!!
3° Fenêtre: il faut choisir (encore??? tu disais qu'il fallait dire tout le temps Oui!!!) entre
LIST
SEARCH
GET
BUILD : compiler les paquets
INSTALL: installer les paquets pour le noyau
BACK
Je choisis INSTALL
Erreur: le paquet Nvidia-kernel-source n'a pas pu être construit, voir /var/cache/modass/nvidia-kernel-source*buildlog* pour plus de détails.
Je vais et dnas /modass, il n'y a que un fichier descriptions; je l'ouvre et voilà ce qu'il dit:

bcm5700: Broadcom's bcm5700 ethernet driver
em8300: Kernel module for DXR3/Hollywood+ decoder cards
exmap-modules: determine how much physical memory and swap is used by individual processes
cloop: compressed loopback device module
nvidia-kernel-legacy: NVIDIA binary kernel module source (legacy version)
rtai:
ftpfs:
realtime-lsm: realtime Linux security module
qla2x00:
nvidia-kernel: NVIDIA binary kernel module
sysprof-module: sysprof module
lm-sensors:
freeswan-modules: IPSEC kernel modules transition package to Openswan
hubcot:
linux-uvc: Linux Kernel USB Video Class module
device3dfx: device driver source for 3Dfx boards for 2.2+ kernels
rt2400: RT2400 wireless network drivers
dvb-driver:
ndiswrapper: ndiswrapper linux kernel module
linux-wlan-ng: linux-wlan-ng driver
vaiostat:
fuse: Fuse kernel module
tidev-modules: drivers for Texas Instruments calculators link cables
wacom-kernel: wacom binary modules
comedi: Comedi kernel module
plex86-kernel:
zd1211: zd1211 wireless driver module
cipe: lightweight encrypted IP tunnels over UDP
lufs:
loop-aes-ciphers:
ivtv: ivtv drivers (0.8 branch)
xdslusb:
e100:
ipw2200: Intel PRO/Wireless 2200BG and 2915ABG (ipw2200) driver
translucency:
dazuko:
ieee80211:
fwatch-modules:
openswan-modules: IPSEC kernel modules source for Openswan
qc-usb: QuickCam Express kernel module
drbd8-module:
cryptoloop:
acx100: ACX100/ACX111 wireless network drivers
thinkpad:
shfs: (secure) SHell File System module
bcm4400:
fglrx-kernel: kernel module source for the ATI graphics accelerators
userlink:
affix:
drbd0.7-module: RAID 1 over tcp/ip for Linux module
hostap:
gpib-modules: kernel modules for various GPIB boards
kqemu: QEMU Accelerator module
ddrmat:
rt2500: RT2500 wireless network drivers
arla-modules:
lirc-modules: Linux Infra-red Remote Control support (kernel modules)
mga-vid: Kernel driver for the back-end scaler on Matrox cards
unionfs: union filesystem
cdfs: shows the tracks on a CD as normal files
at76c503a: at76c503a driver
video4linux-nw802:
sl-modem: SmartLink software modem driver - module building
pcmcia:
ppscsi:
tun:
openafs-modules: AFS distributed filesystem kernel module
unicorn: Bewan ADSL PCI st and USB unicorn driver
loop-aes: loop-AES encryption modules
xlibmesa-drm:
alsa: ALSA driver sources
i2c:
madwifi: Multiband Atheros Driver for WiFi
ov511: OV511, a USB-only chip used in many webcams
cpad-kernel: Synaptics cPad driver
eagle-usb-modules:
spca5xx: spca5xx driver
cryptoapi-core:
squashfs: squash filesystem
ftape:
nozomi: GlobeTrotter HSDPA kernel driver
ipw2100: Intel PRO/Wireless 2100 (ipw2100) driver
misdn-kernel:
rt2570: RT2570 wireless network drivers
zaptel: Zapata telephony interface

Un truc curieux: ventilateur de mon PC; coup d'oeil sur gkrellm: j'ai un CPU à 100% et l'autre qui s'emballe aussi mais de temps en temps, quand le ventilateur ronronne; je sens qu'il va falloir re-démarrer.
Donc reboot; tiens, au Grub, la liste s'est rallongée: en plus de mes 2 Debian 2.6.22-3-k7 initiaux, se sont rajoutés des Debian GNU/Linux kernel 2.6.18-6-k7. J'ouvre avec ce nouveau-venu et me revoilà. (gkrellm montre des CPU normaux: vers 0%)

thveillon
18/02/2008, 23h37
<div class='quotetop'>Citation </div>
ensuite en console lance "module-assistant" en root ou sudo (apt-get install si tu ne l'as pas). Là tu fais toutes les étapes une par une, en prenant soin de lire ce qu'on te raconte, jusqu'à arriver au choix du module que tu veux compiler[/b]

Hum, je crois que tu as brûlé quelques étapes, dont "prepare" sans laquellle ça ne marchera pas...

moniroje
19/02/2008, 09h59
OK!!!
Bon, cet aprem, je vais recommencer...
Mais, il faut, je pense, que d'abord j'efface tout ce que je viens de faire?
Je vois sur le Grub que en plus de mes 2 Debian kernel 2.6.22.3-k7, il y a maintenant 4 kernel 2.6.18.6-k7 et 2 kernel 2.6.18-4-k7!!! pléthore!!!

soit aller sur Synaptic et désinstaller tout ce que j'ai installé: nvidia et kernel autres que 2.622-3-k7; puis nettoyer mon menu.lst.
Ensuite:
<div class='quotetop'>Citation </div>
En root, je tape module-assistant
dès la première page il me propose ce choix:
Overview: afficher toutes les commandes
Update: mettre à jour les infos de
Prepare: configurer le système pour compiler
Select: sélectionne le module ou le paquet
Exit[/b]
et là, choisir Prepare.

thveillon
19/02/2008, 12h33
Pour tes noyaux, si tu les désisntalles le menu.lst sera mis à jour "automagiquement".

Pour module-assistant, chaque étape du menu a son intérêt, surtout quand on l'utilise pour la première fois. Overview va afficher la liste des options possibles car module-assistant (m-a) fonctionne aussi en ligne de commande sans son interface.

"Update" va mettre à jour les informations concernant les paquets installés ou non.

"Prepare" va faire le boulot minimum dans /usr/src pour q'un compilation se passe bien

"Select" va te permettre de sélectionner le module que tu veux installer

"Exit" ... je te laisse deviner !


Une fois que tu es arrivé à "Select", en étant passé par toutes les étapes précédentes, tu vas choisir le module que m-a va préparer (compiler) puis installer (avec tout ce qui va bien comme les scripts de démarrage, placement du module ou il faut, alias le cas échéant, ...etc). Pour choisir tu navigues avec les flèches et tu sélectionnes avec la barre d'espace.

Tu va arriver à un nouveau menu :

"List" cherche si un module précompilé est déjà installé

"Search" recherche si un module est disponible dans les dépôts

"Get" télécharge les sources pour compiler un module

"Build" effectue la compilation proprement dite et te propose l'installation

"Install" effectue l'installation si elle n'a pas été faite à la suite de Build

"Back" revient au menu de sélection.


M-a effectue donc une progression logique pour éviter de bêtes erreurs et faciliter le travail, tout ce qu'il fait est facilement faisable à la main, directement en console, mais m-a évite d'oublier une étape, de ne pas rafraîchir les sources de son noyau, d'avoir un lien vers les mauvaises sources, de placer une entrée pour charger le module au démarrage dans rc5 alors que sous Debian le mode multiusers graphique est rc2, d'oublier depmod -ai et de se demander pourquoi modprobe ne trouve pas le module... Bref, ça peut aider.


Si la version "assistée" te pèse, sois tu utilises un noyau pour lequel un module précompilé est disponible dans les dépôts, soit tu compiles à la main avec "./configure make checkinstall", soit enfin tu installes avec l'installateur Nvidia.

Comme toujours chez Debian ce n'est pas le choix qui manque.