PDA

Afficher la version complète : Clé USB: Erreur demon KDE



safir
24/02/2008, 14h28
Bonjour à tous,
Je viens chercher de l'aide car j'ai un soucis de montage de clé USB. Je suis sous OpenSuse 10.2 et lorsque j'insère la clé USB, j'obtiens le message suivant:

mount: type erroné de système de fichiers, option erronée, super bloc erroné sur /dev/sdb1, codepage manquante ou autre erreur.
Dans quelques cas certaines informations sont utiles dans syslog -essayez dmesg | tail ou quelque chose du genre.


J'ai donc fait dmesg | tail dans un shell et voici le résultat:


<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>linux-mq81:/etc # dmesg | tail
sdc: assuming drive cache: write through
SCSI device sdc: 4096 512-byte hdwr sectors (2 MB)
sdc: Write Protect is off
sdc: Mode Sense: 23 00 00 00
sdc: assuming drive cache: write through
sdc: sdc1
sd 12:0:0:1: Attached scsi removable disk sdc
sd 12:0:0:1: Attached scsi generic sg2 type 0
usb-storage: device scan complete
FAT: Unrecognized mount option "nls=utf8" or missing value
linux-mq81:/etc #
linux-mq81:/etc # </div>

J'ai ensuite édité fstab :<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>/dev/sda5 / ext3 acl,user_xattr 1 1
/dev/sda6 /home ext3 acl,user_xattr 1 2
/dev/sda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sda2 /windows/D ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sdb1 /windows/E vfat ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sda7 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0
</div>

Puis j'ai supprimé nls=utf8, mais ensuite j'obtiens un message me disant qu'il est impossible de lire le super bloc! :angry:

Ne voulant pas lacher l'affaire, j'ai fouillé sur le web mais je n'y ai pas trouvé de réponse qui permet de résoudre mon pb! J'ai quand même tenté un formattage de la clé USB (linux-mq81:/etc # mkfs -t vfat /dev/sdb1 )mais sans succès!

Bref je ne sais pas par où chercher et j'avoue humblement que mes connaissances ne me permettront pas de m'en sortir seul....

Merci d'avance pour votre aide.

Safir

thveillon
24/02/2008, 16h22
Tu ne dois pas avoir d'entrée dans le fstab pour monter une clé usb, efface la lligne qui concerne la clé. Ensuite il faut déterminer le bon type de système de fichier et l'adresse matérielle de la clé (le /dev/sdxx). Si tu es certain du système de fichiers et de l'adresse de la clé tu peux faire


mount -t vfat /dev/sdc1 /media/usb en ayant créé auparavant le répertoire "usb" dans /media. Mount s'utilise en root.

Sinon utilise
fdisk -l pour lister les périphériques et avoir ces informations. (l'option est un L minuscule).


Mais si ta clé n'est pas montée automatiquement par kde c'est peut-être qu'elle a un problème quelconque. Si elle est montée automatiquement tu la trouveras dans /media/disk ou /media/"label-de-ta-clé". Par défaut kde n'affiche pas les raccourcis des périphériques amovibles sur le bureau, il faut le choisir en faisant un clic droit sur le bureau > configurer le bureau > comportement > icones des périphériques.

safir
24/02/2008, 19h56
Bonjour et merci pour ton aide, :)
J'ai donc supprimé la ligne <div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>/dev/sdb1 /windows/E vfat ro,users,gid=users,umask=0002,nls=utf8 0 0</div> mais ça ne fonctionnait toujours pas! :angry: :angry: J'ai rebooté Linux et ça ne voulait toujours rien savoir avec la première clé mais ça fonctionnait parfaitement avec une autre.
Un petit rebbot, passage sous XP, tiens la clé n'est pas formatée! Reformatage, reboot sous Linux et là les deux clés fonctionnent! :) :) :)

Donc pour résumer:
La suppression de la ligne dans fstab a permis de détecter la clé n° 2 (plus de message d'erreur du demon KDE). La clé n°1 entrainait encore l'apparition du message suivant "impossible de lire le super bloc".
Un formatage de la clé n°1 sous XP a ensuite permis sa reconnaissance sous Linux. D'ailleurs quelle aurait été la commande à taper sous Linux pour formater correctement cette clé?


Merci encore une fois pour ton aide! :)


AZ+

Safir

Clark
24/02/2008, 22h25
Bonsoir,
Le message que te donnait KDE est typique d'une erreur dans le système de fichiers.
Pour formater une clef sous linux, il te faut le paquet dosfstools.
Ensuite, en root :

# mkfs.vfat /dev/sdXY
où XY sont la lettre et le chiffre qui désignent ta clef. Attention à ne pas se mélanger les pinceaux pour ne pas formater une autre partition, surtout si ta clef a deux partitions, dont une cachée, contenant des utilitaires spécifiques (chiffrement, compression à la volée et autres) ! Et avec des disques sata, le risque est carrément de formater par erreur une partition du disque dur...

Un petit tour par les pages de man correspondantes te sera utile, mais les options par défaut sont suffisantes.