PDA

Afficher la version complète : [Réglé] écran de login (suse) blanc



fennec.
27/02/2008, 12h46
Bonjour a tous,

après une mise a juor des drivers (remplacement du driver nv)

lorsque j'arrive sur la page de login de suse l'écrant est tout blanc
et vire au vert tou doucement

j'ariive a me connecté, en aveugle, et sur kde c'es pareil

j'ai donc redémarer en failsafe et ai changé le nom du driver dans xorg.conf

j'ai mis "nv" au lieu de "nvidia"

ensuite j'ai rebooté. au début je pensait que c'était un problème de résolution

une fois redémarer j'ai remit "nvidia dans le xorg.conf"

et j'ai tester plusieur résolution avec sax2. j'ai a chaque fois un écran blanc

si je remet "nv" au lieu de "nvidia" et que je refait des test avec sax2 je n'ai plus se problème


ma carte graphique : nvidia geforce 8400m gs
driver installé avec yast :

nvidia-gfxg01-kmp-default
x11-video-nvidiag01

thveillon
27/02/2008, 20h41
Il me semble bien avoir déjà entendu parler de ces écrans blancs avec les pilotes vidia, tu as fait une petite recherche sur le forum ? Sinon tu peux essayer avec l'installateur Nvidia, après avoir enlevé le pilote instalé par Yast.

fennec.
27/02/2008, 23h36
bonsoir,


oui j'ai déjà posté une fois sur alionet concernan ce problème qui na pas été résolut

je supose que l'installeur se trouve sur leur site ?

merci

Pumpkin
27/02/2008, 23h38
Yes.

L'écran blanc c'est avec ou sans compiz et co ?

fennec.
27/02/2008, 23h39
c'est sans compiz et co

Agemen
28/02/2008, 14h48
Je te conseille de quitter le mode graphique pour éditer le xorg.conf, ou pour désinstaller le pilote en question.
peut être un

sax3 -r 0=nvidia
aidera...

fennec.
29/02/2008, 22h21
je n'ai aucun problème pour désinstaller les driver nvidia

je n'arrive pas a les installer correctement.

j'ai essayé de les installer avec yast et 1click install. aucun des deux n'on fonctionné

au redémarage j'ai toujours un écran blanc

fennec.
10/03/2008, 17h08
Bonjour,

petit up

problème toujours pas réglé.

je désespère de pouvoir un jour utilisé ma carte graphique corectement
sur suse

j'ai donc installer suse 10.3 sur un autre pc

p4 3,2Ghz, 1Go ddr1, disque sata 160Go, disque udma 160Go, 1graveur et un dvdrom asuss
carte mere asuss, carte wifi linksys wmp54g, carte d'acquisition vidéo hercule, carte son creative fx

et comme carte graphique une geforce (me souvien plus laquelle)

même problème, écrant blancs au a la fenêtre des login/password de Suse

Chninkel
10/03/2008, 17h52
Bonjour,
Lors de l'installation d'opensuse 10.3, j'ai eu ce problème.
Cela fait longtemps que je n'ai pas réinstaller, mais il me semble que pour le résoudre j'ai édité mon fichier xorg.conf et supprimer toutes les références à des résolutions supérieures à celle de mon écran à savoir 1280x1024.
Je crois qu'à ce moment j'ai récupéré un affichage normal et j'ai juste eu à régler le décalage de l'écran via Sax2.
C'est peut-être une piste ?

noestrium
11/03/2008, 12h26
Salut,

Tu peux aller voir de ce côté pour télécharger les pilotes directement sur le site dee nvidia :

http://www.nvidia.fr/object/linux_fr.html

Ensuite :

- désinstaller les pilotes déjà présents avec Yast
- il faut installer les sources du noyeau + gcc
- se mettre en init 3 (dans une console, su puis init 3)
- aller à l'endroit ou se trouve le ficheir .run téléchargé depuis le site Nvidia
- en root, exécuter : sh ./NVIDIAx-x-x-x-x-x-x.sh
- suivre les instructions
- redémarrer le PC

Ca devrait rouler.

xiloa
11/03/2008, 12h32
je plussoie, j'ai des problemes à peu près equivalent, mais en noir moiré, avec l'installation via yast. Par contre, c'est nickel "à la main". Il y a un script auto qui marche bien aussi. fais un recherche sur nvidia sur ce forum, tu as des centaines de réponses, notamment là : http://www.alionet.org/index.php?showtopic=19588&hl=

fennec.
16/03/2008, 18h23
Bonjour,
Lors de l'installation d'opensuse 10.3, j'ai eu ce problème.
Cela fait longtemps que je n'ai pas réinstaller, mais il me semble que pour le résoudre j'ai édité mon fichier xorg.conf et supprimer toutes les références à des résolutions supérieures à celle de mon écran à savoir 1280x1024.
Je crois qu'à ce moment j'ai récupéré un affichage normal et j'ai juste eu à régler le décalage de l'écran via Sax2.
C'est peut-être une piste ?[/b]


<div class='quotetop'>Citation (Noestrium @ 11/03/2008 à 11:26) <{POST_SNAPBACK}> (index.php?act=findpost&pid=169143)</div>
Salut,

Tu peux aller voir de ce côté pour télécharger les pilotes directement sur le site dee nvidia :

http://www.nvidia.fr/object/linux_fr.html

Ensuite :

- désinstaller les pilotes déjà présents avec Yast
- il faut installer les sources du noyeau + gcc
- se mettre en init 3 (dans une console, su puis init 3)
- aller à l'endroit ou se trouve le ficheir .run téléchargé depuis le site Nvidia
- en root, exécuter : sh ./NVIDIAx-x-x-x-x-x-x.sh
- suivre les instructions
- redémarrer le PC

Ca devrait rouler.[/b]

merci pour vos réponse.

le problème persiste

j'ai donc tenté d'éditer le xorg.conf et de retiré toute les résolution plus grande que celle accèptée par la carte

je suis allé sur le site d'nvidia récupérer les derniers driver
et j'ai suivis a la lettre les instruction
- install : gcc, make et kernel source
- init 3
- exécuter le script de nvidia
-de retour sur kde j'ai fait en plus un sax -r -m 0=nvidia

une fois l'opération terminée il ma ouvert sax et j'ai pus tester si tout était correcte
et j'ai eu mon éternel écran blanc

xiloa
16/03/2008, 18h48
salut
alors tente ça en root :
init 3
sh NVIDIA......
init 5


Et c'est tout, pas de sax, rien nada.

fennec.
17/03/2008, 11h00
Bonjour,


j'ai essayé juste init 3 - sh NVIDIA - init 5 en root

et j'ai toujours l'écran blanc :cray2: :bang:

voila mon xorg.conf après installation des drivers
sans faire de sax2 -r -m 0=nvidia


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Wed Feb 20 17:07:14 PST 2008

# /.../
# SaX generated X11 config file
# Created on: 2008-03-16T17:22:09+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
Identifier "Layout[all]"
Screen "Screen[0]" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
InputDevice "Mouse[3]" "SendCoreEvents"
Option "Clone" "off"
Option "Xinerama" "off"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "be"
Option "XkbModel" "microsoftpro"
Option "XkbOptions" "caps:shiftlock"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "Logitech Premium Optical Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Mouse[3]"
Driver "synaptics"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "on"
Option "InputFashion" "Mouse"
Option "Name" "Synaptics;Touchpad"
Option "Protocol" "explorerps/2"
Option "SHMConfig" "on"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
EndSection

Section "Monitor"
Identifier "Monitor[0]"
VendorName "Unknown"
ModelName "Unknown"
UseModes "Modes[0]"
DisplaySize 305 230
HorizSync 30.0 - 40.0
VertRefresh 43.0 - 75.0
Option "CalcAlgorithm" "XServerPool"
Option "DPMS"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "nvidia"
VendorName "NVidia"
BoardName "GeForce 8400M GS"
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "800x600" "768x576" "640x480"
EndSubSection
EndSection


et quelque in fo sur mon système. si sa peut aider


uname -a
Linux 2.6.22.17-0.1-default #1 SMP 2008/02/10 20:01:04 UTC i686 i686 i386 GNU/Linux

Processor (CPU): Intel® Core™2 Duo CPU T7250 @ 2.00GHz
OS: Linux 2.6.22.17-0.1-default i686

System: openSUSE 10.3 (i586)
KDE: 3.5.7 "release 72.6"

Vendor: nVidia Corporation
Model: GeForce 8400M GS

Chninkel
17/03/2008, 15h13
Bonjour,

Je penses que s'il n'y a pas de messages d'erreur lors de l'installation des pilotes le problème est peut être ailleurs.

Avec la sortie d'OpenSuse 10.3 j'ai eu ce problème alors qu'auparavant aucun souci (sauf sous d'autres distributions)
Je pense que c'est du à des fréquences de rafraîchissement qui ne correspondent pas à celles supportées par l'écran.

Dans ces condition, j'avais configuré mon écran avec Sax2 à l'aide des données du constructeur :

En root :
sax2, dans la partie écran, dans le premier cadre il y a à droite un bouton "Changer" qui donne accès à une fenêtre avec 3 onglets :

- "Moniteur pour carte VESA ...." -> choisir la marque et le modèle de l'écran pour moi le modèle n'est pas reconnu donc j'ai mis VESA et la résolution max de mon écran avec la fréquence de rafraîchissement ie Lxl@60HZ (60HZ car mon LCD ne supporte pas plus, à adapter à ton écran) -> Valider

- "Taille de l'écran" -> à l'aide du manuel de mon écran, je choisis la diagonale, et la taille de l'écran en mm -> Valider

- "Synchroniser les fréquences" -> avec le manuel constructeur, renseigner les fréquences horizontales et verticales de mon écran NE RIEN METTRE AU HASARD. ->Valider

L'intérêt est d'être sur que la configuration de l'écran est bonne.

C'est une piste à explorer, car il me semble avoir résolu le problème comme ça.

Ton écran ne supporte pas de résolution supérieur à 800x600 ?

Quel en est la marque et le modèle ?

Edit : si possible le faire sous session graphique "normale", je viens de faire la manip en init 3 puis sax2 mais il change le driver dans xorg.conf j'ai du éditer ce fichier et remettre nvidia

New2008
17/03/2008, 15h42
J'ai deja eu ce probleme, modifie le fichier /etc/sysconfig/displaymanager a la ligne :

DISPLAYMANAGER_XSERVER="Xgl"

par

DISPLAYMANAGER_XSERVER="Xorg"

et ca refonctionne...

ps : eviter comme la peste le serveur xgl, rien que des problems avec...

fennec.
17/03/2008, 16h11
Bonjour,

Je penses que s'il n'y a pas de messages d'erreur lors de l'installation des pilotes le problème est peut être ailleurs.

Avec la sortie d'OpenSuse 10.3 j'ai eu ce problème alors qu'auparavant aucun souci (sauf sous d'autres distributions)
Je pense que c'est du à des fréquences de rafraîchissement qui ne correspondent pas à celles supportées par l'écran.

Dans ces condition, j'avais configuré mon écran avec Sax2 à l'aide des données du constructeur :

En root :
sax2, dans la partie écran, dans le premier cadre il y a à droite un bouton "Changer" qui donne accès à une fenêtre avec 3 onglets :

- "Moniteur pour carte VESA ...." -> choisir la marque et le modèle de l'écran pour moi le modèle n'est pas reconnu donc j'ai mis VESA et la résolution max de mon écran avec la fréquence de rafraîchissement ie Lxl@60HZ (60HZ car mon LCD ne supporte pas plus, à adapter à ton écran) -> Valider

- "Taille de l'écran" -> à l'aide du manuel de mon écran, je choisis la diagonale, et la taille de l'écran en mm -> Valider

- "Synchroniser les fréquences" -> avec le manuel constructeur, renseigner les fréquences horizontales et verticales de mon écran NE RIEN METTRE AU HASARD. ->Valider

L'intérêt est d'être sur que la configuration de l'écran est bonne.

C'est une piste à explorer, car il me semble avoir résolu le problème comme ça.

Ton écran ne supporte pas de résolution supérieur à 800x600 ?

Quel en est la marque et le modèle ?

Edit : si possible le faire sous session graphique "normale", je viens de faire la manip en init 3 puis sax2 mais il change le driver dans xorg.conf j'ai du éditer ce fichier et remettre nvidia[/b]

nonmon écran supporte bien plus je suis redesendu pour faire des test

le pc, c'est un portable dell vostro 1500. je vai regarder dans les bouquins du pc pour bien parametré l'écran


<div class='quotetop'>Citation (New2008 @ 17/03/2008 à 14:42) <{POST_SNAPBACK}> (index.php?act=findpost&pid=169868)</div>
J'ai deja eu ce probleme, modifie le fichier /etc/sysconfig/displaymanager a la ligne :

DISPLAYMANAGER_XSERVER="Xgl"

par

DISPLAYMANAGER_XSERVER="Xorg"

et ca refonctionne...

ps : eviter comme la peste le serveur xgl, rien que des problems avec...[/b]

c'est déjà mit Xorg pour le DISPLAYMANAGER_XSERVER

merci pour les info

Chninkel
17/03/2008, 17h35
Quelques infos ici :
http://support.euro.dell.com/support/edocs...ecs.htm#wp80738 (http://support.euro.dell.com/support/edocs/systems/vos1500/fr/om_fr/html/specs.htm#wp80738)

En résumé
Fréquence d'affichage 60HZ pas plus de détails

Résolution :
WXGA 1280 x 800 avec 262 K couleurs
WXGA avec TrueLife 1280 x 800 avec 262 K couleurs
WXGA+ avec TrueLife 1440 x 900 avec 262 K couleurs
WSXGA+ avec TrueLife 1680 x 1050 avec 262 K couleurs

Taille de l'écran Axe X 344.5 Axe Y 222.5 Diagonale : 15,4" Rapport 16/10

Sinon j'ai trouvé ça avec une 8600 gt mais la démarche doit être la même:
http://www.nvnews.net/vbulletin/showthread.php?t=107138

xiloa
17/03/2008, 18h33
je pense que ton problème vient de xgl. Il faut regarder de ce coté là et desactiver ce truc. Tu as essayé d'installer compiz non?

fennec.
17/03/2008, 23h06
Chninkel

merci pour les infos,

j'ai regader dans le bios et j'ai trouvé très peu d'info

affichage 1280x800 ; 15,4"

dans les infos système j'ai trouvé ceci

max horiz. freq. : 48
max vert. freq : 90
max horiz. freq. : 31
max vert. freq : 50


j'ai parametré mon écrant de cette façon

monitor
dell 1280X LAPTOP DISPLAY PANEL

display size :
diagonal : 15.4
aspect ratio : 16/10
display size: x = 332 : y = 208 (si je met y = 222 la diagonal passe a 16.7)

Sync frequencies :
horiz : 31 -> 60khz
vert : 50 -> 60khz

installation des driver sans erreur. et après un init 5 de nouveau un écran blanc


xiloa

quand je suis passé a openSuse 10.3 (dé sa sortie). j'ai réussi a installer les driver nvidia via yast
je me suis donc empressé d'installer compiz. j'ai eu quelque problème. je pouvais changer toute les
options que je voulais dans kompiz config manager, aucun paramètre n'était pris en compte.
j'ai essayé d'installer un thème pour compiz sa na pas fonctionné. j'ai donc formaté et tou réinstaller
depuis, plus moyen d'installer les driver nvidia j'ai sans cesse cet écran blanc

compiz était installé quand j'ai refais le pc. la première chose que j'ai fait c'est de le désinstaller
pour le moment, il n'y pas l'ombre de kompiz


xgl était installé. je l'ai donc désinstallé et j'ai réinstallé les drivers

résultat
écran blanc :bang: :bang: :bang:

Chninkel
20/03/2008, 14h59
Bonjour,

Pour la section monitor, essaie de choisir --> LCD 1280x800@60hz

Je ne suis pas certain que les fréquences de l'écran soient bonnes, dans ton cas il faudrait plutôt indiquer :

Sync frequencies :
horiz : 31 -> 48 khz
vert : 50 -> 90 khz

Pour la taille de l'écran (Display size) il s'agit des dimensions physiques de l'écran.

D'après ce que tu dis, l'écran fonctionnait bien auparavant, donc essaie de revenir à une version plus ancienne des pilotes, c'est d'ailleurs de cette facon que fonctionne la méthode que je te donnais dans le lien, à savoir :

- installer les pilotes 100.14.19 ici http://www.nvidia.com/object/linux_display..._100.14.19.html (http://www.nvidia.com/object/linux_display_ia32_100.14.19.html) (méthode habituelle puis reboot)
- s'il n'y a pas de probléme d'affichage lancer NVIDIA X server Settings (menu K -> systeme ->plus de programme)
- trouver CRT-0 ou DFP-0 (dans la partie GPU 0), puis à droite faire Acquire EDID enregistre le fichier edid.bin
- copier ce fichier dans /etc/X11
- Editer le fichier xorg.conf puis
dans la section "Device"
ajouter Option "CustomEDID" "DFP-0:/etc/X11/edid.bin" (remplacer DFP-0 par CRT-0 si besoin)
- Vérifier dans les parties "Screen" et "Display" que les bonnes résolutions sont indiquées, sauvegarder et reboot.

Je crois que c'est moins compliqué que ce qu'il n'y parait.

D'aprés ce que j'ai compris cette méthode permet d'obtenir les bonnes spécifications de l'écran et de les conserver lors des mises à jour des pilotes graphiques.

Cela dit si les pilotes précédents fonctionnent, c'est peut-être plus simple de les conserver.

xiloa
20/03/2008, 20h52
Comment as tu désinstallé xgl ? Par Yast ? Réinstalle xgl, puis installe le pilote nvidia "à la main", par init 3, sh nvidiaxxxxxxxx.sh, init 5 ...

theophane
22/03/2008, 17h12
Salut, j'ai une configuration sensiblement identique à la tienne Acer Aspire 7720G (Inter Core2Duo T7500 2,0Ghz, 2Go ram, Nvidia 8400M GS) et je n'ai aucun souci.
Après une installation toute fraîche j'ai ajouté le dépôt NVIDIA par "référentiel communautaire". Après une mise à jour et un redémarrage, Opensuse m'a installé les derniers pilotes (169.12) et tout marche bien.

Voici pour info mon fichier xorg.conf :

# /.../
# SaX generated X11 config file
# Created on: 2008-03-22T15:16:30+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "fr"
Option "XkbModel" "pc102"
Option "XkbOptions" "caps:shiftlock"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "evdev"
Identifier "Mouse[1]"
Option "Buttons" "10"
Option "InputFashion" "Mouse"
Option "Name" "Logitech USB R*"
Option "Protocol" "event"
Option "SendCoreEvents" "on"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
HorizSync 30-90
Identifier "Monitor[0]"
ModelName "1440X900@70HZ"
Option "DPMS"
VendorName "--> LCD"
VertRefresh 58-72
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
Modeline "1440x900" 126.98 1440 1536 1688 1936 900 901 904 937
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900" "1366x768" "1280x800" "1152x864" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "GeForce 8400M GS"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
VendorName "NVidia"
EndSection



Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection


Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection

fennec.
23/03/2008, 12h56
Bonjour,

Pour la section monitor, essaie de choisir --> LCD 1280x800@60hz

Je ne suis pas certain que les fréquences de l'écran soient bonnes, dans ton cas il faudrait plutôt indiquer :

Sync frequencies :
horiz : 31 -> 48 khz
vert : 50 -> 90 khz

Pour la taille de l'écran (Display size) il s'agit des dimensions physiques de l'écran.

D'après ce que tu dis, l'écran fonctionnait bien auparavant, donc essaie de revenir à une version plus ancienne des pilotes, c'est d'ailleurs de cette facon que fonctionne la méthode que je te donnais dans le lien, à savoir :

- installer les pilotes 100.14.19 ici http://www.nvidia.com/object/linux_display..._100.14.19.html (http://www.nvidia.com/object/linux_display_ia32_100.14.19.html) (méthode habituelle puis reboot)
- s'il n'y a pas de probléme d'affichage lancer NVIDIA X server Settings (menu K -> systeme ->plus de programme)
- trouver CRT-0 ou DFP-0 (dans la partie GPU 0), puis à droite faire Acquire EDID enregistre le fichier edid.bin
- copier ce fichier dans /etc/X11
- Editer le fichier xorg.conf puis
dans la section "Device"
ajouter Option "CustomEDID" "DFP-0:/etc/X11/edid.bin" (remplacer DFP-0 par CRT-0 si besoin)
- Vérifier dans les parties "Screen" et "Display" que les bonnes résolutions sont indiquées, sauvegarder et reboot.

Je crois que c'est moins compliqué que ce qu'il n'y parait.

D'aprés ce que j'ai compris cette méthode permet d'obtenir les bonnes spécifications de l'écran et de les conserver lors des mises à jour des pilotes graphiques.

Cela dit si les pilotes précédents fonctionnent, c'est peut-être plus simple de les conserver.[/b]


merci beaucoup, sa fonctionne très bien avec ces drivers et cette config
:D

xiloa
23/03/2008, 13h06
réglé ?

Chninkel
24/03/2008, 01h38
Bonsoir,
Je suis ravi d'avoir pu te dépanner. :thumbsup:

fennec.
24/03/2008, 10h51
Bonjour

<div class='quotetop'>Citation (xiloa @ 23/03/2008 à 12:06) <{POST_SNAPBACK}> (index.php?act=findpost&pid=170505)</div>
réglé ?[/b]

pas vraiment

ceci


- trouver CRT-0 ou DFP-0 (dans la partie GPU 0), puis à droite faire Acquire EDID enregistre le fichier edid.bin
- copier ce fichier dans /etc/X11
- Editer le fichier xorg.conf puis
dans la section "Device"
ajouter Option "CustomEDID" "DFP-0:/etc/X11/edid.bin" (remplacer DFP-0 par CRT-0 si besoin)
- Vérifier dans les parties "Screen" et "Display" que les bonnes résolutions sont indiquées, sauvegarder et reboot.

ne fonctionne pas

il ne veut pas démarer x

j'arrive en mode comande

Chninkel
24/03/2008, 18h07
Bonjour,

C'est peut-être un problème de syntaxe, ou de nom dans xorg.conf.
Quels sont les messages d'erreurs ?

Cela dit, je suis un peu perdu sur les manipulations effectuées.

Pour y voir clair, essayons de récapituler.

Suite à l'installation, le passage aux pilotes nvidia entraîne un écran blanc, donc :

1ére méthode :
- sauvegarder xorg.conf
- Configurer l'écran avec les bonnes fréquences, taille, etc... avec Sax en utilisant les pilotes nv puis vérifier si cela fonctionne avec les pilotes nvidia.
Si le problème persiste, on passe à l'autre méthode.

2nde méthode :
- installer les pilotes 100.14.19 ici http://www.nvidia.com/object/linux_display..._100.14.19.html (méthode habituelle puis reboot)
- s'il n'y a pas de probléme d'affichage lancer NVIDIA X server Settings (menu K -> systeme ->plus de programme)
- trouver CRT-0 ou DFP-0 (dans la partie GPU 0), puis à droite faire Acquire EDID enregistre le fichier edid.bin attention à la référence, CRT-0, DFP-0 à adapter avec la config
- copier ce fichier dans /etc/X11
- passer en mode console puis désinstaller les anciens pilotes et installer les nouveaux sans reboot
- Editer le fichier xorg.conf puis
dans la section "Device"
ajouter
Option "CustomEDID" "DFP-0:/etc/X11/edid.bin" (remplacer DFP-0 par la référence correspondante)
- Vérifier dans les parties "Screen" et "Display" que les bonnes résolutions sont indiquées,sauvegarder.
- Tester en redémarrant X.

fennec.
24/03/2008, 18h14
bonjour Chinkel,

la deuxième méthode est la bone, ma carte est reconnue
j'ai le logo Nvidia au démarage. et bien que sax signale que la 3d
n'est pas activée, sa fonctionne très bien

sauf quand j'ajoute cette ligne dans le xorg.conf

CustomEDID "DFP-0:/etc/X11/edid.bin"

dans la section device
pour moi c'est bien DFP-0 et pas CRT-0

après avoir générer et copier le fichier dans /etc/X11/

lorsque je redémare il refuse de me lancé le serveur x

Chninkel
24/03/2008, 19h19
Pour résumer :

- installation des pilotes 100.14.19 (pas de modification de xorg.conf avec EDID) -> pas de problème

- en console désinstallation des 100.14.19 puis modifications de xorg.conf avec EDID et installation des derniers pilotes -> le serveur X ne se lance pas

C'est bien cela ?

PS : lorsque tu reviens en console, il n'y a pas de message d'erreur ?

xiloa
24/03/2008, 19h25
salut,

bon, et bien première chose, on respire un grand coup.
deuxième chose, tu enlèves ta modif manuelle de xorg et tu reviens en mode graphique.
troisieme chose, on réfléchit et on donc sort du mode "essai/echec/reinstall"

edit :
- le pilote à jour est le NVIDIA-Linux-x86-169.12-pkg1.run
- je pense qu'il faut que tu lises 2 fois le wiki sur l'installation des pilotes nvidia. Perso, l'install avec yast n'a JAMAIS marché. Chez certain peut être, chez moi JAMAIS. donc, j'utilise la méthode manuelle, sans modifier xorg.
http://wiki.alionet.org/doku.php?id=howto:...ia&s=nvidia (http://wiki.alionet.org/doku.php?id=howto:nvidia&s=nvidia)
lis tout doucement cette page.

Je te résume la tactique :
A *** tu as de la chance ***
- tu restaures le mode graphique
- tu ouvres yast, et installes gcc, make, kernel-source

A' *** tu es pas chanceux et tu n'arrives pas à retrouver le mode graphique ***
- tu tapes yast, en root
- installes gcc, make, kernel-source

B **** ensuite ****

*1** passer en mode superutilisateur dans une console ou tu restes loggé en root
su

*2** passer en mode 3
$init 3
eventuellement, reloggues toi

*4** telecharger le pilote nvidia
$wget http://fr.download.nvidia.com/XFree86/Linu...169.12-pkg1.run

*5** installer le pilote
$sh NVIDIA-Linux-x86-169.12-pkg1.run
suis les instructions, le pilote va se compiler

*6** passer en mode graphique
$init 5
c'est fini, kdm doit vous demander de vous logguez, en mode graphique !


* ATTENTION *
Chaque mise à jour du kernel ou de X11 implique une recompilation du pilote .

C **ENSUITE ENFIN *******
comme tu es revenu en mode graphique à ce niveau, tu vas dans sax2, que tu lances application>systeme>configuration
là, tu as une petite croix pour activer la 3D.

fennec.
24/03/2008, 21h54
bonjour a tous,

<div class='quotetop'>Citation (Chninkel @ 24/03/2008 à 18:19) <{POST_SNAPBACK}> (index.php?act=findpost&pid=170634)</div>
Pour résumer :

- installation des pilotes 100.14.19 (pas de modification de xorg.conf avec EDID) -> pas de problème

- en console désinstallation des 100.14.19 puis modifications de xorg.conf avec EDID et installation des derniers pilotes -> le serveur X ne se lance pas[/b]

C'est bien cela a peu de chose près je ne désinstalle pas les driver 100.14.19 et je ne réinstalle pas les nouveaux driver
je me contente de modifer le xorg.conf avec cette ligne CustomEDID "DFP-0:/etc/X11/edid.bin"
et ensuite je redémare et le serveur x est indisponible

<div class='quotetop'>Citation (xiloa @ 24/03/2008 à 18:25) <{POST_SNAPBACK}> (index.php?act=findpost&pid=170635)</div>
... je pense qu'il faut que tu lises 2 fois le wiki sur l'installation des pilotes nvidia. Perso, l'install avec yast n'a JAMAIS marché. Chez certain peut être, chez moi JAMAIS. donc, j'utilise la méthode manuelle, sans modifier xorg.
...[/b]


l'install avec yast a fonctionné 1 fois. a la sortie de openSuse 10.3

je ne vois pas pourquoi je devrai allé relire le wiki. l'intall des drivers 100.14.19 a bien fonctionné

install de gcc (permet de compiler du code source c, c++, ect...)
les sources du kernel (la version de celui installer) obtenu avec uname -r
make : commande permettant de lance les makefile (suite d'instruction pour compilé du code source)

sont tous les trois installé

ensuite
su
init 3
cd /home/user/driver\ nvidia
sh NVIDIA.............100.14.19.run
init 5

et les drivers sont bien installé. sax me dit qu'il n'y a pas de 3d
mais sa fonctionne

ensuite j'exécute se qu'a dit Chninkel


<div class='quotetop'>Citation (Chninkel @ 24/03/2008 à 18:19) <{POST_SNAPBACK}> (index.php?act=findpost&pid=170634)</div>
...
- trouver CRT-0 ou DFP-0 (dans la partie GPU 0), puis à droite faire Acquire EDID enregistre le fichier edid.bin attention à la référence, CRT-0, DFP-0 à adapter avec la config
- copier ce fichier dans /etc/X11
- passer en mode console puis désinstaller les anciens pilotes et installer les nouveaux sans reboot
- Editer le fichier xorg.conf puis
dans la section "Device"
ajouter
Option "CustomEDID" "DFP-0:/etc/X11/edid.bin" (remplacer DFP-0 par la référence correspondante)
- Vérifier dans les parties "Screen" et "Display" que les bonnes résolutions sont indiquées,sauvegarder.
- Tester en redémarrant X.
...[/b]

et c'est a ce moment que x n'est plus disponible
j'édite /etc/X11/xorg.conf

je met la ligne CustomEDID "DFP-0:/etc/X11/edid.bin"
en commentaire, ensuite je redémare et sa fonctionne

<div class='quotetop'>Citation (xiloa @ 24/03/2008 à 18:25) <{POST_SNAPBACK}> (index.php?act=findpost&pid=170635)</div>
...
*************** ATTENTION *****
Chaque mise à jour du kernel ou de X11 implique une recompilation du pilote .
...[/b]

la manipulation de Chninkel ne permet pas d'évité ce problème ?
ajout de CustomEDID "DFP-0:/etc/X11/edid.bin" dans le xorg.conf

<div class='quotetop'>Citation (xiloa @ 24/03/2008 à 18:25) <{POST_SNAPBACK}> (index.php?act=findpost&pid=170635)</div>
...
*************ENSUITE ENFIN :
comme tu es revenu en mode graphique à ce niveau, tu vas dans sax2, que tu lances application>systeme>configuration
là, tu as une petite croix pour activer la 3D.
...[/b]

avec les driver 100.14.19 correctement installé. sax me dit qu'il n'ya pas de 3d.
quand les driver n'était pas installé certain thème de karamba ne fonctionnais pas (il fesait ramé le pc)
maintenant sa fonctionne correctement

bonne soirée

Chninkel
25/03/2008, 04h37
Nous nous sommes mal compris.

<div class='quotetop'>Citation </div>
C'est bien cela a peu de chose près je ne désinstalle pas les driver 100.14.19 et je ne réinstalle pas les nouveaux driver
je me contente de modifer le xorg.conf avec cette ligne CustomEDID "DFP-0:/etc/X11/edid.bin"
et ensuite je redémare et le serveur x est indisponible[/b]

C'est ici que ca cloche => dans ce cas pas besoin de modifier xorg.conf (c'est pourquoi l'option fait planter X quand on la rajoute).
Puisque ces pilotes fonctionnent on les installe provisoirement pour récupérer le fichier edid.bin.

Aujourd'hui nous en sommes aux 169.12 et pour utiliser une version > à 169.09 il faut modifier le xorg.conf (pour info j'ai essayé chez moi et pas de problème).

D'où 3 situations :

- je sais que mon écran fonctionne bien avec les pilotes 100.14.19 donc je les installe manuellement (init3 sh NVIDIA init5...) sans toucher au xorg.conf mais réinstallation lors de nouveau Kernel

- je souhaite utiliser YAST : dans ce cas comme la version disponible est supérieure à 169.09 je rajoute l'option CustomEDID dans le xorg

- j'installe manuellement des pilotes > à 169.09 => ajout de l'option CustomEDID dans le xorg.

Est-ce plus clair comme cela ?

PS : on ne sait toujours pas si l'option fonctionne avec une version récente des pilotes.

xiloa
25/03/2008, 10h24
salut,

Bon, premier point, Fennec, comment installes tu make, gcc et kernel-source ? Il suffit de passer par yast, et installer ces paquets.

deuxieme point, privilégie un xorg.conf qui fonctionne, retourne en mode graphique avant tout. tu es sur de ne pas avoir la 3D en mode texte. :blink: , c'est plus facile de reflechir.

troisieme point. télécharge le nouveau pilote nvidia ( 169.12), les pilotes nvidia pour linux sont maintenant plus performant que ceux pour win. Pas mal de pbm ont été réglés et le sont au fur et à mesure.
essaie ensuite d'installer ce pilote en mode graphique ( init 3 ...... )

quatrième point : la 3D!!!
La 3D n'est pas activé par défaut. il faut cliquer sur une case à cocher dans sax2. Si le pilote est ok, et xorg Ok, il n'y a pas de problème.

Bon courage, on est là.

edit :
- j'ai vérifié, le pilote pour la Geforce 8400 GS est bien là :
http://www.nvidia.fr/object/linux_display_..._169.12_fr.html (http://www.nvidia.fr/object/linux_display_ia32_169.12_fr.html)
il y a d'ailleurs de nombreuses améliorations pour les séries 8....

- je ne comprends pas la manip de chinkel.

- les pilotes doivent être recompilé à chaque mise à jour du noyau et de xorg (rare). Il faut donc être vigilant quand tu fais tes mises à jours. la procédure init 3 , sh nv...... suffit.

fennec.
25/03/2008, 12h53
salut

xiloa,

j'ai installer gcc,make et kernel source avec yast

Chninkel,

ok, je n'avais pas compris que la ligne CustomEDID était obligatoire uniquement
pour les drivers supérieur a 169.09.

juste une question,

je supose que je doit désinstaller les drivers 100.14.19 avant d'en installer des nouveaux?

une installation de nouveau driver n'écrase pas les ancien ?

Chninkel
25/03/2008, 16h42
Bonjour,

L'incompréhension est du au fait que Xiloa et moi n'avons pas la même approche du problème.

En effet, pour Xiloa, c'est une question d'installation de pilotes, mais d'après ce que nous dit Fennec, l'installation se déroule bien que ce soit par yast ou manuellement.

Pour moi, cet écran blanc signifie que le pilote graphique essaie de faire fonctionner mon LCD à des fréquences ou des résolutions qu'il ne supporte pas et je résoud cela en spécifiant les bons paramètres dans Sax (fréquences, etc...);

Cette manipulation ne fonctionnant pas pour Fennec, j'ai effectué une recherche sur internet et je suis tombé sur cette discussion concernant les portables Vostro 1500 (http://www.nvnews.net/vbulletin/showthread.php?t=107138) qui fait mention d'un "bug" avec les drivers 169.09 et cet écran.
Pour palier à cela, les intervenants proposent de récupérer un fichier edid.bin à l'aide de pilotes qui fonctionnent -en l'occurrence les 100.14.19- pour utiliser les versions suivantes, d'où l'ajout de la ligne dans le xorg.conf.
Cette solution ayant fonctionné pour eux, je la propose à Fennec, d'autant plus que visiblement 'l"incompatibilité" subsiste avec les derniers pilotes en date.

Si ça fonctionne, rien n'empêche de passer par yast pour l'installation des pilotes, ce qui simplifie la gestion des changements de kernel, mais il faudra pour cela utiliser l'option CustomEDID.

Enfin, en conservant edid.bin, lors d'une réinstallation du système ultérieure, il suffira de mentionner l'option CustomEDID dans le xorg.conf .pour s'en sortir.

Il me semble que l'installation des nouveaux drivers se charge de la suppression des précédents, donc la procédure habituelle suffira.

xiloa
25/03/2008, 18h22
ok, je comprends mieux. il faut dans la mesure du possible documenter ses coups magiques. en l'occurence, j'ai quand même du mal à comprendre les tenants et aboutissants.

Concernant le pilote nvidia, chaque réinstallation "fait le menage". Concernant le dernier pilote, il semble regler pas mal de bogues sur la série 8. ( cf page http://www.nvidia.fr/object/linux_display_..._169.12_fr.html )



Sinon, il reste cette solution : linux-bugs@nvidia.com

fennec.
13/04/2008, 13h29
Bonjour a tous,

je n'ai pas eu le temps de me plonger sur mon problème de carte graphique ces dernier temps

voilà mes derniers test

- suppresion des drivers 100.14.19
- a jour de la ligne CustomEDID dans le xorg.conf

test 1.
instalation des drivers avec yast => écran blanc

test 2. installation des drivers en mode commande (init 3 - sh nvidia... - init 5)

j'ai eu cette erreur au retour sur l'interface graphique


X Window System Version 7.2.0
Release Date: Tue Jan 22 17:08:26 UTC 2008
X Protocol Version 11, Revision 0, Release 7.2
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux naxosit-ju 2.6.22.17-0.1-default #1 SMP 2008/02/10 20:01:04 UTC i686
Build Date: 22 January 2008
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu Mar 27 20:53:38 2008
(==) Using config file: "/etc/X11/xorg.conf"
Parse error on line 144 of section Device in file /etc/X11/xorg.conf
"CustomEDID" is not a valid keyword in this section.
(EE) Problem parsing the config file
(EE) Error parsing the config file

Fatal server error:
no screens found

giving up.
xinit: Connection reset by peer (errno 104): unable to connect to X server
xinit: No such process (errno 3): Server error.

j'ai bien ajouter la ligne CustomEDID
dans la section Section "Device"

Chninkel
13/04/2008, 14h09
Bonjour Fennec,
Pourrais-tu nous donner ton xorg.conf, apparemment il y a un problème à la ligne 144, d'après ce qui est dit l'option CustomEDID n'est pas bien placée.

Sinon, d'après le site de nvidia les derniers pilotes résolvent les problèmes de mauvais EDID, tu peux les trouver ici :
http://www.nvidia.fr/object/linux_display_..._173.08_fr.html (http://www.nvidia.fr/object/linux_display_ia32_173.08_fr.html) pour la version 32bits
http://www.nvidia.fr/object/linux_display_..._173.08_fr.html (http://www.nvidia.fr/object/linux_display_amd64_173.08_fr.html) pour la vrsion 64bits

xiloa
13/04/2008, 14h24
bonjour,

et un essai sans cette ligne ?

fennec.
13/04/2008, 15h19
merci a tous,

les drivers 173.08 fonctionne super bien. sans ajouter CustomEDID dans le xorg.conf

installation en moins de 2min et pas d'écran blanc au redemarage

encore merci pour votre aide.

xiloa
13/04/2008, 15h26
un "réglé" pas volé.

Chninkel
13/04/2008, 15h40
Bonjour Xiloa,
effectivement on aura bien galéré.

fennec.
13/04/2008, 15h49
en tout cas, je n'y serai jamais parvenu sans votre aide

merci encore