PDA

Afficher la version complète : Probleme Gravure



io-one
08/03/2008, 12h42
Depuis le passage à la OpenSuse 10.3 impossible de graver CD (DVD oui) cdrecord déconne et envois une erreure de droit ? ce probleme a t'il déjas été traité ? si oui pouvez vous m'indiquer quel topic car je ne le trouve pas :( et j'ai du mal à comprendre pourquoi sur la 10.3 on arrive pas à graver !!!! Bon we à tous ;)

thveillon
08/03/2008, 12h56
Ce n'est pas le même programme qui est utilisé par K3B (c'est ça que tu utilises ?) pour graver les cd et dvd, pour les cd je crois que cdrecord n'est plus qu'un alias pour wodim qui est le programme réellement utilisé.

Quel est le message exact qui t'est renvoyé ? Et peux-tu vérifier que ton utilisateur fasse bien partie du groupe "cdrom" (pour savoir à quels groupes tu appartients tape la commande "groups" sans guillemets dans un terminal).

Agemen
08/03/2008, 16h30
C'est un problème que j'ai jamais vu ici ;)
C'est bizarre... j'ai toujours trouvé la gravure plus puissante sous nunux...
Essaie de lancer K3B dans un terminal, comme ça on aura les erreurs exactes. Si ça suffit pas, peut être qu'il y a un paquet debuginfo qui serait plus bavard, je sais pas...
Sinon... tu as quoi comme graveur? Ca marchait, avant?

io-one
08/03/2008, 16h47
Ce n'est pas le même programme qui est utilisé par K3B (c'est ça que tu utilises ?) pour graver les cd et dvd, pour les cd je crois que cdrecord n'est plus qu'un alias pour wodim qui est le programme réellement utilisé.[/b]
Oui c'est ça j'utilise K3b et en effet c'est wodim qui est utilisé
<div class='quotetop'>Citation (thveillon @ 8/03/2008 à 11:56) <{POST_SNAPBACK}> (index.php?act=findpost&pid=168853)</div>
Quel est le message exact qui t'est renvoyé ? Et peux-tu vérifier que ton utilisateur fasse bien partie du groupe "cdrom" (pour savoir à quels groupes tu appartients tape la commande "groups" sans guillemets dans un terminal).[/b]
ben dans le groupe j'ai bien cdrom et pour le message d'erreur le voici : CDrecord n'a pas la permission d'ouvrir ce périphérique

<div class='quotetop'>Citation (Agemen @ 8/03/2008 à 15:30) <{POST_SNAPBACK}> (index.php?act=findpost&pid=168871)</div>
C'est un problème que j'ai jamais vu ici ;)
C'est bizarre... j'ai toujours trouvé la gravure plus puissante sous nunux...
Essaie de lancer K3B dans un terminal, comme ça on aura les erreurs exactes. Si ça suffit pas, peut être qu'il y a un paquet debuginfo qui serait plus bavard, je sais pas...
Sinon... tu as quoi comme graveur? Ca marchait, avant?[/b]
Moi aussi j'adore k3b et la gravure sous linux, jamais eu de problemes auparavant, c'est pas ça qui va me décourager !!!!

thveillon
08/03/2008, 20h22
Il faut que tu vérifies les permissions sur /dev/cdrom, normalement ça doit être root:cdrom avec rw pour le propriétaire et le groupe.

io-one
08/03/2008, 20h35
Il faut que tu vérifies les permissions sur /dev/cdrom, normalement ça doit être root:cdrom avec rw pour le propriétaire et le groupe.[/b]

Le probleme est récurent même après une nouvelle installation.

il y a tout les droits peut être qu'il faut modifier le groupe ?
lrwxrwxrwx 1 root root 3 mar 8 16:10 /dev/cdrom -> sr1

Et puis ça marche avec les DVD c'est quand même étrange ?

thveillon
09/03/2008, 02h24
Dans /etc tu trouveras un fichiers wodim.conf dans lequel la variable "CDR_DEVICE= " indique quels graveur est utilisé par défaut, vérifie que c'est le bon qui est indiqué (en général c'est un lien symbolique qui va être indiqué plutôt que le périphérique, c'est à dire "cdrom0" plutôt que "/dev/scd0" par exemple).

Vérifie que tous les liens ainsi que le périphérique auquel ils revoient dans /dev ont bien comme propriétaire et groupe "root:cdrom", au besoin tu peux le changer avec Konqueror en root ou la commande


sudo chown root:cdrom /dev/blabla

Il est possible que ça marche avec la gravure dvd parce que c'est un autre lien symbolique qui sert d'identifiant avec les bons droits dessus.