PDA

Afficher la version complète : apt-get update



moniroje
14/03/2008, 15h30
Coucou!!
Me voilà avec ma Debian V
Je suivais la procédure de l'installation précédente et j'en étais à mettre les sources oh!rocks:

# etch
deb http://ftp.fr.debian.org/debian etch main contrib non-free
deb http://security.debian.org/ etch/updates main contrib non-free
# lenny
deb http://ftp.fr.debian.org/debian lenny main contrib non-free
deb http://security.debian.org/ lenny/updates main contrib non-free
qui avait donné avant: " apt-get update : ça a l'air d'avoir fonctionné; pas d'erreurs et message final: Lecture des listes de paquets... Fait"
et cette fois-ci, voilà ce que ça me dit:
"Lecture des listes de paquets...Erreur!
<div class='quotetop'>Citation </div>
Erreur apparue lors du traitement de mono-dbg (NewVersion1)
Problem with Mergelist /var/lib/apt/list/security.debian.org etc
Les listes de paquets ou le fichier status ne peuvent être analysés ou lus."[/b]
que se passe-t-il??? Il y a eu du nouveau, depuis??? ou bien malgré un copié-collé, ma sources.list est foireuse???

oh!rocks
14/03/2008, 15h40
Dans le sources.list, choisis etch ou lenny et commente les deux lignes dont tu n'as pas besoin.
En laissant tel quel, tu mélanges stable (etch) et testing (lenny) et certaines versions de logiciels sont concurrentes (ce qui semble être le cas de mono-dbg).


à plus,

oh!rocks

igziabeher
14/03/2008, 19h29
Salux,

Je te conseille tout simplement de te faire le fichier preferences qui va bien (http://www.google.com/url?sa=t&ct=res&cd=1&url=http%3A%2F%2Fforum.debian-fr.org%2Fviewtopic.php%3Ft%3D5659&ei=srTaR6T1JJaKxAGAp6nGCA&usg=AFQjCNEc83wqGjXj-B5UeTeq3epZM0Wwvw&sig2=JMyZDoX-OWRe30CzX-vt_A) tout en sachant aussi, que en ce moment il est plus facile de rester en etch ou passer en sid..

thveillon
14/03/2008, 19h32
Pour le choix de la version ça peut -être plus logique effectivement de choisir Lenny et commenter Etch (c'est en Lenny qye tu veux être ?). Sauf que certains logiciels Lenny ne marchent pas pendant un bon moment parfois et qu'il peut être intéressant de pouvoir forcer la version Etch (on peut toujours décommenter à ce moment là).

Si ce genre de messages persistent ça peut être du à une taille de cache insuffisante pour apt, ou tout simplement à un problème d'accès au miroir, ça arrive.

Welcome back sur Debian (V), c'est pire que Rocky ou Rambo cette histoire... On va essayer de ne pas aller jusqu'à "Debian X - le_retour_de_la_vengeance_de_la_dernière_fois" ! ;)