PDA

Afficher la version complète : [Réglé] Encore un problème de wifi avec la 11.0



yenyen
05/04/2008, 19h59
Bonjour à tous,

je me permets de vous écrire car j'ai installé la 10.3 quasiment dès sa sortie sur mon pc portable mais le wifi ne marche pas alors j'ai essayé de piocher des infos un peu partout pour eviter de poster un enième sujet sur les cartes atheros... mais je n'y arrive pas

J'ai installé madwifi et Ndiswrapper.
J'ai installé le pilote net5211.inf dans ndiswrapper mais je ne peux rien configurer ensuite...

Y a rien qui marche, je suis bloqué... Help please...

Piratu'
05/04/2008, 22h56
Juste par curiosite, t'as quelle version de 10.3? (32 ou 64 bit) D'ailleurs, c'est quoi comme portable?

En attendant: http://www.madwifi.org
et aussi: http://www.alionet.org/index.php?showtopic=19863

... un peu plus tard:
j'ai vu le type de carte WiFi sur le site d'Atheros et t'as de la chance, c'est une Mini PCI et tu peux la remplacer avec une Intel que tu trouves sur eBay entre 5EUR et 10EUR (sans frais de port).
j'ai un compaq Presario C700 avec un Atheros AR5006EG et la solution a été de la remplacer par une Inter 3495 que j'ai achetée sur eBay pour 8EUR :)

catr
05/04/2008, 23h05
Il ne sert à rien d'installer Madwifi ET Ndiswrapper (avais-je lu je ne sais plus ou).
essaye avec l'un, puis avec l'autre.
certains pilotes peuvent en effet ne pas fonctionner en 64 bits, mais ta présentation dit que tu es en 32.

si tu fais en console

ndiswrapper -l
qu'obtiens-tu?
(tu dois être en su je crois)

n'as-tu pas un bouton matériel?
as-tu fait des essais de wifi sous windows? à partir d'un live cd? (encore que pour le second cas je doute que ce soit utile).
a-t-elle déjà marché?


il n'y a rien à configurer dans ndiswrapper.
juste installer le bon pilote (tu t'assures que c'est le bon grace à la commande que je te donne là haut)
charger le module

modprobe ndiswrapper
et c'est tout.
le reste sera configurer Sax2, Knetwork Manager ou Iufp.

as-tu tenté un
iwlist scan ?

bon courage!

Agemen
06/04/2008, 15h58
Pas mieux. En général, ndiswrapper est pas fan de voir qu'un autre utilitaire wifi tente de faire marcher la carte wifi... ça le vexe, il se bloque ^_^
que renvoie un

hwinfo --wlan
en root?

EDIT : et puis t'as raison de venir demander, souvent ça accélère les choses ;)

chris-b
07/04/2008, 04h24
La 10.3 detecte tout mes chipsets wifi contrairement a la precedente version 10.2

Chipset intel wifi sur pc portable.....

D'ailleur la suse c'est la seule version qui rend le bon fionctionement du wifi avec les chipset , toutes carte pci + de diffilculté a l'installation.

Piratu'
07/04/2008, 22h45
La 10.3 detecte tout mes chipsets wifi contrairement a la precedente version 10.2
Chipset intel wifi sur pc portable.....
D'ailleur la suse c'est la seule version qui rend le bon fionctionement du wifi avec les chipset , toutes carte pci + de diffilculté a l'installation.[/b]
Oui, c'est magnifique! C'est pour cela que j'ai du m'en acheter une Intel 3945ABG car la Atheros AR5006EG fournie avec le portable n'été pas reconnue. Voici comme j'ai resolu le problème des pilotes!

En parlant des distros (petite () ), je poste ce message depuis une Mandriva 2008 One, qui elle aussi rend le bon fionctionement du wifi avec les chipset , toutes carte pci + de diffilculté a l'installation. :)

yenyen
05/08/2008, 18h15
Bonjour à tous,

Désolé, ça fait un bout de temps que je ne suis pas venu (plein de choses à faire...). Depuis le premier post, je suis passé à la 11.0 et le problème de WiFi est toujours le même.

Voici ce que j'obtiens:

<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>linux-0dpt:/home/yves # iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan0 No scan results</div>

<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>linux-0dpt:/home/yves # hwinfo --wlan
05: PCI 602.0: 0282 WLAN controller
[Created at pci.310]
UDI: /org/freedesktop/Hal/devices/pci_168c_13
Unique ID: y9sn.b6fBppeJJc0
Parent ID: 6NW+.InKz0bgid89
SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:06:02.0
SysFS BusID: 0000:06:02.0
Hardware Class: network
Model: "Atheros AR5212/AR5213 Multiprotocol MAC/baseband processor"
Vendor: pci 0x168c "Atheros Communications, Inc."
Device: pci 0x0013 "AR5212/AR5213 Multiprotocol MAC/baseband processor"
SubVendor: pci 0x144f "Askey Computer Corp."
SubDevice: pci 0x7084
Revision: 0x01
Driver: "ath5k_pci"
Driver Modules: "ath5k"
Device File: wlan0
Features: WLAN
Memory Range: 0xb0100000-0xb010ffff (rw,non-prefetchable)
IRQ: 22 (no events)
HW Address: 00:11:f5:75:2e:33
Link detected: no
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: "pci:v0000168Cd00000013sv0000144Fsd00007084bc02sc00 i00"
Driver Info #0:
Driver Status: ath5k is active
Driver Activation Cmd: "modprobe ath5k"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #12 (PCI bridge)</div>

Je n'ai pas encore installé ndiswrapper sur la 11.0...

Dites moi si mon problème vous parle.

Agemen
05/08/2008, 19h16
Regarde si le tuto de thveillon s'applique (http://wiki.alionet.org/doku.php?id=howto:configurer_atheros_5007eg), ça peut peut être t'aider ;)

yenyen
06/08/2008, 14h00
J'ai suivi le HowTo mais je bloque au chapitre installation du module.
- Quand je veux me servir du lien, je tombe sur une page 404 not found.
- De plus ma carte est une AR5212 ou AR5213 ce qui correspond à 5006EG (au lieu de 5007 comme dans le problème de Cédrich). Du coup en fouillant dans les dossiers du site madwifi, je ne trouve rien qui se rapporte à la 5006.

Suis-je un boulet ?!? :bang:

Koy
06/08/2008, 17h20
Salut..

J'ai connu aussi un probleme de wifi sous la 11, avec justement une carte 5212/5213...
En fait, le probleme viendrait ath5k qui crée un conflit avec madwifi..

J'ai suivi ce tuto atheros madwifi (http://en.opensuse.org/Atheros_madwifi), une config par yast, un reboot, et hop, enfin le wifi (depuis 3 jours seulement)

Voili, pour info, je n'ai pas compilé madwifi, j'utilise celui du depot..

Bonne chance

Agemen
06/08/2008, 18h38
pour l'erreur 404, c'est une histoire de version, je pense. Je jette un oeil.

la page est corrigée. mais en effet ça risque de ne pas coller. Je croirais Koy ;)

yenyen
07/08/2008, 14h32
Je viens d'y jeter un oeil mais je n'ai pas encore essayé...

Si je comprends bien, il faut que j'installe madwifi en choisissant une des méthodes proposées... (yast, zypper, smart ou je le compile) et ensuite, je suis le HowTo (en lien en bas de page...).
Le problème est que c'est en anglais. Si quelqu'un pouvait me confirmer en français que j'ai bien compris... :rolleyes:

Koy
07/08/2008, 18h21
Salut..

Alors, je vais tenté, pas certain de reussir :D, a suivre le tuto made in france...

Tout d'abord, quelques infos qui pourraient etre utiles:
Ma version de madwifi est la 0.9.4-1 (installée depuis Yast) plus madwifi-kmp-pae 0.9.4_2.6.25.5_2.1 (les numeros a rallonge, c'est que du bonheur), et eventuellement Networkmanager +kde

Tu fais un uname -r pour connaitre le kernel que tu utilises (perso, c'est le 2.6.25.11-0.1-pae, ce qui comme tu vois, n'est pas exactement le meme, je laisse quelqu'un d'autre expliquer pourquoi)

Ensuite, tu cliques dans yast sur le paquet madwifi-kmp correspondant au kernel que tu as (donc pour moi, c'est le 0.9.4_2.6.25.X-XX).
Apres avoir installé tes paquets, tu lances dans la console, en root, la commande: modprobe ath_pci et ta carte devrait etre détectée (Je dis devrais, car la mienne l'etait deja en fait, le probleme vient plus loin je pense) cliques sur networkmanager dans la systray, et configure ton reseau wifi. S'assurer comme ils disent que tu es bien configurée en DHCP .

Arrivé là, il se pourrait fortement que ca ne fonctionne toujours pas. ! Le probleme est là...ath5k
"Note: in the openSUSE 11.0 may be a conflict with built in module ath5k, which seems is not functional yet, but prevents using madwifi's one. Resolution is to add this module to the blacklist. To do this add the line blacklist ath5k to the file /etc/modprobe.d/blacklist and reboot. "

Pour resumer, il semble bien qu'un conflit ai lieu entre madwifi et ath5k... l'astuce (qui a fonctionné chez moi) est donc de blacklisté ath5k en ajoutant (avec kate en mode superuser) blacklist ath5k dans le fichier /etc/modprobe.d/blacklist
. Un reboot est necessaire apres tout ca.

Voila en tres gros ce qu'il faut que tu fasses, en esperant que ca t'aidera, parce que mine de rien, c'est le genre de truc qui rend dingue :)

( Et pas la peine de preciser que je suis sous KDE hin ? ;)

yenyen
16/08/2008, 15h32
Salut,

Je n'arrive pas à ajouter le dépôt madwifi dans yast pour trouver le fichier .rpm.
Quelqu'un peut m'aider? Je pense que je dois me planter dans la syntaxe... :bang:

jojo965
16/08/2008, 15h48
Salut tout le monde ;) voila pour vous informer que perso j'ai aussi eu le meme probleme avec une etheros 242 ... sur un portable toshiba satellite 210a ... et j'ai reussi a corriger le probleme ( detection reseau, connection wpa, wep , sans probleme ) en installant la version hal du pilote madwifi ... petit tuto ici : http://wlety.free.fr/forum/viewtopic.php?id=208 et le pilote : http://snapshots.madwifi.org/special/madwi...20080604.tar.gz (http://snapshots.madwifi.org/special/madwifi-hal-0.10.5.6-r3698-20080604.tar.gz) . Voilan penser a redemarrer apres l'avoir installer pour une bonne prise en charge par le kernel . Perso sa fonctionne nickel ;) . Dite quoi .