PDA

Afficher la version complète : carte son non reconnue



monsieur milton
10/04/2008, 15h33
Bonjour,
habituelllement je trouve toutes les réponses à mes questions sur les forums linux mais là, je sèche... depuis plusieurs jours de recherche alors je fais appel à la bonté de ceux qui s'y connaissent plus que moi (y'a pas de mal).
J'ai récemment installé SUSE 10.3 sur une carte mere NForce 560 SLI (Asus M2N) et ma carte son n'est pas reconnue.
Même problème sous Mandriva 2008 et Suse 10.2.

Impossible d'installer les drivers trouvés sur le CD d'installation de la CM ni ceux obtenus sur le net.

Le chipset audio est CMédia CM-560.

Je m'arracherais les cheveux si j'en avais encore alors je suis preneur pour toute aide ou piste à suivre.

Merci.

De plus, voulant reporter ici la configuration mat"érielle, je me suis apperçu qu'il m'est impossible d'obtenir les informations système (sysinfo:/)... aargh, je ne comprends plus rien !

a titre d'information voilà ce que me donne lspci :
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev f3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev f2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev f3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:01.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev c0)
05:00.0 VGA compatible controller: nVidia Corporation Unknown device 0404 (rev a1)

Agemen
10/04/2008, 16h06
En utilisant les options diverses de la commande hwinfo (en mode root), tu pourras savoir commen est vu ton matériel. D'ailleurs, pourquoi ne pas commencer par un

hwinfo --sound
? ;)
Au moins on saura e que ton pc en dit :P
sinon, cette carte... elle est récente?

edit : il nous faudrait le nom du pilote ou celui du fabricant, pour savoir si alsa supporte ta carte... du moins je crois ;)

que donne un

alsaconf
?

Chninkel
10/04/2008, 16h35
Bonjour,
Sur le site d'asus la carte son a pour référence CM6501, j'ai lu en diagonale, mais il semble que le problème vienne du fait que la carte est reconnu comme étant une carte usb, apparemment alsa suporte cette carte et j'ai trouvé 2 posts qui peuvent aider :
http://forum.ubuntu-fr.org/viewtopic.php?id=72872
http://www.alsa-project.org/main/index.php...odule-usb-audio (http://www.alsa-project.org/main/index.php/Matrix:Module-usb-audio)

Edit : je viens de trouver celui-ci http://lists.opensuse.org/opensuse-bugs/20...0/msg04297.html (http://lists.opensuse.org/opensuse-bugs/2007-10/msg04297.html)

monsieur milton
10/04/2008, 17h59
tout d'abord, merci de vous soucier de mes problèmes.
la 1ère commande hwinfo répond 2 trucs mais ils passsent très vite et je retombe sur ma ligne normale sans que les inscriptions restent (donc impossible de les reproduire ici, c'est la 1ere fois que je vois ça)
avec hwinfo (juste ça) j'obtiens :
linux-ldwd:/home/milton # hwinfo
> misc.1.2: open parallel


quant à alsaconf, elle ne détecte ni carte pci ni carte pnp.

Donc, on est pas plus avancé

la carte c'est bien C-Média CM6501

Agemen
10/04/2008, 18h06
Donc la solution est plutôt dans le post de Chinkel ;)

monsieur milton
10/04/2008, 18h29
ben, en fait j'ai du mal a comprendre les messages en anglais linuxien et je ne trouve pas vraiment de réponse dans ces posts dont un recommande de changer de matériel (!!)

est-ce normal, d'après vous, que je n'ai pas de /etc/modprobe.d/alsa ?

Agemen
10/04/2008, 18h29
alors alors... déjà, pour ce qui est de hwinfo, pas grave pour l'instant, si c'est une carte branchée en usb, normal que hwinfo ne la voit pas en sound. Peut être avec ça :

hwprobe=+usb hwinfo --sound

La oslution utilisée dans le bug report sur opensuse est la suivante :
éditer (en mode root ;) )le fichier /etc/modprobe.d/alsa , par exemple avec

su
kate /etc/modprobe.d/alsa
commence par faire une sauvegarde (par exemplealsa.back) sur ton bureau (enregistrer sous, ou avant d'appeler kate :

cp alsa /home/nomuser/Desktop/alsa.back )
ensuite, ouvre donc avec kate le fichier de conf alsa (comme montré ci dessus avec kate, ou tout autre éditeur de texte ;) )
donne nous ce qu'il contient par un copier colle entre deux balises code ;)
il y'a une ligne à rajouter (options snd-usb-audio index=0 , et peut être aussi alias snd-card-0 snd-usb-audio)
Dans l'état final ça devra ressembler à ça :

options snd-usb-audio index=0

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-usb-audio

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-12 snd-pcm-oss

apparemment là ça doit le faire ;)

monsieur milton
10/04/2008, 19h00
ola ola, j'ai l'impression d'être vraiment une bille alors que j'arrive a installer des systèmes linux chez tous mes potes !!!

bon, comme je le disais plus haut, je n'ai pas de fichier alsa dans etc/modprobe.d... c'est grave docteur ?

du coup ça m'empêche de tester ce que tu me dis et qui a l'air assez encourageant

quant à la commande hwprobe=+usb hwinfo --sound, comme avant, le résultat passe si vite que je ne vois rien et ça retombe sur ma ligne de commande d'origine sans rien laisser inscrit

Agemen
10/04/2008, 19h43
alsa est bien chargé? tu le vois quand tu fais un

lsmod
?

Chaque machine est différente... honnêtement j'en sais pas plus que toi, je suis juste un peu plus à l'aise en anglais ;) . y'a des configs qui posent parfois un peu problème... mais t'en fais pas, tu peux continuer tes installations, et pas hésiter à revenir quand ça va pas ;)
Je continue mes investigations...
tu es sur une architecture 64 bits ou 32 bits?

Edit : il faut CREER le fichier alsa ;) . J'avais pas fait attention. Donc lance kate en mode super utilisateur par

su
kate
tu vas te placer avec kate dans /etc/modprobe.d, et tu enregistres le fichier que j'ai donné au dessus (dans la balise code, qui commence par options snd-usb-audio index=0) sous le nom alsa.

Chninkel
10/04/2008, 20h18
C'est pas bien grave, il faut créer ce fichier /etc/modprobe.d/alsa
Ensuite, il faut y recopier ce qu'indiquait Agemen.

Edit : il faut ensuite assigner le speaker channel dans kmix

monsieur milton
10/04/2008, 20h35
cool, je viens d'apprendre a rajouter un fichier root avec kate... c'est déjà ça !!

j'ai rajouter, donc, un alsa dans /etc/modprobe.d avec dedans :


options snd-usb-audio index=0

# ALSA portion
alias char-major-116 snd
alias snd-card-0 snd-usb-audio

# OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0

# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-12 snd-pcm-oss


et voici ce que me donne lsmod :
<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>milton@linux-ldwd:~> su
Mot de passe :
linux-ldwd:/home/milton # hwinfo --sound
linux-ldwd:/home/milton # hwprobe=+usb hwinfo --sound
linux-ldwd:/home/milton # lsmod
Module Size Used by
joydev 27904 0
nls_iso8859_1 21888 1
nls_cp437 23680 1
vfat 30336 1
fat 70832 1 vfat
iptable_filter 19840 0
ip_tables 37848 1 iptable_filter
ip6table_filter 19584 0
ip6_tables 31944 1 ip6table_filter
x_tables 37000 2 ip_tables,ip6_tables
snd_pcm_oss 67456 0
snd_mixer_oss 34176 1 snd_pcm_oss
snd_seq 74992 0
af_packet 57100 2
ipv6 372600 20
apparmor 58672 0
loop 36356 0
dm_mod 77152 0
snd_usb_audio 109952 0
snd_pcm 108680 2 snd_pcm_oss,snd_usb_audio
snd_timer 42632 2 snd_seq,snd_pcm
snd_page_alloc 28048 1 snd_pcm
snd_usb_lib 34688 1 snd_usb_audio
snd_rawmidi 44544 1 snd_usb_lib
snd_seq_device 25620 2 snd_seq,snd_rawmidi
snd_hwdep 27528 1 snd_usb_audio
snd 84984 10 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_usb_audio,sn d_pcm,snd_timer,snd_usb_lib,sn
_rawmidi,snd_seq_device,snd_hwdep
soundcore 25360 1 snd
usbhid 58160 0
hid 43776 1 usbhid
ff_memless 22536 1 usbhid
parport_pc 58456 0
k8temp 22656 0
rtc_cmos 25016 0
ohci1394 51272 0
parport 56588 1 parport_pc
rtc_core 38156 1 rtc_cmos
ieee1394 115800 1 ohci1394
sr_mod 33444 0
serio_raw 24068 0
usb_storage 102944 1
forcedeth 65672 0
i2c_nforce2 22784 0
rtc_lib 19968 1 rtc_core
cdrom 52392 1 sr_mod
floppy 79624 0
hwmon 20232 1 k8temp
ide_core 165648 1 usb_storage
nvidia 8896388 24
i2c_core 43648 2 i2c_nforce2,nvidia
gspca 651536 0
videodev 44416 1 gspca
button 26528 0
v4l2_common 36480 1 videodev
usblp 30976 0
v4l1_compat 28676 1 videodev
sg 53304 0
sd_mod 45824 6
ohci_hcd 38020 0
ehci_hcd 50956 0
usbcore 156456 9 snd_usb_audio,snd_usb_lib,usbhid,usb_storage,gspca ,usblp,ohci_hcd,ehci_hcd
edd 26760 0
ext3 156688 2
mbcache 26248 1 ext3
jbd 89192 1 ext3
fan 22792 0
sata_nv 38280 3
pata_amd 31876 0
libata 166800 2 sata_nv,pata_amd
scsi_mod 176536 5 sr_mod,usb_storage,sg,sd_mod,libata
thermal 36112 0
processor 59720 1 thermal
</div>

cependant aucun changement et alsaconf ne détecte toujours aucun pnp ni pci donc toujours pas de son et rien à configurer... vous y comprenez quelque chose?

kmix ne s'ouvre pas au fait

Chninkel
10/04/2008, 20h45
Il faut sans doute rebooter.
Je viens de relire le fil d'opensuse et l'auteur possède 6 machines avec cette carte mère.
Pour lui cette manip suffit, mais dans les messages antérieurs, il y a un autre fichier à modifier. Nous verrons cela si le problème persiste après reboot.

monsieur milton
10/04/2008, 23h45
pas mieux après reboot (ni après une sieste !)

il fallait bien mettre "options snd-usb-audio index=0" au début du texte dans modrpobe.d/alsa ?

merci encore de vous occuper de mon cas. Je dois m'absenter mais je m'y remet dès mon retour.

Du nouveau...

en effet, la carte son est bien reconnue comme usb puisque je la trouve là

linux-ldwd:/home/milton # lsusb
Bus 002 Device 005: ID 0d8c:0201 C-Media Electronics, Inc.
Bus 002 Device 004: ID 05fe:1011 Chic Technology Corp.
Bus 002 Device 002: ID 041e:4053 Creative Technology, Ltd
Bus 002 Device 003: ID 03f0:4c11 Hewlett-Packard
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 05e3:0702 Genesys Logic, Inc. USB 2.0 IDE Adapter
Bus 001 Device 001: ID 0000:0000


ou là :

linux-ldwd:/home/milton # hwinfo --usb
13: USB 00.0: 0000 Unclassified device
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_d8c_201_noserial_if0
Unique ID: cEJe.wilKvUxD7v0
Parent ID: pBe4.PBXwwCc5vJE
SysFS ID: /devices/pci0000:00/0000:00:02.0/usb2/2-7/2-7:1.0
SysFS BusID: 2-7:1.0
Hardware Class: unknown
Model: "C-Media Electronics PnP Audio Device"
Hotplug: USB
Vendor: usb 0x0d8c "C-Media Electronics, Inc."
Device: usb 0x0201 "PnP Audio Device"
Revision: "0.10"
Driver: "snd-usb-audio"
Driver Modules: "snd_usb_audio"
Speed: 12 Mbps
Module Alias: "usb:v0D8Cp0201d0010dc00dsc00dp00ic01isc01ip00"
Driver Info #0:
Driver Status: snd_usb_audio is active
Driver Activation Cmd: "modprobe snd_usb_audio"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #5 (Hub)


en même temps, ça m'avance pas trop non plus...

Chninkel
10/04/2008, 23h48
oui cette option est correcte.
Si je résume la démarche suivie sur l'autre site :

1°) passer hwprobe=+usb comme paramètre de boot => la je ne sais pas comment on foit faire

2°) modifier ou créer le fichier /var/lib/hardware/hd.ids en rajoutant les lignes suivantes :
vendor.id usb 0x0000 à remplacer par 0x0d8c
&device.id usb 0x0000 à remplacer par 0x0201
+class.id 0x401
(où les valeurs de vendor.id et device id sont celles renvoyées par hwinfo --usb)

Une fois ceci effectué, hwinfo --sound et yast doivent "voir" la carte.

3°) faire les modifs dansle fichier /etc/modprobe.d/alsa => sur la version x86_64 seul cette opération semble suffire.

Edit : je viens de voir que tu avais posté le temps que je réponde donc les modifs supplémentaire n'ont peut-être pas lieu d'ête.

Agemen
10/04/2008, 23h57
que dit

lsmod|grep snd_usb_audio
?

monsieur milton
11/04/2008, 00h00
ça avance...

j'ai modifié /var/lib/hardware/hd.ids comme indiqué et voici ce que j'obtiens maintenant :

linux-ldwd:/home/milton # hwprobe=+usb
linux-ldwd:/home/milton # hwprobe=+usb hwinfo --sound
41: USB 00.0: 0401 Multimedia audio controller
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_d8c_201_noserial_if0
Unique ID: cEJe.VsPijs0Hbo8
Parent ID: pBe4.PBXwwCc5vJE
SysFS ID: /devices/pci0000:00/0000:00:02.0/usb2/2-7/2-7:1.0
SysFS BusID: 2-7:1.0
Hardware Class: sound
Model: "C-Media Electronics PnP Audio Device"
Hotplug: USB
Vendor: usb 0x0d8c "C-Media Electronics, Inc."
Device: usb 0x0201 "PnP Audio Device"
Revision: "0.10"
Driver: "snd-usb-audio"
Driver Modules: "snd_usb_audio"
Speed: 12 Mbps
Module Alias: "usb:v0D8Cp0201d0010dc00dsc00dp00ic01isc01ip00"
Driver Info #0:
Driver Status: snd_usb_audio is active
Driver Activation Cmd: "modprobe snd_usb_audio"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #33 (Hub)


avec lsmod |grup j'obtiens :

linux-ldwd:/home/milton # lsmod|grep snd_usb_audio
snd_usb_audio 109952 0
snd_pcm 108680 2 snd_pcm_oss,snd_usb_audio
snd_usb_lib 34688 1 snd_usb_audio
snd_hwdep 27528 1 snd_usb_audio
snd 84984 10 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_usb_audio,sn d_pcm,snd_timer,snd_usb_lib,sn
_rawmidi,snd_seq_device,snd_hwdep
usbcore 156456 9 snd_usb_audio,snd_usb_lib,usbhid,gspca,usblp,usb_s torage,ohci_hcd,ehci_hcd


encourageant ou déconcertant ?

Agemen
11/04/2008, 00h01
après ta manip', éventuellement un alsaconf.... en mode root ;)

Chninkel
11/04/2008, 00h04
Je dirais que c'est malgré tout encourageant puisque maintenant on voit la carte.
Comme le dit Agemen essaie de la configurer en root soit par alsaconf ou par yast s'il reconnait la carte et ne pas oublier d'aller voir dans kmix les options.
Sur ce bonne nuit à tous

monsieur milton
11/04/2008, 00h11
alsaconf ne trouve toujours aucune carte pnp ni pci

impossible d'ouvrir kmix

impossible, d'ailleurs, d'obtenir quoi que ce soit sur le son dans le centre de configuration kde !!

Chninkel
11/04/2008, 00h25
Avant de me coucher, j'ai fait une nouvelle recherche et je suis tomber sur un autre sujet qui propose une solution plus simple.
Aller dans yast -> matériel -> son
Dans la fenête qui s'ouvre faire ajouter :
à gauche dans Fabricant de la carte son choisir Toutes
dans modèles de la carte son choisir USB Audio, Generic
Apparemment cela active la carte.
Cette fois bonne nuit, je lirais la suite demain.

monsieur milton
11/04/2008, 11h13
bonjour, je reprends mon désespoir informatique...

lorsque j'essaie la solution que tu propose en passant par uin ajout dans Yast il me répond qu'il n'a pas pu charger le module du noyau snd-usb-audio. Ce qui me fait penser que c'est peut être un problême de kernel si je ne peux pas trouver la carte son non ?

Cependant, je pense que je vais abandonner suse 10.3 puisque j'ai l'impression que tout déconne (firefox ne veut plus se lancer, impossible d'obtenir les infos systeme, amule non plus...) je réinstalle suse 10.2 et je reprends les mêmes pistes pour voir. Dire que je suis passé sous suse croyant résoudre mon problème de son mais je pense que je vais revenir à Mandriva, plus simple pour des utilisateurs comme moi.

Chninkel
11/04/2008, 11h41
Bonjour,
J'exclu un problème de kernel dans la mesure où dans le lsmod que tu nous a donné précédemment le module snd-usb-audio est bien chargé.
Par contre il est possible que les modifications que nous avons faites auparavant entrent en conflit avec yast.
Aussi, je propose pour le moment d'essayer de configurer la carte par le moyen le plus simple ie par yast, pour cela déplace les fichier alsa et hd.ids dans ton home pour remettre les choses en l'état.
Ensuite en console et en root fait un rmmod snd-usb-audio puis dans yast essaie de choisir ta carte pour savoir s'il peut charger le module.
Vérifie également que les paquets alsa-driver, alsa-lib, alsa-utils sont bien installés.

Vu ce que tu nous dit sur les problèmes que tu rencontre, il est possible également que l'installation se soit mal passée.
Je viens de faire une recherche et sous mandriva tu peix également rencontrer des difiicultés avec cette carte.

monsieur milton
11/04/2008, 16h30
bon, désolé mais je crois que j'ai tout refoutu en l'air ce matin !!!
voulant refaire mon installation pour vérifier si elle avait bien été faite je suis passé sous gnome (pas bien réveillé!!)

bon point : lors de la configuration matérielle j'ai pu configurer la carte son n°0 en port usb audio (index 0) et il l'a accepté mais ça ne m'avance pas a grand chose...

je reporte encore ce que j'obtiens pour voir si il faut encore tout modifier :


linux-6u2i:/home/milton # lsmod
Module Size Used by
nls_iso8859_1 21888 1
nls_cp437 23680 1
vfat 30336 1
fat 70832 1 vfat
iptable_filter 19840 0
ip_tables 37848 1 iptable_filter
ip6table_filter 19584 0
ip6_tables 31944 1 ip6table_filter
x_tables 37000 2 ip_tables,ip6_tables
af_packet 57100 2
ipv6 372600 20
snd_pcm_oss 67456 0
snd_mixer_oss 34176 1 snd_pcm_oss
snd_seq 74992 0
apparmor 58672 0
loop 36356 0
dm_mod 77152 0
snd_usb_audio 109952 1
snd_pcm 108680 2 snd_pcm_oss,snd_usb_audio
snd_timer 42632 2 snd_seq,snd_pcm
snd_page_alloc 28048 1 snd_pcm
snd_usb_lib 34688 1 snd_usb_audio
snd_rawmidi 44544 1 snd_usb_lib
snd_seq_device 25620 2 snd_seq,snd_rawmidi
snd_hwdep 27528 1 snd_usb_audio
snd 84984 12 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_usb_audio,sn d_pcm,snd_timer,snd_usb_lib,sn
_rawmidi,snd_seq_device,snd_hwdep
soundcore 25360 1 snd
parport_pc 58456 0
nvidia 8896388 24
parport 56588 1 parport_pc
sr_mod 33444 0
forcedeth 65672 0
k8temp 22656 0
usb_storage 102944 1
hwmon 20232 1 k8temp
ohci1394 51272 0
rtc_cmos 25016 0
rtc_core 38156 1 rtc_cmos
rtc_lib 19968 1 rtc_core
cdrom 52392 1 sr_mod
gspca 651536 0
ieee1394 115800 1 ohci1394
floppy 79624 0
serio_raw 24068 0
ide_core 165648 1 usb_storage
videodev 44416 1 gspca
v4l2_common 36480 1 videodev
v4l1_compat 28676 1 videodev
i2c_nforce2 22784 0
i2c_core 43648 2 nvidia,i2c_nforce2
usbhid 58160 0
hid 43776 1 usbhid
ff_memless 22536 1 usbhid
button 26528 0
sg 53304 0
sd_mod 45824 6
ehci_hcd 50956 0
ohci_hcd 38020 0
usbcore 156456 8 snd_usb_audio,snd_usb_lib,usb_storage,gspca,usbhid ,ehci_hcd,ohci_hcd
edd 26760 0
ext3 156688 2
mbcache 26248 1 ext3
jbd 89192 1 ext3
fan 22792 0
sata_nv 38280 3
pata_amd 31876 0
libata 166800 2 sata_nv,pata_amd
scsi_mod 176536 5 sr_mod,usb_storage,sg,sd_mod,libata
thermal 36112 0
processor 59720 1 thermal

alsaconf ne trouve toujours rien


linux-6u2i:/home/milton # lsusb
Bus 002 Device 003: ID 05e3:0702 Genesys Logic, Inc. USB 2.0 IDE Adapter
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 004: ID 0d8c:0201 C-Media Electronics, Inc.
Bus 001 Device 002: ID 041e:4053 Creative Technology, Ltd
Bus 001 Device 003: ID 05fe:1011 Chic Technology Corp.
Bus 001 Device 001: ID 0000:0000


linux-6u2i:/home/milton # rmmod snd-usb-audio
ERROR: Module snd_usb_audio does not exist in /proc/modules

en plus je suis un peu perdu avec gnome... plus de kate alors il a fallu m'habituer...

Chninkel
11/04/2008, 17h41
Lors de la configuration à l'installation as tu entendu du son ?
Sinon, retourne dans yast pour voir si la carte est bien présente et en bas à droite dans "autre" tu peux accéder aux options : volume, lancer le son de test.
A voir également si alsamixer reconait quelque chose.
Je crois avoir lu sur le forum ubuntu dont j'ai donné le lien qu'il fallait définir alsa comme gestionnaire de son dans gnome.


.

monsieur milton
11/04/2008, 18h37
pas de son lors de l'installation, la carte est présente dans yast mais toujours pas de son, alsamixer s'ouvre une fois sur deux... bref j'en ai marre ! Je vais tout simplement finir par acheter une carte son tout en ayant honte de reculer devant cet échec mais j'ai vraiment besoin d'avoir du son. Bref, l'erreur c'était d'acheter cette carte mère.

Chninkel
11/04/2008, 18h58
C'est dommage de renoncer d'autant plus qu'il y a moyen de la faire fonctionner.
Malgré tout je suis à cours d'idée et j'atteints mes limites.

monsieur milton
11/04/2008, 19h09
Tu as raison, je n'aime pas renoncer mais là je suis à bouts de nerfs donc : solutions B : je vais prendre une cuite et je recommencerai tout ça demain.

Merci encore beaucoup de l'intérêt que vous m'avez porté. Je continue mes recherches dès que je suis détendu et je vous tiens au courant, si, entre temps, vous pensez à quelque chose, n'hésitez pas.
C'est effectivement dommage d'arrêter parce que je sens qu'il ne manque pas grand chose, j'ai du souffle dans les hauts parleurs maintenant et comme la carte usb est reconnue, je ne comprends pas pourquoi elle ne fonctionne pas...

bref, une bonne soirée avec du whisky et ça ira mieux.

bonne soirée.

Agemen
11/04/2008, 19h59
pour le rmmod, le nom du module est snd_usb_audio avec des _, pas des - ;)
pas besoin de kate... du doit avoir gedit, ça va le faire pareil ;) Même manipulation, tu lances une console, tu te logges en root et tu vas dans le bon dossier. Ensuite, tu lances gedit par la commande

gedit
et tu fais pareil qu'avec kate ;)
et à la tienne ;)

Chninkel
11/04/2008, 20h04
Bonne cuite.
C'est quand même rageant ce souffle est encourageant, reste à savoir comment activer les bons paramètres.

Agemen
11/04/2008, 20h06
Oh, et aussi, tu peux encore installer KDE, c'est pas grave d'avoir les deux sur ton disque, sauf si t'as des problèmes de place! Pour ça, tu passes par yast, c'est tout ;)

monsieur milton
13/04/2008, 19h13
bonsoir,
je me remets au boulot...
alors, rmmod ne trouve rien


linux-6u2i:/home/milton # rmmod snd_usb_audio
ERROR: Module snd_usb_audio does not exist in /proc/modules

quand j'essai de lancer alsamixer j'obtient :
function snd_ctl_open failed for default : no such device

cependant il me semble bien que vendredi il s'était ouvert (en même temps j'ai l'impression que vendredi c'était il y a 2 mois, retour de week-end exige !!)

Chninkel
13/04/2008, 19h48
Il faut distinguer les 2 méthodes :

- Essaies d'abord de configurer la carte par YAST.
- Si ca ne marche tojours pas reprendre les étapes où il faut modifier les fichiers .

Une autre solution pourrait être d'installer une version d'ALSA plus récente.

monsieur milton
13/04/2008, 21h09
alsamixer accepte de s'ouvrir (par moment) et voilà ce que j'en tire comme info :

ALSA version : 1.0.14

/proc/asound/cards :
0 [default] : usb-audio - PnP Audio Device
PnP Audio Device at usb-0000:00:02.0-7, full speed

/proc/asound/devices :
2 : : timer
3 : [0-0] : digital audio playback
4 : [0-0] : digital audio capture
5 : [0] : control
6 : : sequencer

/proc/asound/oss-devices :
no information

/proc/asound/pcm :
00-00 : USB Audio : USB Audio : playback 1 : capture 1

je sais pas si ça a de l'intérêt mais bon...

monsieur milton
14/04/2008, 17h09
j'ai refais (encore) une install pour voir. Cette fois-ci je suis reparti sur suse 10.2 JAD 1.0 que j'avais installé la semaine dernière et avec qui le son fonctionnait (pendant 2 jours).

après avoir refait toute les bidouilles précédemment expliquées j'obtient tout ça :


linux-5sp0:/home/milton # hwinfo --sound
51: USB 00.0: 0401 Multimedia audio controller
[Created at usb.122]
UDI: /org/freedesktop/Hal/devices/usb_device_d8c_201_noserial_if0
Unique ID: X7GA.VsPijs0Hbo8
Parent ID: k4bc.uiksZeKFb6C
SysFS ID: /devices/pci0000:00/0000:00:02.0/usb1/1-7/1-7:1.0
SysFS BusID: 1-7:1.0
Hardware Class: sound
Model: "PnP Audio Device"
Hotplug: USB
Vendor: usb 0x0d8c
Device: usb 0x0201 "PnP Audio Device"
Revision: "0.10"
Driver: "snd-usb-audio"
Driver Modules: "snd_usb_audio"
Speed: 12 Mbps
Module Alias: "usb:v0D8Cp0201d0010dc00dsc00dp00ic01isc01ip00"
Driver Info #0:
Driver Status: snd_usb_audio is active
Driver Activation Cmd: "modprobe snd_usb_audio"
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #45 (Hub)


linux-5sp0:/home/milton # lsmod|grep snd_usb_audio
snd_usb_audio 81024 1
snd_pcm 86916 2 snd_pcm_oss,snd_usb_audio
snd_usb_lib 20992 1 snd_usb_audio
usbcore 114896 6 usbhid,usb_storage,ehci_hcd,ohci_hcd,snd_usb_audio ,snd_usb_lib
snd_hwdep 13956 1 snd_usb_audio
snd 61188 12 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_usb_audio,sn d_pcm,snd_timer,snd_usb_lib,sn
_rawmidi,snd_seq_device,snd_hwdep

mais alsaconf ne détecte toujours rien alors que le driver snd_usb_audio semble bien actif. Est il bien attribué selon vous puisque dans yast j'ai attribué la snd card usb comme principale sans pour autant avoir pu la confirmer (elle est toutefois acceptée).


de plus, il me semble que c'est au boot qu'il fallait que j'entre hwprobe=+usb comme paramètre mais ça ne change rien... j'ai un peu l'impression de mélanger toutes les modif en fait.

Chninkel
14/04/2008, 17h35
Bonjour,
Pour moi la carte est bien reconnue.

Il m'arrive également que ma carte ne soit plus reconnue, c'est souvent le cas lorsque je quitte windows pour démarrer suse, je dois alors la reconfigurer par yast, ce qui pourrait expliquer pourquoi la carte a fonctionné 2 jours.

Essai de forcer KDE à utiliser alsa comme pilotes audio. C'est dans Menu K -> Centre de configuration KDE -> son et multimédia -> Système de sons -> Onglet Matériel -> Choisissez le périphérique audio

Tu es sur que la carte fonctionne bien ?

monsieur milton
14/04/2008, 17h55
je force bien alsa comme tu le dis.
J'avoue que je ne peux pas savoir si la carte fonctionne puisque je n'ai pas pu la faire fonctionner depuis que j'ai lancé ce topic. Cependant, il y a une semaine, elle fonctionnait (2 jours !)
étant donné qu'elle a fonctionné et qu'elle est neuve, je pense qu'elle n'a pas de soucis.

La je commence a faire une overdose de modif et de bidouillages donc je vais attendre le début du mois et en acheter une autre voilà tout.

merci, cependant, de votre intérêt.

Chninkel
14/04/2008, 18h19
Bah là je suis à court d'idées.
Le plus agaçant c'est que je suis persuadé qu'il est possible de la faire fonctionnée et sans trop bidouillé.

PS : et si tu essayais avec une version x86_64

monsieur milton
14/04/2008, 20h13
la suse 10.3 que j'essayais était une 86_64

Torrent
16/04/2008, 15h35
C'est pas dur pour que ca y aille : il faut installer alsadrivers (manque le driver natif de intel pour ce genre de carte)
http://chabu.fr/dl/alsa-driver-1.0.14.tar.bz2

Faire ./configure --with-cards=hda-intel (fais d'abord un lspci | grep -i audio pour être sûr du module)
make
make install

alsaconf
puis alsactl store pour enregistrer les paramètres

monsieur milton
20/04/2008, 13h33
Merci d'essayer Torrent mais c'était un peu plus compliqué que ça...

Bonne nouvelle : ça marche !!!!

j'avais un peu laissé tombé pendant une semaine, bien décidé à acheter une autre carte son et, finallement, voualnt tenter une autre install, je reviens sous suse 10.3, je refais ce qu'on a dit depuis le début et voilà que le son fonctionne ! J'avoue que je suis perdu : pourquoi ça refusait de fonctionner la seamine dernière et que tout va bien cette semaine ? Je ne sais pas (et faut dire que je m'en fou un peu puisque tout est bon aujourd'hui). Donc, je recommande de suivre ce que m'on indiqué Chninkel et Agement (que je remercie infiniment) depuis le début si vous avez les mêmes problèmes avec cette carte mère et sa C-Média 6501.

Merci encore et je pense qu'il faudrait clore ce sujet.

Torrent
20/04/2008, 14h09
Dans ce cas, fallait mettre [REGLE] sur ton post

Agemen
20/04/2008, 14h11
:) :) :) Content que ça marche! Le caméléon a tiré la langue, mais c'est bon ;)