PDA

Afficher la version complète : [Réglé] Toshiba P200 + Ubuntu RC 8.04 64Bit



Whadoon
22/04/2008, 22h30
Salut à tous,

Et bien oui, je suis toujours sur Ubuntu et peut etre que je vais me laisser séduire par la 11.0 de Suse.

Mais j'ai quelques souci avec Mon portable P200.

1. J'ai les touches de fonction qui ne fonctionne pas, j'ai regarder dans les dépot et j'ai trouvé "fnfxd" mais celui ci semble imcopatible vu que j'ai un Phoenix et que ce soft utilise un Bios Toshiba.
2. A cause de la panne des touches fonction je ne sais as activer le Bluetooth.
3. Jai quelques souci avec la mise en veille, mais cela viendrais des pilotes VGA ATI, donc, je vais attendre la sortie d'un cataclyst 8.4.

merci pour un apport en information.

thveillon
22/04/2008, 23h24
Salut, je ne pense pas que tu ais exactement la même série de P200 (carte graphique nvidia) mais ce tuto (http://linux.dobeyracing.net/how_to/toshiba_p200_laptop/Linux_on_Toshiba_Satellite_P200.php) est très complet et concerne l'installation de Debian sur un P200, en utilisant Omnibook pour faire fonctionner les touches de fonction. L'auteur a réussi a faire fonctionner le bluetooth et quasiment tout le reste. J'avais bookmarqué la page pour une install party mais la personne avec le P200 n'est jamais venue, pas pu tester donc.

Plus que 2 jours pour le nouvel Ubuntu (http://www.ubuntu.com/), ça résoudra peut-être aussi des problèmes.

Catalyst 8.4 est sortie : ==>ici (http://ati.amd.com/support/driver.html)<==

Bonne chance !

Whadoon
23/04/2008, 08h47
Merci à toi,

mais je ne sais pas applique le tuto, j'ai une erreur avec le svn.

J'ai tente une compilation a partir des source mais j'ai des erreurs style:

/home/kusanagi/Bureau/omnibook-2.20070211/lcd.c:48: erreur: «struct backlight_device» has no member named «class_dev»
/home/kusanagi/Bureau/omnibook-2.20070211/lcd.c: Dans la fonction «omnibook_set_backlight» :
/home/kusanagi/Bureau/omnibook-2.20070211/lcd.c:58: erreur: invalid type argument of «->»
/home/kusanagi/Bureau/omnibook-2.20070211/lcd.c:61: erreur: «struct backlight_device» has no member named «class_dev»
/home/kusanagi/Bureau/omnibook-2.20070211/lcd.c: Dans la fonction «omnibook_brightness_init» :
/home/kusanagi/Bureau/omnibook-2.20070211/lcd.c:131: attention : passing argument 4 of «backlight_device_register» from incompatible pointer type
make[2]: *** [/home/kusanagi/Bureau/omnibook-2.20070211/lcd.o] Erreur 1
make[1]: *** [_module_/home/kusanagi/Bureau/omnibook-2.20070211] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-headers-2.6.24-16-generic »
make: *** [omnibook.ko] Erreur 2
kusanagi@tashikoma:~/Bureau/omnibook-2.20070211$

Pumpkin
23/04/2008, 09h04
Il n'y a pas une version source stable ? Le SVN reste réservé aux programmeurs. Selon les jours, tu peux y trouver des sources compilables ou d'autres avec des erreurs de compilations... .

thveillon
23/04/2008, 13h11
Tu peux récupérer des sources stabilisées sur la page de téléchargement (http://sourceforge.net/project/showfiles.php?group_id=174260) du projet, il y a aussi des .deb sur un dépôt personnel ici (http://packages.kirya.net/), et sinon dans les dépôts officiels de Sidux. Je me demande si Ubuntu n'a pas ça dans ses dépôts, faut que je vérifie.

J'ai essayé de compiler les svn sur ma Debian, vu l'erreur je pense que ça vient des options de compilation du noyau, certains modules d'accès à la configuration matérielle n'ont pas été compilés (dans la configuration du noyau il y en particulier un module qui permet d'accéder aux réglages matériels de certains écrans lcd). Il faudrait vérifier ça en désactivant cette option à la compilation des sources d'omnibook où en compilant un noyau avec les options qui vont bien. Je vais regarder dans le makefile ce qui pourrait être fait pour se passer de cette option vu que ce n'est pas ce qui t'intéresse, mais pas avant ce soir...

nb: vive les portables avec GNU/Linux préinstallés !!

Whadoon
23/04/2008, 22h52
La version utilisée est la "omnibook-2.20070211".
J'ai essaié d'installer a partir des dépots, mais je n'arurive pas a enregistrer la clef.

Pour ce qui est du depot, elle ne se trouve pas dans les depot de la ubutn 8.04 AMD64...

Ca me ferait tellement plaisir d'avoir le bluetooth pour passer de thunderbird à evolution pour pouvoir faire ma synchronisation avec mon GSM

P'tite info, j'ai vu sensors-applet dans les depot et j'ai vu que les omnibook etaient repertorié

thveillon
29/04/2008, 01h14
Désolé d'avoir laissé couler de l'eau, je ne sais pas où tu en es.

Dans le noyau il y a deux modules toshiba qui sont en générale compilés par défaut, on peut les charger avec modprobe toshiba et modprobe toshiba_acpi, pour un premier test. Ensuite sur Debian il y a différents utilitaires pour exploiter ces modules comme fnfxd, toshset, toshutils. Comme je n'ai pas de Toshiba sous la main je ne peux pas tester. (Curieusement sur ma carte mère Asus ça me dit que ce n'est pas supporté... :rolleyes: )

Pour ce qui est du dépot Sidux, les clé gpg s'installent avec les paquets "keyring-sidux*", sinon elles doivent se trouver sur leur ftp. De toute façon les paquets doivent pouvoir s'installer même non signés, tu peux récupérer les sources ici (http://debian.tu-bs.de/project/sidux/debian/pool/main/o/).

Sur ma Lenny j'ai extrait les sources du .deb (file-roller ou ark savent faire ça), et un simple "sudo checkinstall" (installer checkinstall avant, ou faire "make install") dans le répertoire m'a fait un joli omnibook.deb et installé le bouzin. Ensuite un "modprobe omnibook" a chargé le module sans problème. Vive Sidux.

À savoir ce que tu peux en faire ensuite... à toi de voir, regarde du côté des utilitaires que j'ai indiqué au début du message.

Whadoon
29/04/2008, 12h44
Salut,

Avec Ubuntu 8.04 en AMD64, j'ai essaier les modules toshiba et toshiba_acpi, mais il ne semble aps avoir ete compiler.

Pour les paquets fnfxd, toshset et toshutils, j'avais testé sur ma 7.10 mais ca ne focntionne pas, après recherche,se serait un problème de bios: les paquets cité utilise le Bios Toshiba alors que je possède un Bios Phoenix. et Omnibook n'est pas dans les depots non plus ... je me demande si ma RC c'est bien upgradé en LTS.

Je n'aurai pas plus facile a mettre toshiba et toshiba ACPI dans le noyeau ?

thveillon
29/04/2008, 12h56
Toshiba et Toshiba_acpi sont dans le noyau, il sont compilés comme modules et peuvent donc être chargés d'un simple modprobe (sauf si Ubuntu les a viré de son noyau standard, mais ça m'étonnerait).

Pour les sources d'omnibook sert toi du lien que j'ai mis dans mon message précédent, tu télécharges le .deb (omnibook-source_2.20080313-1_all.deb (http://debian.tu-bs.de/project/sidux/debian/pool/main/o/omnibook/omnibook-source_2.20080313-1_all.deb) ) mais tu ne l'installes pas, tu le traites comme une archive avec file-roller ou ark et tu extraits les sources (il y a deux niveau, data.tar.gz et à l'intérieur les sources).

Ensuite tu installes "checkinstall" avec apt-get (ça doit être sur les dépôts Ubuntu), tu te places en console dans le répertoire des sources et tu fais :


sudo checkinstall
modprobe omnibook

Basta, c'est tout. Testé hier sur Debian sans problème, sauf que ce n'est pas un Toshiba alors l'intérêt est limité pour moi...

Whadoon
03/05/2008, 11h30
Salut,

J'effectue tes instructions et voici les erreurs que j'ai:

*****************************************
**** Debian package creation selected ***
*****************************************

*** Warning: The package name "omnibook-source_2.20080313" contains illegal.
*** Warning: characters. dpkg might not like that so I changed
*** Warning: them to dashes.

*** Warning: The package version "1_all" is not a
*** Warning: debian policy compliant one. Please specify an alternate one


et


Enter a number to change any of them or press ENTER to continue:

Installing with make install...

========================= Installation results ===========================
make: *** Pas de règle pour fabriquer la cible « install ». Arrêt.

**** Installation failed. Aborting package creation.

Cleaning up...OK

Bye.

=> je crois que ca viens du nouveau systeme d'autorisation de ubuntu 8.04, mais je suis un peut etonné, car je fais toutes les commandes en root

thveillon
03/05/2008, 16h02
Tu as bien extrait les sources jusqu'au répertoire nommé "omnibook"; et avant d'installer avec checkinstall tu as fait un "make" ? Parce que là on dirait que tu n'as pas exécuté "make" avant...

Ensuite Checkinstall va te demander de créer un doc pour le paquet (tu mets ce que tu veux, et tu valides deux fois), puis va créer le paquet .deb et l'installer. Je viens de le refaire et ça marche chez moi. Bien sûr il faut les sources de ton noyau, gcc et make comme pour toute compilation.

Une fois le paquet créé et installé par checkinstall il reste à faire le modprobe et ça doit être bon.

Deuxième essaie ?

thveillon
05/05/2008, 12h58
Je viens d'utiliser checkinstall sur ma "hardy heron" 64bit toute neuve, je pense que je comprends les erreurs que tu rencontres...

Donc tu peux oublier ce que je te disais, et être convaincu que Ubuntu est vraiment devenu différent de Debian.

Une fois que tu as extrait les sources du .deb, tu te retrouves avec un dossier "omnibook" dans lequel tu exécutes "make", jusque là rien ne change.

Ensuite tu lances :


sudo checkinstall

checkinstall va te demander de créer la documentation du paquet, tu fais "entrée" pour accepter le choix par défaut, et tu rentres quelques mots de description (genre "module omnibook pour toshiba") et tu valides deux fois (il faut une ligne vide à la fin de la doc).

Ensuite checkinstall va te présenter la liste des paramètres retenus pour la création du paquet, tu tapes "7" (sans les guillemets) pour changer l'architecture et tu écris "amd64" (sans les guillemets) là où il y avait "i386". Tu valides et la création du paquet devrait bien se passer.

Encore deux étapes :


sudo depmod -ae omnibook
sudo modprobe omnibook

Ouf, c'est fini ! Bon encore une fois je ne peux pas te dire ce que ça va changer, je n'ai toujours pas de Toshiba... mais au moins le module compile et se charge sans problème.

Bon courage, mais ce coup là c'est promis ça marche sur le Héron Hardy 64bit que j'ai sous les yeux ! ;)

Whadoon
05/05/2008, 14h16
Salut,

J'ai bien suisvi tes instructions. cette fois ci, j'ai bien décompressé les sources et réalisé la commande make et checkinstall, jusque la, as de soucis.

Ensuite j'ai effectué: "sudo depmod -ae omnibook" toujours sans problème, mais dès que j'ai voulu charger le module, il ne me le trouve pas ... alors que je n'ai eu aucun message d'erreur.

thveillon
05/05/2008, 15h46
Il y a un truc qui ne tourne pas rond, si tu cherches avec :


find /lib/modules/$(uname -r)/* -name omnibook*

est-ce que ça te renvoie "omnibook.ko" avec le chemin complet ? Si ce n'est pas le cas quelque chose a merdouillé pendant la compilation et l'installation. Chez moi je n'ai rien fait de particulier autre que ce que je t'ai indiqué, en vérifiant (au passage je viens de re-refaire la manip, ça marche toujours) je vois que le module omnibook n'est pas listé dans les alias (ni dans /lib/modules ni dans /etc/modprobe.d), par contre il apparaît dans modules.dep. Tu peux vérifier chez toi avec :


cat /lib/modules/$(uname -r)/modules.dep | grep -i omnibook.ko

Si le module n'apparaît nul part c'est qu'il y a eu un problème lors de la compilation/installation.

Whadoon
05/05/2008, 16h02
j'ai fait une recherche et omniboo.ko se trouve dans


/lib/modules/2.6.24.3/extra

je le deplace ou ?

thveillon
05/05/2008, 23h00
Nul part, il est au bon endroit, ajoute cette ligne :

<div class='quotetop'>Citation </div>
/lib/modules/2.6.24-3/extra/omnibook.ko:[/b]

à /lib/modules/2.6.24-3/modules.dep et refait l'essai. Tu peux aussi ajouter le nom du module à /etc/modules pour qu'il soit chargé au démarrage, mais il faut d'abord que modprobe le reconnaisse.

Tu dis avoir fait un upgrade vers hardy heron LTS, mais ton noyau n'est pas celui de hardy LTS (j'ai 2.6.24-16), tu es sur que l'upgrade c'est bien passé ?

Whadoon
07/05/2008, 12h20
Bon, j'ai enfin réussi, j'ai re installé complètement mon système avec la LTS, la version précédente etait la RC.

L'ennuie c'est que le module se charge bien, mais je n'ai toujours pas accès à mon Bluetooth ...

thveillon
07/05/2008, 13h14
Là à part trouver un toshiba dans la rue je ne vais pouvoir t'aider beaucoup. Tu as vu que sur le tuto (http://linux.dobeyracing.net/how_to/toshiba_p200_laptop/Linux_on_Toshiba_Satellite_P200.php) il est indiqué qu'il faut charger le module avec une option adaptée au modèle ("ectype=12" dans ce cas là), et ensuite il est possible de voir ce qui est reconnu par omnibook avec <div class='quotetop'>Citation </div>
ls /proc/omnibook[/b]

À ce stade et vu que tu as bien déblayé le terrain je te conseil de faire le tour de quelques forums Ubuntu ou Debian (attention aux anti-ubuntu...) pour trouver quelqu'un qui utilise effectivement le module omnibook (ça n'a pas l'air d'être le cas ici).
De mon côté je vais regarder si je trouve quelque chose de plus détaillé ou si j' arrive à engager la conversation avec un possesseur de Toshiba qui n'a pas peur de Linux... un bon prétexte pour aller manger dans mon café-hotspot préféré !

Bon appétit et bon courage. ;)

Whadoon
12/05/2008, 10h04
J'ai encore un dernier souci, quand je tape ma commande :
modprobe ectype=12 j'ai une erreur:
FATAL: Module ectype=12 not found.

une idée ?

thveillon
14/05/2008, 01h37
Héhé... "man modprobe" ! ;)

modprobe [module name] [module parameter], en clair "modprobe omnibook ectype=12" .

Whadoon
17/05/2008, 15h27
Yep, j'ai relu correctement la doc de omnibook et je me suis rendu compte de mon erreur.

Maintenant, j'ai du bluetooth et je me prend la tete avec laptop-mode-tools maintenant :P

thveillon
17/05/2008, 17h47
C'est ça le paradoxe : on a hâte de régler un problème, et dès que c'est fait on n'a de cesse que de trouver le suivant... geek inside ?

Whadoon
19/05/2008, 01h06
Même pas, mais j'aime bien quand ca tourne comme une horloge ... tic tac tic tac .... :D

Whadoon
02/07/2008, 14h51
Et merde,

J'ai reinstallé et maintenant lors de la commande "sudo depmod -ae omnibook", j'ai l'erreur suivante:

"WARNING: Couldn't find symtab and strtab in module /lib/modules/2.6.24-19-generic/extra/omnibook.ko"

=> c'est quoi ca ?

thveillon
02/07/2008, 17h59
Tu as un problème d'incompatibilité entre le noyau et le module, mon idée c'est que tu as eu une mise à jour de noyau, et tu as réinstallé le paquet omnibook que tu avais créé avec checkinstall ? Dans ce cas le module n'ayant pas été compilé contre les sources du noyau actuel il ne se chargera pas. Si le diagnostique est bon tu dois recompiler omnibook depuis les sources comme la dernière fois avant de le charger, et bien sur désisntaller le module actuel avant.

Si tel n'est pas le cas, alors il faut voir s'il y a des sources plus récentes du module omnibook et les compiler.

Whadoon
14/07/2008, 16h18
Ce n'est pas un souci de noyau mais de configuration, j'ai refait une install complete avec le meme noyau et la c'est passé sans souci...

Je peux faire commen pour charger le noyau au démarrage sans etre root ?

thveillon
15/07/2008, 11h40
Je pense que tu parles de charger le module, pas le noyau ? Pour charger le module tu peux le mettre dans (enfin son nom) dans /etc/modules. Si tu as besoin de passer des options particulières au module au moment du chargement tu peux mettre un petit script dans /etc/modprobe.d en lui donnant le nom du module. Si c'est plus compliqué, par exemple si le module doit être chargé expressément avant ou après un autre il faut écrire (ou récupérer) un script et le mettre dans le dossier /etc/rc*.d du bon runlevel (rc2.d pour Ubuntu et Debian) en lui donnant un numéro adapté par rapport aux modules avant/après lesquels il doit être chargé.

Dans ton cas je pense que que /etc/modules suffit.

Whadoon
18/07/2008, 22h06
Bon, j'ai tenté le coup mais j'ai des érreurs au boot de ubuntu, voici ce qque je'ai fais:

J'ai créée un fichier "omnibook" dans" /etc/modprobe.d" et dans le fichier j'ai noté "options ectype=12" mais cela ne fonctionne pas, tu peux me corriger ?

Whadoon
15/08/2008, 10h33
UP!

Please ... help meeeee.

Whadoon
19/08/2008, 01h13
Au secours