PDA

Afficher la version complète : [Réglé] synaptic: désélectionner ne marche pas toujours, pourquoi?



moniroje
22/06/2008, 15h03
Bonjour
Là que j'ai fait Synaptic-Recharger-Tout mettre à jour, j'ai donc 89 fichiers téléchargés et on me prévient de bogues graves sur 6 d'entre eux:
(python-sepolgen)(libpoppler3)(grub)(gnome-applets)(uswswsp)(dbus-X11)
1 bogue grave pour chacun.
Je vais donc les désélectionner.
Oui mais deux récalcitrants persistent à s'installer ou à se mettre à jour:
(python-sepolgen), (libpoppler3)
J'ai donc annulé et je vous demande:
A votre avis, ils servent à quoi??? mon anglais et mes connaissances informatiques sont tels que je n'ai rien compris à leur baratin. Est-ce que je peux les installer (c'est pas moi qui ai demandé leur install, à ces 2 là!) quand même?
Grub, ça fait 3 semaines que sa maj a un bogue grave!!! Vous l'avez mis à jour?

thveillon
23/06/2008, 03h11
Tu ne peux désélectionner un paquet s'il est une dépendance d'un autre paquet marqué pour installation, il faut désélectionner le paquet "maître".

Si tu veux comprendre le pourquoi d'une dépendance tu peux utiliser la fonction "why" d'aptitude, je te donne deux exemples avec tes paquets :

<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>thveillon@ubuntu1:~$ aptitude why python-sepolgen gnome-applets
p python-sepolgen Dépend python
i python Suggère python-tk (>= 2.5.2-0ubuntu1)
i A python-tk Dépend tk8.4 (>= 8.4.5)
i A tk8.4 Recommande xterm | x-terminal-emulator
i gnome-terminal Fournit x-terminal-emulator
i gnome-terminal Dépend gnome-control-center (>= 1:2.8.0)
i gnome-control-center Recommande gnome-session
i gnome-session Recommande gnome-panel
i gnome-panel Recommande gnome-applets (>= 2.12.1-1)

thveillon@ubuntu1:~$ aptitude why python-sepolgen dbus-x11
p python-sepolgen Dépend python
i python Dépend python2.5 (>= 2.5.2)
i python2.5 Dépend python2.5-minimal (= 2.5.2-2ubuntu4)
i python2.5-minimal Suggère binfmt-support
i A binfmt-support Dépend perl (>= 5.6.0-16)
i perl Recommande perl-doc
p perl-doc Suggère groff
p groff Recommande gs
p gs Dépend ghostscript
i ghostscript Suggère hpijs
i hpijs Dépend libsane (>= 1.0.11-3)
i libsane Dépend libgphoto2-port0 (>= 2.4.0)
i libgphoto2-port0 Dépend libdbus-1-3 (>= 1.1.1)
i libdbus-1-3 Recommande dbus
i dbus Recommande dbus-x11 </div>

Comme tu peux le voir ça te donne toute la chaîne de dépendances conduisant d'un paquet à l'autre.

Concernant les bogues, si un t'inquiète particulièrement met le rapport ici car je suis en Lenny et je ne suis pas trop ce qui se passe au quotidien chez Sid (tu es toujours en Sid ?). Sur Lenny j'ai fait toutes les màj sans problème, le rapport de bug grub concernait l'écriture de code générique dans le mbr qui n'est pas mis à jour en cas de "update-grub" (me concerne pas), un problème de conversion des notations hdx en sdx (concerne la transition d'un noyau avant 2.6.18 à un noyau 2.6.19 et postérieur, pas ton cas si tu es en Sid) si ma mémoire est bonne.

Pour voir s'il y a de gros problèmes en court sur ton système va voir la "météo Debian (http://edos.debian.net/weather/)", tu cliques sur ta version et ton architecture, et sur la page suivante tu peux accéder au détails des paquets à problèmes.

Apt-listbugs fait un peu flipper au début, mais il faut bien se dire que si l'équivalent existait sur d'autres distributions ça donnerait encore plus de sueurs froides... :blink:

moniroje
24/06/2008, 14h14
OK, clair et net...
Ben oui que je suis toujours en sid: on m'avait déjà prévenu, toi sans doute:
<div class='quotetop'>Citation </div>
Si tu es déjà en Sid (unstable) tu ne peux pas rétrograder en Lenny (testing) comme ça, il y a de très gros risques que tu casses ton système.[/b]
suivi de conseils pour comment revenir en Lenny mais c'était bien trop compliqué pour moi.
Alors j'ai opté de rester en sid jusqu'à ce que ça casse...
et, surprise, j'ai toujours pas cassé ... mais prévenu, je fais gaffe; il est trop bien ma Debian!

thveillon
24/06/2008, 21h29
Testing n'est pas vraiment "plus stable" que Unstable, ce sont deux distributions assez différentes. Les paquets mis en Unstable sont souvent déjà passés par experimental, ils sont souvent boggués mais pas de manière à les rendre inutilisables. Lorsqu'un bug est découvert il est corrigé aussitôt, les correctifs et les patch sont uploadés très rapidement. Testing reçoit les paquets automatiquement de Unstable après un certain temps sans bugs majeurs, mais souvent d'autres bug sont découverts au niveau de Testing. La différence c'est que les bugs de testing sont moins fréquents et nombreux, mais ils ne sont pas corrigés rapidement car les patch et correctifs sont d'abord uploadés dans Unstable avant de redescendre en Testing.
Donc moins de bug mais qui durent plus longtemps.

En ce moment avec la préparation de la future Stable il y a en plus le gèle progressif de Lenny qui ralentit les arrivée de paquets depuis Unstable, et certains paquets qui sont estimés trop boggués pour intégrer la future stable sont purement et simplement supprimés de Lenny.

Sid est donc très bien pour celui qui veut des paquets très récents et avoir un système avec un pied dans le futur, au prix de quelques surprises de temps en temps... Après tout Ubuntu est basée en grande partie sur Unstable (Sid) et ça lui réussit plutôt bien !