PDA

Afficher la version complète : HD3870 comment switcher du radeonhd à fglrx ?



Denebe
23/06/2008, 18h20
Bonjour,

Jusqu'il n'y a pas si longtemps, j'avais une ati x1950xt avec laquelle je maitrisais l'installation des drivers fglrx (ça se finissait par un sax2 -r -m 0=fglrx).

J'ai depuis acheté une ati hd3870. Lors de l'installation d'opensuse 11 est choisi le driver libre radeonhd. Comme avec mon x1950xt, j'installe les drivers fglrx. Mais une fois la procédure finie je suis toujours avec le driver libre radeonhd. Je n'arrive pas à switcher sur le driver fglrx. Ca vous dit quelque chose ?

Une deuxième question, quand je suis avec le driver radeonhd et que je clique dans la case "effet de bureau" mon écran devient tout blanc et je ne ne peux rien faire de plus plus que de passer en console (ctrl+alt+f1). Dès que je reviens sur le bureau (ctrl+alt+f7), je me retrouve avec cet écran blanc. Savez-vous comment désactiver cet option mais en mode console ? (pour le moment la seule solution que j'ai trouvée c'est de réinstaller, elle est plutôt gênante ;) ).

Denebe.

thveillon
24/06/2008, 03h08
Salut, les pilotes radeonhd s'améliorent vite mais ils sont encore expérimentaux.

Après l'installation du pilote fglrx tape en console root :


aticonfig --initial,

si ça ne suffit pas édite le /etc/X11/xorg.conf et change le driver "radeonhd" par "fglrx" dans la section "device".

Denebe
24/06/2008, 14h37
J'ai essayé ou plutôt réessayé mais ça ne marche pas comme il faut.

Voilà ce que j'ai fait:
sh ati...........64.run --buildpkg SuSE-SUSE103-AMD64
init 3
cd /home/moncompte/Desktop
rpm -ivh fglrx.........rpm
sax2 -r -m 0=fglrx
shutdown -r now (sur mon x1950xt ça suffisait)

------------------------------------------------------------
J'ai aussi essayé de tapé aticonfig --initial mais sans succès.
J'ai une question à ce sujet, faut-il le taper à la place de sax2 -r -m 0=fglrx ? Ou bien après ? ou avant ?

-----------------------------------------------------------
J'ai aussi remplacé radeonhd par fglrx dans le xorg.conf mais sans plus de succès. Dans ce cas là j'ai un écran noir et je suis obligé de rebooter (plus rien ne marche, ni ctrl+alt+backspace ni ctrl+alt+f1), et de rechanger mon xorg.conf avec radeonhd.

thveillon
24/06/2008, 15h53
aticonfig est à utiliser immédiatement après l'installation du rpm, avant de faire sax2.... Il faut être sur de désinstaller le résultat de tes tentatives précédentes avant de recommencer, sinon tu vas te retrouver avec un total bazar.

Après avoir fait aticonfig et sax2, reboot (commande "reboot" ou "shutdown -r now").

Si après une installation propre le pilote fglrx n'est pas utilisé, désinstalle le pilote radeonhd avec Yast (comme ça il ne sera plus utilisé automatiquement), et modifie ton /etc/X11/xorg.conf avec un éditeur de texte pour indiquer "fglrx" là ou il y avait "radeonhd".

J'ai eu une radeonhd 2600xt sous suse il y a quelques mois, la meilleur procédure que j'avais trouvé après pas mal de problèmes c'est d'installer le pilote avec l'installateur d'ati en mode automatique (au lieu de créer un paquets), de faire "aticonfig --initial" (tout ça en console en runlevel 3) et de rebooter sans utiliser Sax. En général à ce stade j'avais au redémarrage le pilote fglrx installé et l'accélération matérielle, mais certaines applications ne fonctionnaient pas correctement (et bien sur dans yast les informations étaient fausses et l'accélération matérielle pas détectée). Donc après sauvegarde du xorg.conf je repassais en console pour exécuter "sax2 -r" et rebooter. En général ça fonctionnait bien après... sinon je remettais le xorg.conf sauvegardé en place... Pas simple quoi.

Si ça peut t'aider je te mets le xorg.conf de ma suse avec la 2600xt , j'ai enlevé le début (section "Files") :

<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
Load "dri"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "IgnoreABI" "on"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "fr"
Option "XkbModel" "microsoftpro"
Option "XkbOptions" "caps:shiftlock"
Option "XkbRules" "xorg"
Option "XkbVariant" "oss"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "10"
Option "Device" "/dev/input/mice"
Option "Name" "Microsoft Optical Mouse with Tilt Wheel"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
Option "DIALRelativeAxisButtons" "7 6"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
DisplaySize 376 301
HorizSync 30-81
Identifier "Monitor[0]"
ModelName "SAMSUNG SYNCMASTER"
Option "DPMS"
VendorName "SAM"
VertRefresh 43-75
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
EndSection


Section "Device"
BoardName "ATI Radeon HD 2600 XT (RV630 9588)"
Driver "fglrx"
Identifier "Device[0]"
#Option "NoDDC"
Option "UseInternalAGPGART" "no"
Option "no_accel" "no"
Option "no_dri" "no"
Option "mtrr" "off"
Option "ScreenOverlap" "0"
Option "GammaCorrectionI" "0x00000000"
Option "GammaCorrectionII" "0x00000000"
Option "Capabilities" "0x00000000"
Option "CapabilitiesEx" "0x00000000"
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Option "CenterMode" "off"
Option "PseudoColorVisuals" "off"
Option "Stereo" "off"
Option "StereoSyncEnable" "1"
Option "FSAAEnable" "no"
Option "FSAAScale" "1"
Option "FSAADisableGamma" "no"
Option "FSAACustomizeMSPos" "no"
Option "FSAAMSPosX0" "0.000000"
Option "FSAAMSPosY0" "0.000000"
Option "FSAAMSPosX1" "0.000000"
Option "FSAAMSPosY1" "0.000000"
Option "FSAAMSPosX2" "0.000000"
Option "FSAAMSPosY2" "0.000000"
Option "FSAAMSPosX3" "0.000000"
Option "FSAAMSPosY3" "0.000000"
Option "FSAAMSPosX4" "0.000000"
Option "FSAAMSPosY4" "0.000000"
Option "FSAAMSPosX5" "0.000000"
Option "FSAAMSPosY5" "0.000000"
Option "UseFastTLS" "0"
Option "BlockSignalsOnLock" "on"
Option "ForceGenericCPU" "no"
Option "KernelModuleParm" "locked-userpages=0"
VendorName "ATI"
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Screen "Screen[0]"
EndSection


Section "DRI"
Group "video"
Mode 0660
EndSection
</div>

Attention, tout ce qui concerne l'écran n'est peut-être pas adapté au tiens, c'était un 19 pouce lcd en 1280x1024. Au dernière nouvelles le pilote fglrx ne supportait mal les résolutions supérieures et pas du tout les résolutions 16/10 ou 16/9 (genre 1400x900, format large).

maxxous
24/06/2008, 16h07
J'ai la même carte que toi, est je n'est aucun problème pour installer le pilote Ati :blink:

Reprenons:

1 Télécharger le driver Ati sur le site donc version 8.6.

2 Installer par Yast: gcc , make et kernel-source.

3 Rendre le driver exécutable, click droit préferences cocher la case rendre exécutable.

4 Tu lance le driver Ati dans une console en ROOT.

5 Tu fais installation automatique (normalement la barre avance et se bloque au 3/4 quelques secondes, sa veut dire que c'est bon).

6 Dans la même console tu tape toujours en root ;) :

<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>aticonfig --initial</div>

Et pour finir un reboot. :)

Ps: @Thveillon "Attention, tout ce qui concerne l'écran n'est peut-être pas adapté au tiens, c'était un 19 pouce lcd en 1280x1024. Au dernière nouvelles le pilote fglrx ne supportait mal les résolutions supérieures et pas du tout les résolutions 16/10 ou 16/9 (genre 1400x900, format large)."

Je vais te contredire car j'ai un écran 16/10 donc 1440x900 et sa fonctionne très bien. Mais peut-être que sur d'autre résolution sa peut provoquer des problèmes.

Denebe
24/06/2008, 17h36
Oui, j'avais bien installé gcc, make et kernel-source (du même numéro que mon kernel).

La procédure automatique ne fonctionne pas non plus, j'obtiens un écran noir.

J'ai bien rendu mon fichier ati....64.run exécutable via konqueror en cliquant droit puis en sélectionnant executable.
Ensuite dans un console en root j'ai tapé "./ati......64.run" et j'ai tout mis en automatique. Ca a bien mis une petite minute avec une pause au trois quart.
Ensuite, je suis revenu dans ma console, toujours en root, et j'ai tapé aticonfig --initial.
Puis j'ai rebooté, et c'est le drame.

J'ai donc rebooté en safe mode, rechangé mon xorg.conf par un qui est sain (je l'ai enregistré au début de mon installation ou disons avant de faire quoi que ce soit).

Pour info, voici mon xorg.conf quand j'ai rebooté avec un écran noir: ; désolé je ne sais pas rendre plus petit ma citation

<div class='quotetop'>Citation </div>
# /.../
# SaX generated X11 config file
# Created on: 2008-06-22T22:48:11+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
Identifier "Layout[all]"
Screen 0 "aticonfig-Screen[0]-0" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "fr"
Option "XkbModel" "pc102"
Option "XkbOptions" "caps:shiftlock"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "12"
Option "Device" "/dev/input/mice"
Option "Name" "Logitech USB Receiver"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
ModeLine "1280x1024" 119.4 1280 1368 1504 1728 1024 1025 1028 1063
ModeLine "1024x768" 95.5 1024 1088 1200 1376 768 769 772 807
ModeLine "1024x768" 85.5 1024 1088 1200 1376 768 769 772 803
ModeLine "1024x768" 74.6 1024 1080 1192 1360 768 769 772 799
ModeLine "800x600" 60.1 800 840 928 1056 600 601 604 632
ModeLine "800x600" 53.1 800 840 928 1056 600 601 604 629
ModeLine "800x600" 45.5 800 840 920 1040 600 601 604 625
ModeLine "800x600" 38.2 800 832 912 1024 600 601 604 622
EndSection

Section "Monitor"
Identifier "Monitor[0]"
VendorName "TATUNG"
ModelName "PC DIVISION V70 (XJ63754)"
UseModes "Modes[0]"
DisplaySize 250 190
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 100.0
Option "DPMS"
Option "PreferredMode" "1280x1024"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "radeonhd"
VendorName "ATI"
BoardName "ATI Radeon HD3870"
Option "monitor-TV_7PIN_DIN" "Monitor[0]"
BusID "1:0:0"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection[/b]

Et voici mon xorg.conf sain:
<div class='quotetop'>Citation </div>
# /.../
# SaX generated X11 config file
# Created on: 2008-06-23T10:56:07+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "Module"
Load "freetype"
Load "type1"
Load "dbe"
Load "glx"
Load "extmod"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "fr"
Option "XkbModel" "pc102"
Option "XkbOptions" "caps:shiftlock"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "12"
Option "Device" "/dev/input/mice"
Option "Name" "Logitech USB Receiver"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
DisplaySize 517 323
HorizSync 30-70
Identifier "Monitor[0]"
ModelName "PC DIVISION V70 (XJ63754)"
Option "DPMS"
Option "PreferredMode" "1920x1200"
VendorName "TATUNG"
VertRefresh 50-100
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
EndSection


Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1920x1200" "1900x1200" "1920x1080" "1600x1200" "1680x1050" "1600x1024" "1600x1000" "1400x1050" "1280x1024" "1440x900" "1280x960" "1366x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "ATI Radeon HD3870"
Driver "radeonhd"
Identifier "Device[0]"
Option "monitor-TV_7PIN_DIN" "Monitor[0]"
Screen 0
VendorName "ATI"
EndSection



Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection


Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection[/b]

J'ai comme un petit soupçon sur mon écran. Il est tout neuf, vient tout juste d'arriver sur le marché. 26" en 16/10 (oui, je sais je me suis fait plaisir :rolleyes:)

maxxous
24/06/2008, 19h14
Alors il y a une solution enfaite le problème vient que tu a déjà le driver Radeonhd d'installé.

Solution:

Tu lance une console en ROOT:
tu tape:
<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>init3</div>
Ensuite tu te mets en root dans la console et tu fais:
<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>sax2 -r -m 0=fglrx</div>
Normalement tu à Sax qui doit apparaître tu mets une résolution qui te convient le mieux, et tu tape:
<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>reboot</div>
Opensuse se relance et tu refais la procédure que j'ai indiqué, pour installer le pilote Ati.

Et tu croise tous ce que tu peut, avec une prière au petits Jésus et sa passe.... :)

thveillon
24/06/2008, 20h03
[...]
Ps: @Thveillon "Attention, tout ce qui concerne l'écran n'est peut-être pas adapté au tiens, c'était un 19 pouce lcd en 1280x1024. Au dernière nouvelles le pilote fglrx ne supportait mal les résolutions supérieures et pas du tout les résolutions 16/10 ou 16/9 (genre 1400x900, format large)."

Je vais te contredire car j'ai un écran 16/10 donc 1440x900 et sa fonctionne très bien. Mais peut-être que sur d'autre résolution sa peut provoquer des problèmes.[/b]

C'est bien possible maxxous, et c'est une bonne nouvelle, mais à l'époque où j'avais installé cette carte sur suse ce n'était pas le cas, depuis je n'ai plus de problèmes avec... ni de suse.

Denebe, dans ton xorg.conf qui ne marche pas tu as deux sections "device", supprime celle qui concerne radeonhd, "aticonfig --initial" a bien créé la nouvelle section fglrx mais il n'a pas supprimée l'ancienne.
Maxxous confirmera avec son xorg.conf, mais je pense qu'il te manque [Load "dri"] dans [Section Module], sans ça tu n'aura pas d'accélération et la dernière section :
Section "DRI"
Group "video"
Mode 0660
EndSection
ne sert à rien.

Denebe
24/06/2008, 20h39
Maxou: c'est la première manipulation que j'ai fait c'est "sax2 -r -m 0=fglrx", ça ne marche pas.

thveillon: j'avais perçu qu'il y avait un soucis à ce niveau-là (au moins), et j'avais commenté quelques lignes. Mais je pense que j'ai du mal m'y prendre. Je vais continuer dans ce sens...

Bon, je retourne installer ce driver.... arrggg ;)

Merci pour votre aide,
Je vous tiens au courant.

maxxous
24/06/2008, 20h47
Sa te mets quoi comme erreur avec "Sax2 -r -m 0=fglrx" (0=zero au cas ou on peut se tromper)

Denebe
24/06/2008, 21h49
Sa te mets quoi comme erreur avec "Sax2 -r -m 0=fglrx" (0=zero au cas ou on peut se tromper)[/b]
Ecran noir sans même un curseur. Puis plus rien ne répond.

J'ai désintallé le driver radeonhd, puis j'ai rebooté.

Une fois avec le driver générique fbdev, j'ai installé le driver ati mais j'ai toujours cette écran noir après que sax ai mis son nez dedans (enfin je dis ça comme ça hein, je ne m'y connais pas assez pour affirmer ...).

J'ai commenté quelques lignes dans mon xorg.conf mais rien n'y fait. Voilà ce que j'ai fait:

<div class='quotetop'>Citation </div>
# /.../
# SaX generated X11 config file
# Created on: 2008-06-24T20:50:01+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [SaX2] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
Identifier "Layout[all]"
Screen 0 "aticonfig-Screen[0]-0" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "fr"
Option "XkbModel" "pc102"
Option "XkbOptions" "caps:shiftlock"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "12"
Option "Device" "/dev/input/mice"
Option "Name" "Logitech USB Receiver"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
EndSection

#Section "Monitor"
# Identifier "Monitor[0]"
# VendorName "VSC"
# ModelName "VIEWSONIC VP2650WB"
# UseModes "Modes[0]"
# DisplaySize 550 344
# HorizSync 30.0 - 92.0
# VertRefresh 43.0 - 85.0
# Option "CalcAlgorithm" "XServerPool"
# Option "DPMS"
# Option "PreferredMode" "1600x1200"
#EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

#Section "Device"
# Identifier "Device[0]"
# Driver "fbdev"
# VendorName "VESA"
# BoardName "Framebuffer Graphics"
#EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

#Section "Screen"
# Identifier "Screen[0]"
# Device "Device[0]"
# Monitor "Monitor[0]"
# SubSection "Display"
# Depth 15
# Modes "default"
# EndSubSection
# SubSection "Display"
# Depth 16
# Modes "default"
# EndSubSection
# SubSection "Display"
# Depth 24
# Modes "default"
# EndSubSection
# SubSection "Display"
# Depth 8
# Modes "default"
# EndSubSection
#EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection[/b]
Je ne sais pas si a son importance, j'ai installé les dépots kde4.1 (la dernière beta), opensuse buildservice X11/xgl (il y juste compiz qui est à jour sinon rien de particulier), et opensuse build service openoffice. Et les classiques oss, non-oss, packman, videolan,update11.

maxxous
24/06/2008, 22h30
Attends je ne comprend pas ce que tu a fais??

tu a installer le pilote Ati comme je te l'avais dit avec un aticonfig --initial et un reboot derrière alors pourquoi Sax intervient après ??? tu ne doit pas te servir de sax.......

Denebe
24/06/2008, 22h56
Je viens de réinstaller pour cause de fichier xorg. conf "corrompu".

Honnêtement je ne me souviens plus exactement. Simplement parce qu'avec toutes les manipulations que j'ai effectuées, au bout d'un moment je m'y perd les pédales. Peut-être l'ai-je fait. Je fais de mon mieux. Par contre, après ton premier message, oui je n'ai pas tapé sax2..., mais uniquement aticonfig --initial.

Ca y est, j'ai une installation neuve sur laquelle j'ai uniquement fait les mises à jours principales. (gcc, make et kernel-source y compris)

Je n'ose plus rien faire :blink:

Bon, je vais sauvegarder mon xorg.conf et je réessaie. Je n'utiliserai pas sax2.

maxxous
24/06/2008, 23h22
Normalement avec une Opensuse "fraîche" sa devrais passer sans problème si tu suis mon premier post. :)

Ont est cool içi donc prends ton temps, va y tranquillement et tous va bien. ;)

En cas de problème que je te le souhaite pas, je te donne mon "xorg.conf".

max@linux-xdo8:~> glxgears
55025 frames in 5.0 seconds = 11004.932 FPS


Section "Monitor"
Identifier "Monitor[0]"
VendorName "FUS"
ModelName "C19-1W"
UseModes "Modes[0]"
DisplaySize 410 256
HorizSync 30.0 - 83.0
VertRefresh 43.0 - 75.0
Option "DPMS"
Option "PreferredMode" "1440x900"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "radeonhd"
VendorName "ATI"
BoardName "ATI Radeon HD3870"
Option "monitor-DVI-I_2/analog" "Monitor[0]"
BusID "1:0:0"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1440x900" "1152x864" "1024x768" "800x600" "768x576"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900" "1152x864" "1024x768" "800x600" "768x576"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900" "1152x864" "1024x768" "800x600" "768x576"
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900" "1152x864" "1024x768" "800x600" "768x576"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Denebe
25/06/2008, 00h12
J'ai le regret de vous annoncer que l'opération driver à de nouveau échouée.( J'y vais à la cool, mais je suis un peu embêté pour le temps que tu passes, merci beaucoup, même si ça ne marche pas pour le moment, ça m'a quand même fait avancé. Merci encore)
-----------------------------------------------------------------------------------------------------------------------
Avant de te lire j'ai eu le temps de faire une tentative:
1)init3
2)création du paquet fglrx...rpm
3)rpm -ivh fgr...rpm
4) sax2 -r -m 0=fglrx (désolé mais c'est comme ça que j'ai toujours fait, sauf dernièrement, hein j'ai aussi testé uniquement avec aticonfig)
5)reboot

->juste avant d'arriver à l'ouverture de session l'écran devient noir et plus aucun contrôle n'est possible (peut-être est-ce figé ? difficile à dire vu que tout est noir)
----------------------------------------------------------------------------------------------------------------------
Ensuite j'ai rebooté en safe console, et j'ai remplacé mon xorg par celui d'origine, puis,

1)reboot normalement
2)suppression via yast de fglrx
3)rendre ati...run executable
4)dans une console en root j'ai lancé le driver ati et j'ai tout exécuté en automatique
5)aticonfig --initial (la j'ai jeté un oeil sur le xorg.conf, c'est exactement le tient, je le mets jute en dessous)
6)reboot

->juste avant d'arriver à l'ouverture de session l'écran devient noir et plus aucun contrôle n'est possible

Voici le xorg.conf juste après "aticonfig --initial
<div class='quotetop'>Citation </div>
# /.../
# SaX generated X11 config file
# Created on: 2008-06-24T22:33:15+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
Identifier "Layout[all]"
Screen 0 "aticonfig-Screen[0]-0" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "fr"
Option "XkbModel" "pc102"
Option "XkbOptions" "caps:shiftlock"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "12"
Option "Device" "/dev/input/mice"
Option "Name" "Logitech USB Receiver"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
ModeLine "1920x1200" 151.6 1920 2032 2240 2560 1200 1201 1204 1234
ModeLine "1920x1200" 119.8 1920 1968 2000 2080 1200 1203 1209 1227 +hsync -vsync
ModeLine "1600x1200" 152.7 1600 1704 1880 2160 1200 1201 1204 1240
ModeLine "1600x1200" 121.2 1600 1648 1680 1760 1200 1203 1207 1232 +hsync -vsync
ModeLine "1400x1050" 153.8 1400 1496 1648 1896 1050 1051 1054 1096
ModeLine "1400x1050" 123.8 1400 1448 1480 1560 1050 1053 1057 1087 +hsync -vsync
ModeLine "1280x1024" 153.4 1280 1376 1512 1744 1024 1025 1028 1073
ModeLine "1280x1024" 137.9 1280 1368 1504 1728 1024 1025 1028 1069
ModeLine "1280x1024" 124.0 1280 1328 1360 1440 1024 1027 1034 1064 +hsync -vsync
ModeLine "1280x1024" 123.8 1280 1368 1504 1728 1024 1025 1028 1064
ModeLine "1280x1024" 108.9 1280 1360 1496 1712 1024 1025 1028 1060
ModeLine "1024x768" 94.4 1024 1088 1200 1376 768 769 772 807
ModeLine "1024x768" 83.7 1024 1080 1192 1360 768 769 772 803
ModeLine "1024x768" 79.2 1024 1072 1104 1184 768 771 775 799 +hsync -vsync
ModeLine "1024x768" 74.2 1024 1080 1192 1360 768 769 772 799
ModeLine "1024x768" 64.1 1024 1080 1184 1344 768 769 772 795
ModeLine "800x600" 56.5 800 840 928 1056 600 601 604 630
ModeLine "800x600" 50.8 800 840 928 1056 600 601 604 627
ModeLine "800x600" 50.2 800 848 880 960 600 603 607 625 +hsync -vsync
ModeLine "800x600" 44.4 800 840 920 1040 600 601 604 624
ModeLine "800x600" 38.2 800 832 912 1024 600 601 604 622
ModeLine "1920x1200" 154.0 1920 1968 2000 2080 1200 1203 1209 1235 -hsync +vsync
EndSection

Section "Monitor"
Identifier "Monitor[0]"
VendorName "VSC"
ModelName "VIEWSONIC VP2650WB"
UseModes "Modes[0]"
DisplaySize 550 344
HorizSync 30.0 - 92.0
VertRefresh 43.0 - 85.0
Option "DPMS"
Option "PreferredMode" "1920x1200"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "radeonhd"
VendorName "ATI"
BoardName "ATI Radeon HD3870"
Option "monitor-DVI-I_2/digital" "Monitor[0]"
BusID "1:0:0"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1920x1200" "1600x1200" "1400x1050" "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "1920x1200" "1600x1200" "1400x1050" "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "1920x1200" "1600x1200" "1400x1050" "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 8
Modes "1920x1200" "1600x1200" "1400x1050" "1280x1024" "1024x768" "800x600"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection[/b]
Je vais essayé avec "aticonfig --initial -f" comme c'est indiqué à la fin de l'installation automatique.

maxxous
25/06/2008, 00h19
Perso, je pense que c'est simplement un problème de résolution......... :)

Un coup en "safe mode" puis tu ouvre Sax et mets une résolution adéquate.

thveillon
25/06/2008, 00h28
Maxxous, c'est marrant de constater que ton xorg.conf qui fonctionne parfaitement est en fait tout aussi pourri que celui de Denebe... tu as deux sections "device" avec deux pilotes différents...
Tu n'as pas mis la section "module", tu n'en as pas ?

En fait si OpenSuse a suivi les dernières évolutions de xorg (et Xrandr) le xorg.conf n'est quasiment plus utilisé, d'ailleurs c'est parfaitement possible sur certaines configurations de faire sans... (j'ai une machine en nvidia sous Debian qui n'a que la section clavier pour le layout, et une ligne pour indiquer d'utiliser nvidia dans la section "device", rien d'autre dans le xorg.conf...)
Maintenant on peut utiliser le xorg.conf juste pour les options perso, la plupart des options sont ignorées si la configuration automatique fonctionne.
Un topo sur Xrandr (http://www.thinkwiki.org/wiki/Xorg_RandR_1.2), un sur les mode video (http://www.x.org/wiki/FAQVideoModes) (résolution d'écran), et le wiki du serveur X (http://wiki.debian.org/XStrikeForce/HowToRandR12) chez Debian qui présente bien les nouvelles options (la configuration de Xorg n'est pas spécifique à une distribution). C'est en anglais.

Je pense que le plus important pour toi Denebe c'est d'oublier sax2 et yast jusqu'à ce que ça fonctionne avec l'installateur d'ati et aticonfig, après tu pourras essayer "sax2 -r" pour que les info dans Yast soient correctes.

Ps : toujours pas de "Load "dri"" dans la section module ? C'est pourtant dri qui gère l'accélération matérielle...

maxxous
25/06/2008, 00h33
J'ai vu ça quand je l'ai ouverts sa ma étonnait aussi :D :lol: alors que j'ai un score correcte avec fglxgears. :rolleyes:

Enfin bref, si c'est un écran noir sa ne vient pas de l'installation du pilote, sinon il retonberait en console.........Donc un problème de résolution, car la seule différence avec moi c'est son écran donc.....

Denebe
25/06/2008, 00h43
Rebelotte mais ce coup-ci j'ai essayé avec aticonfig --initial -f (c'est moins le bordel dans le xorg, plus de doublon mais ....)

1)reboot normalement
2)suppression via yast de fglrx
3)rendre ati...run executable
4)dans une console en root j'ai lancé le driver ati et j'ai tout exécuté en automatique
5)aticonfig --initial -f
6)reboot

->juste avant d'arriver à l'ouverture de session l'écran devient noir et plus aucun contrôle n'est possible

Voici le xorg.conf juste après "aticonfig --initial -f
<div class='quotetop'>Citation </div>
# /.../
# SaX generated X11 config file
# Created on: 2008-06-24T22:33:15+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
Identifier "Layout[all]"
Screen 0 "aticonfig-Screen[0]-0" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
EndSection

Section "Module"
Load "dbe"
Load "type1"
Load "freetype"
Load "extmod"
Load "glx"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "fr"
Option "XkbModel" "pc102"
Option "XkbOptions" "caps:shiftlock"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "12"
Option "Device" "/dev/input/mice"
Option "Name" "Logitech USB Receiver"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
ModeLine "1920x1200" 151.6 1920 2032 2240 2560 1200 1201 1204 1234
ModeLine "1920x1200" 119.8 1920 1968 2000 2080 1200 1203 1209 1227 +hsync -vsync
ModeLine "1600x1200" 152.7 1600 1704 1880 2160 1200 1201 1204 1240
ModeLine "1600x1200" 121.2 1600 1648 1680 1760 1200 1203 1207 1232 +hsync -vsync
ModeLine "1400x1050" 153.8 1400 1496 1648 1896 1050 1051 1054 1096
ModeLine "1400x1050" 123.8 1400 1448 1480 1560 1050 1053 1057 1087 +hsync -vsync
ModeLine "1280x1024" 153.4 1280 1376 1512 1744 1024 1025 1028 1073
ModeLine "1280x1024" 137.9 1280 1368 1504 1728 1024 1025 1028 1069
ModeLine "1280x1024" 124.0 1280 1328 1360 1440 1024 1027 1034 1064 +hsync -vsync
ModeLine "1280x1024" 123.8 1280 1368 1504 1728 1024 1025 1028 1064
ModeLine "1280x1024" 108.9 1280 1360 1496 1712 1024 1025 1028 1060
ModeLine "1024x768" 94.4 1024 1088 1200 1376 768 769 772 807
ModeLine "1024x768" 83.7 1024 1080 1192 1360 768 769 772 803
ModeLine "1024x768" 79.2 1024 1072 1104 1184 768 771 775 799 +hsync -vsync
ModeLine "1024x768" 74.2 1024 1080 1192 1360 768 769 772 799
ModeLine "1024x768" 64.1 1024 1080 1184 1344 768 769 772 795
ModeLine "800x600" 56.5 800 840 928 1056 600 601 604 630
ModeLine "800x600" 50.8 800 840 928 1056 600 601 604 627
ModeLine "800x600" 50.2 800 848 880 960 600 603 607 625 +hsync -vsync
ModeLine "800x600" 44.4 800 840 920 1040 600 601 604 624
ModeLine "800x600" 38.2 800 832 912 1024 600 601 604 622
ModeLine "1920x1200" 154.0 1920 1968 2000 2080 1200 1203 1209 1235 -hsync +vsync
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection[/b]

Bon je vais tenter un autre essai (sans sax2, je l'oublie jusque nouvel ordre)

Je vais mettre load "dri" dans la section module (désolé thveillon j'aurais pu essayer plus tôt, c'est que j'ai la tête dans le guidon).

La raison de l'affichage noir, l'écran et sa résolution, c'est bien possible.

maxxous
25/06/2008, 00h51
Si tu a un autre écran (chez toi ou un amis à toi (faut bien qu'ils servent aussi défois les amis)). Pour faire un test sans toucher au xorg.conf.

Denebe
25/06/2008, 01h27
Après l'étape d'installation, j'ai inséré dans la section module Load "dri" , sans plus de succès.

Maxxous: quelle bonne idée !! juste sous mes yeux trône un bon vieux CRT 17"

Je m'en vais de ce pas ...
---------------------------------------------------------------------------------------
Suite: Avec le CRT 17" la réaction a été la même.

Merci beaucoup pour votre aide :) . Il est maintenant l'heure de réfléchir ou temps d'attendre le prochain driver, et aussi de dormir pour demain.

Je vais aussi lire (si j'y arrive) les liens que tu as donné thveillon.

thveillon: tes deux liens (Un topo sur Xrandr, un sur les mode video (résolution d'écran)) pointent sur la même page web, c'est normal ?

thveillon
25/06/2008, 04h52
Pour le lien c'est une erreur, qui est corrigée.

maxxous
25/06/2008, 09h05
Mets toi en safe mode ouvre l'utilitaire Ati catalyst et change la résolution en (1024x768)ou (800x600) et reboot en mode normale et regarde si sa fonctionne. :huh:

stobbart
25/06/2008, 10h37
Bonjour à tous!
Je prends cette discussion au vol et je m'interroge si le problème ne vient pas de l'architecture 64 bits?
Pour ma part, j'ai essayé d'installer sur opensuse 11.0 X86_64 le pilote ATI (j'ai une hd 2400) téléchargé. Mais ça ne marchait pas chez moi, écran noir etc...
Ensuite, j'ai installé via le dépôt YAST ATI le driver fglrx. Là j'ai obtenu une bonne résolution mais pas de 3d...
Actuellement, j'ai installé opensuse 11.0 i586 avec driver du dépôt YAST ATI et ça fonctionne très bien avec 3d activée...

Denebe
25/06/2008, 12h30
Je pars pour une semaine, peut-être un peu plus je ne sais pas trop. Je réessaierai dès mon retour, et vous tiendrai au courant.
Je regarderai aussi les liens sur xrand etc...

Bonne journée,
Denebe.