PDA

Afficher la version complète : [Réglé] Probleme de son avec ioquake3



Gabou
19/09/2008, 15h23
Bonjour!

Je suis nouveau sur ce forum et nouvel utilisateur de OpenSuSE par la même occasion.
Je me sert de linux essentiellement pour internet/bureautique et Quake 3 Arena via Ioquake3 (et par la même occasion les différents mods basés sur le même moteur, tel Openarena.)
Malheureusement j'ai un probleme de son, celui-ci fonctionne, mais je suis confronté à des grésillements intempestifs ainsi qu'a une latence de quelques millisecondes. Je précise que je n'ai ce problême que lorsque que j'utilise ioquake3.
Ce probleme bien connu (faq Ioquake3) a été résoulu sur la plupart des autres distribs que j'ai pu essayé.
Le souci étant que les différentes solutions que j'ai trouvé et que j'ai ensuite appliqué sous OpenSuSE n'ont pas fonctionné.
A priori le problême viendrait d'une histoire de PulseAudio/OSS.

Donc je demande à une âme charitable, si une solution existe afin de résoudre ce souci, sachant que ça m'embetais beaucoup d'être contraint de retourner sur une autre distribution à cause de ce désagrément! :)

Merci d'avance!

phoenix
19/09/2008, 15h33
Hello,

Si tu ne l'utilise pas, tu peux désinstaller PulseAudio.

Gabou
19/09/2008, 15h40
Merci pour la réponse! :)
Par contre n'y a-t-il pas moyen de basculer sous OSS sans avoir a désinstaller PulseAudio?
J'ai pas encore tout compris au sujet de ces différents serveurs audio... mais je m'y mets!
Quelle devrait être la procédure afin de réaliser cela?

phoenix
19/09/2008, 15h52
A mon avis, pour utiliser OSS juste avec une application, il faut ouvrir un terminal et faire
padsp tacommande

Gabou
19/09/2008, 16h03
Malheureusement ça le marche pas...
Le probleme est répertorié ici : http://ioquake3.org/help/ ("Why is my audio crackling / distorted under Linux?")
Le wiki d'Ubuntu-fr traite aussi de ce probleme via Openarena (mod qui utilise Ioquake3) : http://doc.ubuntu-fr.org/openarena ("Le son qui grésille..")

Opensuse est la seule distribution sur laquelle je n'ai pas encore réussi a venir a bout de ce probleme.
Je tiens aussi a préciser que le probleme n'existe plus du tout sur les versions les plus récentes des autres distributions que j'ai pu tester. (sous Ubuntu 8.04 tout marche maintenant d'origine, alors que a priori PulseAudio est aussi utilisé..)

phoenix
19/09/2008, 16h08
Je viens de trouver ça ici : http://www.pulseaudio.org/wiki/PerfectSetup#OSSApplications

<div class='quotetop'>Citation </div>
RTCW / Enemy Territory / True Combat Elite / Quake 3 ¶

To use those games with PulseAudio as audio server, you will have to follow instructions from http://nullkey.ath.cx/~stuff/et-sdl-sound/. Padsp doesn't work with them... No need to try it.

*Warning* Be aware that redirecting library calls to this "wrapper" might be detected as an attempt to cheat. So far PunkBuster? doesn't complain about it but it might in the future. You have been warned!

Setting SDL_AUDIODRIVER="esd" in the wrapper is reported to work better than the default (alsa)[/b]


Sinon, tu as essayé la solution d'ubuntu ?

Si oui, dans ce cas, à part la suppression de PulseAudio, je ne vois pas. Pour le supprimer, vas dans Yast, recherche "pulse" et supprime tous les paquets installés qui comporte ce terme dans leur nom.

Gabou
19/09/2008, 16h12
J'ai réussi a désinstaller PulseAudio!
Que faire maintenant pour activer OSS?
Dois-je rebooter? y a-t-il une commande a éxécuter?

phoenix
19/09/2008, 16h13
Redémarre.

Gabou
19/09/2008, 16h20
Voila, j'ai redémarré, par contre je n'ai plus de son du tout à présent!
Comment puis-je reconfigurer le tout afin de basculer sous OSS?

phoenix
19/09/2008, 16h24
Lance
alsaconf en root, et vérifie que le volume n'est pas au minimum avec la commande
alsamixer

Gabou
19/09/2008, 21h58
Bonsoir!
La désinstallation de PulseAudio c'est bien déroulé.
J'ai du son, sauf dans Ioquake3 ou j'en ai maintenant plus du tout.
Ce problème m'embete de plus en plus car je suis donc obligé de passé d'une distrib a une autre.
Je suis ouvert a ce niveau la mais j'aurais préféré me stabilisé pour le moment.
J'aime le "Look and Feel" d'OpenSuSE! ^^

Donc je repars de zero concernant mon probleme de son avec Ioquake3!
Cependant je m'étonnes quand meme que peu de personnes n'ai été confronté à ce souci dans la communauté OpenSuSE.
( N'y aurait-il pas de joueurs sous cette distrib? :unsure: )

genome
19/09/2008, 22h06
Salut,

C'est un problème avec OpenAL, j'ai eu la même chose avec Supertuxracer. Il faut créer un fichier ".openalrc" directement dans ton home et y mettre :

(define devices '(oss))

Si ça marche toujours pas, essaie d'autres valeurs à la place de "oss" (par exemple "sdl", "alsa"...)

Gabou
19/09/2008, 23h51
Probleme résolu!

Pas besoin de désinstaller PulseAudio. (J'ai fait la procédure suivante à partir d'une "fresh install")
Attention a ne pas oublier toutefois d'installer "openal" (présent dans les dépots), sans quoi les jeux basés sur Ioquake3 ne se lanceront pas du tout!

Après certains tests que j'ai fait il s'avère qu'il n'y a pas besoin de crée de fichier ".openalrc". (test fait sous OpenSuSE 11.0)

Voici la solution au problème: il faut dans Ioquake3 appeler la console de jeu (touche ² ou Alt Gr + é) et y entrer le code suivant:


/s_useopenal 1

et ensuite


/snd_restart

J'ai ensuite redémarré le jeu et depuis tout marche parfaitement! Plus aucun probleme de son!

Merci encore à Phoenix et Genome! :D