PDA

Afficher la version complète : [Réglé] basket ne marche plus!!!



moniroje
25/11/2008, 20h10
Pour que ça ne marche plus (alors que avant, ça marchait autant sur suse que sur ma debian), voilà ce que j'ai fait:
En Debian, j'ai ajouté un utilisateur: tagada; pour celui-ci, j'ai installé Basket en pointant lui aussi vers le répertoire utilisé jusqu'à présent en commun par Suse et Debian.
Oui mais ça ne marchait pas. Je fais donc Propriétés-Droits d'accès et là, je coche Peut lire et écrire pour Groupe et Autres. Et, chouette, le nouvel user Debian: tagada, a accès à mes notes sur Basket....

L'ennui, c'est que revenu au user alain de Debian , quand j'ouvre Basket, j'ai une fenêtre blanche avec: Mauvaises permissions sur les fichiers du panier. Les permissions sont mauvaises. Veuillez vérifier que vous avez les droits en écriture sur celui-ci ainsi que sur les dossiers-parents et plus moyen de fermer cette fenêtre blanche (même avec Ctrl-Alt-Echap); chuis obligé de kill basket pour m'en débarrasser.

Je refais donc répertoire basket, Propriétés- droits d'accès et je remets: Proprio: peut lire et modifier le contenu. Groupe: Peut lire Autres: Peut lire : rien n'y fait: alain n'a plus accès à son basket!!!

Vous avez un remède???

edit: là, je suis sur Suse et là aussi, plus moyen d'accèder à mes notes basket!!!! nom de nom, c'est quoi que j'ai fait????

thveillon
25/11/2008, 20h37
J'aime bien le début de ton sujet: "Pour que ça ne marche plus,[...], voilà ce que j'ai fait:" , on dirait un wiki Linux écrit par Garcimor (http://fr.wikipedia.org/wiki/Garcimore) !


Pour en revenir au problème, sur les répertoires il faut mettre le droit en exécution, car ce droit est nécessaire pour "traverser" ou "cd" le répertoire. Si tu n'as que deux utilisateurs sur ta machine tu peux les ajouter au groupe "users" et faire appartenir le répertoire à ce groupe, tout dépend du résultat voulu. Si tu veux au contraire que les docs soient accessibles en lecture et écriture, mais effaçable seulement par le propriétaire tu peux utiliser le bit "sticky" (http://fr.wikipedia.org/wiki/Permissions_Unix#Sticky_Bit) .

Pour voir ce qu'il en est actuellement un "ls -l" sur les répertoires en question vaudrait mieux qu'un long discours.

moniroje
25/11/2008, 20h43
Me revoilà sur Debian user tagada; ici, basket fonctionne; un clic-droite sur Propriétés du répertoire et, surprise, les Droits d'accès ne sont plus modifiables, en grisé...
OK, voilà le

tagada@debian:/Mesdocs/alain/Documents$ ls -l BasketSuseDebian
total 32
drwxrwxrwx 2 alain alain 4096 mar 14 2008 backgrounds
drwxrwxrwx 16 alain alain 4096 nov 25 19:25 baskets
drwxrwxrwx 2 alain users 4096 oct 24 16:59 Images par liens
drwxrwxrwx 2 alain alain 4096 mar 14 2008 tag-emblems
-rw-rw-rw- 1 alain users 8623 mai 30 16:18 tags.xml
drwxr-xr-x 2 tagada tagada 4096 nov 25 19:25 temp-cut
tagada@debian:/Mesdocs/alain/Documents$

Ce que je veux c'est que les users de suse, de debian qui sont sur ma machine que ma pomme puissent faire ce qu'ils veulent avec basket: lire, écrire, effacer.

thveillon
25/11/2008, 21h18
Le problème vient sans doute du répertoire temporaire "temp-cut", il faut au minimum le rendre rwx pour tous les utilisateurs, ça sera facilement fait en utilisant "users" comme groupe et en ajoutant tes utilisateurs à ce groupe, ou en le rendant rwx pour "others". S'il n'y a pas d'accès concurrentiels (plusieurs comptes utilisant Basket en même temps) tu peux te passer du "sticky bit" sur ce répertoire, mais c'est d'une manière générale une bonne solution sur les répertoires temporaires et dans certains cas de partages.

moniroje
25/11/2008, 22h35
Rendre temp-cut rwx pour tous les utilisateurs, je le fais par clic-droite sur temp-cut-Propriétés-droits d'accès où je mets "Peut voir et modifier le contenu" à Groupes et à Autres.

Sinon, comment fait-on pour
<div class='quotetop'>Citation </div>
ça sera facilement fait en utilisant "users" comme groupe et en ajoutant tes utilisateurs à ce groupe[/b]
?
Vais tout de suite sur Debian-alain pour voir si amélioration.

Ben non, ça ne marche toujours pas...


Le message d'erreur, je le regarde à nouveau, dit que je n'ai pas les droits pour /baskets/basket.xml qui est un fichier à côté de toutes mes notes. Donc lui je dois changer les droits.
Hélas, Propriétés-Droits d'accès: il est en grisé avec le proprio qui peut lire et écrire et Autres et Groupe qui ne peuvent que lire. Nota: utilisateur: tagada et groupe tagada.

Je fais ceci: je renomme basket.xml en basketnaze.xml puis je lance basket!!! Génial, il marche mais qu'avec un dossier Général vide... Je regarde dans /basket et constate qu'il a créé un nouveau fichier basket.xml; et ce fichier, par Propriétés-droits d'accès- pas du tout en grisé, hop!!! je change les droits: Proprio et Groupes et Autres ont le droit de lire et d'écrire.
Puis je regarde dedans: voilà ce qu'il y a:
Général basket
Je regarde dans basketnaze.xml :
<div class='quotetop'>Citation </div>
Linux basket Lignes de commande basket Debian basket PureOs basket Suse tuto basket Suse 11.0 basket Suse selon journaux basket Bienvenue folder_home Ex.: Notes knotes Ex.: Recherche folder_violet Astuces ktip Open-Office.org basket Adrienne basket Gimp basket[/b]
où je reconnais tous les titres de paniers de mes notes.
Donc, mon idée est de copier ce texte de naze et de le mettre dans le nouveau fichier basket.xml
L'ennui est que copier le texte, ça le fait, coller, il n'y a pas....


Je vais y arriver!!! je vais y arriver!!! je sens ça!!!
kdesu kwrite et voilà le fichier baskets.xml
<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'><?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE basketTree>
<basketTree>
<basket lastOpened="true" folderName="basket15/" >
<properties>
<name>Général</name>
<icon>basket</icon>
<appearance backgroundColor="" backgroundImage="" textColor="" />
<disposition mindMap="false" columnCount="1" free="false" />
<shortcut combination="" action="show" />
<protection key="" type="0" />
</properties>
</basket>
</basketTree></div>
Maintenant, le fichier en grisé pour les droits d'accès, l'ancien, celui que j'ai appelé nase:
<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'><?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE basketTree>
<basketTree>
<basket lastOpened="true" folderName="basket14/" >
<properties>
<name>Linux</name>
<icon>basket</icon>
<appearance backgroundColor="" backgroundImage="" textColor="" />
<disposition mindMap="false" columnCount="1" free="false" />
<shortcut combination="" action="show" />
<protection key="" type="0" />
</properties>
</basket>
<basket folderName="basket7/" >
<properties>
<name>Lignes de commande</name>
<icon>basket</icon>
<appearance backgroundColor="" backgroundImage="" textColor="" />
<disposition mindMap="false" columnCount="1" free="false" />
<shortcut combination="" action="show" />
<protection key="" type="0" />
</properties>
</basket>
<basket folderName="basket8/" >
<properties>
<name>Debian</name>
<icon>basket</icon>
<appearance backgroundColor="" backgroundImage="" textColor="" />
<disposition mindMap="false" columnCount="1" free="false" />
<shortcut combination="" action="show" />
<protection key="" type="0" />
</properties>
</basket>
<basket folderName="basket9/" >
<properties>
<name>PureOs</name>
<icon>basket</icon>
<appearance backgroundColor="" backgroundImage="" textColor="" />
<disposition mindMap="false" columnCount="1" free="false" />
<shortcut combination="" action="show" />
<protection key="" type="0" />
</properties>
</basket>
<basket folded="false" folderName="basket10/" >
<properties>
<name>Suse tuto</name>
<icon>basket</icon>
<appearance backgroundColor="" backgroundImage="" textColor="" />
<disposition mindMap="false" columnCount="1" free="false" />
<shortcut combination="" action="show" />
<protection key="" type="0" />
</properties>
<basket folderName="basket12/" >
<properties>
<name>Suse 11.0</name>
<icon>basket</icon>
<appearance backgroundColor="" backgroundImage="" textColor="" />
<disposition mindMap="false" columnCount="1" free="false" />
<shortcut combination="" action="show" />
<protection key="" type="0" />
</properties>
</basket>
</basket>
<basket folderName="basket11/" >
<properties>
<name>Suse selon journaux</name>
<icon>basket</icon>
<appearance backgroundColor="" backgroundImage="" textColor="" />
<disposition mindMap="false" columnCount="1" free="false" />
<shortcut combination="" action="show" />
<protection key="" type="0" />
</properties>
</basket>
<basket folded="false" folderName="basket2/" >
<properties>
<name>Bienvenue</name>
<icon>folder_home</icon>
<appearance backgroundColor="" backgroundImage="strings.png" textColor="" />
<disposition mindMap="false" columnCount="0" free="true" />
<shortcut combination="" action="show" />
<protection key="" type="0" />
</properties>
<basket folderName="basket3/" >
<properties>
<name>Ex.: Notes</name>
<icon>knotes</icon>
<appearance backgroundColor="#cce6ff" backgroundImage="pins.png" textColor="" />
<disposition mindMap="false" columnCount="0" free="true" />
<shortcut combination="" action="show" />
<protection key="" type="0" />
</properties>
</basket>
<basket folderName="basket4/" >
<properties>
<name>Ex.: Recherche</name>
<icon>folder_violet</icon>
<appearance backgroundColor="#e6ccff" backgroundImage="pens.png" textColor="" />
<disposition mindMap="false" columnCount="0" free="true" />
<shortcut combination="" action="show" />
<protection key="" type="0" />
</properties>
</basket>
<basket folderName="basket5/" >
<properties>
<name>Astuces</name>
<icon>ktip</icon>
<appearance backgroundColor="#ffffcc" backgroundImage="light.png" textColor="#000000" />
<disposition mindMap="false" columnCount="1" free="false" />
<shortcut combination="" action="show" />
<protection key="" type="0" />
</properties>
</basket>
</basket>
<basket folderName="basket6/" >
<properties>
<name>Open-Office.org</name>
<icon>basket</icon>
<appearance backgroundColor="" backgroundImage="" textColor="" />
<disposition mindMap="false" columnCount="1" free="false" />
<shortcut combination="" action="show" />
<protection key="" type="0" />
</properties>
</basket>
<basket folderName="basket13/" >
<properties>
<name>Adrienne</name>
<icon>basket</icon>
<appearance backgroundColor="" backgroundImage="" textColor="" />
<disposition mindMap="false" columnCount="1" free="false" />
<shortcut combination="" action="show" />
<protection key="" type="0" />
</properties>
</basket>
<basket folderName="basket1/" >
<properties>
<name>Gimp</name>
<icon>basket</icon>
<appearance backgroundColor="" backgroundImage="" textColor="" />
<disposition mindMap="false" columnCount="1" free="false" />
<shortcut combination="" action="show" />
<protection key="" type="0" />
</properties>
</basket>
</basketTree></div>
et là, normalement, effacer le contenu du premier fichier et y copier-coller celui-ci, ça devrait marcher, non???
J'attends un peu au cas où vous diriez: "T'es fou!!! surtout pas ça!!!"

moniroje
25/11/2008, 23h37
Voilà, je me suis lancé: et ça marche!!! Que je sois Debian-alain ou Debian-tagada j'ouvre baskets avec toutes mes notes.
A tout hasard, je regarde par Suse et là, déception:
<div class='quotetop'>Citation </div>
Les permissions du fichier /Mesdocs/alain/Documents/BasketSuseDebian/baskets/baskets.xml sont mauvaises. Veuillez vérifier que vous avez les droits sur celui-ci, ainsi que sur les dossiers parents...[/b]
snif... et obligé de le killer...
Quand même curieux!!! il est à Propriétés-droits d'accès à nouveau grisé avec Peut lire et écrire rien que pour le proprio, les autres ne pouvant que lire. Appartenance: tagada et pourquoi tagada??? que je n'y ai mis basket qu'aujourd'hui??? et groupe 1001 , tiens, ça c'est nouveau!!!
Là, je fatigue, vais me coucher....
Désinstaller basket de suse et le re-installer n'y fera rien si je veux qu'il se dirige vers mes notes....
zut!

thveillon
26/11/2008, 00h19
Lorsque tu donnes à un dossier/fichier le groupe "tagada" comme propriétaire, le seule membre de ce groupe est à priori l'utilisateur "tagada", et personne d'autre. L'utilisateur "tagada" lui est (seul) membre du groupe "tagada", et de quelques autres (groupes "audio", "scanner", "video", "floppy", "cdrom", "sudo"... que sais-je encore, la commande "groups" te renseignera sur tous les groupes auquel l'utilisateur appartient).

"alain" lui est (seul) membre du groupe "alain", de quelques autres également (comme précédemment ), mais PAS du groupe "tagada".

Les fichiers créés par un utilisateur prennent comme groupe le groupe principal du créateur, soit pour l'utilisateur "alain" "alain:alain", et ce fichier ne sera pas accessible par "tagada" (sauf si "others" a un accès rwx, ce qui ne sera pas le cas par défaut).

Pour arriver à ce que tu veux il faut utiliser une astuce:

avoir un groupe en commun pour "alain" et "tagada" ("users"), et utiliser le bit "setgid" sur le répertoire "basket" pour que tous les éléments créés dans ce répertoire prennent le bon groupe ("users") au lieu du groupe principal de l'utilisateur.

1° Donc il faut commencer par ajouter les utilisateurs au groupe "users", ça ne prendra effet qu'après avoir redémarré une session pour l'utilisateur en court :


su
usermod -aG users alain
usermod -aG users tagada

Terminer sa session, et en démarrer une nouvelle (pour tous les utilisateurs si alain et tagada sont connectés en même temps.

2° Changer le groupe du répertoire "basket" et de TOUS les sous-répertoires à "users" :


su
chgrp -R users basket (ça se fait dans le répertoire qui contient "basket" évidemment)

3° Donner des droits rwxrwxr-x à "basket" et à TOUS les sous-répertoires, et donner également le "bit setgid"


su
chmod -R 2775 basket

À partir de maintenant tous les fichiers créés dans "basket" prendront le groupe "users", et seront lisibles/modifiables/effaçables par les membres de ce groupe.

Attention aux commandes, pas de moufles quand on est en root avec des "chmod" et "usermod", sinon ça peut faire mal !
Et bien commencer par se placer dans le répertoire où se trouve "basket" avec la commande "cd" avant les "chgrp" et "chmod" !

PS: pour que ça fonctionne avec la suse aussi il faut que l'utilisateur de Suse soit aussi membre du groupe "users" ("sudo usermod -aG users ton_user"), et que ce groupe ait le même gid (100 par défaut sur Debian, je pense que c'est pareil sur Suse, sinon pour le changer sur la suse c'est "sudo groupmod -g 100 users" )

moniroje
26/11/2008, 17h43
Au lieu d'aller me coucher, j'ai insisté et ce matin, ai jugé préférable de:
1°) nettoyer: dans /BasketSuseDebian, tout ce qui n'était pas les paniers de mes notes, hop: viré! ensuite j'ai remonté ce dossier et renommé en: /Mesdocs/alain/BasketDebSuse
2°) m'inspirer de ta lecture (en inspirant profondément)

alain@debian:~$ groups
alain dialout cdrom floppy audio video plugdev netdev powerdev fuse
alain@debian:~$ man groups
alain@debian:~$ groups tagada
tagada fuse
alain@debian:~$
puis:

su
usermod -aG users alain
usermod -aG users tagada
et le:

alain@debian:/Mesdocs/alain$ su
Mot de passe :
debian:/Mesdocs/alain# chgrp -R users basket
chgrp: ne peut accéder `basket': Aucun fichier ou répertoire de ce type
J'étais dans /Mesdocs/alain où je pouvais voir le dossier BasketDebSuse; vais donc descendre d'un cran:

debian:/Mesdocs/alain# cd /Mesdocs/alain/BasketDebSuse
debian:/Mesdocs/alain/BasketDebSuse# chgrp -R users basket
chgrp: ne peut accéder `basket': Aucun fichier ou répertoire de ce type
_Ah??? OK, c'est parce que le maître a dit basket alors que dans /BasketsDebSuse/ il y a baskets... avec un s

debian:/Mesdocs/alain/BasketDebSuse# chgrp -R users baskets
debian:/Mesdocs/alain/BasketDebSuse#
ça semble avoir marché; je continue:

alain@debian:/Mesdocs/alain/BasketDebSuse$ su
Mot de passe :
debian:/Mesdocs/alain/BasketDebSuse# chmod -R 2775 baskets
debian:/Mesdocs/alain/BasketDebSuse#
et je suis arrivé au PS: où, je suppose, faut ouvrir Suse; je tape:
sudo usermode -aG users alain : il me répond: command not found, même quand auparavant, je fais un su
sudo groupmode -g 100 users : même réponse, il trouve pas...

Etant dans Suse, j'y reste et j'ouvre Basket-sauvegarder et restaurer-utiliser un autre dossier existant et je choises mon nouveau tout propre: /Mesdocs/alain/BasketDebSuse
Il s'ouvre mais sur le panier Général qui est vide: donc opérationnel mais n'ayant pas tenu compte des paniers de mes notes. Certes, son fichier baskets.xml ne doit avoir que Général...
Préparant mon coup insidieusement, je clique droite baskets.xml Propriétés-droits d'accès et Lire et écrire, je rajoute Groupes et Autres; idem pour temp-cut; par contre le répertoire baskets, ses droits d'accès sont en grisé!!! Oui mais il y a Droits d'accès avancés où je peux cocher Ecriture et tant qu'à faire sticky.
Puis mon coup que j'ai mijoté: je kdesu kwrite baskets.xml, en fait une sauvegarde; ensuite je copie le naze que j'avais mis à Alionet (chez moi, ce matin, j'avais tout effacé) et Enregister.
J'ouvre Basket: la vache, ça roule!!!! tous mes paniers, toutes mes notes!!!! sauf le premier panier: Linux qui reste en chargement plusieurs minutes. Je pige que le copier-coller ne l'a pas mis exactement où il fallait. Je le supprime, quitte à y remettre plus tard sa sauvegarde d'il y a un mois. Je supprime aussi Général.
Donc, chez Suse, ça roule. Je passe à Debian, user alain: merci thveillon!!! c'est!!!!! J'écris une note pour voir, au cas où....
Reboot et Debian user tagada: alors là, ça déconne mais d'une façon inédite:
<div class='quotetop'>Citation </div>
Espace disque insuffisant pour enregister le panier.
Veuillez supprimer des fichiers sur le disque /Mesdocs[/b]
Editor partitions me montre que /Mesdocs a 141 Go dont 11 utilisés...
Je reviens à Debian-alain: basket nickel!!!
Tit tour à suse: basket aussi nickel!!!
Conclusion: bien content que basket marche sur suse et debian-alain : c'est l'essentiel; et j'ai appris plein de trucs. Et debian-tagada, qu'il reste dans le X. Petite déception: finalement, tout ça pour en revenir à mon point de départ, avant que je crée tagada
Si t'en as marre, on peut dire Réglé à ce post. Si t'en as pas marre, pourquoi tagada-basket trouve que 130 Go, c'est pas assez grand pour lui???

thveillon
26/11/2008, 18h14
Le dossier cible est à adapter à ton système, s'il s'appelle "BasketSuseDebian" c'est ça qu'il faut mettre.

Pour les commandes non-trouvées sur Suse c'est du à la variable PATH (l'ensemble des chemins dans lequel le shell cherche les commandes) de l'utilisateur, par défaut elle ne contient pas /usr/sbin et /sbin, pour que ça fonctionne il faut passer root, ou alors mettre le chemin complet (/usr/sbin/usermod, la commande "which" te donnera le chemin), ou encore modifier le PATH (c'est une autre histoire).


Tu dis avoir mis le "sticky bit", c'est fait pour que dans un dossier partagé (typiquement un dossier temporaire ou un partage réseau) les fichiers soient accessibles par tous (avec des droits rwxrwxrwx), mais effaçable seulement par leur propriétaire et non par les membres du groupe ou de "others", vu ton objectif je ne pense pas que ça soit adapté, le bit setgid est plus indiqué, avec des droits rwxrwxr-x correctement appliqués.

C'est bien que ça fonctionne à peu près, mais si tu ne comprends pas la logique de la chose ça risque de coincer à nouveau, et tu ne sauras pas quoi faire... Sans compter que si tu restaures une sauvegarde les droits et permissions seront différents...

moniroje
26/11/2008, 18h28
Mon dossier-cible est : /Mesdocs/alain/BasketDebSuse
Comment le mettre ? puisque dès que Basket s'ouvre chez tagada, il est naze avec ce message débile et que je ne peux que faire Ctrl-Alt-Echap
Ah oui, j'ai aussi essayé la ligne de commande en tapant basket pour que ça me montre les erreurs; en fait à peine Entrée après avoir tapé basket, j'ai la fenêtre naze avec message naze. Si je la Ctrl-Alt-Echap, la console ne me montre rien d'autre que ce que j'ai tapé.

OK, vais enlever "sticky bit" : en le voyant, ça m'a rappelé que tu m'avais dit un truc à ce sujet et je l'ai confondu avec le bit setgid dont tu parlais. Où est ce bit setgid???

Mais si que je comprends la logique des choses;.. . enfin, un tit peu... faudra que je mette tout ça dans mes baskets, bien rangé, et je comprendrai un peu plus. Et si ça coince, au cas où, je vais en faire une copie ailleurs que dans baskets.

thveillon
26/11/2008, 19h44
Si tu veux mettre le bit setgid en mode graphique ça s'appel "donner le GID" dans la version française de KDE, mais de cette manière il faut cocher "appliquer les modifications aux sous-dossiers et à leur contenu" (c'est équivalent à l'option "-R" de la ligne de commande) pour que ce soit récursif.

À ce stade il faudrait nous donner le résultat de :


ls -l /Mesdocs/alain/ | grep BasketDebSuse

ls -Rla /Mesdocs/alain/BasketDebSuse

Pour trier le bon grain de l'ivraie. Ça va être long, mets tout ça entre "codebox".

moniroje
26/11/2008, 20h03
OK, j'ai trouvé: clic-droite sur /Mesdocs/alain/BasketDebSuse puis Propriétés-Droits d'accès-Droits d'accès avancés et là, je coche: Donner le GID.
Je ne vois pas: "Appliquer les modifs aux sous-dossiers et à leur contenu"
Puis, à ce stade, voilà le résultat:

<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>alain@debian:~$ ls -l /Mesdocs/alain/ | grep BasketDebSuse
drwxrwsrwx 5 alain alain 4096 nov 26 18:31 BasketDebSuse
alain@debian:~$ ls -Rla /Mesdocs/alain/BasketDebSuse
/Mesdocs/alain/BasketDebSuse:
total 32
drwxrwsrwx 5 alain alain 4096 nov 26 18:31 .
drwxrwxrwx 57 alain users 4096 nov 26 13:49 ..
drwxrwsrwx 19 alain users 4096 nov 26 18:31 baskets
drwxr-xr-x 2 alain users 4096 nov 26 14:44 tag-emblems
-rw-rw-rw- 1 alain users 4705 nov 26 14:03 tags.xml
drwxr-xr-x 2 alain alain 4096 nov 26 18:31 temp-cut

/Mesdocs/alain/BasketDebSuse/baskets:
total 104
drwxrwsrwx 19 alain users 4096 nov 26 18:31 .
drwxrwsrwx 5 alain alain 4096 nov 26 18:31 ..
drwxrwsr-x 2 alain users 4096 oct 24 18:37 basket1
drwxrwsr-x 2 alain users 4096 nov 7 10:57 basket10
drwxrwsr-x 2 alain users 4096 oct 19 12:24 basket11
drwxrwsr-x 2 alain users 4096 nov 22 21:10 basket12
</div>

Désolé, mais le codebox n'a pas l'air de marcher... J'ai recommencé par Modifier mais ça fait pareil...

moniroje
26/11/2008, 22h38
Quand je dis: "Je ne vois pas: "Appliquer les modifs aux sous-dossiers et à leur contenu" je le vois mais le fenêtre Droits d'accès étant en grisé, je ne peux pas cocher

phoenix
26/11/2008, 23h57
Le codebox :'(

moniroje
27/11/2008, 00h18
ben wé, ça n'a pas marché!!! j'ai essayé deux fois par Insérer CODEBOX, là, à gauche

thveillon
27/11/2008, 01h01
Avec ce beau (et long !) "ls" j'imagine que tu vas mieux visualiser les points qui coincent :

_Là où un répertoire n'a pas le "s" qui indique le bit setgid il y a problème.

_Là où un fichier/répertoire n'appartient pas au groupe "users" il y a problème

_Là où un répertoire n'a pas les permissions drwxrwsr-x(le "d" au début indique juste "directory", soit "répertoire". Le "s" c'est le bit setgid.) il y a problème.

_Là où un fichier n'a pas les permissions rwxrwxr-x au minimum il y a problème.


... Reste à reprendre ton "ls" et traquer les erreurs, où tout corriger en bloque avec :


su
chgrp -R users /Mesdocs/alain/BasketDebSuse/
chmod -R 2775 /Mesdocs/alain/BasketDebSuse/

la ligne "chmod" va donner le bit setgid à tous les éléments, en pratique ça n'est utile que sur les répertoires, mais ce n'est pas un problème sur les fichiers. Les permissions "2775" correspondent à : gid ou "s" (le 2), rwx (le 7), rwx (le 7), et r-x (le 5). Ça donnera donc rwxrwsr-x .

Il faut aussi que tu ais bien ajouté tes utilisateurs au groupe "users", y compris dans Suse (j'ai vérifié et le gid de "users" dans Suse est 100 également, donc pas de problème).

Si tu préfères la méthode graphique, et cliquer sur chaque élément dans une fenêtre de konqueror pour ouvrir les propriétés > permissions > permissions avancées tu peux aussi... mais tu vas vite constater l'utilité de la ligne de commande ! Dès qu'il y a plus de deux éléments à traiter, ou plus d'une opération à effectuer, la ligne de commande s'impose sans hésitation...

phoenix
27/11/2008, 11h07
Mince, c'est vrai que le codebox ne veut pas marcher. Va falloir que je m'y penche...

moniroje
27/11/2008, 15h44
J'ai donc fait comme tu m'as dit:

su
chgrp -R users /Mesdocs/alain/BasketDebSuse/
chmod -R 2775 /Mesdocs/alain/BasketDebSuse/
et enfin!!! basket marche autant avec le user alain de debian que le user tagada de debian.
Oui mais...
je passe à suse (qui ouvrait dernièrement basket) et là, avec le user alain de suse, ça s'ouvre mais avec ce fichu message:
<div class='quotetop'>Citation </div>
Mauvaises permissions sur le fichier /Mesdocs/alain/BasketDebSuse/baskets/baskets.xml[/b]
Je vais par Konqueror regarder ce fichier; en droits d'accès il y a: Propriétaire: peut lire et écrire et Groupes et Autres: peut lire. Avec: utilisateur: tagada Groupe 1001
Je reviens à ton aideci-dessus:
"Pour que ça fonctionne avec la Suse, il faut que l'utilisateur sur Suse soit aussi membre du groupe users...
Je suis sur Suse, user: alain et je tape:

alain@linux-9rwn:~> sudo usermod -aG users alain
root's password:
sudo: usermod: command not found
alain@linux-9rwn:~> which usermod
which: no usermod in (/opt/kde3/bin:/usr/lib64/mpi/gcc/openmpi/bin:/home/alain/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib64/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin)
alain@linux-9rwn:~> sudo /usr

Apparemment which n'a pas suggéré /usr/sbin ; je regarde par Konqueror: il y a bien /usr/sbin mais dedans, il n'y a pas usermod
... pffff... c'est compliqué!!!! on dirait un sac de noeuds. Quand j'arrange basket pour Suse et Debian, le user tagada de Debian ne peut l'ouvrir . On arrive à arranger pour que tagada ait lui aussi accès à basket mais en contre-partie, le user alain de suse n'y accède plus!!

Il y a bien la solution radicale: retour case Départ: je supprime le user tagada de Debian; je désinstalle basket sur suse et Debian, je nettoie le dossier basketsDebSuse de tout ce qui n'est pas mes notes; puis hop, je re-installe basket sur suse et Debian.

moniroje
27/11/2008, 16h57
et re zut!!!
de retour sur Debian-alain et si j'ouvre basket, même message que sur Suse!
les permissions sur le fichier baskets.xml sont mauvaises!!!
Je crois que c'est parce que je rajoute des notes: dans baskets, je copie-colle nos messages pour les garder pour mon instruction...
J'attends un peu votre avis et sinon, ce soir, je vire tout et je re-installe pour retrouver comme avant: un basket qui marche avec alain de suse et alain de Debian.
Un tit tour sur Debian-tagada: là, il marche. Bon, je vais sauvegarder tous mes paniers en tar.gz au cas où que je désinstalle Basket pour le re-installer tout neuf ensuite.

thveillon
27/11/2008, 19h26
"usermod" est dans /usr/sbin, si tu fais le "which" depuis ton utilisateur la commande ne va chercher que sur ton PATH... qui ne contient pas /usr/sbin. Si tu fais un "sudo which" tu devrais le trouver.
Sinon tu peux utiliser Yast pour faire ça en graphique.

Ça serait pas mal d'arrêter de copier/coller des morceaux pendant que tu mets tout en place, sinon tu vas à chaque fois introduire des erreurs difficiles à diagnostiquer... Tu fais ces ajouts par copier/coller depuis quel système, quel utilisateur, de quelle façon ?

L'autre question c'est que tu as deux comptes sur Suse et Debian avec le même nom, mais sans doute pas le même user ID. Où est situé la partition qui contient le dossier de basket, et est-ce que les répertoires /home sont partagés ?

moniroje
27/11/2008, 20h00
Je fais ces ajouts par copier-coller depuis Suse, user: alain ou Debian, user: alain et récemment, Debian: user: tagada; c'est selon là où je suis et que je lis Alionet.
Parce que je me sers de basket pour réunir toutes les réponses alionet à mes questions ou aux questions des autres qui pourraient m'intéresser. C'est ma bible linux, super-efficace avec son filtre.
De quelle façon? tu me demandes; ben, avec copier-coller

Oui, je m'appelle alain sur suse et aussi sur debian (c'est quoi, un user ID ?) : par commodité; mais pas avec le même mot de passe et déjà, rien que ça, si je ne l'écris pas quelque part, danger. C'est déjà arrivé.

Non, Suse a sa partition /home, en sda7 et Debian sa partition /home, en sda9 : donc pas de /home partagés; parce que j'avais bien lu qu'il fallait pas le partager avec le même user.
Et Basket, je l'ai installé dans suse par Yast; et plus tard, je l'ai installé dans Debian par Synaptic..
Il n'y a que le dossier de sauvegarde de basket, celui qui contient mes notes alionet, qui est partagé: il est dans ma partition /Mesdocs, sda8, mes données persos où je puise quelque soit le système où je suis.

moniroje
27/11/2008, 21h27
Passé à Deb user tagada et là, Basket marche. J'ai regardé ses proprité et j'ai coché pour tous les droits en écriture et le Gid et les sous-dossiers; Basket marche toujours. J e passe à Deb-user alain: tiens!!! il marche!!! Je reboot sur suse et là aussi, ça marche!!! :)
J'espère la question réglée.
Vais rajouter une note; et regarder à nouveau si ça marche partout.

Passé à Deb user tagada et là, Basket marche. J'ai regardé ses proprité et j'ai coché pour tous les droits en écriture et le Gid et les sous-dossiers; Basket marche toujours. J e passe à Deb-user alain: tiens!!! il marche!!! Je reboot sur suse et là aussi, ça marche!!! :)
J'espère la question réglée.
Vais rajouter une note; et regarder à nouveau si ça marche partout.

Donc à suse, j'ouvre basket, j'écris une note. Puis je passe à deb alain: basket s'ouvre sans pb; je rajoute encore une note; puis je passe à deb-tagada et là, déception! basket coince!!! Je regarde à nouveau les droits d'accès et je vois que à temp-cut et baskets.xml, se sont décochés ce que j'avais coché (écriture pour Groupes et Autres) et pas moyen de modifier: fenêtre en grisé et droits avancés inaccessibles.
J'enlève basket de debian-tagada.
J'essaie à debian-alain: ouf!! basket marche toujours. Je reboote sur suse et là aussi, basket fonctionne.
Bon, de toute façon, c'est l'essentiel et je m'en contente: merci pour ton aide et ta patience et tout ce que tu m'as appris.

thveillon
27/11/2008, 21h35
l'identifiant d'un utilisateur est un chiffre normalement unique qui lui est attribué, généralement supérieur à 999 car en dessous c'est réservé aux comptes système. Tu peux voir la liste des id des groupes auxquels tu appartient, et le tien par la même occasion, avec :


egrep alain /etc/group

pour l'utilisateur alain.

Le copier/coller à l'intérieur d'un fichier déjà existant, où le glisser/déposer depuis un navigateur de fichier peuvent donner des choses étranges au niveau des permissions. Tu peux facilement vérifier si c'est le cas avec la commande "ls" donnée précédemment. Ou plus rapidement avec "find" et une expression du type :


find /Mesdocs/alain/BasketDebSuse/ -type d ! -group users -exec ls -l '{}' ';'

Ça c'est pour les répertoires uniquement, pour trouver aussi les fichiers c'est la même chose avec "-type f" au lieu de "-type d", ou pour avoir les deux en même temps on enlève l'option "-type".

Pour trouver tous les répertoires qui n'ont pas le bit suid et les permissions rwxrwxr-x ça donne :


find /Mesdocs/alain/BasketDebSuse/ -type d ! -perm 2775 -exec ls -l '{}' ';'

Pour l'explication la commande est "find" suivie du chemin de recherche, l'option "-type" indique le type d'élément à chercher (fichier ou répertoire), "-group" le groupe, "-perm" les permissions à considérer, "!" est une exclusion d'une option ("qui n'est pas"), et ce qui suit "-exec" est exécuté sur le résultat.



Pour tester si ça marche façon bourrin tu peux essayer de mettre tout en rwxrwxrwx, tu verras si ça fonctionne comme ça, et on pourra partir de là pour affiner. Pour faire ça c'est


chmod -R 0777 /Mesdocs/alain/BasketDebSuse/


PS: tu as écrit en même temps, si le résultat te suffit à toi de voir...

moniroje
27/11/2008, 23h45
Super!!! on continue!!!!

alain@linux-9rwn:~> find /Mesdocs/alain/BasketDebSuse/ -type d ! -group users -exec ls -l '{}' ';'
alain@linux-9rwn:~> find /Mesdocs/alain/BasketDebSuse/ -type d ! -perm 2775 -exec ls -l '{}' ';'
total 20
drwxrwsrwx 19 alain users 4096 nov. 27 21:52 baskets
drwxrwsrwx 2 alain users 4096 nov. 26 14:44 tag-emblems
-rwxrwsrwx 1 alain users 4705 nov. 26 14:03 tags.xml
drwxr-sr-x 2 alain users 4096 nov. 27 20:17 temp-cut
total 96
drwxrwsr-x 2 alain users 4096 oct. 24 18:37 basket1
drwxrwsr-x 2 alain users 4096 nov. 7 10:57 basket10
drwxrwsr-x 2 alain users 4096 oct. 19 12:24 basket11
drwxrwsr-x 2 alain users 4096 nov. 22 21:10 basket12
drwxrwsr-x 2 alain users 12288 nov. 27 21:52 basket13
drwxrwsr-x 2 alain users 4096 nov. 27 21:27 basket14
drwxrwsr-x 2 alain users 4096 nov. 25 20:56 basket15
drwxrwsr-x 2 alain users 4096 nov. 25 22:13 basket16
drwxrwsr-x 2 alain users 4096 nov. 25 22:51 basket17
drwxrwsr-x 2 alain users 4096 avril 21 2008 basket2
drwxrwsr-x 2 alain users 4096 oct. 29 14:09 basket3
drwxrwsr-x 2 alain users 4096 mai 30 17:43 basket4
drwxrwsr-x 2 alain users 4096 nov. 27 11:17 basket5
drwxrwsr-x 2 alain users 4096 sept. 30 16:50 basket6
drwxrwsr-x 2 alain users 4096 nov. 27 21:29 basket7
drwxrwsr-x 2 alain users 4096 nov. 25 14:18 basket8
drwxrwsr-x 2 alain users 4096 oct. 30 22:03 basket9
-rw-r--r-- 1 alain users 4969 nov. 27 21:52 baskets.xml
-rwxrwsr-x 1 root users 443 nov. 26 14:03 baskets.xml~
-rwxrwsrwx 1 tagada users 4969 nov. 26 14:57 baskets.xmlZvgfta.new
total 0
total 0
Je remarque: -rw-r--r-- 1 alain users 4969 nov. 27 21:52 baskets.xml
dis, ya Insérer: CODEBOX, à gauche qui mouline longtemps.... pour le reste je vais Insérer du code , le bouton en haut à droite mais résumer car c'est hyper-immense!!
puis ceci:

alain@linux-9rwn:~> chmod -R 0777 /Mesdocs/alain/BasketDebSuse/
chmod: modification des permissions de `/Mesdocs/alain/BasketDebSuse/baskets/baskets.xml~': Opération non permise
chmod: modification des permissions de `/Mesdocs/alain/BasketDebSuse/baskets/baskets.xmlZvgfta.new': Opération non permise
alain@linux-9rwn:~> su
Mot de passe :
linux-9rwn:/home/alain # chmod -R 0777 /Mesdocs/alain/BasketDebSuse/
linux-9rwn:/home/alain # find /Mesdocs/alain/BasketDebSuse/ -type d ! -perm 2775 -exec ls -l '{}' ';'
total 20
drwxrwsrwx 19 alain users 4096 nov. 27 21:52 baskets
drwxrwsrwx 2 alain users 4096 nov. 26 14:44 tag-emblems
-rwxrwxrwx 1 alain users 4705 nov. 26 14:03 tags.xml
drwxrwsrwx 2 alain users 4096 nov. 27 20:17 temp-cut
total 96
drwxrwsrwx 2 alain users 4096 oct. 24 18:37 basket1
drwxrwsrwx 2 alain users 4096 nov. 7 10:57 basket10
drwxrwsrwx 2 alain users 4096 oct. 19 12:24 basket11
drwxrwsrwx 2 alain users 4096 nov. 22 21:10 basket12
drwxrwsrwx 2 alain users 12288 nov. 27 21:52 basket13
drwxrwsrwx 2 alain users 4096 nov. 27 21:27 basket14
drwxrwsrwx 2 alain users 4096 nov. 25 20:56 basket15
drwxrwsrwx 2 alain users 4096 nov. 25 22:13 basket16
drwxrwsrwx 2 alain users 4096 nov. 25 22:51 basket17
drwxrwsrwx 2 alain users 4096 avril 21 2008 basket2
drwxrwsrwx 2 alain users 4096 oct. 29 14:09 basket3
drwxrwsrwx 2 alain users 4096 mai 30 17:43 basket4
drwxrwsrwx 2 alain users 4096 nov. 27 11:17 basket5
drwxrwsrwx 2 alain users 4096 sept. 30 16:50 basket6
drwxrwsrwx 2 alain users 4096 nov. 27 21:29 basket7
drwxrwsrwx 2 alain users 4096 nov. 25 14:18 basket8
drwxrwsrwx 2 alain users 4096 oct. 30 22:03 basket9
-rwxrwxrwx 1 alain users 4969 nov. 27 21:52 baskets.xml
-rwxrwxrwx 1 root users 443 nov. 26 14:03 baskets.xml~
-rwxrwxrwx 1 tagada users 4969 nov. 26 14:57 baskets.xmlZvgfta.new
total 420
-rwxrwxrwx 1 alain users 0 sept. 15 18:54 note100.html
-rwxrwxrwx 1 alain users 690 oct. 13 17:14 note101.html
-rwxrwxrwx 1 alain users 1606 oct. 16 11:23 note102.html
-rwxrwxrwx 1 alain users 1108 nov. 26 17:48 note103.html
-rwxrwxrwx 1 alain users 878 nov. 26 19:19 note104.html
-rwxrwxrwx 1 alain users 555 mars 17 2008 note10.html
-rwxrwxrwx 1 alain users 584 mars 17 2008 note11.html
......
-rwxrwxrwx 1 alain users 2825 avril 21 2008 writer.desktop
total 0
total 0
linux-9rwn:/home/alain #
et promis-juré, il n'y a que du -rwxwxrwx tout le long

Au fait, pour l'identifiant, je viens d'essayer de sue où je suis actuellement:

alain@linux-9rwn:~> egrep alain /etc/group
dialout:x:16:alain,tagada
video:x:33:alain,tagada
alain@linux-9rwn:~>
je ne vois pas de chiffre > 999

thveillon
28/11/2008, 13h58
Ce que tu as fait c'est donner des droits de lecture/écriture/exécution à tout le monde, forcément ça va fonctionner, mais jusqu'à ce qu'un nouveau fichier soit créé par un utilisateur avec des droits plus restrictifs...

Le résultat de ton "egrep alain /etc/group" est plus surprenant, "alain" est membre de deux groupes en commun avec "tagada", et de rien d'autre, mais il n'y a pas de groupe "alain" ? Ça ne colle pas du tout avec le résultat que tu donnais précédemment :

<div class='quotetop'>Citation </div>
alain@debian:~$ groups
alain dialout cdrom floppy audio video plugdev netdev powerdev fuse
alain@debian:~$ man groups
alain@debian:~$ groups tagada
tagada fuse
alain@debian:~$[/b]


... ? Que c'est-il passé entre-temps ?

Si "alain" n'est membre que de "dialout" et "video", et que "alain" ou "users" n'est pas son groupe primaire tu ne vas tarder à avoir des problèmes.

moniroje
28/11/2008, 14h36
J'ai rien fait du tout, entre temps!!!
Mais je ne t'avais pas dit que sur Suse, j'avais déjà les users alain et tagada (celui-ci, je ne m'en sers quasiment pas) qui datent de la Suse 10.0
Que sur Debian, j'avais le user alain depuis l'install de Debian et que je venais de rajouter cette semaine le user tagada (où j'avais voulu consulter basket, ce qui a entraîné ces ennuis).
Ce matin passé à Debian-alain et basket aussi bien qu'à Suse, comme avant. :)

Oui, je pige:

alain@linux-9rwn:~> egrep alain /etc/group
dialout:x:16:alain,tagada
video:x:33:alain,tagada
alain@linux-9rwn:~>
c'est quand je suis à Suse
et quand je suis Debian, je le refais, c'est:

alain@debian:~$ egrep alain /etc/group
dialout:x:20:alain
cdrom:x:24:alain
floppy:x:25:alain
audio:x:29:alain
video:x:44:alain
plugdev:x:46:alain
users:x:100:alain,tagada
netdev:x:106:alain
powerdev:x:109:alain
alain:x:1000:
fuse:x:116:alain,tagada,root
alain@debian:~$