PDA

Afficher la version complète : travelMate 4270 + Ndiswrapper = Gel du PC



aldolinux
01/12/2008, 09h22
Bonjour

C'est un peu plus complexe que le titre voilà :
le pc est un travelMate 4270 d'acert
l'ubuntu c'est le 8.10
le wifi n'a pas été reconnu à l'installation

lspci donne :
Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)

j'ai installé Ndiswrapper et son interface GTK

j'ai télécharger sur Acer le drivers du wifi (Intel 802.11a+b+g Wireless Lan Driver 10.1.0.11)
utilise le fichier : w39n51
d'apres Ndis le matériel est présent.

Au redémarrage ca a figé

En redémarrant en coupant la carte wifi pas de problème
mais dès que j'active physiquement la carte ... frizz du pc complet
plus de souris plus de clavier...

Quelqu'un a une idée?

aldolinux
01/12/2008, 14h38
Petit "UP"

mince alors ... personne n'a une idée ou une piste ? :unsure:

Heero_Yuy
01/12/2008, 15h23
Tiens, ça me rappelle le problème que j'avais avec ma carte PCMCIA WiFi sur openSUSE 10.0, mais j'ai jamais trouvé la solution.

Je sais, ça ne va pas t'aider.

Par contre, il n'existe pas un driver Linux ? T'es obligé de passer par Ndiswrapper ?

thveillon
01/12/2008, 20h45
Salut,

je passe juste pour essayer de te faire avancer car je n'ai JAMAIS été confronté à ce matériel précis. Cela étant dit, je crois que tu pars sur une fausse piste avec ndiswrapper, ta puce était supporté par le pilote ipw qui est devenu iwl en étant intégré au noyau (vers le 2.6.24 je crois).

Tu peux savoir si le pilote est présent et compilé dans ton noyau avec :


egrep -i '(iwl|ipw)' /boot/config-$(uname -r)

ou


/sbin/modprobe -l | grep -i iwl

Si tu as un "iwl3945.ko" (modules) ou "CONFIG_IWL3945=m" (config) ça devrait faire ton affaire.

Si le pilote inclus n'est pas à jour ou te paraît insatisfaisant, tu en as peut-être un plus récent dans le paquet "linux-backports-modules-intrepid-generic" (ou un truc dans le genre ;) ), il faut activer les dépôts "backport" pour y avoir accès.

Bien entendu il faut désinstaller ndiswrapper proprement avant de charger iwl3945.ko.


L'autre piste, c'est que NetworkManager est vraiment pourri sur Intrepid, particulièrement pour le wifi, je te conseil très vivement de le remplacer par WICD (http://wicd.sourceforge.net/) en attendant qu'une version corrigée voit (éventuellement) le jour.
La seule limitation de wicd c'est l'absence des plugins pour vpn.


Pour l'ajouter tu peux mettre le dépôt dans ton sources.list (conseillé) :

<div class='quotetop'>Citation </div>
deb http://apt.wicd.net intrepid extras[/b]

ou te rendre sur le serveur et télécharger le paquet :

http://apt.wicd.net/dists/intrepid/extras/

La clé gpg de signature du dépôt se trouve là :

http://apt.wicd.net/wicd.gpg

NetworkManager sera marqué en conflit et désinstallé, il n'y a pas de dépendance particulière à part "wireless-tools" et "wpasupplicant".

aldolinux
02/12/2008, 13h34
ah !! ok ok parfait je regarde ca ce midi et je vous dis quoi

j'vous dis pas merci tout de suite pour pas me porter la poisse ... lol

alors visiblement le module est bien là :

candice@candice-laptop:~$ /sbin/modprobe -l | grep -i iwl
/lib/modules/2.6.27-9-generic/kernel/drivers/net/wireless/iwlwifi/iwlagn.ko
/lib/modules/2.6.27-9-generic/kernel/drivers/net/wireless/iwlwifi/iwl3945.ko
/lib/modules/2.6.27-9-generic/kernel/drivers/net/wireless/iwlwifi/iwlcore.ko

mais visiblement c'est pas suffisant puisque ca bug...
j'ai désinstallé ndiswrapper

je ferai les test ce soir avec l'autre programme

merci

thveillon
02/12/2008, 13h48
Bon test, j'avais oublié de signaler qu'il y a une page bien faite sur ubuntu-fr au sujet de WICD : http://doc.ubuntu-fr.org/wicd