PDA

Afficher la version complète : [Réglé] Problème parcage des têtes de disque dur toujours existant ?



Heero_Yuy
01/12/2008, 17h04
Salux,

Il y a quelques temps, un problème de parcage des têtes de disque dur a été mentionné, notamment pour les distrib Debian/Ubuntu (voir ICI (http://doc.ubuntu-fr.org/laptop_mode)).

Je viens d'installer Debian Lenny 64bits sur mon portable ( qui aura une semaine demain ) et je voulais savoir si ce problème existait toujours ?

Merci de votre réponse.

Pumpkin
01/12/2008, 18h49
Vu la date de modification de l'article (2008/11/26), surement qu'il est encore d'actualité.

thveillon
01/12/2008, 20h07
Le bug a affecté Debian aussi, mais à priori il est résolu depuis un moment, voir :

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=448673

par exemple.

Tu peux regarder ce fil (http://forum.debian-fr.org/viewtopic.php?f=3&t=13867&hilit=parcage+des+t%C3%AAtes) pour des tests et des solutions de contournement (il y en a eu plein d'autres, celui-ci m'est revenu...), de même que le paquet "acpi-support" qui contenait à l'époque du problème un script de contournement (mais il a peut-être été retiré depuis.).

D'après ce que j'avais compris à l'époque ça ne touchait que les utilisateurs du paquet "laptop-mode" (ou "laptop-mode-tools"), sur certains modèles de portables.

Personnellement je n'ai jamais été confronté au problème avec Debian, mais je sais qu'il a existé de la même façon que sur Ubuntu.

Heero_Yuy
02/12/2008, 11h07
Merci thveillon ;)

Je vais essayer de voir les manip pour vérifier que le souci existe ou pas sur mon laptop. Je regarderais aussi si j'ai laptop-mode installé - ce que je ne suis pas sûr.

Heero_Yuy
09/12/2008, 12h08
Salux,

Après vérification, laptop-mode ou laptop-mode-tools n'est pas installé.

Je n'ai pas testé le reste, mais je crois que je vais laisser comme ça, surtout si le problème semble résolu. Et comme indiqué chez Ubuntu-fr, ce n'est pas un problème urgent urgent à régler dans l'heure :P

Merci pour votre aide.

thveillon
20/01/2009, 15h35
Surprise ! Sur Ubuntu, et sur certains matériels seulement, le bug était toujours présent ! La preuve c'est qu' un correctif est (enfin !) apparu. Je pense qu'il n'est accessible que via "update-proposed" pour le moment, il devrait passer en màj normale avant Jaunty.

Voir Launchpad (https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/59695)

Burn2
27/04/2010, 21h59
Je crois que j'ai le problème sur mon pc portable (configuré d'origine à 128), j'entends le dd parquer ses têtes assez souvent, et je vois qu'en 57h je suis déjà à 2000 load cycle count, comment on fait pour appliquer définitivement sous openSuse un paramètre du style:
hdparm -B 200 /dev/sda ?

Comment configurer l'Advanced Power Management level définitivement?


EDIT: j'ai rajouté le paquet laptop-tools et tout est ok maintenant pour le parcage. :)

craslin
02/10/2011, 12h04
j'ai rajouté le paquet laptop-tools et tout est ok maintenant pour le parcage. :)

J'ai fait la même chose et après un reboot, je n'entends plus les clics réguliers de mon disque dur que j'entendais très nettement avant.
Qu'est-ce que fait réellement ce paquet sachant que je n'ai rien configuré après l’installation de ce paquet et le reboot de mon pc ?

craslin
03/10/2011, 09h01
Finalement je vais virer le paquet laptop-mode-tools, car il n'est pas vraiment conseillé car il aurait tendance à causer le problème que je souhaite régler chez moi, à savoir le parcage des têtes de mon disque dur.
"The use of Laptop-mode and laptop-mode-tools is not recommended in SuSE Linux. The supplied powersaved already takes care of everything regarding power saving"
http://www.thinkwiki.org/wiki/Laptop-mode

Je vais donc voir ce que fais ce module powersaved, et scruter attentivement le comportement de mon disque dur...

En fait, je n'y comprends pas grand chose dans l'origine ce problème, et donc dans sa résolution...