PDA

Afficher la version complète : Démarrage Gnome = Metacity puis Compiz



Heero_Yuy
09/12/2008, 12h16
Salux,

Je continue de découvrir Debian (sous environnement Gnome) et je dois avouer que je me sens aussi à l'aise que lorsque j'ai débuté avec openSUSE.

Pour le moment, Debian est le seul système installé sur mon portable et risque de l'être un p'tit moment :)

Rien à redire côté install (pas eu de souci). Compiz tourne nickel avec ma carte Intel X3100, mais voilà, au démarrage de Gnome, j'ai noté qu'il commence à lancer Metacity, puis une fois fusion-icon lancée dans le tableau de bord, il lance seulement Compiz.

J'ai cherché sur le Net, et la procédure indiquée est celle que j'ai réalisé avant de chercher. Ajouter fusion-icon dans les programmes à lancer au démarrage de la session Gnome.

Donc, voilà ma question. Comment faire pour que Metacity ne se lance pas au démarrage de Gnome ? Sous openSUSE et Gnome, Compiz se lançait automatiquement, mais là, j'ai cette étape Metacity qui est un peu ennuyante, car je vois mon bureau se lancer une première fois et dès que le tableau de bord apparaît, tout s'efface sur le bureau pour le lancement de Compiz et ensuite tout roule.

J'ai essayé aussi de paramétrer dans gconf-editor, mais la ligne trouvée est marquée obsolète :blink: et dès que je la modifie, et que je relance ma session Gnome, les modifications n'ont pas été prises en compte et tout revient comme au départ, à savoir Metacity se lance avant Compiz.


Si vous avez une solution, je suis preneur. C'est pas un énorme problème en soi, mais juste un peu ennuyant de voir son bureau se lancer 2 fois (une fois avec Metacity et une fois avec Compiz).


Merci d'avance pour votre aide.


Ah, j'allais oublié quelques petites précisions. J'utilise Debian Lenny amd64, et Gnome 2.22 :) Tout provient des 5 DVD téléchargés sur le site de Debian (j'ai pas encore Internet pour faire des éventuelles mises-à-jour).

phoenix
09/12/2008, 17h57
L'idéal serait de demander à Blacksad, souvent sur le salon #terralio, c'est un pro de compiz, il aura peut-être une idée.

Agemen
09/12/2008, 19h19
après t'as pas internet, donc si je vois blacksad, je lui demanderai de passer ici ^_^ encore faut-il qu'il accepte :P

Heero_Yuy
10/12/2008, 10h42
Agemen, tant que je suis au boulot, j'ai Internet et je suis connecté sur Jabber (Phoenix pourra te le confirmer ;) ).

Bon, j'irais faire un tour sur le salon Terralio alors, pour voir s'il est là.

A moins qu'un Debianiste pourra m'aider (je pense à Yoplait, ou encore thveillon - hey les gars, si vous passez par là, faites un signe :lol: :lol: )

thveillon
11/12/2008, 01h43
Je passe, je passe, mais je n'utilise ni metacity ni compiz qui me donne des boutons... Sur la machine de ma femme il y a tout ça, je regarderai demain, mais comme c'est Ubuntu et que tout marche impeccablement ça n'a jamais retenu mon attention.

En jetant un petit coup d'œil dans /etc/X11/Xsession.d on trouve des passages comme :

<div class='quotetop'>Citation </div>
# If there is still nothing to use for a startup program, try the system
# default session manager, window manager, and terminal emulator.
if [ -z "$STARTUP" ]; then
if [ -x /usr/bin/x-session-manager ]; then
STARTUP=x-session-manager
elif [ -x /usr/bin/x-window-manager ]; then
STARTUP=x-window-manager
elif [ -x /usr/bin/x-terminal-emulator ]; then
STARTUP=x-terminal-emulator
fi
fi[/b]


Donc une première idée serait de vérifier les alternatives avec :


update-alternatives --config x-window-manager


Ensuite Gconf-editor a sans doute également une option dans le genre, je ne suis pas expert, je regarderai demain.

L'autre facteur c'est que compiz-icon-fusion est lancé par le gestionnaire de session de Gnome, donc sans doute tard dans le processus, à mon avis il vaudrait mieux trouver une solution sans compiz-fusion-icon...

À demain...

Heero_Yuy
11/12/2008, 11h22
Merci thveillon de t'occuper de moi :lol: :lol:

J'attends que tu m'en dises plus alors ;)

logeais ludovic
11/12/2008, 21h57
bonjour

peut tu m'expliquer clairement ce que tu souhaite faire ?

si c'est lancer compiz fusion automatiquement au demarage faut pas utiliser fusion icon a mon avis car c'est un switcheur d'activation desactivation et changeur de decorateur bref une surcouche qui n'est qu'une interface pour active rou desactiver compiz fusion

normalement sous debian il suffit de lancer compiz fusion en ayant cocher dans les options compiz et non metalcity pour ne pas le charger

sinon tu peut forcer la mains via les ligne de commande avec par exemple un gtk-window-decorator --replace & ou emerald --replace&



Le problème vient du script :
/usr/bin/compiz.

Vers la ligne 69 :

# Defines the decorator and arguments.
# Set it to empty to make the script use the best decorator for your environment
DECORATOR=""

Il faut donc renseigner la variable DECORATOR avec /usr/bin/emerald

puis :

modifier la clé /desktop/gnome/applications/window_manager/default pour y mettre /usr/bin/compiz à la place de /usr/bin/metacity.

ça devrait t'aider a comprendre la http://www.quebecos.com/modules/newbb/view...p?topic_id=4034 (http://www.quebecos.com/modules/newbb/viewtopic.php?topic_id=4034)

et bien sur http://www.linuxpedia.fr/doku.php/compiz-fusion

<div class='quotetop'>Citation (phoenix @ 9/12/2008 à 17:57) <{POST_SNAPBACK}> (index.php?act=findpost&pid=195927)</div>
L'idéal serait de demander à Blacksad, souvent sur le salon #terralio, c'est un pro de compiz, il aura peut-être une idée.[/b]


c'est gentil phoenix comme tous ici on reste tous un eternel newbe devant linux :D

[mode pub on] http://www.linuxpedia.fr mais le peut de connaissance peut etre partager ici :D [ Mode pub off]

Heero_Yuy
12/12/2008, 11h00
Salux Blacksad,

Tu as effectivement bien compris ce que je voulais faire : lancer compiz automatiquement au démarrage de Gnome.

Tu parles de cocher dans les options Compiz et non Metacity, mais de quelles options parles-tu ? Je n'ai rien trouvé dans ce sens.

Egalement, la clé que tu dis qu'il faut changer dans gconf-editor, je l'ai bien changé. Mais cette clé est dite obsolète dans la description. Et à chaque fois que je la modifie, et que je relance ma session Gnome, elle reprend sa valeur initiale /usr/bin/metacity. Aurais-je oublié de sauvegarder ? Mais j'ai pas vu de menu de sauvegarde.


Et merci pour les liens, je vais y jeter un oeil.

J'essaierais tout cela ce week end à tête reposée ;)


Encore merci.


[Edit]

Par contre, tu parles de emerald, mais il ne me semble pas qu'il soit installé. Je vérifierais quand même :)

Heero_Yuy
15/12/2008, 14h33
bonjour

peut tu m'expliquer clairement ce que tu souhaite faire ?

si c'est lancer compiz fusion automatiquement au demarage faut pas utiliser fusion icon a mon avis car c'est un switcheur d'activation desactivation et changeur de decorateur bref une surcouche qui n'est qu'une interface pour active rou desactiver compiz fusion

normalement sous debian il suffit de lancer compiz fusion en ayant cocher dans les options compiz et non metalcity pour ne pas le charger[/b]

Salux Blacksad,

J'ai toujours pas trouvé ces options dont tu parles. Peux-tu me dire où elles sont ?

<div class='quotetop'>Citation (blacksad44 @ 11/12/2008 à 20:57) <{POST_SNAPBACK}> (index.php?act=findpost&pid=196239)</div>
sinon tu peut forcer la mains via les ligne de commande avec par exemple un gtk-window-decorator --replace & ou emerald --replace&[/b]

Bon, la première commande apparemment me relance Compiz. Mais il ne connaît pas emerald. Normal, il n'est pas installé. Et sur les DVD, je ne l'ai pas trouvé. S'il faut l'installer à partir du Net, ça attendra que j'ai Internet. Donc, les congés.

<div class='quotetop'>Citation (blacksad44 @ 11/12/2008 à 20:57) <{POST_SNAPBACK}> (index.php?act=findpost&pid=196239)</div>
Le problème vient du script :
/usr/bin/compiz.

Vers la ligne 69 :

# Defines the decorator and arguments.
# Set it to empty to make the script use the best decorator for your environment
DECORATOR=""

Il faut donc renseigner la variable DECORATOR avec /usr/bin/emerald[/b]

Bon, on ne doit pas avoir le même script. Je n'ai pas cette ligne :( - peut-être que je n'ai pas non plus la dernière version. Faudrait que je fasse une mise-à-jour de Lenny avec les dernières versions Testing. Ou alors attendre qu'elle sorte en stable pour repartir sur un bonne config.

<div class='quotetop'>Citation (blacksad44 @ 11/12/2008 à 20:57) <{POST_SNAPBACK}> (index.php?act=findpost&pid=196239)</div>
puis :

modifier la clé /desktop/gnome/applications/window_manager/default pour y mettre /usr/bin/compiz à la place de /usr/bin/metacity.[/b]

Justement, cette ligne dans gconf-editor, dans sa description est marquée (Obsolète) depuis le kernel 2.12.

phoenix
15/12/2008, 18h06
<div class='quotetop'>Citation </div>
depuis le kernel 2.12.[/b]

Le Gnome 2.12 je pense ^^

Heero_Yuy
16/12/2008, 09h51
Euh, peut-être, j'ai écrit ça en fonction de mes souvenirs, mais je me suis peut-être trompé ;)

thveillon
22/12/2008, 20h50
Salut Heero_Yuy, j'ai passé un moment loin de ce sujet car ma femme a eu raison de sa carte mère : deux slots mémoires grillés d'un coup !

Bon après remplacement j'ai regardé cette histoire de window manager, tu n'as pas dit si tu as essayé ce que j'avais indiqué dans le premier message :


update-alternatives --config x-window-manager

Tu peux aussi utiliser "galternatives" en mode "clic-clic". Si la valeur /usr/bin/compiz n'existe pas il faut la créer et la choisir manuellement. C'est bien ce que j'ai fait ici et ça supprime le phénomène que tu décris au lancement de session, en plus ça l'accélère sérieusement.

Pour aller plus loin il y a un hic, tu peux déléguer entièrement la gestion du bureau à compiz avec le plug-in "wallpaper" pour gérer le fond d'écran, mais il faut également désactiver la clé correspondante dans Gconfig pour que Gnome cesse de s'en occuper :

desktop > gnome > background > draw_background

et ça ne suffira pas... Gnome ne sait pas dessiner un arrière plan de bureau transparent, donc il restera une couleur s'affichant par dessus ton fond d'écran... Galère. Pour éviter ça il faut désactiver également l'affichage des icônes sur le bureau, ce qui prive évidement des icônes mais également du clic-droit sur le bureau... Pas beaucoup mieux.

Pas vraiment de solution donc pour déléguer totalement l'affichage du bureau à compiz, il existe un tas de bidouilles passant par des versions de Nautilus patchées à la main avec les pieds... Pas ma tasse de thé. Mon idée serait plutôt d'exploiter la gestion du composite qui est entrée dans les dernières versions de Gnome, ça devrait permettre d'avoir un fond d'écran transparent avec les icônes dessus, et le fond d'écran "graphique" dessiné par compiz en dessous.


Essaye quand même la première étape (x-window-manager), ça marche bien ici.

Heero_Yuy
05/01/2009, 12h27
Salux Thveillon,

Merci de ces précisions.

Je ne me rappelle plus si j'avais fait les commandes que tu m'avais donné, mais depuis, j'ai abandonné l'idée d'utiliser Compiz-fusion pour le moment du moins.

J'ai noté 2 problèmes avec. Le premier est la lecture des vidéos qui s'accadent. Si je passe par Metacity, je ne note plus ce phénomène. Phoenix m'avait donné quelques lignes à ajouter à mon Xorg.conf, mais ça n'y changeait rien.

L'autre problème est l'utilisation de Blender avec Compiz-fusion. Lorsque je lance Blender en mode plein écran, tout va pour le mieux, mais dès que je souhaite accéder à un menu de Blender, c'est le menu Gnome qui apparaît (celui du tableau de bord qui est recouvert par Blender).

Alors, peut-être qu'il y a des choses à régler dans mon Xorg.conf, mais pour le moment, j'ai abandonné l'idée d'utiliser Compiz-fusion sous Debian (je vérifierais si j'ai le même phénomène sous openSUSE).

Mais il faut que je réinstalle Debian également, je vais prendre la version stable de chez stable de Lenny lorsqu'elle sortira enfin ;)

Pour le moment, je reste sous Metacity.

Mais le sujet reste ouvert en attendant. N'hésitez pas à donner d'autres conseils ;)

thveillon
05/01/2009, 14h08
Je ne connais pas les chip Intel qui ont la réputation d'être bien supportés, mais le comportement de compiz-fusion dépend pas mal du matériel et du pilote video sur lequel il tourne (et des choix propres aux distributions: rendu direct/indirecte, aiglx...). Sur la Ubuntu de ma femme, avec une ati HD et pilote fglrx c'est la galère, j'ai eu tous les problèmes que tu décris, plus des videos violettes, Googlearth qui clignote, wine qui part en cacahouète, les machines virtualbox qui font clignoter l'écran pendant 30 secondes au lancement, le dock de "advanced windows navigator" qui disparaît... J'en passe ! En général la plupart des problèmes se résolvent à coup de bidouilles, mais ça devient un job à plein temps ! Ce n'est pas ma conception d'une interface graphique qui doit être agréable, mais surtout se faire "invisible" autour des "vrais" activitées de l'utilisateur. Dans cette optique les effets "moyens" des choix par défaut d'Ubuntu me paraissent un bon compromis.

Sur une carte Nvidia et pilotes Nvidia j'ai fait quelques tests qui se sont révélés meilleurs, même sous kde (3.*), ça fonctionne de manière plus fluide, moins de ressources utilisées et moins de problèmes. Mais ça ne suffit pas à me convaincre de l'utilité de ces "trucs"... ;)

Reste que la gestion de l'affichage composite est entrée nativement dans Gnome, est présente dans kde depuis un moment et surtout dans kde4, et que compiz-fusion en temps que projet a du plomb dans l'aile... Il y a eu un fork récemment avec réécriture du code en c++, ça paraît le meilleur espoir, mais la branche "officielle" ne semble ni très active, ni très organisée, ni très claire quand à ses objectifs et sa roadmap...

Reste que ma femme a bien aimé la neige sur l'écran pendant les vacances de Noël, et mon fils adore les poissons qui nagent dans le bureau "cube-aquarium" de sa maman... Indispensable donc ! :rolleyes:

Heero_Yuy
05/01/2009, 17h29
Phoenix m'a justement parlé de l'affichage composite dans Gnome, je vais m'y intéresser, car ça semble le minimum que j'utilisais avec Compiz-fusion (sans compter le cube ;) ).

Maintenant, ce que j'aurais aimé, mais ça ne semble pas encore existé (peut-être dans un avenir plus ou moins proche, vu les progrès esthétiques réalisés sous Gnome ;) c'est d'avoir une décoration de fenêtre style Crystal que l'on retrouve sous KDE.


Mais j'aimerais me renseigner aussi sur ce fork réécrit en C++ dont tu parles, tu as plus d'infos à ce sujet ?


Encore merci.

thveillon
05/01/2009, 19h00
Il y a eu une news sur phoronix il y a une semaine environ, l'annonce est ici (http://lists.freedesktop.org/archives/compiz/2008-December/003227.html) , on en parle sur les blogs des membres du projet, comme ici (http://smspillaz.wordpress.com/2008/12/24/breaking-compiz-branch-hits-git/), et l'évolution du projet sera suivi de prêt sur les news du site compiz-fusion (http://www.compiz-fusion.org/) et sur phoronix.

Quand à l'avenir de la branche "officielle", on en parle là (http://lists.freedesktop.org/archives/compiz/2008-December/003236.html) , phoronix (http://www.phoronix.com/scan.php?page=news_item&px=Njk2Mg) , et le buzz se répand rapidement sur le web. Il semble que tout ce qui touche à compiz déchaîne les passions, ça va ressembler à la guerre de l'époque Beryl... Idiot à mon humble avis. :wise: ;)

Heero_Yuy
06/01/2009, 10h32
Merci des infos, je lirais tout ça lorsque j'aurais un peu de temps ;)

yoplait
06/01/2009, 12h38
Je découvre ton sujet.. Désolé de n'avoir pas réagi avant.

Effectivement, de mon côté aussi je n'utilise pas compiz-fusion car je l'ai trouvé trop lent sur mon PC et il me faisait saccader mes vidéos.
Je n'ai qu'une carte nvidia 6200, c'est sûrement pour ca d'ailleurs, à moins que ca soit à cause de l'amd64 que j'ai aussi.

En tout cas, je ne savais pas que y'avait du composite dans gnome ... ca se manifeste comment ? on l'active comment ?

phoenix
06/01/2009, 12h53
Il faut mettre la clé /apps/metacity/general/compositing_manager à yes.

Ça ajoute des ombres, permet la vraie transparence dans le terminal, les miniatures sont mise à jour en temps réel avec le Alt+Tab. Et c'est un gestionnaire de composite, donc ça permet d'utiliser les docks style Cairo-dock.

Heero_Yuy
06/01/2009, 15h15
Je découvre ton sujet.. Désolé de n'avoir pas réagi avant.[/b]

Pas de souci ;)

<div class='quotetop'>Citation (yoplait @ 6/01/2009 à 11:38) <{POST_SNAPBACK}> (index.php?act=findpost&pid=198523)</div>
En tout cas, je ne savais pas que y'avait du composite dans gnome ... ca se manifeste comment ? on l'active comment ?[/b]
Phoenix a tout dit, faut que je le teste.

A près tout, avec Compiz-fusion, je n'utilisais que très peu d'effets (le cube - ou plutôt le cylindre, le mode Exposé, le sélecteur de fenêtres en cascade sont ceux que j'utilisais le plus). Donc le mode composite de Gnome me suffira amplement ;) .