PDA

Afficher la version complète : Bug concernant la gestion de l'énergie



Xylane
17/12/2008, 00h25
Bonjour,

Je voulais signaler un bug que j'ai trouvé sous OpenSuse 11.1 (mais je pense l'avoir déjà eu avec 11.0).

Description : A chaque fois que je démarrais mon ordinateur portable sous OpenSuse, la luminosité était à chaque fois réglée au minimum. Je pouvais la monter manuellement (touche Fn+F6), mais c'était très embêtant à la longue!

Résolution : Par hasard, j'ai remarqué que dès que je débranchais la prise du secteur, la luminosité augmentait. Et lorsque je la rebranchais, la luminosité retournait au minimum (!). Après avoir recherché, j'ai trouvé où cela était réglé : dans Poste de travail -> Configuration du système -> Onglet "Avancé" -> Power Management -> Modifier les profils -> Performance -> Onglet "Ecran" -> Régler la luminosité.à la valeur désirée.

Bug : Jusque là, vous vous disez "il est gentil, il nous explique comment régler la luminosité de mon portable, c'est pas un bug, juste un tuyau!". Voici précisément le bug : la barre pour régler la luminosité du portable, selon son état (sur serveur, débranché, batterie basse etc) est INVERSEE! En mettant la luminosité au minimum, l'écran est très clair. A l'inverse, en réglant la barre au maximum (curseur à fond à droite), l'écran est extrèrement sombre! Ce qui explique qu'avec les réglages par défaut, la luminosité (réelle) est très basse lorsque le portable est sur secteur (car le curseur est à fond), et plus haute lorsque la prise secteur est débranchée (curseur à mi-chemin)...

J'aurais aimé signaler ce bug de manière plus "officielle", mais je n'ai pas un niveau d'anglais suffisant, et surtout je serais incapable de dire quel est le module en cause! J'espère ça aidera des personnes ayant ce bug, et que quelqu'un avec une meilleur connaissance de Linux (et une meilleure maîtrise de l'anglais) pourra transmettre ce bug à l'endroit voulu (bugzilla ou je ne sais pas où :P ), afin qu'il soit remonté aux intéressés et corrigés!

Merci à tous de votre attention ;)

phoenix
18/12/2008, 21h38
Est-ce que tu l'as sur la version finale ?

Foxysama
18/12/2008, 21h43
Quel est le fabricant?

J'utilise OpenSUSE depuis la 10.2 sur ce Pc portable, que ce soit sur batterie ou sur secteur, je n'ai jamais eu de soucis de luminosité ..

Xylane
18/12/2008, 23h11
Actuellement je suis sous KDE "four" Live! car impossible d'installer Opensuse 11.1 final : je n'arrive même pas à la 1e page où ça demande si l'on veux booter sur le disque dur, intaller etc (la RC1 s'installait bien par contre :/ ), donc sous KDE 4.2 beta 2 (j'avais ommis ce détail, mais j'avais le même soucis avec KDE 4.1.3).

A part ça c'est un portable Asus M51Sn.

kermo
19/12/2008, 00h57
J'ai le même modèle de portable, Asus m51sn et depuis la 11.1 la luminosité est aussi inversée, alors que ça marchait parfaitement sur la 11.0 !
C'est vraiment inversé partout : quand je modifie à la molette, via les raccourcis du clavier, même la gestion de l'énergie foire - du coup quand les batteries sont presque vides il me monte la lumière :lol:
Comment fait-on remonter ça ?

phoenix
20/12/2008, 00h17
Le bogue semble déjà connu : https://bugzilla.novell.com/show_bug.cgi?id=450149