PDA

Afficher la version complète : Problème touchpad avec openSUSE 11.1



mthlwn
22/12/2008, 11h41
Bonjour à tous,

je viens de mettre à jour mon portable Sony Vaio SZ4 vers openSUSE 11.1 et j'ai maintenant un gros problème avec le touchpad.

D'abord je dois dire que dans les versions précédentes de openSUSE il n'a jamais bien marché et il était très difficile de l'utiliser. Mais maintenant c'est encore bien pire. Je m'explique (enfin j'essaie) : quand je pose le doigt sur le touchpad, la souris saute instantanément à un endroit de l'écran correspondant à là où j'ai posé le doigt. Par exemple si je pose le doigt en haut à gauche, la souris saute immédiatement en haut à gauche de l'écran, même si elle était en bas à droite. Conséquence : je n'arrive pas à accéder aux bords de l'écran. Comme le touchpad n'est pas assez grand, je dois lever le doigt et donc ma souris saute immédiatement à l'autre bout. C'est très désagréable, en particulier je ne peux accéder ni au menu, ni fermer les fenêtres.

Bon je sais pas si vous avez compris ce que je veux dire, mais si oui, je veux bien de l'aide...


---------------------
Je précise que dans Yast, trois souris sont détectées, la souris USB normale que je suis obligé de brancher pour m'en sortir, un touchpad "ALPS" et un autre "Sony Vaio Jogdial". J'ai essayé de désactiver l'un ou l'autre sans observer aucune différence. De même j'ai essayé de remplacer le premier par synaptics sans que ça ne change rien.

Je précise aussi que j'utilise le driver NVIDIA et qu'il a probablement touché à mon xorg.conf.

Enfin, je vous copie les sections correspondantes dans le xorg.conf

Section "InputDevice"
Driver "evdev"
Identifier "Mouse[1]"
Option "HWHEELRelativeAxisButtons" "7 6"
Option "InputFashion" "Mouse"
Option "Name" "Logitech VX Nano Laser Mouse"
Option "Pass" "3"
Option "Vendor" "Sysp"
Option "evBits" "+1-2"
Option "keyBits" "~272-287"
Option "relBits" "~0-2 ~6 ~8"
EndSection

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[3]"
Option "AccelFactor" "0.01"
Option "BottomEdge" "650"
Option "Buttons" "5"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
Option "CircularScrolling" "1"
Option "Device" "/dev/input/mice"
Option "EdgeMotionMaxSpeed" "15"
Option "EdgeMotionMinSpeed" "15"
Option "Emulate3Buttons" "on"
Option "EmulateMidButtonTime" "75"
Option "FingerHigh" "15"
Option "FingerLow" "14"
Option "HorizScrollDelta" "20"
Option "InputFashion" "Mouse"
Option "LeftEdge" "120"
Option "MaxSpeed" "0.5"
Option "MaxTapMove" "110"
Option "MaxTapTime" "180"
Option "MinSpeed" "0.2"
Option "Name" "Touchpad"
Option "Protocol" "auto-dev"
Option "RightEdge" "830"
Option "SHMConfig" "on"
Option "TopEdge" "120"
Option "UpDownScrolling" "1"
Option "Vendor" "ALPS"
Option "VertScrollDelta" "20"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[5]"
Option "AccelFactor" "0.01"
Option "BottomEdge" "650"
Option "Buttons" "5"
Option "CircScrollDelta" "0.1"
Option "CircScrollTrigger" "2"
Option "CircularScrolling" "1"
Option "Device" "/dev/input/mice"
Option "EdgeMotionMaxSpeed" "15"
Option "EdgeMotionMinSpeed" "15"
Option "Emulate3Buttons" "on"
Option "EmulateMidButtonTime" "75"
Option "FingerHigh" "15"
Option "FingerLow" "14"
Option "HorizScrollDelta" "20"
Option "InputFashion" "Mouse"
Option "LeftEdge" "120"
Option "MaxSpeed" "0.5"
Option "MaxTapMove" "110"
Option "MaxTapTime" "180"
Option "MinSpeed" "0.2"
Option "Name" "Touchpad"
Option "Protocol" "auto-dev"
Option "RightEdge" "830"
Option "SHMConfig" "on"
Option "TopEdge" "120"
Option "UpDownScrolling" "1"
Option "Vendor" "ALPS"
Option "VertScrollDelta" "20"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[7]"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "on"
Option "Name" "Sony Vaio Jogdial"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
InputDevice "Mouse[7]" "SendCoreEvents"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

mthlwn
03/01/2009, 11h18
Personne ne peut m'aider ??? :(