PDA

Afficher la version complète : [Réglé] drivers NVIDIA → pas d'interface graphique



paul92
22/12/2008, 13h40
Bonjour à toutes et tous,

Je suis encore assez novice sur OpenSUSE (sur Ubuntu ça va B) ) et je ne parviens pas avec OpenSUSE 11.1 à avoir les derniers drivers NVIDIA pour ma 6600GT installés.
Durant le cycle de bêtas, j'y étais arrivés avec les drivers .run, mais maintenant qu'il y a eu les dernières mises à jour du noyau, ça fonctione plus :huh: . Bref, j'ai alors ajouté le dépot NVIDIA pour OpenSUSE 11.1 et acceptai la clé GPG (jusque là pas de problème), j'ai installé les plus récents, mais pas moyen, c'est comme s'ils n'étaient pas installés, pourtant nvidia-xconfig en root, en ligne de commande (j'ai plus d'interface graphique, même avec VESA, depuis que j'ai tenté un rm -rf /etc/X11/xorg* pour repartir de zéro...)

Enfin voila où j'en suis... Notons que j'ai suivis cette page de doc http://fr.opensuse.org/NVIDIA mais rien n'y fait, même avec le sax2 -r

PS: pour déinstaller les NVIDIA.run, j'ai lancer le run avec l'option --uninstall, ces derniers sont donc bien déinstallés.

A+ et merci!

Chninkel
22/12/2008, 14h47
Bonjour,
Il est posible d'utiliser YAST en ligne de commande, il suffit de taper yast dans une session root.
Pour se déplacer : fléches du clavier pour se déplacer, ou la touche Tab pour changer de section ; ALT+Lettre jaune pour la commande correspondante

Aller dans la section Software ; Touche Tab pour se déplacer à gauche ; se placer sur Software management valider
Taper nvidia dans la section Search valider ; Sélectionner les packages à installer (touche espace pour choisir l'opération à effectuer un signe + doit apparaître)
Normalement c'est le paquet nvidia-gfxG002-kmp-default qu'il faut installer.
De cette manière lors des mises à jour de kernel, il nest pas nécessaire de réinstaller les pilotes.

PS : il faut que le dépôt nvidia soit activer

paul92
22/12/2008, 17h26
salut, merci pour ta réponse, mais c'est déjà la démarche que j'ai effectuée.

Chninkel
22/12/2008, 18h17
Pour mon premier post je ne devais pas avoir les yeux en face des trous.

Lorsqu'on installe les pilotes par la méthode manuelle ie .run, il est nécessaitre de les réinstaller à chaque changement de noyau.

L'installation automatique ie par les dépôts évite la réinstallation.

Dans Yast les paquets nvidia sont marqués comme installés ou non ?

Quels sont les messages d'erreurs lorqsue tu lance la commande startx (ou voir /var/log/Xorg.log)

paul92
22/12/2008, 19h15
salut, merci encore pour ta réponse, cependant, il n'y a pas de message d'erreur, juste un écran noir. Quant au /var/log/Xorg.log, benh y' a rien...

paul92
23/12/2008, 12h47
Salut, finalement j'ai refait une install toute fraîche et c'est ok (avec mon home sur partition à part)