PDA

Afficher la version complète : Impossible de lancer l'interface graphique



~~LTC_972~~
06/02/2009, 17h01
Bonjour à tous,

J'ai installer les paquets de ma carte graphique (7900 GS nvidia)
Au redémarrage je suis dans l'impossibilité de lancer ma suse comme d'habitude :(

J'ai droit à plusieurs option qui sont en FAILED comme :

Loading CPU FREQ Modules
Starting VirtualBox kernel Module

Après avoir suivis les conseils de l'ami thveillon dans le problème de virtualbox..
J'ai taper ceci

sax2 -r
Malheure :( je recoit ceci ..

sax sorry could no start configuration server
sax for détails refer.......

snif que faire :(

Koy
08/02/2009, 01h16
Salut..

Je n'ai pas suivi ta discussion a thveillon, mais as tu desinstallé les anciens drivers de ta carte video ? Si non, je te conseille tres vivement de le faire..
Pour ce, lance yast2 apres t'etre loggué en root..; et supprime tous les drivers nvidia (mme les recents, que tu reinstalle apres).

apres les avoir desinstallé, tape init3 ,lance un sax2 -r 0=nv , tapes init5 ,là, 2 possibilités, soit kdm démarre et tu devrais redemearrer ta suse sans acceleration graphique. si non, tapes startx.

apres, tente de reinstaller tes drivers...

Salut

thveillon
08/02/2009, 18h16
Essaye de suivre les conseils de Koy, mais vu que tu sembles avoir de nombreux modules qui en se chargent pas, je me demande si en essayant d'installer le pilote Nvidia tu n'as pas entraîné l'installation d'un nouveau noyau, ou de headers qui ne correspondent pas à ton noyau.

Ça serait intéressant de voir ce que tu as dans /boot/ et /usr/src :


ls -l /boot
ls -l /usr/src

~~LTC_972~~
13/02/2009, 22h53
Bonjour à vous,

C'est vraiment dommage mais j'ai copier mes documents important sur mon disque dur et j'ai formater :( (je devais déjà le faire pour équilibré mes partitions)

J'avais voulu désinstaller les drivers nvidia mais comment faire ?

Chninkel
13/02/2009, 23h18
Si les paquets ont été installés par yast, il suffit de le lancer en ligne de commande sous le compte root et de les désinstaller.
Si c'est une installation manuelle c'est sh ./nvidia................ --uninstall

~~LTC_972~~
16/02/2009, 01h23
Si les paquets ont été installés par yast, il suffit de le lancer en ligne de commande sous le compte root et de les désinstaller.[/b]

oui mais comment ou aller :rolleyes:

Chninkel
16/02/2009, 03h15
Yast fonctionne bien en ligne de commande.
Touches utiles : tab, touches directionnelles, barre espace, alt+lettre jaune
en console en root : taper yast se placer avec la touche tab + touches bas sur installer et supprimer des logiciels valider
taper nvidia dans "recherche de la phrase"
il devrait proposer les paquets nvidia, modifier l'état des paquets par la barre d"espace pour les supprimer il doit y avoir un signe "-"
Effacer nvidia-GFX02... et x11-video-nvidia-GFX02

~~LTC_972~~
16/02/2009, 03h26
Merci des astuces ;)

Parlerai-tu d e yast2 ?
Car j'ai fait rechercher et il n'a rien trouvé :(

Chninkel
16/02/2009, 14h35
Tu as fait rechercher avec quoi ?
yast2... c'est pour l'interface graphique or comme tu ne peux la lancer.
Par contre si en console root tu tapes yast et que rien ne se lance, il y a un problème.