PDA

Afficher la version complète : [Résolu]Problème d'activation carte Wifi ( OpenSuSE 11.1 )



8t88s
07/02/2009, 23h59
Salut,

Je viens de revenir à mes premiers amours après qqs sorties vers Ubuntu et pour mon prochain taff, je me suis installé OpenSuSE 11.1.

Seulement voilà, comme à chaque fois j'ai une surprise, là... le wifi débloque.

Alors, le problème ne m'est pas inconnu mais j'ai pas réussi pour autant à le résoudre sous la SuSE.

En fait, la carte wifi est bien détectée, le drivers aussi, elle est reconnue et tout mais... elle ne s'active pas, ou enfin... elle marche pas quoah.

Sur Ubuntu 8.10, j'ai subi le même problème et j'avais suivi le tuto suivant : http://www.paperblog.fr/1427415/probleme-d...buntu-intrepid/ (http://www.paperblog.fr/1427415/probleme-dactivation-du-wifi-avec-ubuntu-intrepid/) et hop, nickel du premier coup.

Forcement, sous la SuSE, je sais pas où chercher.

Pour info, les résultats sur 2 commandes :

hwinfo --wlan
<div class='quotetop'>Citation </div>
20: PCI 1000.0: 0282 WLAN controller
[Created at pci.318]
UDI: /org/freedesktop/Hal/devices/pci_8086_4222
Unique ID: y9sn.trkNZjh+GB2
Parent ID: qTvu._Y5kuEY+GiC
SysFS ID: /devices/pci0000:00/0000:00:1c.1/0000:10:00.0
SysFS BusID: 0000:10:00.0
Hardware Class: network
Model: "Hewlett-Packard Company Compaq 6710b"
Vendor: pci 0x8086 "Intel Corporation"
Device: pci 0x4222 "PRO/Wireless 3945ABG [Golan] Network Connection"
SubVendor: pci 0x103c "Hewlett-Packard Company"
SubDevice: pci 0x135c "Compaq 6710b"
Revision: 0x02
Driver: "iwl3945"
Driver Modules: "iwl3945"
Device File: wlan0
Features: WLAN
Memory Range: 0xe4100000-0xe4100fff (rw,non-prefetchable)
IRQ: 17 (no events)
HW Address: 00:1b:77:c0:08:a7
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 36 40 44 48 52 56 60 64
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.4572.462 5.18 5.2 5.22 5.24 5.26 5.28 5.3 5.32
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: "pci:v00008086d00004222sv0000103Csd0000135Cbc02sc80 i00"
Driver Info #0:
Driver Status: iwl3945 is active
Driver Activation Cmd: "modprobe iwl3945"
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #9 (PCI bridge)[/b]

et iwlist scan :
<div class='quotetop'>Citation </div>
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

pan0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan0 Interface doesn't support scanning : Network is down[/b]

j'ai un peu cherché sur le woueb, mais rien de concret, donc si vous avez une idée, je prend :)

nino
08/02/2009, 13h05
Bonjour,
Pour ma part les problémes rencontrés avec cette carte ont été complétement résolus en supprimmant (k)networkmanager et en installant wicd à partir de "one-click-install"
C'est d'ailleur un probléme récurrant, et déja cité dans le forum si je ne m'abuse <_<

8t88s
09/02/2009, 23h24
bon, j'ai donc réinstallé OpenSuSE 11.1 en version 64 Bits et un bureau Gnome et ... oh miracle, ça marche.

Vraiment plus fait pour moi le bureau KDE :)