PDA

Afficher la version complète : [Script] APT security



lucienmathieu
20/09/2004, 15h44
L'utiliité de ce script est de vérifier que certains packages sont bien à leur dernière version pour cause de sécurité.

http://www.alionet.org/style_emoticons/<#EMO_DIR#>/arrow.gif Security Announcement (http://www.suse.com/de/security/announcements/index.html)

http://www.alionet.org/style_emoticons/<#EMO_DIR#>/arrow.gif voici le script, fichier apt-security.shp_security() {
PACK=`rpm -q $1`
OK=0
for i in $PACKAGES
do
if [ "$i" = "$PACK" ]
then
OK=1
fi
done
if [ $OK -eq 0 ]
then
echo "please update $1 for security"
fi
}

clear
echo "check security..."
PACKAGES=`cat apt-security.dat`
p_security nessus-core
p_security XFree86-libs
echo "done"http://www.alionet.org/style_emoticons/<#EMO_DIR#>/arrow.gif voici le fichier de données, apt-security.datnessus-core-2.0.10a-24.7
XFree86-libs-4.3.99.902-43.31
gdk-pixbuf-0.22.0-62.7
gdk-pixbuf-gnome-0.22.0-62.7
gdk-pixbuf-devel-0.22.0-62.7
gtk2-2.2.4-125.4
gtk2-devel-2.2.4-125.4
libapr0-2.0.49-27.14
apache2-worker-2.0.49-27.14
apache2-doc-2.0.49-27.14
apache2-prefork-2.0.49-27.14
apache2-example-pages-2.0.49-27.14
apache2-devel-2.0.49-27.14
apache2-2.0.49-27.14
cups-libs-1.1.20-108.8
foomatic-filters-3.0.1-41.6il y en a encore d'autres plus anciens, je les ajouterai au fur et à mesure ;-P J'essayerai aussi de les enlever si ils ne sont plus d'actualité...

molodoi
20/09/2004, 16h13
pardonne mon imbécilité mais, heu, ça sert à quoi ton script?

Un petit descriptif sur les tenants et aboutissants serait le bienvenu http://www.alionet.org/style_emoticons/<#EMO_DIR#>/wink.gif

lucienmathieu
20/09/2004, 19h00
UP, si besoin de plus de détails, je les ajouterai ;-P