PDA

Afficher la version complète : problème installation nouvelle carte graphique



Courtine
08/03/2009, 20h53
Bonjour,
j''ai des difficultés pour installer les drivers de ma nouvelle carte graphique nvidia quadro 290 nvs?
Comme expliqué sur le site de nvidia, j'ai ajouté le dépôt dans yast, j'ai fait une recherche sur nvidia et j'ai installé les drivers.
J'ia étiens mon pc, mis ma nouvelle carte graphqiue et au redémarrage, l'interface graphique ne se lance pas, j'arrive au login en mode console.
J'ai essayé de me connecter et de faire sax2 -r mais cela m'a renvoyé une erreur comme quoi sax2 n'était pas une commande définie et si je vais dans /usr/sbin, je ne triuve pas sax2.
Que faut-il que je fasse?
Installer sax2 via yast et rebooter et exécuter la commande sax2 -r?

N.B. : j'ai un dual boot xp/opensuse 11.0 et depuis l'installation des drivers nvidia j'ai 2 lignes supplémentaires qui se sont rajoutées à l'écrna d'accuiel du dual boot :
opensuse ... (pae) et opensuse failsafe (pae)

Merci d'avance pour vos réponses,
Fabien

thveillon
09/03/2009, 22h55
Salut,

je pense qu'il faut installer le pilote avec la carte dans l'ordinateur sous Linux.

Sinon pour sax2, ça doit être un truc comme /sbin/sax ou /sbin/Sax2 ... Enfin quelque chose comme ça ;) (et non, je ne suis pas sur Suse !)

Courtine
10/03/2009, 01h05
Salut,

je pense qu'il faut installer le pilote avec la carte dans l'ordinateur sous Linux.

Sinon pour sax2, ça doit être un truc comme /sbin/sax ou /sbin/Sax2 ... Enfin quelque chose comme ça ;) (et non, je ne suis pas sur Suse !)[/b]



J'ai installé/mis à jour sax2 depuis Yast
Pour la carte graphique nvidia, dès que je la met dans le pc, je démarre en mode "console", sans interface graphique, si j'en crois les lignes qui défilent à l'écran, je suis en runlevel5. A ce stade-là je ne peux pas faire grand chose!
J'ai essayé l'installation par compilation, mais apparemment cela n'a pas réussi, même en redémarrant le serveur x, rien n'y fait. J'ai remarqué que même que lors de l'install de la nouvelle carte graphique nvidia, l'os lance le service atieventsd et l'interface graphique ne démarre pas.
N.B. : la carte graphique que je veux remplacer est une ati et elle est externe

Quelqu'un aurait-il une idée?

Fabien

thveillon
10/03/2009, 01h48
"runlevel 5" c'est le niveau d'exécution normal sur Suse, c'est à dire que tu peux faire exactement la même chose que lorsque tu démarrais avec ton ancienne carte graphique, sauf que tu es en console.
Démarre avec ta carte nvidia dans la machine.
Connecte toi en console.
Passe en runlevel 3
(quand je mets un "#" devant la commande, il ne faut pas le taper, ça veut dire qu'il faut des droits root (ou sudo).

# init 3


Ensuite il faut désinstaller le pilote ati (fglrx je présume), par exemple avec :


# rpm -e $(rpm -qa | grep fglrx)

en root. Ou la même chose avec zypper, ou encore en lançant yast en console (/sbin/yast en root), le maniement est un peu différent mais tu devrais t'y retrouver au bout d'un moment.

Quand tu as fait ça, et vu que tu as certainement fichu le bazar à essayer d'installer le pilote nvidia dans tous les sens, tu le désinstalles complètement:


# nvidia-installer --uninstall
# rpm -e $(rpm -qa | grep nvidia)

Toujours en root. Si tu veux utiliser Yast en console, pas de problème, sauf qu'il faut quand même faire la première commande pour enlever l'installation manuelle "par compilation". (Si elle a complètement échouée, tu peux passer cette étape).

Puis tu réinstalles le pilote nvidia, le plus simple sera de le faire avec Yast en console, mais avec le ".run" de Nvidia ça marchera aussi.

Avec le ".run" de nvidia :


wget ftp://download.nvidia.com/XFree86/Linux-x86/180.37/NVIDIA-Linux-x86-180.37-pkg1.run
# zypper refresh
# zypper in gcc make kernel-syms
# sh NVIDIA-Linux-x86-180.37-pkg1.run


Tu réponds "ok" aux questions jusqu'au bout, et tu redémarres :


# reboot


Si xorg plante encore c'est que le fichier /etc/X11/xorg.conf contient encore des références au pilote fglrx, dans ce cas là il faudra l'éditer manuellement, ou essayer la commande :


# sax2 -r -m 0=nvidia


Voila pour l'idée.

nota: il y a aussi un sujet permanent pour le pilote Nvidia : http://www.alionet.org/index.php?showtopic=18259

Courtine
11/03/2009, 23h45
Bonjour,
j'ai bien réussi l'installation de ma nouvelle carte nvidia.
Mais j'ai des problèmes d'affichage : je n'ai plus qu'un seul bureau à la place de 4, à chaque fois que j'ouvre une fenêtre je la voi se dessiner, et lorsque je la ferme, je vois tout le bureau se rafraîchir.
Avec la carte ati radeon x550, je n'avais pas ces problèmes. Est-ce normal ou bien il faut configurer quelque chose d'o*autre?

thveillon
12/03/2009, 00h06
Ces symptômes montrent que c'est le pilote générique "vesa" qui est utilisé au lieu du pilote nvidia. Le plus simple est d'utiliser l'utilitaire de configuration de nvidia, plutôt que d'éditer le fichier à la main :


nvidia-xconfig

en root (ou sudo).

Il faut redémarrer le serveur graphique pour voir les effets. Si la commande renvoie "command not found", ça veut dire que le pilote nvidia n'est pas installé correctement.

Si le résultat est toujours décevant, copie ici ton fichier /etc/X11/xorg.conf dans une boite "CODEBOX" (voir le menu à gauche quand tu écris un message, "Accès rapide > Insérer : CODEBOX" ).

Courtine
12/03/2009, 00h42
J'ai toujours le même problème et en plus les fenêtres en plein écran ne tiennent plus sur l'écran
voici le fichier xorg.conf<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'># nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder57) Sat Jan 24 20:04:42 PST 2009

# /.../
# SaX generated X11 config file
# Created on: 2009-03-11T23:20:16+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
Identifier "Layout[all]"
Screen "Screen[0]" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
EndSection

Section "Module"
Load "freetype"
Load "type1"
Load "dbe"
Load "glx"
Load "extmod"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "fr"
Option "XkbModel" "pc102"
Option "XkbOptions" "caps:shiftlock"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "ImPS/2 Generic Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
EndSection

Section "Monitor"
Identifier "Monitor[0]"
VendorName "GSM"
ModelName "LG ELECTRONICS 702S"
UseModes "Modes[0]"
DisplaySize 310 230
HorizSync 30.0 - 71.0
VertRefresh 43.0 - 160.0
Option "DPMS"
Option "PreferredMode" "1280x800"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "nv"
VendorName "ATI"
BoardName "RADEON X550"
Screen 0
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 16
SubSection "Display"
Depth 15
Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
EndSection

</div>

thveillon
12/03/2009, 00h57
Tu peux essayer avec celui-ci, dans l'ancien tu avais le pilote libre "nv" à la place de "nvidia". J'ai donc changé "driver", le reste dans la section "device" est là pour décorer si on a une seule carte, j'ai corrigé quand même.

J'ai aussi changé "DefaultDepth" dans la section "screen", passé de 15 à 24.

Assure-toi d'avoir une copie de sauvegarde du xorg.conf avant de le modifier.


<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'># nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder57) Sat Jan 24 20:04:42 PST 2009

# /.../
# SaX generated X11 config file
# Created on: 2009-03-11T23:20:16+0100.
#
# Version: 8.1
# Contact: Marcus Schaefer , 2005
# Contact: SaX-User list
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
Identifier "Layout[all]"
Screen "Screen[0]" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
EndSection

Section "Module"
Load "freetype"
Load "type1"
Load "dbe"
Load "glx"
Load "extmod"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "fr"
Option "XkbModel" "pc102"
Option "XkbOptions" "caps:shiftlock"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "ImPS/2 Generic Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
EndSection

Section "Monitor"
Identifier "Monitor[0]"
VendorName "GSM"
ModelName "LG ELECTRONICS 702S"
UseModes "Modes[0]"
DisplaySize 310 230
HorizSync 30.0 - 71.0
VertRefresh 43.0 - 160.0
Option "DPMS"
Option "PreferredMode" "1280x800"
EndSection

Section "Device"
Identifier "Device[0]"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "nvidia"
Screen 0
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
EndSection
</div>

Courtine
12/03/2009, 01h26
Si je modifie le fichier xorg.conf, lors du reboot, je reviens en mode console (runlevel5).
N.B. : j'ai installé les drivers nvidia via yast plutôt que la méthode avec le script de nvidia car j'ai installé un vieux gcc (4xxx). De plus si je fais nvidia- et que j'essaye l'autocomplétion, il ne me propose pas nvidia-installer

thveillon
12/03/2009, 01h47
Je n'ai jamais fait grand chose avec Yast, et maintenant il y a encore moins de chance que je m'y mette vu que j'utilise Debian :) .

Bon, ça devrait marcher quand même avec le pilote installé par "usine-à-gaz". Est-ce que tu as utilisé la commande magique après l'installation du pilote :


sax2 -r -m 0=nvidia

(C'est un zero avant "=nvidia").

Tu peux tester lorsque tu te retrouves en console avec le xorg.conf modifié.

Je ne t'ai pas demandé, mais les autres infos du xorg.conf correspondent bien à ton matériel, ton écran est bien :

<div class='quotetop'>Citation </div>
"LG ELECTRONICS 702S"[/b]

avec une résolution de 1280x800 ?


Enfin, as-tu comparé ce que tu as fait avec le wiki : http://www.kameleon-facile.org/wiki/carte:nvidia

Courtine
12/03/2009, 02h05
sax2 -r -m 0=nvidia --> cela ne fait rien de mieux
Mon écran est un ag neovo f-417, est-ce qu'ilne serait pas reconnu comme il faut?
En regardant les fichiers de log de sax, j'ai vu l'erreur
FATAL:ERROR inserting nvidia (/lib/modules/2.6.25.20-0.1-default/updates/nvidia.ko)
j'ai vérifié le fichier nvidia.ko existe bien

thveillon
12/03/2009, 03h16
L'écran est mal identifié, la résolution est fausse, tu es en 1280x1024 et pas en 1280x800 comme indiqué dans le xorg.conf.

Ensuite pour ce qui est de l'erreur, ça ressemble à un différence de version entre le module et le noyau, vérifie que ton noyau est à jour, regarde sa version avec :


uname -r

et vérifie que le module installé (dans Yast) correspond au noyau.

Pour le xorg.conf, je propose de le "simplifier" :

<div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>## 1280x1024_60HZ nvidia driver

Section "ServerLayout"
Identifier "Layout[all]"
Screen "Screen[0]" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
EndSection

Section "Files"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
EndSection

Section "Module"
Load "freetype"
Load "type1"
Load "dbe"
Load "glx"
Load "extmod"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "fr"
Option "XkbModel" "pc102"
Option "XkbOptions" "caps:shiftlock"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "ImPS/2 Generic Wheel Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Identifier "Monitor[0]"
Modeline "1280x1024_60.00" 108.88 1280 1360 1496 1712 1024 1025 1028 1060 -HSync +Vsync
EndSection

Section "Device"
Identifier "Device[0]"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "nvidia"
Screen 0
EndSection

Section "Screen"
Identifier "Screen[0]"
Device "Device[0]"
Monitor "Monitor[0]"
DefaultDepth 24
Option "metamodes" "1280x1024_60 +0+0; nvidia-auto-select +0+0"
SubSection "Display"
Virtual 1280 1024
Depth 24
Modes "1280x1024@60" "1024x768@60" "800x600@60"
EndSubSection
EndSection </div>

Je me suis simplement servie des caractéristiques de ton écran, de "gtf" pour générer un "modeline" adapté, et de nvidia-xconfig pour les options de base.


Mais il faut régler le problème de chargement du module avant tout, ça ne fonctionnera pas sans ça. Au pire désinstalle tout dans Yast et installe avec le ".run" (paquets kernel-syms, make et gcc obligatoires)

MD25
12/03/2009, 10h25
En regardant les fichiers de log de sax, j'ai vu l'erreur
FATAL:ERROR inserting nvidia (/lib/modules/2.6.25.20-0.1-default/updates/nvidia.ko)
j'ai vérifié le fichier nvidia.ko existe bien[/b]

Quelque chose de similaire m'est arrivé.
Cela se produisait suite à des essais multiples d'install du driver d'nvidia avec le .run ou avec yast suivi d'une mise à jour du noyau du système.
J'ai fait un <div class='codetop'>CODE</div><div class='codemain' style='height:200px;white-space:pre;overflow:auto'>find /lib/modules -name nvidia.ko</div>
et je me suis aperçu que j'avais 2 nvidia.ko, dont l'un (celui pointé dans le log) était en fait un lien logique.
Je l'ai écrasé avec l'autre et tout s'est remis à fonctionner.
Espérons que cela soit juste cela.

Courtine
12/03/2009, 21h49
Bonjour,
si je faix uname -r, j'obtiens default et j'ai comme driver nvidia d'installé, nvidia-gfx-kmp-default et x11-video-nvidia.
En changeant le xorg.conf, je redémarre systématiquement au runlevel5!
Si je fais modprobe nvidia, j'obtiens l'erreur suivante :
FATAL:ERROR inserting nvidia(/lib/modules/2.6.25.20-01-default/updates/nvidia.ko) : no suche device.
Comme l'a suggéré MD25, j'ai regardé le fichier nvidia.ko et je n'en ai qu'un seul!
Par contre je me suis aperçu que j'avais dans le répertoire /lib/modules, des répertores 2.6.25.20-01-pae et 2.6.25.20-01-xen alors que le noyau est default.
Faut-il que je les supprime?
J'ai déjà désinstallé et réinstallé plusieurs fois les drivers nvidia, faut-il ce coup-ci que je supprime le fichier nvidia.ko aussi.
Il me semble que j'ai fait une mise à jour du système avec zypper il n'y a pas longtemps, cela peut-il engendré des erreurs?
Si quelqu'un a une idée je suis preneur!

Fabien

Bon, j'ai supprimé le fichier nvidia.ko et j'ai enlevé les rpm et j'ai suivi la méthode proposée par thveillon avec le script .run de nvidia.
Ceci m'a permis d'installer correctement les drivers!
lorsque j'ai fait zypper in gcc make kernel-syms, cela m'a installé le module kernel-syms, le souci venait de là je pense.
Quelqu'un pourrait-il m'expliquer à quoi correspond ce module?
Je dois faire l'installation des drivers de mon imprimante (canon pixma mp160), quelqu'un peut-il me donner une méthode à suivre?
Merci d'avance