PDA

Afficher la version complète : Fonctionnement de la 3D ?



5diamonds
02/04/2009, 19h25
Bonjour à tous,

Je viens enfin de réussir à installer les pilotes d'une carte nVidia 7600 GT. Vérification faite via Yast =>carte graphique et moniteur=> Sax2, la carte est reconnue et l'option 3D est cochée, mais est grisée et pas accessible.

Et quand je lance par exemple le jeu PlanetPenguinRacer, ou GL117, ou FooBilliard, aucun ne se lance.

J'imagine qu'il reste quelque chose à configurer mais quoi et comment ?

Merci de votre aide.

Agemen
03/04/2009, 14h14
tu as fait comment pour installer ton pilote?

5diamonds
03/04/2009, 16h39
tu as fait comment pour installer ton pilote?[/b]

Au départ, avant d'installer la nouvelle carte, j'ai désinstallé les pilotes de l'ancienne (GeForce MX440) puis installé ceux qui me semblaient être ceux de la 7600. Evidemment quand j'ai rebooté, je suis tombé sur le mode console. Là j'ai galéré pendant deux, parce que je ne savait pas par quel bout le prendre, ce mode console.
Finalement, à force de lectures par petits bouts du forum, j'ai réussi à lancer Yast en mode console (je la fais courte) et à installer les pilotes qui m'ont permis d'avoir le mode graphique. Comme je le dis dans mon post, Sax2 me donne bien la carte GeForce 7600GT,la case Activation 3D est cochée mais grisée et n'est plus accessible, et enfin certains jeux demandant la 3D,auxquels j'avais accès auparavant, ne se lancent pas.
J'ai constaté également que la rubrique Device de Xorg comporte toujours le référence à la MX440.
Si celà peut servir voici les pilotes que j'ai validé dans Yast:
- nvidia-gfxG02-kmp-default 180.29_2.6.27.18
- nvidia-gfxG02-kmp-pae 180.29_2.6.27.18
- nvidia-settings 173.08-0
- x11-video-nvidiaG02 180.29-0.1
- xorg-x11-driver-video-nouveau 0.10.1
-xorg-x11-driver-video-nouveau-3d 0.10.1


Merci de ton aide.

bibi
10/04/2009, 10h37
Poste ton /etc/X11/xorg.conf

Bibi

Burn2
10/04/2009, 13h56
Au départ, avant d'installer la nouvelle carte, j'ai désinstallé les pilotes de l'ancienne (GeForce MX440) puis installé ceux qui me semblaient être ceux de la 7600. Evidemment quand j'ai rebooté, je suis tombé sur le mode console. Là j'ai galéré pendant deux, parce que je ne savait pas par quel bout le prendre, ce mode console.
Finalement, à force de lectures par petits bouts du forum, j'ai réussi à lancer Yast en mode console (je la fais courte) et à installer les pilotes qui m'ont permis d'avoir le mode graphique. Comme je le dis dans mon post, Sax2 me donne bien la carte GeForce 7600GT,la case Activation 3D est cochée mais grisée et n'est plus accessible, et enfin certains jeux demandant la 3D,auxquels j'avais accès auparavant, ne se lancent pas.
J'ai constaté également que la rubrique Device de Xorg comporte toujours le référence à la MX440.
Si celà peut servir voici les pilotes que j'ai validé dans Yast:
- nvidia-gfxG02-kmp-default 180.29_2.6.27.18
- nvidia-gfxG02-kmp-pae 180.29_2.6.27.18
- nvidia-settings 173.08-0
- x11-video-nvidiaG02 180.29-0.1
- xorg-x11-driver-video-nouveau 0.10.1
-xorg-x11-driver-video-nouveau-3d 0.10.1
Merci de ton aide.[/b]
Bonjour
Ou là là alors un nettoyage s'impose;
fais uname -r pour savoir sur quel noyau tu es (car tu n'as besoins que d'un nvidia-gfx et qu'un seul noyou, soit default, soit pae mais les deux ne servent à rien) par contre supprimes:
- nvidia-settings 173.08-0
- xorg-x11-driver-video-nouveau 0.10.1
-xorg-x11-driver-video-nouveau-3d 0.10.1

car ce sont des pilotes en conflicts.
Après ça tu feras un beau:
Sax2 -r 0=nvidia pour qu'il redétecte bien ta 3D et te régénère un beau xorg.conf tout neuf (sauvegarde le précédent au cas ou).