PDA

Afficher la version complète : [Réglé] [Réglé] driver ATI, encore une victime



guiv
13/04/2009, 23h20
J'avais déjà passé pas mal de temps (sans succès) à tenter d'installer le driver proprio ATI lorsque j'avais installé la Suse 11.0. J'avais finalement fait une croix dessus, mais depuis que je suis passé à un écran wide (pas géré correctement par le driver libre), je remets le couvert.

Encore un topic sur les drivers ATI... Désolé, mais je n'ai pas trouvé la réponse à ma question en fouillant les forums.

Ca foire dès l'installation. J'installe les paquets x11-video-fglrx01 et ati-fglrX01-kmp-default depuis Yast (qui me dit que l'install est OK)
Ensuite, en root, "aticonfig --initial" me répond lâchement : "aticonfig : No supported adapters detected"
un petit "lsmod | grep fglrx" ne me renvoie rien, et tend à me laisser penser que le driver n'est pas installé.

précision : carte ATI Radeon 9250

Si vous avez une idée...

maxxous
14/04/2009, 07h04
Salut installe une version anterieur genre 8.10

passe-partout
15/04/2009, 18h48
as-tu tenté avec les drivers du dépot ATI?

J'ai réussi à m'en tirer grace à ce tuto (en Anglais, mais fort complet.):
http://en.opensuse.org/Howto/ATI_Driver

guiv
15/04/2009, 23h07
merci pour ces conseils, je vais tester et je vous tiens au courant
<div class='quotetop'>Citation (passe-partout @ 15/04/2009 à 18:48) <{POST_SNAPBACK}> (index.php?act=findpost&pid=206588)</div>
as-tu tenté avec les drivers du dépot ATI?[/b]
oui... sans succès. Merci pour le lien sur le tuto, effectivement très complet. Je vais essayer de repartir de là.

passe-partout
16/04/2009, 07h00
euh en me relisant, je ne sais pas si je me suis bien fait comprendre. Je voulais parler des derniers drivers catalyst, ceux du site AMD-ATI (les 9.3)?

guiv
16/04/2009, 18h23
Je voulais parler des derniers drivers catalyst, ceux du site AMD-ATI (les 9.3)?[/b]
Ok, c'est noté, merci !
Je les ai téléchargé sur le site d'AMD, il ne me reste plus qu'à trouver un peu de temps pour tester tout ça (un peu difficile en ce moment)

naindejardin
19/04/2009, 21h55
Ok, c'est noté, merci !
Je les ai téléchargé sur le site d'AMD, il ne me reste plus qu'à trouver un peu de temps pour tester tout ça (un peu difficile en ce moment)[/b]

Ne prends pas les 9.3, les gens d'ATI/AMD sont des spécialistes de la non-qualité.
J'ai voulu les installer avec un kernel 2.6.25.20. L'installation s'est bien passée. Au reboot, j'ai eu le droit à un joli écran noir.
Je réinstalle mon système.

guiv
20/04/2009, 00h15
Ne prends pas les 9.3, les gens d'ATI/AMD sont des spécialistes de la non-qualité.
J'ai voulu les installer avec un kernel 2.6.25.20. L'installation s'est bien passée. Au reboot, j'ai eu le droit à un joli écran noir.[/b]
Et pas moyen de récupérer en recopiant l'ancien xorg.conf ? (même à partir d'un liveCD ?)
J'avoue qu'une telle expérience me fait un peu douter, mais comme décidément je n'y arrive pas avec les derniers drivers, j'hésite quand même...

guiv
20/04/2009, 15h27
Bon, en résumé, je peux prendre la méthode que je veux (tirée du tuto), et le driver que je veux, j'arrive toujours au même résultat : le driver n'est pas installé
un petit détail surprenant, mais pas forcément important : le one-click-install et le générateur de rpm m'ont tous les 2 installé le paquet ati-fglrxG01-kmp-debug, alors que je tourne sur le kernel -default (vérification faite avec 'uname -r'). Note, que j'installe l'un ou l'autre, ou les 2, cela ne change rien au résultat.
J'ai essayé également d'installer les drivers après avoir booté sur liveCD pour voir si ça ne venait pas de ma config logicielle, ça ne change rien.

Conclusion : le résultat est toujours le même
- les paquets requis sont installés (ati-fglrxG01-kmp-default et X11-video-fglrxG01), a priori correctement et sans conflit d'après Yast
- la commande 'aticonfig --initial' me renvoie "No supported adapters detected"

Une hypothèse (peut-être farfelue, je débute en linux) : j'ai l'impression que les paquets sont bien téléchargés, mais que le module correspondant n'est pas inséré dans le noyau.
Je m'attendais à recevoir quelque chose en réponse à un 'lsmod | grep fglrx', mais rien du tout
Si j'essaie de charger à la main le module : 'modprobe fglrx', je reçois une réponse qui me surprend :
"FATAL: Error inserting fglrx (/lib/modules/2.6.25.20-0.1-default/updates/fglrx.ko): Cannot allocate memory"

:blink:
Je me demande si je n'aurais pas plus vite fait de racheter une vieille nVidia sur ebay...

Denebe
20/04/2009, 16h51
Bonjour,

Je ferais comme maxous t'as dit, installe le 8.10 ou la 8.11 (il faut que ton driver supporte ton xorg, donc trop vieux ne passera pas, 8.10 c'est bien).

Sinon tu peux aussi installer les drivers libres xf86-video-ati (http://forum.hardware.fr/hfr/OSAlternatifs/Hardware-2/pilotes-driver-radeonhd-sujet_68936_1.htm) dont la dernière version est la 6.12 (mais je ne sais pas trop comment ça se passe pour la suse ni comment l'installer ni il se trouve, haïe !!). Il y a un dépot ici (http://download.opensuse.org/repositories/home:/dbahi:/xorg-x11-driver-video-ati/)mais qui est vide.

Le radeonHD est fait pour les r600 et r700 (radeonhd 2*** 3*** et 4***) mais pas en dessous je crois.

J'ai aussi remarqué qu'en passant par le depot ati, ati-fglrxG01-kmp-debug était installé, alors qu'il y a un mois ce n'était pas le cas.

Le driver proprio 9.4 ne supporte officiellement plus que les radeonhd 2*** 3*** et 4*** (c'est peut-être pour ça que tu as le message "No supported adapters detected", à vérifier...)

Pour l'installation, c'est peut-être pour partie inutile je n'en sais trop rien, chez moi j'ai installé kernel-source, gcc, make. Ensuite, avec les drivers proprio, je fais comme ça:
1) je rends le driver executable (clique droit dessus, propriété, droit d'accès et je coche executable)
2) dans une console en root, je lance l'installation du driver par ./ati....run (je laisse tout en automatique)
3) je fais crtl+alt+f2
4) je me loggue en root
5) je tape aticonfig --initial
6)sax2 -r -m 0=fglrx
7) je reboot en tapant reboot

Voilà, avec un hd3870, ça s'installe correctement.

Si jamais ça ne marchait pas, il te faudrait alors allumer ton ordinateur en console, puis en root désinstaller le driver en tapant ./usr/share/ati/fglrx-uninstall.sh

Je ne t'ai pas beaucoup avancé, j'ai même répété certains propos, en espérant que ça t'aide un peu à y voir plus clair...

guiv
21/04/2009, 00h30
En tous cas, merci pour les encouragements, c'est toujours sympa d'avoir un support actif sur les forums !
Effectivement il est possible que ma carte graphique date un peu. Je viens de refaire un tour sur le site d'ATI/AMD, à la recherche de tous vieux drivers... et même les plus vieux ne mentionnent pas ma carte dans la liste des compatibilités. :cray2: J'aurais probablement dû commencer par là, j'aurais perdu moins de temps ! :bang:
Le + simple est peut-être tout simplement de racheter une carte un peu moins ancienne... Allez, on y croit ! :)

Je viens de revérifier sur le site d'ATI, c'est quand même hallucinant... Je passe par la fonction de recherche de drivers, je sélectionne dans une liste la réf de ma carte, et aucun des drivers qu'il me trouve ne cite ma carte parmi les matériels supportés.
A quoi ça sert, alors, les recherches ??? (un peu énervé quand même)

passe-partout
21/04/2009, 18h01
Quand je vais sur le site d'amd-ati et que je cherche les drivers pour ta carte je tombe là:
http://support.amd.com/us/gpudownload/Page...on-prer200.aspx (http://support.amd.com/us/gpudownload/Pages/linux64-radeon-prer200.aspx)
:rolleyes:
et celui à prendre c'est celui pour Xorg. (le dernier dans le tableau.) ;)

Denebe
21/04/2009, 20h54
Je ne pense pas que ça passe, ces drivers fonctionnent jusque Xorg 7.1 . Sous opensuse 11.1 on est à 7.3 et sous la 11.0 , 7.2 me semble-t-il.

Dans ton cas, je chercherais plus vers le driver libre, même s'il ne gère a priori pas bien les écrans larges, peut-être une solution existe-t-elle. Mon ancien voisin de l'année passée était sous debian avec la même carte graphique, ça marchait impeccable, mais sans écran large.

guiv
22/04/2009, 13h50
Je confirme, cela ne fonctionne pas. Pas évident de faire le grand écart entre une distrib récente, un écran récent, et une carte graphique qui date...
Je laisse tomber avec cette carte, je vais essayer d'en acheter une plus récente sur e-bay. Ca doit se trouver sans pb à quelques euros, je n'ai pas du tout besoin de grandes performances ! (mais un écran large correctement géré, ça ne serait pas désagréable ^_^ ).
Du coup j'hésite un peu : est-ce qu'il vaut mieux prendre une nvidia (d'après les forums que j'ai parcourus, les chances de succès sont plus élevées) ? Ceci dit, avec tout le temps que j'ai passé à essayer d'installer mon ATI, je commence à connaître un peu le sujet... Promis je vous tiens au courant quand j'y serai arrivé (et j'y arriverai ! ;) )

Denebe
22/04/2009, 15h52
Tu peux aussi essayer une autre distribution avant un achat. Des fois ça peut résoudre ton problème, on ne sait jamais. Surtout qu'il y a deux grosses sorties de prévues en fin de semaine je crois...

passe-partout
22/04/2009, 17h30
C'est clair qu'avec ma vieille geforce 4ti 4800se pas de problèmes pour gérer les écrans avec des res du type 900*1440 ou 1050x1650. Switcher d'un écran à un autre à chaud, etc... avec la HD4670 c'est pas la même histoire... ^_^

guiv
04/05/2009, 23h38
Bon, et bien voilà un problème réglé lâchement
J'ai finalement investi dans une nvidia Geforce 6200 (1.5€ sur e-bay, ça n'est pas la ruine !)
Carte reconnue au boot, l'écran wide est géré correctement par le driver libre.
Un petit coup de Yast, installation des drivers nvidia, et tout marche nickel y compris la 3D.
C'est une solution un peu facile, mais ça marche ! :D
Merci pour vos conseils !

MD25
05/05/2009, 09h45
J'ai finalement investi dans une nvidia Geforce 6200 (1.5€ sur e-bay, ça n'est pas la ruine !)[/b]
Je suis vert ! :bang:
La 6200 (AGP-256 Mo) que j'ai achetée en magasin il y une dizaine de jours m'a couté 44 € !
Chapeau pour l'affaire !

guiv
05/05/2009, 20h47
Je suis vert ! :bang:[/b]
Il n'y a pas forcément de quoi, ça dépend de ce que tu cherches. Des 6200 il y en a plein, la mienne n'a que 64Mo... ce qui me suffit amplement.