PDA

Afficher la version complète : [réglé] Nvidia + 19'' 16/10eme = écran décalé :(



Nuke-Refugee
15/04/2009, 11h43
Salut les gens,

J'ai reçu mon nouvel écran ce matin, et il y a un truc bizarre...
Que ce soit avec ou sans le mode Xinerama (j'ai toujours mn 17'' à côté) l'écran du 19'' large est décalé vers la gauche... Sans compter la barre des tâches qui ne se montre plus, je me demande s'il n'y aurait pas aussi un décalage vertical. Mais une chose à la fois...
J'ai utilisé les réglages de l'écran pour le ramener vers la droite mais là je suis à fond, il manque encore un bon centimètre, au bas mot. Quant aux réglages de position et de t aille de SaX2, ils sont tout simplement inopérants...
Je précise que j'ai mis à jour mon pilote Nvidia à toutes fins utiles. Sans effet.
Voici mon xorg.conf. La carte est une 6800, le 19'' est sur la sortie DVI avec un adaptateur VGA, le 17'' est sur la sortie VGA.


# /.../
# SaX generated X11 config file
# Created on: 2009-04-15T11:33:13+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "Module"
Load "dri"
Load "dbe"
Load "freetype"
Load "extmod"
Load "glx"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "fr"
Option "XkbModel" "microsoftpro"
Option "XkbOptions" "caps:capslock"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "9"
Option "Device" "/dev/input/mice"
Option "Name" "Creative Wireless Keyboard & Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
DisplaySize 408 255
HorizSync 30-83
Identifier "Monitor[0]"
ModelName "VW195"
Option "DPMS"
Option "PreferredMode" "1440x900"
VendorName "ACI"
VertRefresh 43-76
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1440x900" 106.00 1440 1520 1672 1904 900 903 909 932 +HSync -VSync
Modeline "2720x1024" 106.50 2720 1520 1672 1904 1024 903 909 932
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "GeForce 6800"
Driver "nvidia"
Identifier "Device[0]"
Option "IgnoreEDID"
Option "RenderAccel"
Option "SaXDualHead"
Option "TwinView"
Option "SaXDualMonitorVendor" "AOC"
Option "SecondMonitorHorizSync" "30-83"
Option "SaXDualVSync" "50-75"
Option "MetaModes" "1440x900,1280x1024;1366x768,1366x768;1360x768,1360 x768;1280x800,1280x800;115
x864,1152x864;1280x768,1280x768;1280x720,1280x720; 1024x768,1024x768;1280x600,128
x600;1024x600,1024x600;800x600,800x600;768x576,768 x576;640x480,640x480"
Option "SaXDualOrientation" "LeftOf"
Option "SaXDualResolution" "1280x1024"
Option "TwinViewOrientation" "LeftOf"
Option "SaXDualMode" "Xinerama"
Option "SecondMonitorVertRefresh" "50-75"
Option "SaXDualHSync" "30-83"
Option "SaXDualMonitorModel" "AOC LM720/LM720A"
VendorName "NVIDIA"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
Option "Composite" "on"
EndSection

Quelqu'un a une idée?
C'est la première fois que j'ai un écran large...

Seb.

PS: Grub prend bien tout l'écran, lui. Le décalage apparaît dès l'écran de chargement.

Carnaby
15/04/2009, 12h27
Tu n'as pas la possibilité de branché ton 19" en DVI? Ca rêgle tous les problème de géométrie et de taille de l'image (propre au signal analogique du VGA)

Un autre truc tout bête mais ton écran n'a pas de mode d'autocalibration? Si oui qu'est ce que ça donne? Il se remet a droite?

Nuke-Refugee
15/04/2009, 12h45
Et non, c'est un bas de gamme ;)
Un 19'' DVI pour 90€, ça serait trop beau...
Pas d'auto calibration non plus (mon 17'' lui a cette fonction, mais pas le nouveau).
Chose étrange, en faisant des essais un peu dans tous les sens, je me suis retrouvé avec le 19'' en 1280x1024 au lieu de 1440x900... Bien entendu l'image s'est retrouvée déformée vu que ce n'est pas le bon rapport, par contre elle occupait tout l'écran! Retour en 1440x900 et hop, décalage...

Edit: En fait il semble qu'il ait bien un mode de calibration auto, mais il n'y a pas de bouton... Il le fait tout seul au démarrage ou en cas de changement de résolution.

Nuke-Refugee
15/04/2009, 16h43
Bon, alors...
J'ai carrément viré le 17'' à tout hasard, histoire de simplifier... Pour le moment je n'arrive à rien.
Voici mon xorg.conf actuel, si quelqu'un a une idée de génie, je suis preneur...
Notez que l'écran est nommé DFP-1 assez curieusement bien qu'il n'y en ait plus d'autre... Le custom edid c'est tout simplement l'edid fourni par l'outil de conf de Nvidia. De toute façon, avec ou sans lui, le résultat est identique...


# /.../
# SaX generated X11 config file
# Created on: 2009-04-15T16:17:44+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#
Section "Files"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "Module"
Load "dri"
Load "dbe"
Load "freetype"
Load "extmod"
Load "glx"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "fr"
Option "XkbModel" "microsoftpro"
Option "XkbOptions" "caps:capslock"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "Holtek USB Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
DisplaySize 408 255
HorizSync 30-83
Identifier "Monitor[0]"
ModelName "VW195"
Option "DPMS"
Option "PreferredMode" "1440x900"
VendorName "ACI"
VertRefresh 43-76
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "1440x900" 106.00 1440 1488 1640 1904 900 903 909 932
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1440x900" "1366x768" "1360x768" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "GeForce 6800"
Driver "nvidia"
Identifier "Device[0]"
Option "IgnoreEDID"
Option "RenderAccel"
Option "ConnectedMonitors" "0x9a13a08"
Option "CustomEDID-DFP-1" "0x9686820"
VendorName "NVIDIA"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
Option "Composite" "on"
EndSection

A priori ce serait lié au pilot Nvidia 180.xx... http://answers.yahoo.com/question/index?qi...11070215AAoyhNm (http://answers.yahoo.com/question/index?qid=20090311070215AAoyhNm)
J'aimerais mieux ne pas repasser aux 17 je vais continuer à chercher.

AH-AH! J'ai fini par trouver la fonction de réglage auto de mon écran... Elle état planquée! En fait le nom n'a rien à voir, dans un menu qui concerne uniquement (à priori) les réglages de l'affichage OSD, il y a une option "ALL RESET"... Ben ça a marché!
Sauvé.